首页

RO相关手册由美雨儿制作维护


前言

前言

99nets haoxiaoyuhao

编写这本电子书,希望可以为大家尽一份绵薄之力.

由于时间匆忙,可能有所遗漏,请大家多多见谅!可以

E-mail给我,提出您的宝贵建议,偶会尽量修正! ：）

E-mail:haoxiaoyuhao@hotmail.com

论坛:http://bbs.99nets.com/index.php

http://baobei.6vv.net/

多多の宝贝论坛

http://baobei.6vv.net/


RO单机架设教程

以下是模拟器的基本配置... 所以如果机器配置过低... 就不要尝试athena了...

可能架设起来也不一定能正常进入游戏...

【基本配置】----------------------------------------------------------
系統：中文Windows 98/ME/2000/XP
CPU:：600MHz以上
内存：256MB以上
硬盘容量：1.2 GB以上硬盘可用空间

先下载两个韩国客户端 安装在同一个文件夹 然后更新
下载地址1:
ftp://211.39.136.141/pub/ragnarok/RAG_SETUP0615.EXE
ftp://211.39.136.141/pub/ragnarok/SAK_SETUP0621.EXE

下载地址2:
ftp://ragnarok.nefficient.co.kr/pub/ragnarok/RAG_SETUP0615.EXE
ftp://ragnarok.nefficient.co.kr/pub/ragnarok/SAK_SETUP0621.EXE

下载地址3:
ftp://download.ragnarok.nefficient.co.kr/pub/ragnarok/RAG_SETUP0615.EXE
ftp://download.ragnarok.nefficient.co.kr/pub/ragnarok/SAK_SETUP0621.EXE

下载地址4:
ftp://211.233.76.131/pub/ragnarok/RAG_SETUP0615.EXE
ftp://211.233.76.131/pub/ragnarok/SAK_SETUP0621.EXE

下载地址5:
ftp://211.233.76.132/pub/ragnarok/RAG_SETUP0615.ZIP
ftp://211.233.76.132/pub/ragnarok/SAK_SETUP0621.EXE

下载地址6:
ftp://211.233.76.134/pub/ragnarok/RAG_SETUP0615.ZIP
ftp://211.233.76.134/pub/ragnarok/SAK_SETUP0621.EXE

另外 再在某个盘上建个文件夹 文件名叫RO

例如E 盘

那么路径就是E:\RO

好 然后复制韩国客户端安装出来的 所有的DLL后缀文件 data.grf 和 sdata.grf

还有三个音乐文件:BGM文件夹 Mp3dec.asi Mssfast.m3d 全部复制到E:\RO

然后下载ATHENA:ftp://61.134.36.39/athena/AthenaTxt-C151.rar

把它安装在RO里

再下载汉化补丁:ftp://61.134.36.39/Patch/0717.rar
如果下载不了 换个时间试试 推荐晚上

解压到RO里

然后conf\grf-files.txt 里路径设置是
//data.grf sdata.grf路径设置，请修改为你的data.grf sdata.grf所在路径
data: E:\RO\data.grf
sdata: E:\RO\sdata.grf

把上面那段话粘贴到conf\grf-files.txt里 覆盖原来的(记住,你的RO文件夹要保证在E盘里 名字叫RO)

好了 分别启动map-server.exe login-server.exe char-server.exe

先点击仙境配置.exe设置一下

然后进游戏了...仙境传说.exe启动进游戏

-------摘自99nets haoxiaoyuhao(多多の宝贝 美雨儿)


RO新人常见问题

如何申请帐号?

account_id要在2000000以上,不然会出现使不出技能等各种问题
TXT版用XXX_M/xxx_F,xxx代表你的ID，M代表男，F代表女 密码任意...
SQL版的用ASP或PHP网页注册

map挂掉是什么原因?

在MSDOS下单独启动map 可以查看出错的地方...如果看不出来...截图发到论坛 另外请确定你的游戏已

经更新了韩国客户端...

怎么关系统自带防火墙?

如果沒有关防火墙的软件 那么按开始---控制面板---网络连接 右键点击本地连接 属性...高

级...Internet连接防火墙 不要打勾就可以了

为什么三个程序都正常启动了? 还是进不去游戏呢?

请去掉一些地图...减少怪物的数量...等map完全跑完再进... 不然就多加条内存...

如何关闭地图?

map-athena.conf里 在不用的地图前加上//

如何修改怪物数据?

修改mob_db.txt文件...格式如下
mob_db.txt
怪物资料库
內容:
ID,Name,JName,LV,HP,SP,EXP,JEXP,Range1,ATK1,ATK2,DEF,MDEF,STR,AGI,VIT,INT,DEX,LUK,Range2,Ra

nge3,Scale,Race,Element,Mode,Speed

,ADelay,aMotion,dMotion,Drop1id,Drop1per,Drop2id,Drop2per,Drop3id,Drop3per,Drop4id,Drop4per

,Drop5id,Drop5per,Drop6id,Drop6per

,Drop7id,Drop7per,Drop8id,Drop8per,Item1,Item2,MEXP,ExpPer,MVP1id,MVP1per,MVP2id,MVP2per,MV

P3id,MVP3per
怪物ID,名字,日文名,等級,体力,魔力,经验值,职业经验值,锁定范围,攻击力1,攻击力2,防御力,魔法防

御力,力量....

Speed,ADelay,aMotion,dMotion,
移动速度,动作延遲,攻击時速度,被攻击時速度

Drop1id,Drop1per......
掉落物品1,物品1掉落机率......
MVP1id,MVP1per......
MVP物品1,MVP物品1掉落机率......

如何修改怪物数量?

battle_athena.conf里
// 怪物数量的倍率（100正常、200两倍....）
mob_count_rate: 100

哪里可以修改IP 登陆别人的SF?

data文件夹里 找到sclientinfo.xml 文件 用记事本打开
<connection>
<display>伺服器名稱display>
<desc>AthenaServer</desc>
<address>IP位置</address>
<port>6900</port>

怎么添加GM帐号?

在save\account.txt里把自己的帐号ID改成默认有的GMid 或者把自己的ID添加到GM_account.txt文件

具体格式 看看就明白了

如何让GM号显示GM造型?

在data文件夹 找到sclientinfo.xml
<admin>100001</admin>
<admin>100002</admin>
<admin>100003</admin>
admin中间填上你的GMID就可以了

如何让经验超过99级?

下载一个新的经验表 覆盖原来db文件夹里的就可以了

如何固定我的IP?

申请一个域名绑定动态IP就可以了...

下载的脚本应当怎么添加到游戏里?

把下载的脚本放在服务端里的npcdata\里的任意目录下。
再在服务端里的conf里的map_athena.conf里添加入NPC的地址。格式按照
npc: npcdata/存放的目录/脚本的文件名.txt

GM命令是什么?

参照游戏目录下 athena说明文件\Athena单机说明

怎么调整怪物的经验倍数 以及 物品的爆率?

conf\battle-athena.conf 许多设置都在这里面

save文件夹多出许多临时文件，应该如何解决？

把其中一个临时文件后缀删除 修改为文本文件 其余都可以删除

-------摘自99nets haoxiaoyuhao(多多の宝贝 美雨儿)


RO服务器架设教程

看见很多人想架设SF 又摸不到一点头绪
希望这个教程能有所帮助 大家都可以架设起自己的RO服务器 ^_^
当然 要架设SF 前提是把单机架设好...

好了 继续... -_-!!

一、了解各类IP地址，知道自己的IP是外网还是内网

1.什么是IP地址 ?
    IP地址是在网络上分配给每台计算机或网络设备的32位数字标识。在Internet上，每台计算机或网

络设备的IP地址是全世界唯一的。IP地址的格式是 xxx.xxx.xxx.xxx，其中xxx是 0 到 255 之间的任意

整数。例如，99nets网站主机的IP地址是 218.83.155.223。

2.什么是固定IP地址
    固定IP地址是长期分配给一台计算机或网络设备使用的IP地址。一般来说，采用专线上网的计算机

才拥有固定的IP地址。

3.什么是动态IP地址
    通过Modem、ISDN、ADSL、有线宽频、小区宽频等方式上网的计算机，每次上网所分配到的IP地址都

不相同，这就是动态IP地址。因为IP地址资源很宝贵，大部分用户都是通过动态IP地址上网的。

4.什么是内网、内网TrueHost、什么是公网、什么是NAT
    公网、内网是两种Internet的接入方式。

    内网接入方式：上网的计算机得到的IP地址是Inetnet上的保留地址，保留地址有如下3种形式：
        10.x.x.x
        172.16.x.x至172.31.x.x
        192.168.x.x
    内网的计算机以NAT（网络地址转换）协议，通过一个公共的网关访问Internet。内网的计算机可向

Internet上的其他计算机发送连接请求，但Internet上其他的计算机无法向内网的计算机发送连接请求

    公网接入方式：上网的计算机得到的IP地址是Inetnet上的非保留地址。公网的计算机和Internet上

的其他计算机可随意互相访问。

    NAT（Network Address Translator）是网络地址转换，它实现内网的IP地址与公网的地址之间的相

互转换，将大量的内网IP地址转换为一个或少量的公网IP地址，减少对公网IP地址的占用。NAT的最典型

应用是：在一个局域网内，只需要一台计算机连接上Internet，就可以利用NAT共享Internet连接，使局

域网内其他计算机也可以上网。使用NAT协议，局域网内的计算机可以访问Internet上的计算机，但

Internet上的计算机无法访问局域网内的计算机。

    Windows操作系统的Internet连接共享、sygate、winroute、unix/linux的natd等软件，都是使用

NAT协议来共享Internet连接。

    所有ISP（Internet服务提供商）提供的内网Internet接入方式，几乎都是基于NAT协议的。

5.如何查看我的电脑的IP地址
    下面以几种最常用的操作系统为例，介绍IP地址的查看方法。

(1)、Windows 9x/Me

    用鼠标选择“开始”->“程序”->“MS-DOS方式”，打开一个DOS命令行窗口，执行：ipconfig，执

行结果示例如下：

(2)、Windows NT/2000/XP

    用鼠标选择“开始”->“程序”->“附件”->“命令提示符”，打开一个DOS命令行窗口，执行：

ipconfig，执行结果示例如下：

（用红色框起来的部分即为本机的IP地址。一台计算机可以有多个IP地址。）
(3)、unix/linux
    在命令行下输入ifconfig，执行结果示例如下：
    （下图是在solaris下的执行结果，各种unix/linux的结果不一样，但都大同小异。）

（用红色框起来的部分即为本机的IP地址。一台计算机可以有多个IP地址。）

6.如何检测公网和内网

来这个网址:http://www.ip138.com/ 可以显示你的IP地址

用上述的几种方法查看自己的IP 例如：你点击自己电脑窗口的“开始”“运行”输入“cmd”，

在DOS命令窗口输入“ipconfig/all”,得到的IP如果和上面一样，同时不在下面的范围内，说明你拥有自己的外网IP
如果显示的IP地址在以下范围内，说明你没有外网IP：
10.x.x.x
172.16.x.x至172.31.x.x
192.168.x.x
请注意：
(1)、如果您的浏览器里设置了使用代理服务器，请清除代理服务器设置，并刷新本页面，之后再检测。
(2)、有些学校或大型的机关单位虽然分配公网IP给用户，但学校或单位为了安全起见，会封闭校外对校

内的访问请求。这部分用户虽然有公网IP地址，但依然要用内网动态域名来建网站。如果您通过校园网

或机关单位的网络上网，并检测到自己有公网IP，请您在本机调试好网站后，把防火墙打开，请外网的

朋友通过IP地址来访问您的网站。如果能访问，就是公网；如果不能访问，就是内网。
(3)、如果您使用带端口映射功能的ADSL共享器/路由器上网，或通过其他有公网IP的电脑上网，而且您

对网关电脑有设置端口映射的操作权限，这种情况虽然属于内网，但也可以使用公网动态域名。

二、如果测试出来的结果是外网……恭喜你 修改好IP就可以架设起自己的RO服务器了。

具体修改方法：首先你的系统自带防火墙要关上…… 防火墙里也不能把RO必须的端口封住……

char_athena.conf
//服务器IP设置（可修改為你的IP）
login_ip: 【填写你的IP地址】
//服务器端口设置（不可修改）
login_port: 6900
//服务器IP设置（可修改為你的IP）
char_ip: 【填写你的IP地址】
//服务器端口设置（不可修改）
char_port: 6121
---------------------------------------------------------
map_athena.conf
//服务器IP设置（可修改為你的IP）
char_ip: 【填写你的IP地址】
//服务器端口设置（不可修改）
char_port: 6121
//服务器IP设置（可修改為你的IP）
map_ip: 【填写你的IP地址】
//服务器端口设置（不可修改）
map_port: 5121

如果是动态IP 可以申请一个域名绑定IP 花生壳就很简单……

花生壳网址：http://www.oray.net/

使用说明：

“花生壳”是一套完全免费的动态域名解析服务，可建立拥有类似于“固定域名”的域名和最大自

主权的互联网主机，而无论连接获得的IP属于动态还是静态。

第一步：申请“网域护照”
我们首先要为自己申请一个“网域护照”,这是网域科技有限公司对其联机服务用户的身份认证，用

户如要使用它的服务则需要提供用户名和口令才能登录。“网域护照”申请成功之后，即可使用包括花

生壳动态域名解释服务在内的在线服务。
注册过程比较简单，分为三步：一，签署用户协议；二，填写护照基本信息；三：设置密码保护问

题。
“网域护照”的申请向导地址为：

http://www.vicp.net/Console/Passport/Passport_welcome.asp
。在注册向导的帮助下，我们就能轻松地完成注册过程，在此不详述。

第二步：激活花生壳服务向导
在成功地申请“网域护照”之后，如需要动态域名解析服务，我们还需要激活花生壳服务，先申请到一

个域名，如techin.vicp.net。
我们使用“激活花生壳服务向导”来完成激活过程，地址为：

http://www.vicp.net/Console/Pean ... _Wizard_welcome.asp
。当然，要激活它，我们要用刚才申请到的“网域护照”的用户名和口令来登录到“我的控制台”，然

后，再输入以上网址或是点击网页右下方的“激活花生壳服务”的超链接，即可进入到“激活花生壳服

务向导”。

整个花生壳服务激活过程分为三步：一，选择激活域名，我们选择“免费域名”，输入自己的域名

（可使用英文、数字和连字符）；二，签署用户协议；三，填写站点信息，如“站点的分类属性”、“

站点描述”、“站点更新消息”、“您的站点在线时间”等等，对于用户而言，最后一项，即“您打算

将站点建设成为”最重要，我们要根据个人主页的内容来进行选择，如“WEB服务器”、“FTP”等，并

设置好它们所使用的端口（如用户对端口不太熟悉，则可使用它的默认值），如图

申请好“网域护照”，并成功激活花生壳动态域名解析服务之后，你的动态IP再也不用发愁别人找

不到了，自己的电脑就成了标准的服务器。

三、如果测试出来是内网IP 呃…… 就要麻烦点了

首先设置好IP

char_athena.conf
//服务器IP设置（可修改為你的IP）
login_ip: 【填写内网IP】
//服务器端口设置（不可修改）
login_port: 6900
//服务器IP设置（可修改為你的IP）
char_ip: 【填写外网IP】
//服务器端口设置（不可修改）
char_port: 6121
---------------------------------------------------------
map_athena.conf
//服务器IP设置（可修改為你的IP）
char_ip: 【填写内网IP】
//服务器端口设置（不可修改）
char_port: 6121
//服务器IP设置（可修改為你的IP）
map_ip: 【填写外网IP】
//服务器端口设置（不可修改）
map_port: 5121

接下来就是映射端口了……

1、用ADSL路由上网 映射端口
采用路由方式大多数是指ADSL拥有一个固定的IP，ADSL直接接在HUB或交换机上，所有的电脑共享上网。
这时ADSL的外部地址只有一个，那就是电信局分配的，比如61.154.*.*。而内部的IP是人为设置的比如
ADSL设为192.168.0.1，下面的电脑就依次设为192.168.0.*（*表示2、3``````）。

当我们用IP为192.168.0.2的电脑在Internet创建一个游戏服务器的时候外面的电脑如果想加入你创建的
游戏，必须和你的电脑用TcP协议通过端口进行通讯。但局域网只共享了一个合法的地址，问题由此产生

解决的方法：

现在的ADSL设备一般都具有NAT（网络地址转换）功能，就是将使用私有地址的网络与公用网络Internet
相连，使用私有地址的内部网络通过NAT路由器发送数据时，私有地址将被转化为全法注册的IP地址从而
可以与Internet上的其他主机进行通讯。当多个内部方机共享一个全法IP地址时，地址转换是通过端口
多路复用即改变外出数据包的源端口映射完成的。

各种ADSL设置可能有所不同……可以在搜索引擎中搜索一下你的ADSL名称＋映射方法就可以了

2、使用软件映射端口

我们以PortTunnel软件为例

由于整个局域网在Internet上只有一个真正的IP地址，而这个IP地址是属于局域网中服务器独有的

，即使我们在其它计算机中架设了服务器，但是无法让Internet上的朋友访问。这是为什么呢？打个比

方说，如果你仅仅知道朋友在某幢写字楼上班，但是不知道它具体的房间，你就无法找到他。同样的道

理，如果直接在局域网中架设了服务器，那么Internet上的朋友登录的时候仅仅可以找到局域网中的服

务器，但是至于怎样才能连接到你的计算机上就是一个问号了。为了解决这个问题，我们在局域网中建

造自己服务器的时候需要一个端口映射软件来帮助，在此推荐一个小巧实用的工具－PortTunnel，它可

以帮助大家轻松搞定这一切。顾名思义，PortTunnel的中文意思就是“端口通道”，它的作用就是在服

务器上为你的计算机指定一条通道，使得Internet上的朋友可以顺利的与你建立连接。

在使用PortTunnel之前有一点需要强调，就是它必须运行在服务器端，这样才能够实现端口映射的

目的。运行PortTunnel之后将会看见图所示的窗口：

这时点击下部的“增加”按钮进行相关的设置。这里有几个比较重要的项目重点介绍一下：

1、名称：在此中填写你的名称，这在局域网中有多台计算机需要端口映射的时候能够区分出每一台

计算机。
    2、输入端口：注意不能使用重复的端口，端口号重复将会导致系统冲突。
    3、输出端口：这里填写的是你计算机中的服务器端口。
    4、输出地址：这里填写你的计算机在整个局域网中的IP地址，比如此处是“129.156.0.21”。
    点击下部的“确定”按钮保存之后，服务器端的端口映射就完成了，这时会发现原先的主窗口中多

出了一项记录，按下“开始”就可以激活PortTunnel的端口映射服务了。此时你可以通过其他网友来访

问你的服务器，如果能够顺利登录就说明已经全部搞定了。

最后再提醒大家一下：PortTunnel需要在服务器端才可以运行，至于怎样才能让网络管理员为你开

通端口映射就要看各位的本事了，大家就各显神通吧^_^

3、未经测试..现有的RO端口与其提供的默认端口不一致 大家可以试试的一种方法

先给大家一个地址：http://www.dns0755.net/。这是科迈网（动态域名、虚拟专用网），上这个网

站申请一个二级域名是我们要做的第一步。申请过程相当简单，相信大家都会做，在此略过不谈。

    主要的一步，我们对申请的二级域名信息在网站上进行更改，点“修改”，然后出现如图1界面：

你可以看到很多端口号和需要填写的端口名称（图1），一般我们只要开一个服务器服务就可以了。所以

你可以选择一个你喜欢的端口号，然后在端口名处填写端口名称就可以了。用户最多可以设置5个端口映

射，加上默认开通的两个端口WWW和SMTP，实际上用户最多可以使用7个端口。例如端口1是空的，那么在

端口1这行右边的端口名里写上大写的端口名，比如“服务器”、“POP3”等等（用户可以随意定义端口

名，但必须要用大写）。填好端口名后，再记下端口号，比如上述界面里端口号是“13670”，再按“提

交”，让修改生效。

    下面就是客户端软件的设置（很小的一个绿色软件，该站页面上可下载）。

    设置过程也相当简单，节约篇幅，不多加入图片了。大家看软件中填“需要代理的域名”，就是填

你申请的二级域名，跟着下面填入你的用户密码，跳过两步，直接到重要的一步（如图2）。

填写完之后，单击“完成”，软件的设置就告结束。

4、还有一个RO代理软件 传说这个软件是在客户端运行的，可以穿透防火墙连接到服务器。

究竟怎样使用 及效果如何……未经测试……

以上使用的软件可以在多多の宝贝论坛下载…… 地址:http://baobei.6vv.net/

好了 希望大家都可以架设起自己的服务器 我是美雨儿 谢谢大家~ 嘿嘿~

版权所有 请勿转载 ^_^

-------摘自多多の宝贝 美雨儿(99nets haoxiaoyuhao)


脚本常见问题

脚本安装方法

首先把脚本用存为TXT文件。放在服务端里的npcdata\里的任意目录下。
再在服务端里的conf里的map_athena.conf里添加入NPC的地址。格式按照
npc: npcdata/存放的目录/脚本的文件名.txt

NPC商人制作

格式
prontera.gat,48,58,8 shop 蔬菜商人 91,515:15,516:15,535:15

解释：
prontera.gat：NPC所在的地图
48,58：所在地图的坐标
蔬菜商人：人物名称
91,515:15,516:15,535:15：物品的ID和物品的价格

里面的515是物品的ID，15就是物品的价格

如果你要修改什么东西的价格就可以在这里改（这里只能修改买价不能修改卖价）

做完NPC请放在npcdata里的shops里

地图刷怪设置

格式
aldeg_cas01.gat,115,226,0,0 monster 宝箱 1324,1,0,0,2

解释
aldeg_cas01.gat：刷怪的地图
115,226：具体坐标位置
0,0：x,y坐标的+/-值，这是附加的，可以不用
monster：显示的是怪物npc
宝箱：怪物的名字，可以随便改
1324：怪物的ID
1：刷怪的数量
0，0：刷怪的时间

刷怪文件请放在npcdata\\mob\\里

-----摘自99nets


第一讲 基础知识

Athena脚本制作讲座(一)----基础知识 Hack 编写
第一讲 基础知识

一、如何添加自己制作的NPC
做一个脚本放到npc目录里面
如：商人.text
然后在map_athena里面添加就是了
运行NPC脚本设置（不需要运行的脚本在npc前输入表示关闭）
npc npc商人.txt
npc npc商人1.txt
npc npc商人2.txt

二、如何设定NPC的位置与造型
例1：
prontera.gat,167,204,6 shop hack专场特卖会 96,50110,

50210,50310,50410,50510,50610 此处省略若干物品
prontera.gat 为所在地图
167为X坐标
204为Y坐标
6为NPC面朝的方向
2 1 8
3 X 7
4 5 6
shop为NPC类型
hack专场特卖会为NPC的显示名称
96为NPC的造型
50110,50210,50310,50410 ..... 为 物品代码价格

三、高级技巧
基本的NPC格式如下：
map,X,Y,angle script name skin,{
具有一定作用域的NPC如下，当玩家进入这个区域后NPC自动生效
map,X,Y,angle script name skin,X size,Y size,{
其他类型的NPC请参看 dispbbs.aspboardID=3&ID=2351&page=1

[第一讲完]

第二讲预告，输入输出与流程控制
第一讲作业
1.挑几个你感兴趣的已有NPC,改变其位置与造型
2.仿造例一制作一个贩卖铁匠物品的NPC，放于首都喷泉旁(物品代码可于dbitem_db.txt中查到)


第二讲 流程控制与输入输出

Athena脚本制作讲座(二)----流程控制与输入输出 Hack 编写
第二讲 流程控制与输入输出
(参考索克的脚本可用命令)
一、流程控制
2、next ""
next;
产生按钮"下一步"
3、close ""
close;
产生按钮"关闭"
4、menu "*","l"
menu "好的",L_YES,"不好",L_NO;
产生选择列表,有2个选项"好的"、"不好",选择后即发生跳转

选择"好的"跳转至L_YES,选择"不好"跳转至L_NO
5、goto "l"
goto L_YES;直接跳转至L_YES
平时使用时,常跟在if等条件判断语句后
12、if "igi"
if(@value==1) goto L_YES;
如果@value=1,跳转到L_YES,不然就顺序执行
常用的判断符:<、>、==、!=、>=、<=
38、end ""
end;
强制结束脚本
二、输入输出
1、mes "s"
mes "你好";
在NPC对话框中显示"你好"
7、input ""
input @value;产生一个输入框,输入的内容赋值在@value变量中
变量可以是数字,也可以是字符(好像不能为字符,请索克兄帮忙,偶不搞不定了)
54、announce "si"
announce "你好" 3;
在服务器内用黄色字体广播"你好"
广播命令,可以控制广播内容和广播颜色 3:黄色 19:蓝色
55、mapannounce "ssi"
mapannounce "prontera.gat" "你好" 3;
在普隆德拉地图内内用黄色字体广播"你好" 地图广播命令,可以指定地图
56、areaannounce "siiiisi"
areaannounce "prontera.gat" 100 100 10 10 "你好" 3;
在普隆德拉X100Y100,X+-10,Y+-10的区域内内用黄色字体广播"你好"
区域广播,可以使得特定区域的玩家看到系统消息
三、注意事项
1、goto语句的标号是区分大小写的，若出错则会使map-server死掉，且不会自动重启
2、一行显示一般为37个字符，超出的话偶也不知道会发生什么事

请阅读以下范例，以加强对基本流程及mes语句使用方法的了解。
例1，发钱的hack
// 里面有几个命令是偶们还没有学过的，不过没有关系，很容易理解，
// delitem 2278,1; 表示删除2278号物品1个
// set Zeny,Zeny+200000; 表示增加200000块钱
// 特别需要注意的是你的Goto语句，如果出现错误可能会使服务器当机，特别要注意大小写
prontera.gat,155,174,4 script 发钱的hack 706,{
mes "[发钱的hack]";
mes "嘿嘿！哇呀呀！";
mes "我是^5577FF发钱的hack^000000。";
mes "我愿意拿钱和你换一些东西。";
next;
menu "询问 ^3355FF笑脸面具^000000 换钱的一些信息",Case1,"拿

 ^3355FF笑脸面具^000000 换钱",Case2,"拿 ^3355FF兔耳发圈^000000
              换钱",Case4,"取消",Case3;
Case1:
mes "[发钱的hack]";
mes "你有笑脸面具吗？ ";
mes "我朋友^5577FF乖宝宝^000000想要几个面具来玩。";
mes "可是我没有材料去制作啊。";
mes "你有已经制成的面具吗？";
mes "我可以拿很多钱跟你换哦！";
next;
mes "[发钱的hack]";
mes "制作^3355FF笑脸面具^000000";
mes "需要搜集一些物品.";
mes "你如果能搜集到这些材料";
mes "就可以去找微笑小姐做成笑脸面具";
mes "下面是制作^3355FF笑脸面具^000000所需要的一些道具.";
next;
mes "[发钱的hack]";
mes "10个^3355FF杰比勒结晶^000000";
mes "10个^3355FF毛^000000";
mes "10个^3355FF三叶幸运草^000000";
next;
mes "[发钱的hack]";
mes "做好了拿来给我，我就给你大把大把的钱！ ";
close;
Case2:
if(countitem(2278)<1) goto Case2NOT;
mes "[发钱的hack]";
mes "哈哈，^5577FF乖宝宝^000000一定会很高兴的~:)";
mes "那么^3355FF笑脸面具^000000。我拿走了!.";
next;
delitem 2278,1;
set Zeny,Zeny+200000;
mes "[发钱的hack]";
mes "拿好咯！";
mes "这里是答应你的^5577FF200000Z^000000";
mes "如果你还有笑脸面具，还可以拿过来和我换。";
mes "好东西我不嫌多！";
close;
Case2NOT:
mes "[发钱的hack]";
mes "我";
next;
mes "[发钱的hack]";
mes "要";
next;
mes "[发钱的hack]";
mes "笑";
next;
mes "[发钱的hack]";
mes "脸";
next;
mes "[发钱的hack]";
mes "面";
next;
mes "[发钱的hack]";
mes "具";
close;
//狸猫的猫耳发圈掉落率是2
Case4:
if(countitem(2214)<1) goto Case4NOT;
mes "[hack]";
mes "哈哈，高兴~:)";
mes "那么^3355FF兔耳发圈^000000。我拿走了!.";
next;
delitem 2214,1;
set Zeny,Zeny+20000000;
mes "[发钱的hack]";
mes "拿好咯！";
mes "这里是答应你的^5577FF20000000Z^000000";
mes "如果你还有兔耳发圈，还可以拿过来和我换。";
mes "好东西我不嫌多！";
close;
Case4NOT:
mes "[发钱的hack]";
mes "我";
next;
mes "[发钱的hack]";
mes "要";
next;
mes "[发钱的hack]";
mes "的";
next;
mes "[发钱的hack]";
mes "是";
next;
mes "[发钱的hack]";
mes "兔";
next;
mes "[发钱的hack]";
mes "耳";
next;
mes "[发钱的hack]";
mes "发";
next;
mes "[发钱的hack]";
mes "圈";
close;
Case3:
mes "[发钱的hack]";
mes "再见，再见";
next;
mes "[发钱的hack]";
mes "白白，白白";
close;
}

第三讲预告，属性控制指令
第二讲作业
1.制作一个"Hello, world!" NPC
2.制作一个广播员置于首都中央，交200000块钱就可以发一条自己的广播。

(目前偶只会输入数字,建议设定好几条固定消息选择,等索克兄来了,偶问问他input怎么用)
3.密码看门人:输入正确的密码后才可以进入此房间


第三讲 属性相关指令

Athena脚本制作讲座(三)----属性相关指令 Hack 编写
第三讲 属性相关指令
(参考索克的脚本可用命令)

6、jobchange "i"
jobchange 0;转职成初心者
0:初学者 7:骑士 14:十字军
1:剑士 8:牧师 15:武僧
2:法師 9:魔法师 16:贤者
3:弓箭手 10:铁匠 17:流氓
4:服士 11:猎人 18:炼金术士
5:商人 12:刺客 19:诗人
6:盗賊 13:骑士《骑鸟状态》 20:舞者
21:十字军《骑鸟状态》22.结婚造型 23.超级初心者
10、setlook "ii"
设置发型发色命令
具体可以看一下现有脚本
11、set,"ii"
set @value,1;将1赋值到@value
可以给自定义变量或系统变量赋值
系统变量如下:
StatusPoint
BaseLevel
SkillPoint
Class
Zeny
Sex
Weight
MaxWeight
JobLevel
BaseExp
JobExp
NextBaseExp
NextJobExp
Hp
MaxHp
Sp
MaxSp
例: set Zeny,Zeny+200000; 表示增加200000块钱
除去系统变量外,l或@开头的为每个玩家的变量,$开头的为每个地图的变量,
无上述前缀且非系统变量的为全局变量

15、cutin "si"
显示NPC的大图片,比如卡普拉那些漂亮MM
具体参数可以参考自带脚本
17、heal "ii" heal 100,100;回复100HP、100SP
按数值回复
19、percentheal "ii" heal 100,100;
回复HP100%、SP100%
按比例回复
22、checkweight "ii"
两个参数分别为:物品代码和数量,
命令作用是检查拿了这些物品后是否超重,
若超重则返回0,否则返回1
22、readparam","i"
读取参数
支持的变量在const.txt中说明
23、strcharinfo,"i"
人物信息读取,目前仅支持strcharinfo(0),
返回值为人物名称
33、bonus "ii"
得到一个附加bonus
34、bonus2 "iii"
补充、bonus3 "iiii"
以上三个命令用法见另一帖 dispbbs.asp?boardID=3&ID=3129&page=1
35、skill "ii*"
参数为:技能代码,等级,(标识1)
例如: skill 140,1,0; 学习第140号技能,等级为1,技能代码参看skill_db
36、getskilllv "i"
获取技能等级
37、basicskillcheck "*"
读取battle_athena.conf中basic_skill_check项的值,并返回
39、setoption "i" setoption 0;
回复普通,无任何特殊状态无手推车无鹰无骑鸟
设置状态,参数请参考GM命令@option的Z项
在实际使用中,需要注意的是,状态可以叠加
例如:setoption 3;3=1+2,于是结果就是火狩+隐匿
z = 01 火狩
z = 02 隱暱
z = 04 隱身
z = 08 手推車
z = 16 带老鹰
z = 32 骑鸟
z = 64 隱身
62、sc_start "iii"
特殊状态开启
三个参数分别为:类型,参数1(技能等级),参数2(暂时未用)
例如
sc_start SC_FREEZE,1,0; //变成冰冻状态
支持的状态表另外再发,可以先参看skill_db,状态都是把_前面改成SC

63、sc_end "i"
特殊状态关闭

67、resetstatus ""
resetstatus;
重置所有属性点
68、resetskill ""
resetskill;
重置所有技能点
69、changebase "i"
改变人物显示的职业,但实际职业不变,可用于结婚系统
如:changebase 22; //变成结婚人物形象
补充
statusup i
statusup2 ii
参数提升指令(str,vit,agi,dex,agi,luk)
statusup bStr; 参数提升1点
statusup bStr,10;参数提升10点
bStr,bAgi,bVit,bInt,bDex,bLuk其他可查看const.txt

例1:重置辅助人员(已包括在npc目录中)
//By GeisHa
prontera.gat,146,192,4 script 重置辅助人员 763,{
mes "[重置辅助人员]";
mes "我专门负责重置点数";
mes "你想重置什么呢？";
next;
menu "^FF3355技能点(费用50w)^000000",L1,"^FF3355属性点(费用50w)^000000",L2

,"^FF3355技能点和属性点(费用80w)^000000",L3,"取消",LEnd;

L1:
if (Zeny<500000) goto NeedZenys;
mes "[重置辅助人员]";
mes "已经重置好了";
mes "^FF3355请好好分配^000000";
set Zeny,Zeny-500000;
resetskill;
close;
L2:
if (Zeny<500000) goto NeedZenys;
mes "[重置辅助人员]";
mes "已经重置好了";
mes "^FF3355请好好分配^000000";
set Zeny,Zeny-500000;
resetstatus;
close;
L3:
if (Zeny<800000) goto NeedZenys;
mes "[重置辅助人员]";
mes "已经重置好了";
mes "^FF3355请好好分配^000000";
set Zeny,Zeny-800000;
resetstatus;
resetskill;
close;
NeedZenys:
mes "[重置辅助人员]";
mes "穷人不要来凑热闹！影响我做生意";
close;
LEnd:
close;
}

第四讲预告,物品相关指令
第三讲作业
1.转生脚本: 即lv99级可以转生为超级初心者,所有参数设为初心者状态
附参考资料 dispbbs.asp?BoardID=3&ID=1986


第四讲 物品相关指令

Athena脚本制作讲座(四)----物品相关指令 Hack 编写
第四讲 物品相关指令
(参考索克的脚本可用指令)
13、getitem "ii"
getitem 501,1;取得红色药水1个
道具代码请查看item_db.txt
14、delitem "ii"
delitem 501,1;删除红色药水1个
请在执行这条语句前确定是否有该项物品 不然可能发生未知错误
18、itemheal "ii"
可能与道具损坏有关
具体用法不明,武器损坏还没开放
21、countitem "i"
if(countitem(501)==1) goto L_YES;
如果红色药水数量为1,跳转到L_YES 否则顺序执行
物品语句统计命令,在()内填入想检查的物品代码
24、getequipname","i"
getequipname(1);
按照精练时列出的装备顺序取第1个(头1),以次类推 取得装备名,一般用于判断
25、getequipisequiped "i"
getequipisequiped(1);
判断头1是否有装备 序号同上
26、getequipisenableref "i"
getequipisenableref(1);
判断头1上的装备是否可精练 序号同上
27、getequipisidentify "i"
getequipisidentify(1);
判断头1的装备是否鉴定过
有些奇怪的命令,没鉴定的装备怎么装备呢
28、getequiprefinerycnt "i"
if(getequiprefinerycnt(1)<10) goto L_YES;
如果头1的精练<10,跳转到L_YES 判断装备是否达到预定精练值
29、getequipweaponlv "i"
if(getequipweaponlv(1)>0) goto L_YES;
判断头1是否是武器 判断武器等级,小于1为防具,1为1级武器,2为2级武器,依此类推
30、getequippercentrefinery "i"
if(getequippercentrefinery(1)==100) goto L_YES;
判断头1的装备是否到达安定值
这里需要读取refine_db.txt中的数据以判断是否到达安定值
在实际使用中,可以用rand(100)得到1个随机数与已知安定值比较以判定是否精练成功
31、successrefitem "i"
successrefitem 1;
将头1装备升1级 装备升级语句
32、failedrefitem "i" failedrefitem 1;
将头1装备做精练失败处理
40、setcart ""
setcart;
得到手推车,限定商人铁匠
41、setfalcon ""
setfalcon;
得到猎鹰,限定猎人
42、setriding ""
setriding;
得到骑乘的大嘴鸟或嘟嘟鸟,限定骑士十字军
44、openstorage ""
openstorage;
原地打开仓库
45、itemskill "iis"
三个参数分别为技能代码,技能等级,和名称
46、produce "i"
制造物品,参数为物品等级,
具体等级可以查看produce_db.txt

例1,精炼+20的脚本
cmd_in01.gat,127,81,8 script 神秘人 731,{
mes"[神秘人]";
mes"很久没看到猫妹妹了，你有她的照片吗？";
next;
mes"[神秘人]";
mes"有的话我可以帮你把物品安全+20";
next;
mes"[神秘人]";
mes"说吧！你想要锻治装置项目";
mes"中的哪一项物品呢？";
next;
menu getequipname(1),L_MENU_1,getequipname(2),L_MENU_2,getequipname(3),

L_MENU_3,getequipname(4),L_MENU_4,getequipname(5),L_MENU_5,getequipname(6),

L_MENU_6,getequipname(7),L_MENU_7,getequipname(8),L_MENU_8,getequipname(9),

L_MENU_9,getequipname(10),L_MENU_10;
L_MENU_1:
set @part,1;
if (getequipisequiped(1)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_2:
set @part,2;
if (getequipisequiped(2)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_3:
set @part,3;
if (getequipisequiped(3)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_4:
set @part,4;
if (getequipisequiped(4)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_5:
set @part,5;
if (getequipisequiped(5)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_6:
set @part,6;
if (getequipisequiped(6)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_7:
set @part,7;
if (getequipisequiped(7)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_8:
set @part,8;
if (getequipisequiped(8)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_9:
set @part,9;
if (getequipisequiped(9)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_MENU_10:
set @part,10;
if (getequipisequiped(10)) goto L_START_1;
mes"[神秘人]";
mes"有毛病啊!";
goto L_CLOSE;
L_START_1:
if (getequipisenableref(@part)) goto L_START_2;
mes"[神秘人]";
mes"这个项目是无法锻治的。";
mes"我想我师傅应该可以";
goto L_CLOSE;
L_START_2:
if (getequipisidentify(@part)) goto L_START_3;
mes"[神秘人]";
mes"这个还没通过鉴定，无法锻治。";
goto L_CLOSE;
L_START_3:
if (getequiprefinerycnt(@part) < 20) goto L_REFINE_0;
mes"[ 神秘人]";
mes"还想炼？你有毛病啊！";
goto L_CLOSE;
L_REFINE_0:
L_0_SUB:
L_REFINE_1:
if (countitem(4131) < 1) goto L_CANCEL_2;
delitem 4131,1;
L_1_SUB:
L_REFINE_2:
L_2_SUB:
L_REFINE_3:
L_3_SUB:
L_REFINE_4:
L_4_SUB:
L_REFINE_5:
mes"[神秘人]";
mes" 锵！锵！锵！";
mes" 锵！锵！锵！锵！";
successrefitem @part;
mes" 宝刀未老啊！";
goto L_CLOSE;
L_REFINE_6:
L_CANCEL_1:
L_CANCEL_2:
mes"[神秘人]";
mes" 拿到照片再来吧！";
goto L_CLOSE;
L_CANCEL_3:
mes"[神秘人]";
mes" ......";
L_CLOSE:
close;
}
第五讲预告,地图相关指令
第四讲作业
1.物品打孔NPC.提示:物品上加孔是不可能的,但是可以通过删除无孔物品,增加有孔物品的方式来实现,
因为某些物品是没有孔的,所以本作业可以仅实现几样物品就可以了


第五讲 地图相关指令

Athena脚本制作讲座(五)----地图相关指令 Hack 编写

第五讲 地图相关指令

16、viewpoint "iiiii"
viewpoint 1,134,221,1,0x00ffff;
以颜色0x00ffff标记小地图上的坐标X134Y221
43、savepoint "sii"
savepoint "prontera.gat" 100 100;
在普隆德拉X100Y100的地点做记录
存储记录点
8、warp "sii"
warp "prontera.gat",100,100;传送至普隆德拉X100Y100的地方
地图名必须加""
9、areawarp "siiiisii"
areawarp "<origin map>",X0,Y0,X1,Y1,"<destination map>",X,Y
将X0,Y0-X1,Y1区域的所有玩家都传送到目标地图的X,Y
72、setmapflagnosave "ssii"
参数:原地图名,存储地图名,存储X位置,存储Y位置
例:setmapflagnosave "force_1-1.gat","prontera.gat",156,191
设置force_1-1.gat地图为不可储存,并把储存点设为prontera.gat,156,191
73、setmapflag "si"
功能:设置地图属性(无nosave)
参数:地图名,属性代码
属性代码从1开始依次为
NOMEMO,NOTELEPORT,NOSAVE,NOBRANCH,NOPENALTY,
PVP,PVP_NOPARTY,PVP_NOGUILD,GVG,GVG_NOPARTY
PVP和GVG无效果
74、removemapflag "si"
功能:取消地图属性(无nosave)
参数:地图名,属性代码
用法参考73
75、pvpon "s"
pvpon "prontera.gat";
开启普隆德拉的即时PK 开启PVP
76、pvpoff "s"
pvpoff "prontera.gat";
关闭普隆德拉的即时PK 关闭PVP
77、gvgon "s"
gvgon "prontera.gat";
开启地图工会PK
78、gvgoff "s"
gvgoff "prontera.gat";
关闭地图工会pk


第六讲 怪物相关指令

Athena脚本制作讲座(六)----怪物及宠物相关指令 Hack 编写

第六讲 怪物相关指令

47、monster "siisii*"
monster "prontera.gat" 100 100 "天使波利" 1096 1;
在普隆德拉X100Y100的地方放出1只天使波利,命名为"天使波利"
召唤怪物命令,在指定地图指定地点放出指定怪物,可控制召唤数量
在这里有一个特殊名字"--ja--",定义为mob_db中默认的JName
48、areamonster "siiiisii*"
areamonster "prontera.gat" 100 100 10 10 "天使波利" 1096 1;
在普隆德拉X100Y100,X+-10,Y+-10区域内召唤1只天使波利,命名为"天使波利"
区域招怪命令
49、killmonster "ss"
killmonster "prontera.gat" "s";
将普隆德拉地图内所有MOB_DATA为"s"的魔物都杀死
65、pet "i"
pet 1002;
抓取1只宠物波利
抓取宠物,即获取一个宠物蛋
66、bpet ""
孵化一个宠物蛋

例1,测试怪物专用NPC(取自RO另类)
//by GeisHa
prontera.gat,163,176,4 script 测试怪物专用NPC 734,{
mes "[测试怪物专用NPC]";
mes "我是测试怪物专用NPC";
mes "专为大家测试怪物而设立的";
next;
mes "[测试怪物专用NPC]";
mes "你想在哪里测试怪物？";
next;
menu "首都西门",L_MENU_1,"首都东门",L_MENU_2,"首都南门",L_MENU_3,"首都北门",L_MENU_4;
L_MENU_1:
mes "[测试怪物专用NPC]";
mes "请输入你想测试的怪物ID";
mes "有效怪物ID为^FF33551001～1392^000000";
mes "其中^FF33551324～1363^000000为宝箱";
next;
input a;
mes "[测试怪物专用NPC]";
mes "请输入你想测试的怪物数量";
mes "建议输入500，哈哈哈！！！";
next;
input b;
if (a < 1001) goto L_TSET;
if (a > 1392) goto L_TSET;
monster "prt_fild05.gat",338,216,"Monster_Test",a,b,"Monster_Test";
next;
mes "[测试怪物专用NPC]";
mes "现在是否要移动过去？";
menu "是",-,"不是",L_CLOSE;
mes "[测试怪物专用NPC]";
mes "冲啊!!!";
next;
warp "prt_fild05",367,206;
close;
L_MENU_2:
mes "[测试怪物专用NPC]";
mes "请输入你想测试的怪物ID";
mes "有效怪物ID为^FF33551001～1392^000000";
mes "其中^FF33551324～1363^000000为宝箱";
next;
input a;
mes "[测试怪物专用NPC]";
mes "请输入你想测试的怪物数量";
mes "建议输入500，哈哈哈！！！";
next;
input b;
if (a < 1001) goto L_TSET;
if (a > 1392) goto L_TSET;
monster "prt_fild06.gat",55,195,"Monster_Test",a,b,"Monster_Test";
next;
mes "[测试怪物专用NPC]";
mes "现在是否要移动过去？";
menu "是",-,"不是",L_CLOSE;
mes "[测试怪物专用NPC]";
mes "冲啊!!!";
next;
warp "prt_fild06",31,193;
close;
L_MENU_3:
mes "[测试怪物专用NPC]";
mes "请输入你想测试的怪物ID";
mes "有效怪物ID为^FF33551001～1392^000000";
mes "其中^FF33551324～1363^000000为宝箱";
next;
input a;
mes "[测试怪物专用NPC]";
mes "请输入你想测试的怪物数量";
mes "建议输入500，哈哈哈！！！";
next;
input b;
if (a < 1001) goto L_TSET;
if (a > 1392) goto L_TSET;
monster "prt_fild08.gat",170,350,"Monster_Test",a,b,"Monster_Test";
next;
mes "[测试怪物专用NPC]";
mes "现在是否要移动过去？";
menu "是",-,"不是",L_CLOSE;
mes "[测试怪物专用NPC]";
mes "冲啊!!!";
next;
warp "prt_fild08",170,370;
close;
L_MENU_4:
mes "[测试怪物专用NPC]";
mes "请输入你想测试的怪物ID";
mes "有效怪物ID为^FF33551001～1392^000000";
mes "其中^FF33551324～1363^000000为宝箱";
next;
input a;
mes "[测试怪物专用NPC]";
mes "请输入你想测试的怪物数量";
mes "建议输入500，哈哈哈！！！";
next;
input b;
if (a < 1001) goto L_TSET;
if (a > 1392) goto L_TSET;
monster "prt_fild01.gat",201,73,"Monster_Test",a,b,"Monster_Test";
next;
mes "[测试怪物专用NPC]";
mes "现在是否要移动过去？";
menu "是",-,"不是",L_CLOSE;
mes "[测试怪物专用NPC]";
mes "冲啊!!!";
next;
warp "prt_fild01",200,47;
close;
L_TSET:
mes "[测试怪物专用NPC]";
mes "^FF3355你输入的怪物ID出错^000000";
mes "有效怪物ID为^FF33551001～1392^000000";
mes "其中^FF33551324～1363^000000为宝箱";
close;
L_CLOSE:
mes "[测试怪物专用NPC]";
mes "好吧";
close;
close;
}


第七讲 其他高级指令

Athena脚本制作讲座(七)----其他高级指令 Hack 编写
第七讲 其他高级指令
(参考索克的脚本可用指令)
艾力克斯催的急啊,先写脚本啦,
好多命令都没详细说明,慢慢改吧!
20、rand "i*"
产生一个随机数
具体用法不明
50、doevent "s"
具体用法不明
51、addtimer "is"
添加一个定时器
第一参数为时间,单位毫秒
第二参数为事件名,可自定义
52、deltimer "s"
删除一个定时器
当定时器被定义后如果判定不要使用,用此命令删除
如果不执行删除动作,后果不明
53、addtimer "si"
统计定时器
具体用法不明
57、getusers "i"
取得服务器在线玩家人数
具体用法不明
58、getmapusers "s"
getmapusers("prontera.gat");
取得普隆德拉地图玩家人数
可以得到指定地图上的玩家人数
59、getareausers "siiii"
getareausers("prontera.gat" 100 100 10 10);
取得在普隆德拉X100Y100,X+-10,Y+-10的区域内的玩家人数
待测试
60、enablenpc "s"
控制NPC是否出现
具体用法不明
61、disablenpc "s"
控制NPC是否出现
具体用法不明
64、debugmes "s"
debugmes "测试成功";
在Map-Server的DOS窗口中输出信息"测试成功"
Debug输出命令,可以输出字符串或直接使用变量
例如debugmes @value;将变量@value中的值输出
70、waitingroom "si*"
waitingroom "等待比尔" 0;
开启一个名叫"等待比尔"的聊天室,可容纳人数0 开启聊天室命令,可当作招牌
71、warpwaitingpc "sii"
具体用法不明

例1,艾力克斯的创意
"我想寫一個NPC，
跟那人物對話過後他會要玩家去打敗他所召喚出來的怪物，
如果不幸敗陣了，
那麼被NPC召喚出來的怪物就會自動消失，
如果戰勝，
那剛才召喚怪物的NPC就會自動向你對話並且送給當初和他對話的人一樣禮物，
而且這個任務不論失敗與否每個人物都只能進行一次。"
---- 艾力克斯

//禁止 memo teleport save
prt_are_in.gat mapflag nomemo dummy
prt_are_in.gat mapflag noteleport dummy
prt_are_in.gat mapflag nosave prontera.gat,156,191
force_1-1.gat mapflag nomemo dummy
force_1-1.gat mapflag noteleport dummy
force_1-1.gat mapflag nosave prontera.gat,156,191
//主NPC,放在普隆XX中间
prontera.gat,160,180,6 script 艾力克斯 116,{
mes "你想要进入艾力克斯的怪物魔境吗?"; //此处可以添加判断,以确定每人只能进一次
next;
menu "偶还是宝宝耶,不要打太疼哦!",L_GOARENA1,"偶是猛将兄,警告你哦,

不惹我哦!!!",L_GOARENA2,"不要啦,偶怕怕!",L_YAME1;
L_GOARENA1:
if( getmapusers("force_1-1.gat")>0 ) goto L_WAIT1;
disablenpc "ThatsIt";
addtimer 5000,"might-test1";
disablenpc "艾力克斯";
warp "force_1-1.gat",25,26;
end;
L_GOARENA2:
if( getmapusers("force_1-1.gat")>0 ) goto L_WAIT1;
disablenpc "ThatsIt";
addtimer 5000,"might-test3";
disablenpc "艾力克斯";
warp "force_1-1.gat",25,26;
end;
L_WAIT1:
mes "艾力克斯的怪物魔境有MM在换衣服耶,";
mes "不许偷看!!!";
L_YAME1:
close;
}

//宝宝级
force_1-1.gat,25,26,0 script might-test1 -1,{
killmonster "force_1-1.gat","might-test2";
killmonster "force_1-1.gat","might-test4";
monster "force_1-1.gat",25,25,"--ja--",1002,1,"might-test2";
monster "force_1-1.gat",20,25,"--ja--",1002,1,"might-test2";
monster "force_1-1.gat",25,20,"--ja--",1002,1,"might-test2";
monster "force_1-1.gat",30,25,"--ja--",1002,1,"might-test2";
monster "force_1-1.gat",25,30,"--ja--",1002,1,"might-test2";
set $might00,5;
}
//检查怪物是否死光光
force_1-1.gat,25,26,0 script might-test2 -1,{
set $might00, $might00 - 1;
if( $might00 > 0 ) goto L_CONT1;
announce "你成功了耶!",3;
enablenpc "ThatsIt";
L_CONT1:
end;
}
//猛将级
force_1-1.gat,26,27,0 script might-test3 -1,{
killmonster "force_1-1.gat","might-test2";
killmonster "force_1-1.gat","might-test4";
monster "force_1-1.gat",26,27,"--ja--",1147,1,"might-test4";
set $might01,1;
}
//检查怪物是否死光光
force_1-1.gat,25,26,0 script might-test4 -1,{
set $might01, $might00 - 1;
if( $might01 > 0 ) goto L_CONT1;
announce "你成功了耶!",3;
enablenpc "ThatsIt";
L_CONT1:
end;
}
//end of fight
force_1-1.gat,25,26,6 script ThatsIt 116,{
mes "太好了!!!";
mes "你成功闯过了Alex的怪物魔境";
mes "希望你有一个美好的回忆哦^^";
mes "偶来送你回首都吧."; //此处可以添加奖励物品
next;
enablenpc "艾力克斯";
warp "prontera.gat",156,191;
close;
}


第八讲 事件触发及计时指令

补充:Athena脚本制作讲座(八)----事件触发及计时指令 Hack 编写
第八讲 事件触发及计时指令
一、事件触发及计时指令
1.doevent 执行某事件
例1:
prontera.gat,155,180,0 script ev_doevent 116,{
doevent "event_test";
}
prontera.gat,150,185,0 script event_test -1,{
announce " 工会战开启!!!",15;
close;
}
event_test的类型定义为了-1，表示是一个事件而不是NPC，
访问ev_doevent这个NPC之后，将会执行event_test这个事件。
2.执行召唤monster事件
例2:
prontera.gat,150,185,0 script ev_mobevent 116,{
monster "this",0,0,"Event_Mob2",1002,1,"event_test";
}
访问这个NPC之后将会召唤出可爱的小波利
3.将怪杀死后执行某事件
例3:
prontera.gat,150,180,0 monster Event_Mob 1008,1,0,0,event_test3
prontera.gat,150,185,0 script event_test3 -1,{
announce " 华丽金属被破坏！",15;
close;
}
4.addtimer 定时器
用法：addtimer 时间,"事件名::标号"
注：时间以毫秒为单位，标号必须以On开头
例4:
prontera.gat,155,185,0 script ev_timerevent 116,{
addtimer 5000,"ev_timerevent::OnTimer";
end;
OnTimer:
announce "还有5秒钟将关闭工会战",15;
close;
}
5.OnInit NPC初始化事件
例5:
prontera.gat,145,180,0 script ev_initevent 116,{
end;
OnInit:
waitingroom "OnInit测试",1,"ev_initevent::OnMax";
end;
OnMax:
warpwaitingpc "prontera.gat",155,190;
end;
}
初始化时开启一个聊天室，此处用到了waitingroom的第三个参数，
仍然是一个事件参数，有兴趣的可以实际测试一下效果。
6.指定时间执行
例7:
prontera.gat,145,185,0 script ev_clockevent 116,{
end;
// 每个小时的第5分钟执行
OnMinute05:
announce "每个小时的第5分钟到了！",15;
end;
// 每天12点执行
OnHour12:
announce "中午到了！！",15;
end;
// 23点59分执行
OnClock2359:
announce "还有一分钟就要到明天了！！",15;
end;
// 2月14日零时执行
OnDate0214:
announce "又是一个情人节了，请Kiss旁边最近的MM！！",8;
end;
}

二、事件的写法
例8:
// 最简单的事件
prontera.gat,150,185,0 script event_test -1,{
announce strcharinfo(0) + " 召唤怪兽成功！",16;
close;
}
// 仅对范围5格内的有效(待测试)
prontera.gat,155,180,0 script event_test2 -1,5,5 {
announce "仅对范围5格内的有效",16;
close;
}
// 效果不明
prontera.gat,150,180,0 script event_test3 -1,-1,-1 {
mes "偶不知道什么效果耶！";
close;
}
三、禁止某些功能
prontera.gat mapflag nosave prontera.gat,156,190
禁止存储，把存储点设为prontera.gat,156,190
prontera.gat mapflag nomemo dummy
禁止记录(服事系列传送技能)
prontera.gat mapflag noteleport dummy
禁止使用苍蝇、蝴蝶，也禁止飞。
其他设置参看mapflag.txt


第九讲 新增的脚本功能介绍

Athena脚本讲座(九)----近期新增的脚本功能介绍 Hack 编写

第九讲 新增的脚本功能介绍(Athena-C137后)

一.数组
1.[]
和C语言用法相同,
在变量后面加上[],表示数组下标,
若不加[],表示数组的第一个元素[0]
2.setarray 起始变量,数值1,数值2,...
赋值操作,把列出的值依次赋给起始变量开始的N个元素
3.getarraysize()
取元素个数
4.copyarray
把一个数组复制到另一个上
5.deletearray 起始变量,N
删除从起始变量起N个元素,之后元素前移

数组使用示例:
prontera.gat,164,190,1 script 数组使用示例 112,{
set @hoge[0],1;
set @hoge[1],5;
mes "请输入hoge[2]";
next;
input @hoge[2];
mes "hoge => " + @hoge;
mes "hoge[0]=> " + @hoge[0];
mes "hoge[1]=> " + @hoge[1];
mes "hoge[2]=> " + @hoge[2];
next;
setarray @hoge[1],2,3,4,5;
mes "true: 5,1,2,3,4,5";
mes "hoge size = "+ getarraysize(@hoge);
mes "hoge[0]=> " + @hoge[0];
mes "hoge[1]=> " + @hoge[1];
mes "hoge[2]=> " + @hoge[2];
mes "hoge[3]=> " + @hoge[3];
mes "hoge[4]=> " + @hoge[4];
next;
copyarray @fuga[0],@hoge[2],2;
mes "true: 3,4,0";
mes "fuga[0]=> " + @fuga[0];
mes "fuga[1]=> " + @fuga[1];
mes "fuga[2]=> " + @fuga[2];
next;
deletearray @hoge[1],2;
mes "true: 1,4,5,0";
mes "hoge[0]=> " + @hoge[0];
mes "hoge[1]=> " + @hoge[1];
mes "hoge[2]=> " + @hoge[2];
mes "hoge[3]=> " + @hoge[3];

close;
}

二.函数与过程
1.callfunc
调用函数,可有返回值
2.callsub
调用过程,无返回值

函数与过程示例:

// 无返回值的函数
function script func001 {
mes "无返回值的函数";
next;
return; // 无返回值的函数
}

// 有返回值的函数
function script func002 {
return "有返回值的函数";
}

// 函数与过程示例
prontera.gat,168,189,1 script 函数与过程示例 112,{
callfunc "func001"; // 调用无返回值的函数
mes callfunc("func002"); // 调用有返回值的函数
next;
callsub L_SUB001; // 调用过程
close;
end;

L_SUB001:
mes "过程示例";
return; // 无返回值
}

三.时间日期事件
1.OnSecond%02d
2.OnMinute%02d
3.OnClock%02d%02d
4.OnDateTime%02d%02d%02d%02d
5.OnDayTime%02d%02d%02d
6.OnWeekTime%02d%02d%02d

例: OnDateTime06011200 表示6月1日12:00执行以下脚本
OnDayTime161235 表示每个月16号12:35分执行以下脚本
OnWeekTime001200 表示星期天12:00执行以下脚本
OnWeekTime061200 表示星期六12:00执行以下脚本
增加以上命令,便于安排工会战时间

四.item_db新增脚本执行功能
item_db每行最后可以有四个{},{},{},{}, 最后的空{}可以省略
分别表示使用物品,装备物品后人物属性变化,装备上物品时和卸下物品时执行的脚本命令

1.使用物品
例:
把item_db.txt中苹果行改为
512,Apple,苹果,0,15,,20,,,,,10477567,2,,,,,{ doevent "Apple_Event";
              },{}
并增加一个脚本
prontera.gat,116,74,0 script Apple_Event -1,{
Announce strcharinfo(0)+"吃了个大苹果!",8;
End;
}
则每次吃苹果就会启动Apple_Event (调用事件中某段也可以,只要加上标号,如Apple_Event::OnEatApple)

2.装备物品后人物属性变化
此处仅能用简单修改属性的脚本, 因为每次人物属性变化时都会调用

3.装备上物品时和卸下物品时执行的脚本命令
例如把item_db.txt中短剑行改为:
1201,Knife,短剑,4,50,,400,17,,1,3,10444527,2,2,1,1,1,{},{},{ doevent
              "Knife_Event"; },{ doevent "Knife_Event2"; }
再加上以下脚本
prontera.gat,116,73,0 script Knife_Event -1,{
Announce "偶是"+strcharinfo(0)+"!",8;
Announce "今天阿爸阿妈给偶买了第一把剑,偶好开心啊,",8;
Announce "偶一定要好好练习,或许偶还有机会成为天下第一用剑高手捏!",8;
End;
}

prontera.gat,116,74,0 script Knife_Event2 -1,{
Announce "俺是"+strcharinfo(0)+"!",8;
Announce "别人给俺起了个名字叫做剑魔独孤求败,",8;
Announce "俺第一次拿剑便立志要成为天下第一高手",8;
Announce "但自从再无敌手之后,俺发誓今生不再用剑...",8;
End;
}


第十讲 结婚相关及人物移动指令介绍

第十讲,结婚相关脚本指令及人物移动指令介绍(C143后) －－－hack编写

结婚后,配偶char_id存储在char表中partner_id字段中

1.marriage
用法:marriage "人物名"
返回值为0表示失败,1表示成功
使用此命令时,双方必须同时在线,否则会失败

注:marriage仅需使用一次,使用效果为双方都结婚,但并不发结婚戒指,
而且此命令不检测性别.
例:
set Result, marriage("Hack");
if (Result>0) goto L_MarryOK;
if (Result==0) goto L_MarryFail;

2.divorce
用法:divorce
返回值为0表示失败,1表示成功
使用此命令时,双方必须同时在线,否则会失败

注:divorce仅需使用一次,使用效果为双方都离婚,并且删除结婚戒指
例:
set Result, divorce();
if (Result>0) goto L_DivorceOK;
if (Result==0) goto L_DivorceFail;

3.结婚戒指
2634,Unknown_Item,结婚戒指,5,,,0,,0,,0,10477567,1,136,,0,,{},{ skill 334,1; skill 336,1; }
2635,Unknown_Item,结婚戒指,5,,,0,,0,,0,10477567,0,136,,0,,{},{ skill 335,1; skill 336,1; }
配带戒指会增加相应技能,男的戒指为2634,女的戒指为2635
想见你为共同技能,使用效果为召唤配偶
保护你为GG技能,使用效果为增加MM的HP
为你牺牲为MM技能,使用效果为增加GG的SP,会有一个大大的心形效果哦

使用技能时,双方必须同时在线,否则会失败

4.人物移动指令
类似GM指令,无返回值
jumpto
jumptoid
recall
recallid

使用方法:
jumpto "GM01";
jumptoid 150001;
recall "GM01";
recallid 150001;

注:以上id全为char_id,非account_id


GM命令

GM命令帮助文件
-----------------------
命令使用方法:在聊天对话框内打入这些命令,不包括<>.
注:GM造型用右键点人可以踢人,也可以查看人物的account_id.

<公告类>

/b <信息> ---- 发送服务器公告，并且包括发送人姓名,为黄色字
/lb <信息> ---- 发送本地图公告，并且包括发送人姓名,为黄色字
/nb <信息> ---- 发送服务器公告，并且不包括发送人姓名,为黄色字
/nlb <信息> ---- 发送本地图公告，并且不包括发送人姓名,为黄色字
@kami <信息>　 ---- 同/b
@kamib <信息>　 ---- 发送服务器公告，并且不包括发送人姓名,为蓝色字

<信息类>

@who ---- 在线人物信息列表
@who2 ---- 在线人物信息列表
@who3 ---- 在线人物信息列表
@where <人物名称> ---- 显示人物当前位置

<控制类>

@die ---- 本人自杀
@alive ---- 本人复活
@kill <人物名称> ---- 杀死指定人物
@killid <char_id> ---- 杀死指定人物
@killid2 <account_id> ---- 杀死指定人物
@save ---- 把存储点设为当前位置
@load ---- 回到存储点
@memo ---- 存储记录点

@warp <地图名> <x> <y>
@rura <地图名> <x> <y>
@rura+ <地图名> <x> <y> <人物名>
/mm <地图名> <x> <y>
/mapmove <地图名> <x> <y>
瞬移到指定地点
例子:
@warp morocc 150 160 -> 瞬移到梦罗克 (X:150, Y:160)
@rura prontera 50 80 -> 瞬移到普隆德拉 (X:50, Y:80)
@rura+ prontera 50 80 Hack-> 把Hack瞬移到普隆德拉 (X:50, Y:80)

@jump <x> <y> ---- 瞬移到当前地图的X,Y位置

@jumpto <人物名称> ---- 瞬移到指定人物处
@jumptoid <人物char_id>
@jumptoid2 <人物account_id>
例子:
@jumpto Hack -> 瞬移到Hack当前位置

@go <数字> ---- 简化移动命令
0:首都 5:剑士村
1:梦罗克 6:钟楼
2:吉芬 7:圣诞村
3:裴扬 8:克魔岛
4:商人城 9:古城
10:天空之城 11:天津城
12:昆仑山 13:猿人部落
14:死亡之城 15:中国洛阳

@hide ---- GM隐身,完全看不到的隐身.

@heal <HP> <SP> ---- 恢复指定量的HP和SP. 不指定值则完全恢复.
@storage ---- 打开仓库
@gstorage ---- 打开工会仓库(可以把权限设为0,这样所有玩家都可使用)

@recall <人物名> ---- 召唤指定人物到身边
@recallid <char_id> ---- 召唤指定人物到身边
@recallid2 <account_id> ---- 召唤指定人物到身边
@recallall ---- 召唤所有人到身边
@revive <人物名> ---- 复活指定人物
@reviveid <char_id> ---- 复活指定人物
@reviveid2 <account_id> ---- 复活指定人物
@kick <人物名> ---- 踢指定人物下线
@kickid <char_id> ---- 踢指定人物下线
@kickid2 <account_id> ---- 踢指定人物下线

<怪物类>

@monster [召唤出的怪物名稱] [怪物代码] [召唤数量] [x坐标] [y坐标]
-- x坐标 y坐标可省略，省略＝在当前位置召唤
@killmonster [地图名] ---- 杀死指定地图上的所有怪,并且搞物品

(不输入地图名,表示当前地图)
@killmonster2 [地图名] ---- 杀死指定地图上的所有怪,但不掉物品

<地图类>

@pvpon ---- 开启即时PK。
@pvpoff ---- 解除即时pk。
@gvgon ---- 开启工会pk。
@gvgoff ---- 解除工会pk。
@agitstart ---- 开启攻城战。
@agitend ---- 关闭攻城战。

<CHARACTER CONTROL COMMANDS>

@Lvup [1-255] ---- 巜基本等级上升。
@jobLvup [1-50] ---- 巜职业等级上升。

@jobchange <职业ID> <高阶代码> ---- 0～23职业选择 0-2高阶代码
0:初学者 7:骑士 14:十字军
1:剑士 8:牧师 15:武僧
2:法師 9:魔法师 16:贤者
3:弓箭手 10:铁匠 17:流氓
4:服士 11:猎人 18:炼金术士
5:商人 12:刺客 19:诗人
6:盗賊 13:骑士《骑鸟状态》 20:舞者
21:十字军《骑鸟状态》22.结婚造型 23.超级初心者
高阶代码 0普通 1进阶二转 2宝宝

@option <x> <y> <z> ---- x y z 改变现有角色状态
例： @option 0 0 16 带老鹰
@option 0 0 32 十字军骑鸟
@option 0 0 8 拿小车
x = 01 石化 y = 01 中毒 z = 01 火狩
x = 02 冰冻 y = 02 背後霊 z = 02 隱暱
x = 03 头冒金星 y = 04 沉没状态 z = 04 隱身
x = 04 睡觉 y = 16 周围变暗 z = 08 手推車等级1
x = 06 暗闇(歩ける) z = 16 带老鹰
z = 32 骑鸟
z = 64 GM隱身
z = 128 手推車等级2
z = 256 手推車等级3
z = 512 手推車等级4
z = 1024 手推車等级5
z = 2048 变身为怪兽
z = 4096 变为结婚造型
z = 8192 光猎

@speed [1-999] ---- ～999移动速度，1表示为最快。

@model <发型> <发色> <衣服颜色>
转变人物造型

发型ID (0-17) 发色 (0-8) 衣服颜色 (0-4)
0 默认 0 默认
1 金色 1 红色
2 紫色 2 绿色
3 褐色 3 白色
4 绿色 4 褐色
5 蓝色
6 白色
7 黑色
8 红色

@stpoint [数字] ---- 增加Status point点数，
@skpoint [数字] ---- 增加技能点数(只增加点数，还是要自己手动加上去的)

@zeny [数字] ---- 增加钱￥￥￥￥

@str,@agi,@vit,@int,@dex,@luk [数字]---- 具体属性点上升点数(可以为负数)，

例： @str 98表示str上升99点， 注意属性最高到99点

@spiritball [数字] ---- 蓄气个数[1--1000]之间
@questskill [技能ID] ---- 学习一个新技能
@lostskill [技能ID] ---- 删除一个技能
例：@lostskill 144 删除移动恢复HP技能
技能ID:
剑士
144 = 移动HP恢复
145 = 攻击弱点
146 = 狂暴状态
魔法师
157 = 能量外套
弓箭手
147 = 制作箭
148 = 冲锋箭
服事
156 = 神圣之光
商人
153 = 手推车攻击
154 = 改装手推车
155 = 大声呐喊
盗贼
149 = 喷砂
150 = 后退回避
151 = 拣石头
152 = 扔石头

@allskill 学会所有技能

<工会组队类>

@guild <工会名> ---- 新建工会
@party <组队名> ---- 新建组队
@guildlvup [数字] ---- 工会等级上升。
@gstorage ---- 打开工会共有仓库(可以把权限设为0,这样所有玩家都可使用)

<物品类>

@item [物品代码] [数量] ---- 得到物品。(注意：此方式得到的宠物蛋不能孵化）
@item2 [物品代码][数量][是否鉴定][精练等级][属性][卡片1][卡片2][卡片3][卡片4]
@itemreset　　　　　　　 ---- 清除物品栏内所有物品。
@itemcheck ---- 检查当前装备的合法性
@refine [位置代码] [精炼值] ---- 精炼指定位置的装备（位置编号参见下表：）
例：@refine 256 10 帽子精练+10
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
| 头1 : 256 头2 ：512　 |
| 头3 : 1 身上： 16 |
| 右手: 2 左手： 32 |
| 肩膀： 4 脚部： 64 |
| 装饰：　8 装饰：128 |
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

@produce [武器代码] [属性代码] [星星角的数量]
-- 制造武器 属性代码 0=无 1=水 2=地 3=火 4=风 武器代码请参照item.txt
(注：是任何武器都能加属性和强悍，不限制于铁匠能打造的那些，^^)

<可爱宠物类>
@makepet [宠物蛋代码] ---- 制作宠物蛋，宠物蛋代码请看pet_db.txt。

建议不要使用，直接抓宠去，不至于这么懒吧^_^
@petfriendly [数字]---- 宠物亲密度変更(0-1000)
@pethungry [数字] ---- 宠物饥饿度(0-100)
@petrename [名字] ---- 宠物改名(如果服务器设置不能改1次以上，就不能重命名了)

<角色类>

@charjob <职业ID> <人物名> ---- 改变玩家职业,参看jobchange
@charjobid <职业ID> <char_id> ---- 改变玩家职业,参看jobchange
@charjobid2 <职业ID> <account_id> ---- 改变玩家职业,参看jobchange
@charbaselvl [数字] [玩家名] ---- 巜调节指定玩家的base等级。
@charbaselvlid [数字] [char_id] ---- 巜调节指定玩家的base等级。
@charbaselvlid2 [数字] [account_id] ---- 巜调节指定玩家的base等级。
@charjlvl [数字] [玩家名] ---- 巜调节指定玩家的Job等级。
@charjlvlid [数字] [char_id] ---- 巜调节指定玩家的Job等级。
@charjlvlid2 [数字] [account_id] ---- 巜调节指定玩家的Job等级。
@charstats [玩家名] ---- 巜列出指定玩家的加点情况，(如等级，属性数值，

身上的$$数目
@charstatsid [char_id] ---- 巜列出指定玩家的加点情况，(如等级，属性数值，

身上的$$数目
@charstatsid2 [account_id] ---- 巜列出指定玩家的加点情况，(如等级，属性数值，

身上的$$数目 等相关信息)
@charoption x y z [玩家名] ---- 巜调节指定玩家的状态(如中毒，骑鸟等，

参照前面的@option x y z命令)。
@charsave [地图名] [x坐标] [y坐标] [玩家名] ---- 巜指定玩家存储点。

<全局类>

@night ---- 黑夜
@day ---- 白天
@doom ---- 服务器内，除GM外，所有人死亡。
@doommap ---- 当前地图，除GM外，所有人死亡。
@raise ---- 复活服务器内所有人。
@raisemap ---- 复活当前地图内所有人。
@kick [玩家名字] ---- 巜踢指定玩家下线。
@kickall ---- 踢所有人下线。（包括自己）

<其他类>

@anticheat <开关> ---- @anticheat 1 表示打开外挂检测(占用资源),

@anticheat 0 表示关闭
@gat ---- 调试用途，查看周围坐标信息
@packet ---- 调试用途

--------摘自99nets


RO地图

lou_in02.rsw#洛阳区域#
lou_in01.rsw#洛阳区域#
lou_dun03.rsw#洛阳区域#
lou_dun02.rsw#洛阳区域#
lou_dun01.rsw#洛阳区域#
lou_fild01.rsw#洛阳区域#
louyang.rsw#洛阳区域#
valkyrie.rsw#死亡城区域#
nif_in.rsw#死亡城区域#
yggdrasil01.rsw#死亡城区域)#
nif_fild02.rsw#死亡城区域#
nif_fild01.rsw#死亡城区域)#
niflheim.rsw#死亡城区域#
um_dun01.rsw#丛林迷穴1#
um_dun02.rsw#丛林迷穴2#
um_in.rsw#部落内部#
um_fild01.rsw#原始丛林1#
um_fild02.rsw#原始丛林2#
um_fild03.rsw#原始丛林3#
um_fild04.rsw#原始丛林4#
umbala.rsw#猿人部落#
sec_in01.rsw#巴哈拉宫 内部#
sec_in02.rsw#巴哈拉宫 内部#
sec_pri.rsw#巴哈拉宫 反省的房间(监狱)#
gon_test.rsw#战斗场#
gon_dun01.rsw#西王母神殿#
gon_dun02.rsw#神仙的围棋台#
gon_dun03.rsw#武陵道院#
gon_fild01.rsw#昆仑原野#
gon_in.rsw#昆仑内部#
gonryun.rsw#神仙之岛 昆仑#
ama_test.rsw#摩摩塔乐 体验所#
ama_dun03.rsw#樱花城 地下庙堂#
ama_dun02.rsw#地下森 战场#
ama_dun01.rsw#榻榻米 迷宫#
ama_fild01.rsw#樱花城原野#
ama_in02.rsw#天水角内部#
ama_in01.rsw#樱花城内部#
amatsu.rsw#天水之国 樱花城#
alde_alche.rsw#炼金术师 转职所#
yuno_in05.rsw#伊美乐的心脏 动力室#
yuno_in04.rsw#朱诺 内部#
job_duncer.rsw#克魔岛 小剧场#
job_sage.rsw#贤者 转职 考试场#
job_cru.rsw#十字军 转职 考试场#
job_monk.rsw#圣 卡毕利那 修道院#
monk_test.rsw#圣 卡毕利那 修道院#
in_rogue.rsw#流氓工会 内部#
mag_dun02.rsw#诺可罗德#
mag_dun01.rsw#诺可罗德#
yuno_fild04.rsw#尔迈斯 瀑雷德#
yuno_fild03.rsw#尔迈斯 瀑雷德#
yuno_fild02.rsw#吉 海伊洛 别墅#
yuno_fild01.rsw#国界 检查站#
yuno_in03.rsw#朱诺 内部#
yuno_in02.rsw#贤者 城堡内部#
yuno_in01.rsw#朱诺 内部#
yuno.rsw#修发兹 共和国 首都 朱诺#
job_wiz.rsw#巫师转职 考场#
job_prist.rsw#祭司转职 考场#
job_knt.rsw#骑士转职 考场#
job_hunte.rsw#猎人转职 考场#
gld_dun04.rsw#地下工会 密穴#
gld_dun03.rsw#地下工会 密穴#
gld_dun02.rsw#地下工会 密穴#
gld_dun01.rsw#地下工会 密穴#
payg_cas05.rsw#青林湖泊 工会#
payg_cas04.rsw#青林湖泊 工会#
payg_cas03.rsw#青林湖泊 工会#
payg_cas02.rsw#青林湖泊 工会#
payg_cas01.rsw#青林湖泊 工会#
pay_gld.rsw#青林湖泊#
aldeg_cas05.rsw#露依纳 工会#
aldeg_cas04.rsw#露依纳 工会#
aldeg_cas03.rsw#露依纳 工会#
aldeg_cas02.rsw#露依纳 工会#
aldeg_cas01.rsw#露依纳 工会#
alde_gld.rsw#艾尔帕兰卫星都市 露依纳#
gefg_cas05.rsw#咘哩妥利亚 工会#
gefg_cas04.rsw#咘哩妥利亚 工会#
gefg_cas03.rsw#咘哩妥利亚 工会#
gefg_cas02.rsw#咘哩妥利亚 工会#
gefg_cas01.rsw#咘哩妥利亚 工会#
prtg_cas05.rsw#巴基力雷恩 工会#
prtg_cas04.rsw#巴基力雷恩 工会#
prtg_cas03.rsw#巴基力雷恩 工会#
prtg_cas02.rsw#巴基力雷恩 工会#
prtg_cas01.rsw#巴基力雷恩 工会#
prt_gld.rsw#巴基力雷恩#
tur_dun01.rsw#乌龟岛#
tur_dun02.rsw#乌龟岛 密穴#
tur_dun03.rsw#良龟村#
tur_dun04.rsw#旧良宫#
tur_dun05.rsw#地下 沼泽地带#
tur_dun06.rsw#地下 沼泽地带#
guild_vs5.rsw#工会 对抗竞技场#
guild_vs4.rsw#工会 对抗竞技场#
guild_vs3.rsw#工会 对抗竞技场#
guild_vs2.rsw#工会 对抗竞技场#
guild_vs1.rsw#工会 对抗竞技场#
guild_room.rsw#工会对抗竞技场 休息室#
quiz_00.rsw#OX益智游戏竞赛场#
quiz_01.rsw#OX益智游戏竞赛场#
gef_fild12.rsw#克特 森林#
gef_fild13.rsw#怖立特离亚#
gef_fild14.rsw#西边 兽人村落#
cmd_in02.rsw#克魔岛 内部#
cmd_in01.rsw#克魔岛 内部#
comodo.rsw#海边之都 克魔岛#
beach_dun.rsw#西边 洞穴 加露#
beach_dun2.rsw#北边 洞穴 卢安达#
beach_dun3.rsw#东边 洞穴 马吾#
cmd_fild01.rsw#巴不其卡 森林#
cmd_fild02.rsw#克克魔 海边#
cmd_fild03.rsw#基乃依 沼泽地#
cmd_fild04.rsw#克克魔 海边#
cmd_fild05.rsw#巴不其卡 森林边界#
cmd_fild06.rsw#要塞都市 山特乐曼(西边)#
cmd_fild07.rsw#发乐斯 灯塔岛#
cmd_fild08.rsw#要塞都市 山特乐曼(东边)#
cmd_fild09.rsw#要塞都市 山特乐曼(南边)#
xmas_in.rsw#姜饼城内部#
xmas_dun02.rsw#玩具分类场#
xmas_dun01.rsw#玩具工厂仓库#
xmas_fild01.rsw#姜饼城原野#
xmas.rsw#白雪村落 姜饼城#
mjolnir_01.rsw#妙勒尼 山脉#
mjolnir_02.rsw#妙勒尼 山脉#
mjolnir_03.rsw#妙勒尼 山脉#
mjolnir_04.rsw#妙勒尼 山脉#
mjolnir_05.rsw#妙勒尼 山脉#
mjolnir_06.rsw#妙勒尼 山脉#
mjolnir_07.rsw#妙勒尼 山脉#
mjolnir_08.rsw#妙勒尼 山脉#
mjolnir_09.rsw#妙勒尼 山脉#
mjolnir_10.rsw#妙勒尼 山脉#
mjolnir_11.rsw#妙勒尼 山脉#
mjolnir_12.rsw#妙勒尼 山脉#
prt_fild00.rsw#普隆德拉 区域#
prt_fild01.rsw#普隆德拉 区域#
prt_fild02.rsw#普隆德拉 区域#
prt_fild03.rsw#普隆德拉 区域#
prt_fild04.rsw#普隆德拉 区域#
prt_fild05.rsw#普隆德拉 区域#
prt_fild06.rsw#普隆德拉 区域#
prt_fild07.rsw#普隆德拉 区域#
prt_fild08.rsw#普隆德拉 区域#
prt_fild09.rsw#普隆德拉 区域#
prt_fild10.rsw#普隆德拉 区域#
prt_fild11.rsw#普隆德拉 区域#
prt_monk.rsw#圣卡毕利那 修道院#
gef_fild00.rsw#吉芬 区域#
gef_fild01.rsw#吉芬 区域#
gef_fild02.rsw#吉芬 区域#
gef_fild03.rsw#吉芬 区域#
gef_fild04.rsw#吉芬 区域#
gef_fild05.rsw#吉芬 区域#
gef_fild06.rsw#吉芬 区域#
gef_fild07.rsw#吉芬 区域#
gef_fild08.rsw#吉芬 区域#
gef_fild09.rsw#吉芬 区域#
gef_fild10.rsw#东边 兽人村落#
in_orcs01.rsw#兽人村落 室内#
gef_fild11.rsw#吉芬 区域#
moc_fild01.rsw#苏克拉特 沙漠#
moc_fild02.rsw#苏克拉特 沙漠#
moc_fild03.rsw#苏克拉特 沙漠#
moc_fild04.rsw#苏克拉特 沙漠#
moc_fild05.rsw#苏克拉特 沙漠#
moc_fild06.rsw#苏克拉特 沙漠#
moc_fild07.rsw#苏克拉特 沙漠#
moc_fild08.rsw#苏克拉特 沙漠#
moc_fild09.rsw#苏克拉特 沙漠#
moc_fild10.rsw#苏克拉特 沙漠#
moc_fild11.rsw#苏克拉特 沙漠#
moc_fild12.rsw#苏克拉特 沙漠#
moc_fild13.rsw#苏克拉特 沙漠#
moc_fild14.rsw#苏克拉特 沙漠#
moc_fild15.rsw#苏克拉特 沙漠#
moc_fild16.rsw#苏克拉特 沙漠#
in_moc_16.rsw#刺客 工会#
moc_fild17.rsw#苏克拉特 沙漠#
moc_fild18.rsw#苏克拉特 沙漠#
moc_fild19.rsw#苏克拉特 沙漠#
pay_fild01.rsw#斐扬 树林#
pay_fild02.rsw#斐扬 树林#
pay_fild03.rsw#斐扬 树林#
pay_fild04.rsw#苏克拉特 沙漠#
pay_fild05.rsw#斐扬 树林#
pay_fild06.rsw#斐扬 树林#
pay_fild07.rsw#斐扬 树林#
pay_fild08.rsw#斐扬 树林#
pay_fild09.rsw#斐扬 树林#
pay_fild10.rsw#斐扬 树林#
pay_fild11.rsw#斐扬 树林#
new_1-1.rsw#初学者 修练场#
new_2-1.rsw#初学者 修练场#
new_3-1.rsw#初学者 修练场#
new_4-1.rsw#初学者 修练场#
new_5-1.rsw#初学者 修练场#
new_1-2.rsw#初学者 修练场#
new_2-2.rsw#初学者 修练场#
new_3-2.rsw#初学者 修练场#
new_4-2.rsw#初学者 修练场#
new_5-2.rsw#初学者 修练场#
new_1-3.rsw#初学者 修练场#
new_2-3.rsw#初学者 修练场#
new_3-3.rsw#初学者 修练场#
new_4-3.rsw#初学者 修练场#
new_5-3.rsw#初学者 修练场#
new_1-4.rsw#初学者 修练场#
new_2-4.rsw#初学者 修练场#
new_3-4.rsw#初学者 修练场#
new_4-4.rsw#初学者 修练场#
new_5-4.rsw#初学者 修练场#
anthell01.rsw#蚂蚁 地狱 密穴#
anthell02.rsw#蚂蚁 地狱 密穴#
gef_dun00.rsw#吉芬 地下 密穴#
gef_dun01.rsw#吉芬 地下 密穴#
gef_dun02.rsw#葛帔尼亚 密穴#
gef_dun03.rsw#葛帔尼亚 密穴#
iz_dun00.rsw#海底 洞窟#
iz_dun01.rsw#海底 洞窟#
iz_dun02.rsw#海底 洞窟#
iz_dun03.rsw#海底 洞窟#
iz_dun04.rsw#海底 洞窟#
iz_dun05.rsw#海底 洞窟#
in_sphinx1.rsw#史芬克斯 密穴#
in_sphinx2.rsw#史芬克斯 密穴#
in_sphinx3.rsw#史芬克斯 密穴#
in_sphinx4.rsw#史芬克斯 密穴#
in_sphinx5.rsw#史芬克斯 密穴#
moc_pryd01.rsw#金字塔 迷宫#
moc_pryd02.rsw#金字塔 迷宫#
moc_pryd03.rsw#金字塔 迷宫#
moc_pryd04.rsw#金字塔 迷宫#
moc_pryd05.rsw#金字塔 迷宫#
moc_pryd06.rsw#金字塔 迷宫#
moc_prydb1.rsw#盗贼 工会#
mjo_dun01.rsw#妙勒尼 废弃矿场#
mjo_dun02.rsw#妙勒尼 废弃矿场#
mjo_dun03.rsw#妙勒尼 废弃矿场#
orcsdun01.rsw#兽人地下洞窟#
orcsdun02.rsw#兽人地下洞窟#
pay_dun00.rsw#斐扬 地下#
pay_dun01.rsw#斐扬 地下#
pay_dun02.rsw#斐扬 地下#
pay_dun03.rsw#地下废弃村落#
pay_dun04.rsw#地下废弃村落#
prt_maze01.rsw#迷藏森林#
prt_maze02.rsw#迷藏森林#
prt_maze03.rsw#迷藏森林#
prt_sewb1.rsw#普隆德拉 地下水道#
prt_sewb2.rsw#普隆德拉 地下水道#
prt_sewb3.rsw#普隆德拉 地下水道#
prt_sewb4.rsw#普隆德拉 地下水道#
treasure01.rsw#沉没之船 1楼#
treasure02.rsw#沉没之船 2楼#
hunter_1-1.rsw#猎人转职所#
hunter_2-1.rsw#猎人转职所#
hunter_3-1.rsw#猎人转职所#
in_hunter.rsw#猎人转职所#
knight_1-1.rsw#骑士转职所#
knight_2-1.rsw#骑士转职所#
knight_3-1.rsw#骑士转职所#
priest_1-1.rsw#祭司转职所#
priest_2-1.rsw#祭司转职所#
priest_3-1.rsw#祭司转职所#
sword_1-1.rsw#剑士转职所#
sword_2-1.rsw#剑士转职所#
sword_3-1.rsw#剑士转职所#
job_thief1.rsw#盗贼转职所#
wizard_1-1.rsw#巫师转职所#
wizard_2-1.rsw#巫师转职所#
wizard_3-1.rsw#巫师转职所#
force_1-1.rsw#限时激斗模式#
force_2-1.rsw#限时激斗模式#
force_3-1.rsw#限时激斗模式#
force_1-2.rsw#限时激斗模式#
force_2-2.rsw#限时激斗模式#
force_3-2.rsw#限时激斗模式#
force_1-3.rsw#限时激斗模式#
force_2-3.rsw#限时激斗模式#
force_3-3.rsw#限时激斗模式#
ordeal_1-1.rsw#团体战斗模式#
ordeal_2-1.rsw#团体战斗模式#
ordeal_3-1.rsw#团体战斗模式#
ordeal_1-2.rsw#团体战斗模式#
ordeal_2-2.rsw#团体战斗模式#
ordeal_3-2.rsw#团体战斗模式#
ordeal_1-3.rsw#团体战斗模式#
ordeal_2-3.rsw#团体战斗模式#
ordeal_3-3.rsw#团体战斗模式#
ordeal_1-4.rsw#团体战斗模式#
ordeal_2-4.rsw#团体战斗模式#
ordeal_3-4.rsw#团体战斗模式#
alb_ship.rsw#艾尔贝塔 船舶内#
alberta.rsw#港口之都 艾尔贝塔#
alberta_in.rsw#港口之都 艾尔贝塔#
alb2trea.rsw#沉船附近的岛屿#
aldebaran.rsw#运河之都 艾尔帕兰#
aldeba_in.rsw#运河之都 艾尔帕兰#
gef_tower.rsw#吉芬 中央塔#
geffen.rsw#魔法之都 吉芬#
geffen_in.rsw#魔法之都 吉芬#
moc_castle.rsw#梦罗克 城内#
moc_ruins.rsw#沙漠之都 梦罗克#
morocc.rsw#沙漠之都 梦罗克#
morocc_in.rsw#沙漠之都 梦罗克#
pay_arche.rsw#山岳之都 斐扬#
payon.rsw#山岳之都 斐扬#
payon_in01.rsw#山岳之都 斐扬#
payon_in02.rsw#山岳之都 斐扬#
prontera.rsw#卢恩 米德加兹王国 首都 普隆德拉#
prt_in.rsw#卢恩 米德加兹王国 首都 普隆德拉#
prt_castle.rsw#普隆德拉 城内#
prt_church.rsw#普隆德拉 圣堂内#
izlude.rsw#卫星都市 依斯鲁得岛#
izlude_in.rsw#卫星都市 依斯鲁得岛#
izlu2dun.rsw#卫星都市 依斯鲁得岛#
monk_in.rsw#圣卡毕利那 修道院内#
prt_are_in.rsw#亚雷那 等候室#
arena_room.rsw#亚雷那 等候室#
prt_arena01.rsw#亚雷那#
prt_are01.rsw#亚雷那#
glast_01.rsw#克雷斯特汉姆古城#
alde_dun01.rsw#艾尔帕兰 钟塔地下楼层 1楼#
alde_dun02.rsw#艾尔帕兰 钟塔地下楼层 2楼#
alde_dun03.rsw#艾尔帕兰 钟塔地下楼层 3楼#
alde_dun04.rsw#艾尔帕兰 钟塔地下楼层 4楼#
c_tower1.rsw#艾尔帕兰 钟塔地上楼层 1楼#
c_tower2.rsw#艾尔帕兰 钟塔地上楼层 2楼#
c_tower3.rsw#艾尔帕兰 钟塔地上楼层 3楼#
c_tower4.rsw#艾尔帕兰 钟塔地上楼层 4楼#
gl_cas01.rsw#克雷斯特汉姆古城 地上楼层 1楼#
gl_cas02.rsw#克雷斯特汉姆古城 地上楼层 2楼#
gl_church.rsw#克雷斯特汉姆古城 修道院#
gl_chyard.rsw#克雷斯特汉姆古城 地下公墓#
gl_dun01.rsw#克雷斯特汉姆 最下层 地下洞窟#
gl_dun02.rsw#克雷斯特汉姆 最下层 地下洞窟#
gl_in01.rsw#克雷斯特汉姆古城 室内#
gl_knt01.rsw#克雷斯特汉姆 骑士团1楼#
gl_knt02.rsw#克雷斯特汉姆 骑士团2楼#
gl_prison.rsw#克雷斯特汉姆 地下监狱1楼#
gl_prison1.rsw#克雷斯特汉姆 地下监狱2楼#
gl_sew01.rsw#克雷斯特汉姆 地下水道#
gl_sew02.rsw#克雷斯特汉姆 地下水道#
gl_sew03.rsw#克雷斯特汉姆 地下水道#
gl_sew04.rsw#克雷斯特汉姆 地下水道#
gl_step.rsw#克雷斯特汉姆 楼梯密穴#
pvp_y_room.rsw#PvP : 等待室#
pvp_n_room.rsw#PvP : 等待室#
pvp_c_room.rsw#PvP : 打斗场#
pvp_n_1-1.rsw#PvP : 三明治 房间#
pvp_n_2-1.rsw#PvP : 三明治 房间#
pvp_n_3-1.rsw#PvP : 三明治 房间#
pvp_n_4-1.rsw#PvP : 三明治 房间#
pvp_n_5-1.rsw#PvP : 三明治 房间#
pvp_n_6-1.rsw#PvP : 三明治 房间#
pvp_n_7-1.rsw#PvP : 三明治 房间#
pvp_n_8-1.rsw#PvP : 三明治 房间#
pvp_n_1-2.rsw#PvP : 雷达锁定 房间#
pvp_n_2-2.rsw#PvP : 雷达锁定 房间#
pvp_n_3-2.rsw#PvP : 雷达锁定 房间#
pvp_n_4-2.rsw#PvP : 雷达锁定 房间#
pvp_n_5-2.rsw#PvP : 雷达锁定 房间#
pvp_n_6-2.rsw#PvP : 雷达锁定 房间#
pvp_n_7-2.rsw#PvP : 雷达锁定 房间#
pvp_n_8-2.rsw#PvP : 雷达锁定 房间#
pvp_n_1-3.rsw#PvP : 四通道 房间#
pvp_n_2-3.rsw#PvP : 四通道 房间#
pvp_n_3-3.rsw#PvP : 四通道 房间#
pvp_n_4-3.rsw#PvP : 四通道 房间#
pvp_n_5-3.rsw#PvP : 四通道 房间#
pvp_n_6-3.rsw#PvP : 四通道 房间#
pvp_n_7-3.rsw#PvP : 四通道 房间#
pvp_n_8-3.rsw#PvP : 四通道 房间#
pvp_n_1-4.rsw#PvP : 反十字 房间#
pvp_n_2-4.rsw#PvP : 反十字 房间#
pvp_n_3-4.rsw#PvP : 反十字 房间#
pvp_n_4-4.rsw#PvP : 反十字 房间#
pvp_n_5-4.rsw#PvP : 反十字 房间#
pvp_n_6-4.rsw#PvP : 反十字 房间#
pvp_n_7-4.rsw#PvP : 反十字 房间#
pvp_n_8-4.rsw#PvP : 反十字 房间#
pvp_n_1-5.rsw#PvP : 罗盘 房间#
pvp_n_2-5.rsw#PvP : 罗盘 房间#
pvp_n_3-5.rsw#PvP : 罗盘 房间#
pvp_n_4-5.rsw#PvP : 罗盘 房间#
pvp_n_5-5.rsw#PvP : 罗盘 房间#
pvp_n_6-5.rsw#PvP : 罗盘 房间#
pvp_n_7-5.rsw#PvP : 罗盘 房间#
pvp_n_8-5.rsw#PvP : 罗盘 房间#
pvp_y_1-1.rsw#PvP : 普隆德拉#
pvp_y_2-1.rsw#PvP : 普隆德拉#
pvp_y_3-1.rsw#PvP : 普隆德拉#
pvp_y_4-1.rsw#PvP : 普隆德拉#
pvp_y_5-1.rsw#PvP : 普隆德拉#
pvp_y_6-1.rsw#PvP : 普隆德拉#
pvp_y_7-1.rsw#PvP : 普隆德拉#
pvp_y_8-1.rsw#PvP : 普隆德拉#
pvp_y_1-2.rsw#PvP : 依斯鲁得岛#
pvp_y_2-2.rsw#PvP : 依斯鲁得岛#
pvp_y_3-2.rsw#PvP : 依斯鲁得岛#
pvp_y_4-2.rsw#PvP : 依斯鲁得岛#
pvp_y_5-2.rsw#PvP : 依斯鲁得岛#
pvp_y_6-2.rsw#PvP : 依斯鲁得岛#
pvp_y_7-2.rsw#PvP : 依斯鲁得岛#
pvp_y_8-2.rsw#PvP : 依斯鲁得岛#
pvp_y_1-3.rsw#PvP : 斐扬#
pvp_y_2-3.rsw#PvP : 斐扬#
pvp_y_3-3.rsw#PvP : 斐扬#
pvp_y_4-3.rsw#PvP : 斐扬#
pvp_y_5-3.rsw#PvP : 斐扬#
pvp_y_6-3.rsw#PvP : 斐扬#
pvp_y_7-3.rsw#PvP : 斐扬#
pvp_y_8-3.rsw#PvP : 斐扬#
pvp_y_1-4.rsw#PvP : 艾尔贝塔#
pvp_y_2-4.rsw#PvP : 艾尔贝塔#
pvp_y_3-4.rsw#PvP : 艾尔贝塔#
pvp_y_4-4.rsw#PvP : 艾尔贝塔#
pvp_y_5-4.rsw#PvP : 艾尔贝塔#
pvp_y_6-4.rsw#PvP : 艾尔贝塔#
pvp_y_7-4.rsw#PvP : 艾尔贝塔#
pvp_y_8-4.rsw#PvP : 艾尔贝塔#
pvp_y_1-5.rsw#PvP : 梦罗克#
pvp_y_2-5.rsw#PvP : 梦罗克#
pvp_y_3-5.rsw#PvP : 梦罗克#
pvp_y_4-5.rsw#PvP : 梦罗克#
pvp_y_5-5.rsw#PvP : 梦罗克#
pvp_y_6-5.rsw#PvP : 梦罗克#
pvp_y_7-5.rsw#PvP : 梦罗克#
pvp_y_8-5.rsw#PvP : 梦罗克#
pvp_2vs2.rsw#PvP : 活动 竞技场#

---------摘自99nets


物品代码

501#红色药水#
502#赤色药水#
503#黄色药水#
504#白色药水#
505#蓝色药水#
506#绿色药水#
507#红色药草#
508#黄色药草#
509#白色药草#
510#蓝色药草#
511#绿色药草#
512#苹果#
513#香蕉#
514#葡萄#
515#红萝卜#
516#蕃薯#
517#肉#
518#蜂蜜#
519#牛奶#
520#西纳雷叶子#
521#芦荟叶子#
522#玛丝黛拉果实#
523#圣水#
525#万能药#
526#蜂胶#
528#魔物饲料#
529#糖果#
530#拐杖糖#
531#苹果汁#
532#香蕉汁#
533#葡萄汁#
534#红萝卜汁#
535#南瓜#
536#冰淇淋#
537#宠物饲料#
538#姜饼#
539#小蛋糕#
540#猎鹰饲料#
541#大嘴鸟饲料#
544#生鱼片#
545#红色纤细药水#
546#黄色纤细药水#
547#白色纤细药水#
548#吉士#
549#美味蕃薯#
550#仙贝#
551#明虾寿司#
552#KETUPAT#
553#包子#
554#葛骂#
555#侗#
556#啊贰侗#
557#抗悔霸_戒赴_啊贰侗#
558#檬妮房#
558#巧克力#
559#勤靛皋捞靛_檬妮房#
559#手制巧克力#
560#勤靛皋捞靛_檬妮房#
561#拳捞飘_檬妮房#
562#歹喉农矾胶飘_胶困胶_掐掂#
563#歹喉农矾胶飘_胶困胶_掐掂#
601#苍蝇翅膀#
602#蝴蝶翅膀#
603#神秘箱子#
604#枯树枝#
605#曼特疗伤药#
606#芦荟汁液#
607#天地树果实#
608#天地树芽#
609#返魂符#
610#天地树叶子#
611#放大镜#
612#携带用熔矿炉#
613#钢铁锤子#
614#黄金锤子#
615#神之金属锤子#
616#老旧收集册#
617#神秘紫箱#
618#老旧卷轴#
619#青苹果#
620#浓缩柳橙汁#
621#苦味草#
622#彩色红萝卜#
623#变态蚯蚓#
624#腐臭之鱼#
625#锈铁#
626#魔物饮料#
627#魔物牛奶#
628#营养大骨#
629#呢喃花#
630#青苔#
631#青嫩毒草#
632#营养蚯蚓#
633#魔物番薯#
634#魔物香蕉#
635#魔物之证#
636#魔物信件#
637#魔物扫把#
638#纯洁银刃#
639#驯服手镯#
640#闪烁之石#
641#黑暗合约书#
642#恶魔召唤书#
643#携带用孵蛋器#
644#礼物箱#
645#集中药水#
656#觉醒药水#
657#菠色克药水#
658#组织的团结力#
659#心爱女人之回忆#
660#红色蜡烛#
661#摇曳的围裙#
663#年糕#
664#礼盒#
665#礼盒#
666#礼盒#
667#礼盒#
668#红包#
669#咐乐霸_焊捞绰_侗惫#
670#陛拳_林赣聪#
671#陛拳#
672#悼拳_林赣聪#
673#悼拳#
674#固胶副拳#
675#篮拳#
676#篮拳_林赣聪#
677#归陛拳#
678#刀距捍#
679#家券窜#
680#付仿狼_墨匙捞记#
701#欧拉欧拉#
702#家畜血#
703#西纳雷花#
704#芦荟#
705#三叶幸运草#
706#四叶幸运草#
707#哀唱草#
708#曼特花#
709#迷幻药#
710#幻想花#
711#芽苗#
712#花#
713#空瓶#
714#华丽金属#
715#黄色魔力矿石#
716#红色魔力矿石#
717#蓝色魔力矿石#
718#深红宝石#
719#紫宝石#
720#天蓝宝石#
721#绿宝石#
722#珍珠#
723#红宝石#
724#诅咒红宝石#
725#大红宝石#
726#蓝宝石#
727#白宝石#
728#黄宝石#
729#青绿宝石#
730#1克拉钻石#
731#2克拉钻石#
732#3克拉钻石#
733#受损的钻石#
734#红色相框#
735#蓝色陶瓷器#
736#白色盘子#
737#黑色杓子#
738#笔筒#
739#化妆品#
740#疯兔娃娃#
741#波利娃娃#
742#苍蝇娃娃#
743#魔菇娃娃#
744#花束#
745#捧花#
746#玻璃珠#
747#水晶镜子#
748#永恒玫瑰#
749#冰雕玫瑰#
750#巴风特娃娃#
751#俄塞里斯娃娃#
752#摇滚蝗虫娃娃#
753#溜溜猴娃娃#
754#狸猫娃娃#
756#神之金属原石#
757#铝原石#
901#辫子#
902#树根#
903#爬虫类舌头#
904#蝎子尾巴#
905#植物梗#
906#鳞片梗#
907#枯木汁#
908#青蛙蛋#
909#杰勒比结晶#
910#加勒结晶#
911#雪勒结晶#
912#剎勒空结晶#
913#蝙蝠牙#
914#毛#
915#蛹壳#
916#羽毛#
917#鸟指甲#
918#粘糊的蹼#
919#动物外皮#
920#狼指甲#
921#香菇芽孢#
922#兽人犬齿#
923#恶魔角#
924#蝴蝶翅膀粉末#
925#鸟嘴#
926#蛇鳞#
928#昆虫触角#
929#不死心脏#
930#腐烂绷带#
931#兽人战士之证#
932#死人遗骨#
934#亡者遗物#
935#坚硬外壳#
936#鳞片皮肤#
937#毒牙#
938#粘稠液体#
939#蜂针#
940#蝗虫后腿#
941#牛鼻环#
942#猴子尾巴#
943#坚硬外皮#
944#马蹄#
945#变身叶子#
946#蜗牛壳#
947#硬角#
948#熊掌#
949#柔毛#
950#人鱼之心#
951#背鳍#
952#仙人掌刺#
953#石心#
954#发亮鳞片#
955#昆虫外壳#
956#鳃刺#
957#亡者指甲#
958#亡者牙齿#
959#腐烂鳞片#
960#钳子#
961#海螺#
962#触须#
963#锐利麟片#
964#螃蟹外壳#
965#蛤蜊外壳#
966#蛤蜊肉#
967#乌龟外壳#
968#兽人英雄之证#
969#黄金#
970#酒精#
971#帝特立米药水#
972#卡勒波迪药水#
973#中和剂#
974#混合剂#
975#红色染料#
976#黄色染料#
978#蓝色染料#
979#绿色染料#
980#赤色染料#
981#紫色染料#
982#白色染料#
983#黑色染料#
984#神之金属#
985#铝#
986#铁砧#
987#神之金属铁砧#
988#黄金铁砧#
989#华丽金属铁砧#
990#火灵矿石#
991#水灵矿石#
992#风灵矿石#
993#地灵矿石#
994#火灵原石#
995#水灵原石#
996#风灵原石#
997#土灵原石#
998#铁#
999#钢铁#
1000#星星的角#
1001#星星的粉末#
1002#铁矿石#
1003#煤矿#
1004#忠诚之证#
1005#高级铁砧#
1006#古魔法书#
1007#慧眼#
1008#泯灭之心#
1009#神之手#
1010#强化武器金属-级数一#
1011#强化武器金属-级数二#
1012#伞蜥颈#
1013#彩色昆虫外壳#
1014#蚂蚁下巴#
1015#细长舌头#
1016#鼠尾#
1017#鼠须#
1018#鼠指甲#
1019#玛哪树枝#
1020#长发#
1021#土人之角#
1022#狐狸尾巴#
1023#鱼尾#
1024#墨汁#
1025#蜘蛛丝#
1026#橡实#
1027#刺猬尖刺#
1028#野猪毛#
1029#虎皮#
1030#虎掌#
1031#螳螂臂#
1032#噬人树花#
1033#噬人树根#
1034#哥布灵毛#
1035#龙牙#
1036#龙鳞#
1037#龙尾#
1038#小恶魔角#
1039#小恶魔翅膀#
1040#老妖精胡须#
1041#手提灯#
1042#昆虫后脚#
1043#兽人指甲#
1044#兹诺克之牙#
1045#圣殿士面具#
1046#蝎子之钳#
1047#蛇女之首#
1048#蛇发#
1049#韩服#
1050#血管#
1051#脑管#
1052#单细胞#
1053#人鱼之牙#
1054#人鱼嘴巴#
1055#蚯蚓皮#
1056#黄玉碎片#
1057#蛾蝶虫翅膀粉末#
1058#蛾蝶翅膀#
1059#透明之布#
1060#金色头发#
1061#魔女之星沙#
1062#南瓜头#
1063#锐利锥子#
1064#鞭绳#
1065#设置用陷阱道具#
1066#天地树枝#
1067#智慧树枝#
1068#世界树枝#
1069#毒香菇#
1070#恶臭香菇#
1071#黑色液体试管#
1072#曼修的信件#
1073#送货收据#
1074#送货收据#
1075#送货收据#
1076#送货收据#
1077#送货收据#
1078#送货收据#
1079#送货收据#
1080#送货收据#
1081#送货的木箱子#
1082#送货的木箱子#
1083#送货的木箱子#
1084#卡普拉使用券#
1085#黑色液体试管#
1086#黑色液体试管#
1087#黑色液体试管#
1088#梦罗克水溶液试管#
1089#斐扬水溶液试管#
1090#黑色液体试管#
1091#送货用的木箱子#
1092#空试管#
1093#空药瓶#
1094#短辫子#
1095#指针#
1096#圆形外皮#
1097#破旧书页#
1098#手铐#
1099#老旧犯人服#
1101#长剑#
1102#长剑#
1103#长剑#
1104#圆月刀#
1105#圆月刀#
1106#圆月刀#
1107#厚刃剑#
1108#厚刃剑#
1109#厚刃剑#
1110#击刺长剑#
1111#击刺长剑#
1112#击刺长剑#
1113#弯刀#
1114#弯刀#
1115#弯刀#
1116#武士刀#
1117#武士刀#
1118#武士刀#
1119#日本刀#
1120#日本刀#
1121#日本刀#
1122#圆柄马刀#
1123#海东剑#
1124#兽人刀#
1125#圆柄马刀#
1126#骑兵之剑#
1127#骑兵之剑#
1128#海东剑#
1129#水纹之剑#
1130#多刃尖刺刀#
1131#水灵之刀#
1132#秘剑 慕恋#
1133#火灵之剑#
1134#利剪剑#
1135#狂击之剑#
1136#烈阳之剑#
1137#石中剑#
1138#妖剑 弒光#
1139#魔刀 吞神#
1140#首领之剑#
1141#圣剑 浑沌#
1142#寻宝之剑#
1143#寻矿之剑#
1144#生鱼片刀#
1145#神圣复仇者之剑#
1151#双手剑#
1152#双手剑#
1153#双手剑#
1154#亚尔特剑#
1155#亚尔特剑#
1156#亚尔特剑#
1157#双手巨剑#
1158#双手巨剑#
1159#双手巨剑#
1160#双手重剑#
1161#神器 三十二朔月#
1162#双手重剑#
1163#十字巨剑#
1164#名刀 不知火#
1165#秘刀 十六夜月#
1166#龙牙剑#
1167#风灵之剑#
1168#巨大双手剑#
1169#死神之剑#
1170#亚蓝斯之剑#
1201#短剑#
1202#短剑#
1203#短剑#
1204#卡特短剑#
1205#卡特短剑#
1206#卡特短剑#
1207#笨拙短剑#
1208#笨拙短剑#
1209#笨拙短剑#
1210#德克短剑#
1211#德克短剑#
1212#德克短剑#
1213#大驹短剑#
1214#大驹短剑#
1215#大驹短剑#
1216#双刃短剑#
1217#双刃短剑#
1218#双刃短剑#
1219#长柄短剑#
1220#长柄短剑#
1221#长柄短剑#
1222#大马士革短剑#
1223#幸运短剑#
1224#削刃短剑#
1225#破甲短剑#
1226#大马士革短剑#
1227#锄草短剑#
1228#战斗短剑#
1229#厨刀#
1230#破甲短锥#
1231#华丽短剑#
1232#妖短剑 泣神怨#
1233#除灵短剑#
1234#月灵短剑#
1235#变形短剑#
1236#砂尘短剑#
1237#魔短剑 闇噬#
1238#金币短剑#
1239#巨毒短剑#
1240#皇家短剑#
1241#诅咒的短剑#
1242#反击短剑#
1243#初学者笨拙短剑#
1250#拳刃#
1251#拳刃#
1252#卡塔勒拳刃#
1253#卡塔勒拳刃#
1254#秘刃 闇啸#
1255#秘刃 闇啸#
1256#冰灵拳刃#
1257#刺藤拳刃#
1258#火灵拳刃#
1259#风灵拳刃#
1260#骸灵拳刃#
1261#刺杀拳刃#
1301#斧#
1302#斧#
1303#斧#
1304#兽人斧#
1305#切削之斧#
1306#血腥战斧#
1351#巨斧#
1352#巨斧#
1353#巨斧#
1354#钢斧#
1355#钢斧#
1356#钢斧#
1357#毁灭之斧#
1358#毁灭之斧#
1359#毁灭之斧#
1360#双手斧#
1361#双手斧#
1362#双手斧#
1363#血斧#
1364#克莱伊特斧#
1365#暗灵之斧#
1366#智天使之斧#
1367#斯勒特斧#
1368#风灵之斧#
1369#斩首之斧#
1401#长戟#
1402#长戟#
1403#长戟#
1404#长矛#
1405#长矛#
1406#长矛#
1407#步兵长矛#
1408#步兵长矛#
1409#步兵长矛#
1410#骑士长矛#
1411#骑士长矛#
1412#骑士长矛#
1413#刚尼尔长矛#
1414#地灵之矛#
1415#魔力之矛#
1416#邪灵之矛#
1417#镰戟#
1451#弯刃长矛#
1452#弯刃长矛#
1453#弯刃长矛#
1454#长枪#
1455#长枪#
1456#长枪#
1457#双刃长戟#
1458#双刃长戟#
1459#双刃长戟#
1460#德瑞尹长戟#
1461#德瑞尹长戟#
1462#德瑞尹长戟#
1463#斧锤长矛#
1464#斧锤长矛#
1465#斧锤长矛#
1466#死神之镰#
1467#修尔特长矛#
1468#风灵之矛#
1469#龙戚弩斯长矛#
1470#圣光之戟#
1471#火灵之矛#
1472#灵魂之杖#
1473#大巫师之杖#
1501#木锤#
1502#木锤#
1503#木锤#
1504#铁锤#
1505#铁锤#
1506#铁锤#
1507#思麦斯铁锤#
1508#思麦斯铁锤#
1509#思麦斯铁锤#
1510#流星锤#
1511#流星锤#
1512#流星锤#
1513#日星锤#
1514#日星锤#
1515#日星锤#
1516#尖刃铁锤#
1517#尖刃铁锤#
1518#尖刃铁锤#
1519#链锤#
1520#链锤#
1521#链锤#
1522#昏迷之锤#
1523#闇盲之锤#
1524#黄金之锤#
1525#秘银长锤#
1526#魔锤 安魂曲#
1527#秘锤 冷月#
1528#圣锤 十字星#
1529#高尔夫球杆#
1530#雷神之锤#
1531#钣手#
1550#书#
1551#圣言之书#
1552#智慧石碑#
1553#水灵之书#
1554#地灵之书#
1555#火灵之书#
1556#风灵之书#
1557#预言录#
1558#日记本#
1599#圣锤 十字星#
1601#手杖#
1602#手杖#
1603#手杖#
1604#橡木魔杖#
1605#橡木魔杖#
1606#橡木魔杖#
1607#智慧魔杖#
1608#智慧魔杖#
1609#智慧魔杖#
1610#言灵魔杖#
1611#言灵魔杖#
1612#言灵魔杖#
1613#巫杖 魂咬#
1614#圣杖 英灵#
1615#骷髅魔杖#
1701#弓#
1702#弓#
1703#弓#
1704#坎普兹弓#
1705#坎普兹弓#
1706#坎普兹弓#
1707#克罗伊特弓#
1708#克罗伊特弓#
1709#克罗伊特弓#
1710#十字弓#
1711#十字弓#
1712#十字弓#
1713#埃布尔雷弓#
1714#角弓#
1715#埃布尔雷弓#
1716#角弓#
1718#猎人之弓#
1719#盗贼之弓#
1720#炽天使之弓#
1721#十字机弩#
1722#贝利斯塔强弩#
1750#箭矢#
1751#银箭矢#
1752#火箭矢#
1753#钢铁箭矢#
1754#水灵箭矢#
1755#风灵箭矢#
1756#地灵箭矢#
1757#无形箭矢#
1758#昏迷箭矢#
1759#冰冻箭矢#
1760#光芒箭矢#
1761#诅咒箭矢#
1762#铁锈箭矢#
1763#毒箭矢#
1764#锐利箭矢#
1765#神之金属箭矢#
1766#破魔箭矢#
1767#影子箭矢#
1768#睡眠箭矢#
1769#宁静箭矢#
1770#铁箭矢#
1801#虎爪拳套#
1802#虎爪拳套#
1803#钢铁拳套#
1804#钢铁拳套#
1805#贺勒拳套#
1806#贺勒拳套#
1807#升龙拳套#
1808#升龙拳套#
1809#龙爪拳套#
1810#龙爪拳套#
1811#鹰爪拳套#
1812#鹰爪拳套#
1813#风灵拳套#
1814#秘拳套 闪光#
1901#小提琴#
1902#小提琴#
1903#曼陀林#
1904#曼陀林#
1905#鲁特琴#
1906#鲁特琴#
1907#吉他#
1908#吉他#
1909#竖琴#
1910#竖琴#
1911#焚鹤琴#
1912#焚鹤琴#
1950#鞭子#
1951#鞭子#
1952#细长鞭子#
1953#细长鞭子#
1954#钢铁鞭子#
1955#钢铁鞭子#
1956#流星鞭子#
1957#流星鞭子#
1958#幸运鞭子#
1959#幸运鞭子#
1960#玛哪鞭子#
1961#玛哪鞭子#
1962#细刃鞭子#
1963#毒鞭 蔷薇#
1964#秘鞭 眷恋#
2101#铁盾#
2102#铁盾#
2103#圆盾#
2104#圆盾#
2105#钢盾#
2106#钢盾#
2107#镜盾#
2108#镜盾#
2109#谎言纪录本#
2110#圣耀之盾#
2111#大天使之盾#
2112#初学者铁盾#
2199#圆盾#
2201#太阳眼镜#
2202#太阳眼镜#
2203#眼镜#
2204#眼镜#
2205#泳镜#
2206#婚礼头纱#
2207#花朵头饰#
2208#紫蝶发带#
2209#紫蝶发带#
2210#发箍#
2211#方头巾#
2212#独眼龙眼罩#
2213#猫耳发圈#
2214#兔耳发圈#
2215#花发圈#
2216#圣职之帽#
2217#圣职之帽#
2218#口罩#
2219#口罩#
2220#渔夫帽#
2221#渔夫帽#
2222#圆帽#
2223#圆帽#
2224#防风皮革眼镜#
2225#防风皮革眼镜#
2226#无边帽#
2227#无边帽#
2228#金属头盔#
2229#金属头盔#
2230#宝石头盔#
2231#宝石头盔#
2232#头箍#
2233#头箍#
2234#后冠#
2235#王冠#
2236#圣诞帽#
2237#落腮胡#
2238#鼻毛#
2239#单眼眼镜#
2240#胡须#
2241#白胡须#
2242#高级太阳眼镜#
2243#旋转眼镜#
2244#红蝶发带#
2245#绅士帽#
2246#黄金帽#
2247#回忆帽#
2248#牛仔帽#
2249#黄金冠冕#
2250#粉纱发圈#
2251#神圣之帽#
2252#魔法帽#
2253#向日葵头饰#
2254#天使发圈#
2255#恶魔发圈#
2256#山羊头盔#
2257#兽角头饰#
2258#尖角发圈#
2259#竹蜻蜓发圈#
2260#迷你眼镜#
2261#普隆德拉军帽#
2262#小丑鼻子#
2263#时髦眼罩#
2264#殭尸帽#
2265#侍卫口罩#
2266#金属口罩#
2267#香烟#
2268#烟斗#
2269#花叶#
2270#草叶#
2271#眼镜头饰#
2272#停止标志头饰#
2273#医师发箍#
2274#亡者发箍#
2275#头巾#
2276#大眼睛眼镜#
2277#护士帽#
2278#笑脸面具#
2279#火线头饰#
2280#草帽#
2281#舞会面具#
2282#光环#
2283#耳罩#
2284#鹿角头饰#
2285#苹果头饰#
2286#妖精长耳朵饰#
2287#海盗头巾#
2288#整人面具#
2289#粪便帽#
2290#葬礼帽#
2291#蝴蝶假面#
2292#钢铁面具#
2293#戏剧头盔#
2294#星星发夹#
2295#眼罩#
2296#望远镜#
2297#哥布灵面具#
2298#触角头饰#
2299#兽人头盔#
2301#棉衬衫#
2302#棉衬衫#
2303#皮制外套#
2304#皮制外套#
2305#冒险衣#
2306#冒险衣#
2307#大衣#
2308#大衣#
2309#长大衣#
2310#长大衣#
2311#毛皮大衣#
2312#铁制铠甲#
2313#铁制铠甲#
2314#钢铁锁子甲#
2315#钢铁锁子甲#
2316#钢铁铠甲#
2317#钢铁铠甲#
2318#秘衣 美德#
2319#秘衣 恶德#
2320#西装外套#
2321#丝质外袍#
2322#丝质外袍#
2323#圣职之袍#
2324#圣职之袍#
2325#圣职之衣#
2326#圣职之衣#
2327#天衣 月舞#
2328#木制铠甲#
2329#木制铠甲#
2330#紧身便衣#
2331#紧身便衣#
2332#秘银之衣#
2333#秘银之衣#
2334#魔法外套#
2335#盗贼之衣#
2336#盗贼之衣#
2337#忍服 血樱#
2338#结婚礼服#
2339#三角裤#
2340#初学者胸铠#
2341#秘银金属铠甲#
2342#秘银金属铠甲#
2343#创作者外袍#
2344#火鳞铠甲#
2345#火鳞铠甲#
2346#水鳞铠甲#
2347#水鳞铠甲#
2348#风鳞铠甲#
2349#风鳞铠甲#
2350#地鳞铠甲#
2351#地鳞铠甲#
2352#初学者斗篷#
2401#轻便鞋#
2402#轻便鞋#
2403#长靴#
2404#长靴#
2405#战士长靴#
2406#战士长靴#
2407#玻璃鞋#
2408#脚炼#
2409#抗魔鞋#
2410#史雷普尼尔之靴#
2411#重靴#
2412#重靴#
2413#安全鞋#
2414#初学者海滩鞋#
2501#连帽披肩#
2502#连帽披肩#
2503#披肩#
2504#披肩#
2505#斗篷#
2506#斗篷#
2507#伯爵斗篷#
2508#抗魔斗篷#
2509#生存斗篷#
2510#初学者阴险披肩#
2601#力量戒指#
2602#智力耳环#
2603#体力项链#
2604#防御手套#
2605#敏捷别针#
2607#发夹#
2608#幸运珠链#
2609#骷髅戒指#
2610#金戒指#
2611#银戒指#
2612#花戒指#
2613#钻石戒指#
2614#永恒戒指#
2615#防御戒指#
2616#潜能戒指#
2617#智慧手套#
2618#黑狐颈链#
2619#神射手套#
2620#怪盗戒指#
2621#力量戒指#
2622#智力耳环#
2623#体力项链#
2624#防御手套#
2625#敏捷别针#
2626#幸运珠链#
2627#皮带#
2628#初学者手镯#
2629#雷神腰带#
2630#女神颈链#
2631#周岁纪念戒指#
2634#结婚戒指#
2635#结婚戒指#
2636#圣诞金戒#
2637#圣诞银戒#
4001#波利卡片#
4002#绿棉虫卡片#
4003#虫蛹卡片#
4004#土波利卡片#
4005#圣诞波利卡片#
4006#疯兔卡片#
4007#大嘴鸟蛋卡片#
4008#小鸡卡片#
4009#苍蝇卡片#
4010#树精卡片#
4011#蛋壳小鸡卡片#
4012#盗虫卵卡片#
4013#蚁卵卡片#
4014#罗达蛙卡片#
4015#秃鹰卡片#
4016#盗虫卡片#
4017#小野猪卡片#
4018#白蚁幼虫卡片#
4019#蜂兵卡片#
4020#吸血蝙蝠卡片#
4021#摇滚蝗虫卡片#
4022#魔菇卡片#
4023#沙漠幼狼卡片#
4024#漂浮虫卡片#
4025#邪骸战士卡片#
4026#浮勒盗虫卡片#
4027#库克雷卡片#
4028#白鼠卡片#
4029#狼卡片#
4030#曼陀萝魔花卡片#
4031#大嘴鸟卡片#
4032#蜗牛卡片#
4033#波波利卡片#
4034#森灵卡片#
4035#海葵卡片#
4036#摩卡卡片#
4037#青蛇卡片#
4038#腐尸卡片#
4039#瓢虫卡片#
4040#克瑞米卡片#
4041#松鼠卡片#
4042#绿苍蝇卡片#
4043#白蚁卡片#
4044#狸猫卡片#
4045#锹形虫卡片#
4046#土拨鼠卡片#
4047#幽灵波利卡片#
4048#毒魔菇卡片#
4049#螃蟹卡片#
4050#玛勒盗虫卡片#
4051#溜溜猴卡片#
4052#长老树精卡片#
4053#黑蚁卡片#
4054#天使波利卡片#
4055#水母卡片#
4056#猎蝇卡片#
4057#重金属蝗虫卡片#
4058#突变蛙卡片#
4059#战蚁卡片#
4060#哥布灵卡片#
4061#卡那多斯卡片#
4062#黄蛇卡片#
4063#刺猬虫卡片#
4064#杰洛米卡片#
4065#卡浩卡片#
4066#兽人战士卡片#
4067#邪骸食人鱼卡片#
4068#蝎子卡片#
4069#红蝙蝠卡片#
4070#转转蛋卡片#
4071#兽人腐尸卡片#
4072#巨石怪卡片#
4073#邪骸海盗卡片#
4074#大脚熊卡片#
4075#艾斯蜘蛛卡片#
4076#魔锅蛋卡片#
4077#剑鱼卡片#
4078#野猪卡片#
4079#螳螂卡片#
4080#噬人花卡片#
4081#蚯蚓卡片#
4082#沙漠之狼卡片#
4083#草精卡片#
4084#气泡虫卡片#
4085#邪骸兽人卡片#
4086#邪骸士兵卡片#
4087#基尔瑟卡片#
4088#伞蜥卡片#
4089#异变鱼卡片#
4090#殭尸卡片#
4091#犬妖卡片#
4092#邪骸矿工卡片#
4093#人鱼卡片#
4094#邪骸弓箭手卡片#
4095#乌贼卡片#
4096#兹诺克卡片#
4097#黑狐卡片#
4098#土人卡片#
4099#帕莎纳卡片#
4100#鬼女卡片#
4101#泥人卡片#
4102#白幽灵卡片#
4103#鬼火卡片#
4104#诺可伊卡片#
4105#马克卡片#
4106#木乃伊卡片#
4107#木乃伊犬卡片#
4108#麦斯特卡片#
4109#南瓜先生卡片#
4110#绿腐尸卡片#
4111#海神卡片#
4112#马尔杜克卡片#
4113#傀儡娃娃卡片#
4114#艾吉欧蜈蚣卡片#
4115#赤苍蝇卡片#
4116#蛇女伊丝卡片#
4117#黑蛇卡片#
4118#毕帝特地龙卡片#
4119#巫婆卡片#
4120#毕帝特飞龙卡片#
4121#皮里恩卡片#
4122#小恶魔卡片#
4123#虎王卡片#
4124#米杜沙卡片#
4125#狄奥斯卡片#
4126#米洛斯卡片#
4127#梦魇卡片#
4128#黄金虫卡片#
4129#小巴风特卡片#
4130#蝎子之王卡片#
4131#月夜猫卡片#
4132#蜂后卡片#
4133#幽灵剑士卡片#
4134#德古拉伯爵 卡片#
4135#兽人酋长卡片#
4136#卡利斯格卡片#
4137#海盗之王卡片#
4138#安毕斯卡片#
4139#裘卡卡片#
4140#深渊骑士卡片#
4141#闇神官卡片#
4142#死灵卡片#
4143#兽人英雄卡片#
4144#俄塞里斯卡片#
4145#贝雷杰卡片#
4146#蚁后卡片#
4147#巴风特卡片#
4148#法老王卡片#
4149#妖道卡片#
4150#兽人弓箭手卡片#
4151#邪恶箱卡片#
4152#恶灵卡片#
4153#钟怪卡片#
4154#卷甲虫卡片#
4155#飞行魔书卡片#
4156#邪骸战俘卡片#
4157#腐尸战俘卡片#
4158#暗黑祭司卡片#
4159#朽魔卡片#
4160#艾斯恩魔女卡片#
4161#弑神者卡片#
4162#兽牙怪卡片#
4163#行刑者卡片#
4164#虎蜥人卡片#
4165#史汀卡片#
4166#邪骸浪人卡片#
4167#蓝鼠卡片#
4168#曼斯锹型虫卡片#
4169#伊特瓢虫卡片#
4170#铁蝎卡片#
4171#兽人战士长卡片#
4172#巧克猴卡片#
4173#灰森灵卡片#
4174#梅纳海葵卡片#
4175#冰波利卡片#
4176#雪熊卡片#
4177#邪恶老公公卡片#
4178#玩具士兵卡片#
4179#邪恶礼盒卡片#
4180#魔灵娃娃卡片#
4181#冰暴骑士卡片#
4182#卡仑卡片#
4183#蝙蝠弓箭手卡片#
4184#奈吉鸟卡片#
4185#奈利虫卡片#
4186#单眼虫卡片#
4187#邪恶使者卡片#
4188#哥布灵弓箭手卡片#
4189#狮鹰兽卡片#
4190#镜妖卡片#
4191#风魔巫师卡片#
4192#人鱼士兵卡片#
4193#绿饼人卡片#
4194#海星卡片#
4195#卡拉特小丑卡片#
4196#血腥骑士卡片#
4197#古钟魔卡片#
4198#钟塔守护者卡片#
4199#鳄鱼人卡片#
4200#黑暗之王卡片#
4201#兽人女战士卡片#
4202#邪恶摩艾卡片#
4203#爱丽斯卡片#
4204#幽灵弓箭手卡片#
4205#将军魔碑卡片#
4206#钟乳巨石怪卡片#
4207#三叶虫卡片#
4208#蒸汽哥布灵卡片#
4209#贤者虫卡片#
4210#犬妖弓箭手卡片#
4211#凯美拉卡片#
5001#耳机#
5002#首领冠冕#
5003#小丑帽#
5004#氧气罩#
5005#防毒面具#
5006#颓废眼镜#
5007#领导者头箍#
5008#花冠#
5009#安全帽#
5010#印地安发箍#
5011#天线头饰#
5012#学士帽#
5013#卡浩之角#
5014#剑士头盔#
5015#蛋壳帽#
5016#学生帽#
5017#骨制头盔#
5018#羽毛帽#
5019#海盗船长帽#
5020#卡普拉发圈#
5021#破产之哀#
5022#太阳神头盔#
5023#包袱帽#
5024#蛋糕帽#
5025#天使头盔#
5026#厨师帽#
5027#魔法师帽#
5028#蜡烛头饰#
5029#魔菇帽#
5030#熊猫帽#
5031#矿坑安全帽#
5032#出游帽子#
5033#狸猫帽#
5034#灯泡发圈#
5035#波利帽#
5036#十字架发圈#
5037#水果皮帽#
5038#小恶魔帽#
5039#蓝白蛋壳帽#
5040#红晕#
5041#爱心发夹#
5042#丸子头饰#
5043#歌剧之魂假面#
5044#恶魔之翼#
5045#魔术师帽#
5046#妖道帽#
5047#时尚太阳眼镜#
5048#上弦月发夹#
5049#条纹发带#
5050#神秘的水果皮帽#
5051#猫猫铃铛#
5052#蓝色发带#
5053#人面狮身帽#
5054#刺客口罩#
5055#初学者蛋壳帽#
5056#爱心果实#
5057#八篮_绊剧捞蓖#
5058#疵绢柳_绊剧捞#
5059#磅倒捞_葛磊#
5060#部彬葛磊#
5061#采_赣府巧#
5062#剐陇葛磊#
5063#馆芒绊#
5064#函脚_唱沟蕾#
5065#仟弗_积急#
5066#辑钮滚胶狼_辉#
5067#钾宏饭肺#
5068#厩付狼_朝俺蓖#
5069#咯快啊搁#
5070#凯趋赣府鹅#
5071#牢叼救狼_赣府鹅#
5072#牢钮滚胶狼_辉#
5073#磊技背沥葛磊#
5074#玫荤狼_朝俺蓖#
5075#墨快焊捞葛磊#
5076#判葛磊#
5077#偏赋赣府巧#
5078#秦崔葛磊#
5079#X磊赣府巧#
5080#绊措咯空狼_空包#
5081#固胶飘饭胶狼_空包#
5082#滚几赣府鹅#
5083#弧埃抛老狼_府夯#
5084#蓖满篮_呈备府#
5085#滴街狼_累篮府夯#
5086#舅恩啊搁#
5087#公钎沥_啊搁#
5088#愁鄂传_啊搁#
5089#蓖满篮_啊搁#
5090#绊喉赴府歹狼_啊搁#
5091#目促鄂_陛规匡#
5092#荐赤狼_葛磊#
5093#荐赤狼_葛磊#
5094#坷农洒绢肺狼_捧备#
7001#霉菌粉末#
7002#兽人之牙#
7003#虎蜥皮#
7004#泥团#
7005#骷髅头#
7006#红色蝙蝠翅膀#
7007#巨鼠指甲#
7008#钢硬之角#
7009#彩色外皮#
7010#铁蝎尾巴#
7011#猴子指甲#
7012#强韧鳞梗#
7013#珊瑚#
7014#破旧画像#
7015#回忆书签#
7016#老旧汤匙#
7017#行刑者手套#
7018#小树枝#
7019#傲慢之像#
7020#恶梦之石#
7021#盲人之证#
7022#老旧剑柄#
7023#断柄之刀#
7024#血染之刀#
7025#魔王之悲#
7026#钟塔之钥#
7027#钟塔钥匙#
7028#参赛券#
7029#观赏券#
7030#沙漠之狼之指甲#
7031#破旧平底锅#
7032#蛋壳碎片#
7033#毒魔菇芽孢#
7034#破洞圣诞袜#
7035#火柴#
7036#卡仑之牙#
7037#优惠券#
7038#毛线#
7039#初学者名片#
7040#扩音器#
7041#黄晶沙的一角#
7042#神奇皮革袋子#
7043#黄晶沙#
7044#加油药水#
7045#魔术油漆#
7046#手推车组件#
7047#艾丽斯的围裙#
7048#狮鹫兽的指甲#
7049#石头#
7050#席子#
7051#丝绸席子#
7052#废弃杂志#
7053#赛依伐#
7054#布里刊#
7055#动物粪便#
7056#卡普拉薪资明细表#
7057#角笛#
7058#魔法铁链#
7059#卡普拉仓库 免费利用券#
7060#卡普拉传送点 免费利用券#
7061#卡普拉手推车 免费利用券#
7062#乌龟背壳#
7063#柔软的羽毛#
7064#蜻蜓的翅膀#
7065#海獭的皮革#
7066#冰块一角#
7067#石头一角#
7068#燃烧一半的木材#
7069#破裂的铠甲一角#
7070#破裂的硬壳#
7071#破烂烂的衣服#
7072#锈的飞镖#
7073#菲力亚宝石#
7074#拖尔的铁手套#
7075#拷问器具#
7076#未知的锯齿轮子#
7077#银饰品#
7078#巴吉利的愤怒#
7079#天使翅膀羽毛#
7080#猫脚步声音#
7081#女人的胡须#
7082#石头的根#
7083#鱼的灵魂#
7084#鸟的口水#
7085#熊的筋#
7086#太阳神的象征#
7087#灵魂的呼吸声音#
7088#雪的结晶#
7089#爆风雨的征兆#
7090#安静的水波#
7091#海浪雕像#
7092#空气雕像#
7093#齿轮#
7094#未知的碎片#
7095#金属破片#
7096#凝固的岩浆#
7097#燃烧的心脏#
7098#火种#
7099#老旧魔法图#
7100#尖锐的叶子#
7101#七彩大嘴鸟之羽#
7102#恶梦#
7103#未知的液体瓶#
7104#伪天使的翅膀#
7105#伪灵魂光圈#
7106#魔羌之角#
7107#魔羌之毛皮#
7108#盾牌的碎片#
7109#闪亮的枪锥#
7110#破裂之剑#
7111#光滑的纸#
7112#恐怖的纸刃#
7113#破碎的法老王象征#
7114#杜唐卡门面具#
7115#哈比的羽毛#
7116#哈比的指甲#
7117#撕裂的魔法书#
7118#撕裂的滚动条#
7119#菌丝#
7120#燃烧的马蹄铁#
7121#蜂蜜罐#
7122#炙热的毛#
7123#龙皮#
7124#砂团#
7125#蝎子之螯#
7126#巨大杰勒比结晶#
7127#酒精制作说明书#
7128#火烟瓶制作说明书#
7129#盐酸瓶制作说明书#
7130#植物瓶制作说明书#
7131#刺锤瓶制作说明书#
7132#护贝药制作说明书#
7133#纤细药水制作说明书#
7134#药钵#
7135#火烟瓶#
7136#盐酸瓶#
7137#噬人植物瓶#
7138#刺锤瓶#
7139#护贝药#
7140#生命的种子#
7141#天地树露水#
7142#艾普理欧#
7143#生化试管#
7144#一般药水制作说明书#
7145#RO-T恤#
7146#旅游券#
7147#茉莉花#
7148#母亲的信#
7149#黄色碟子#
7150#竹筒#
7151#油纸#
7152#光泽的头发#
7153#旧和服#
7154#毒粉#
7155#牛蛙之皮#
7156#破旧之手里剑#
7157#黑色覆面#
7158#破碎的酒缸#
7159#天狗的鼻子#
7160#领主的通行证#
7161#拉链熊毛皮#
7162#片云#
7163#锐利的触角#
7164#石榴桃#
7165#害羞之服#
7166#柔软的绸缎布#
7167#魔幻拉链#
7168#巨大翅膀#
7169#太极盘#
7170#燕尾服#
7171#花豹外皮#
7172#花豹指甲#
7174#缎带#
7175#包装纸#
7176#国王的证明书#
7177#喊蝴狼_儒蠢肠_炼阿#
7178#喊蝴狼_儒蠢肠#
7179#捐款证明书#
7180#茄籍豪狼_家俺厘#
7181#拱前_荐飞_康荐刘#
7182#可可#
7183#咯悼积狼_祈瘤#
7184#乔酒畴_扒馆#
7185#柠令曼啊鼻#
7186#啊蠢促鄂_临扁#
7187#绵力_啊搁#
7188#哎祸谎府#
7189#唱公缴厘#
7190#窜窜茄_殿伯龙#
7191#殿阂#
7192#官恩俺厚狼_漠朝#
7193#惯酒货较#
7194#何靛矾款_钱蕾#
7195#货醚#
7196#绢柄焊龋措#
7197#龙变_唱公耽酿#
7198#目促鄂_蕾荤蓖#
7199#捻迄#
7200#藕仿乐绰_临#
7201#烹唱公#
7202#捧备国饭狼_笼霸#
7203#瓢瓢茄_唱沟啊瘤#
7204#拳距#
7205#八篮_玫炼阿#
7206#八篮_绊剧捞_牢屈#
7207#嘲篮_噶配#
7208#踌郊_侥漠#
7209#掂扼茄狼_捧备#
7210#掂扼茄狼_癌渴炼阿#
7211#肺力鸥胶沛_炼阿#
7212#概崔赴_牢屈#
7213#官疵接瘤#
7214#冠零快府#
7215#何矾柳_官疵#
7216#弧埃_赣敲矾#
7217#角菩#
7218#解篮_瑰临#
7219#临公刺_剧富#
7220#咀配敲扼硫#
7221#爵腮_荤浇#
7222#唱公_克捞#
7223#老弊矾柳_磊拳惑#
7224#泅磊狼_倒#
7225#龋冠_檬氛#
7226#券距#
7227#TCG墨靛#
7228#陛鲍#
7229#篮鲍#
7230#归陛鲍#
7231#陛堡籍#
7232#篮堡籍#
7233#固胶副堡籍#
7234#辨靛狼_付澜#
7235#倒拜狼_付澜#
7236#荐龋狼_付澜#
7237#蛆悼狼_付澜#
7238#炼拳狼_付澜#
7239#傈柳狼_付澜#
7240#脚汾狼_付澜#
7241#搬加狼_付澜#
7242#拳钦狼_付澜#
7243#蛆仿狼_付澜#
7244#窜搬狼_付澜#
7245#快沥狼_付澜#
7246#乞拳狼_付澜#
7247#辟己狼_付澜#
7248#疙抗狼_付澜#
7249#豪荤狼_付澜#
7250#康堡狼_付澜#
7251#铰府狼_付澜#
7252#茄规距犁#
7253#陛祸狼_怕必扁#
7254#叼瘤判牢拳鼻#
7262#功鲍狼_何盲#
7263#功救籍#
7264#富扼滚赴_葛贰#
7265#侩狼_辉#
7266#侩狼_撇聪#
7267#龋尔捞_埔萍#
7268#家蓖飞#
7269#酒扁狼_盼罐魔#
7270#酒扁狼_快蜡捍#
9001#波利魔物蛋#
9002#土波利魔物蛋#
9003#波波利魔物蛋#
9004#疯兔魔物蛋#
9005#小鸡魔物蛋#
9006#苍蝇魔物蛋#
9007#绿苍蝇魔物蛋#
9008#赤苍蝇魔物蛋#
9009#小野猪魔物蛋#
9010#沙漠幼狼魔物蛋#
9011#摇滚蝗虫魔物蛋#
9012#魔菇魔物蛋#
9013#毒魔菇魔物蛋#
9014#大嘴鸟魔物蛋#
9015#狸猫魔物蛋#
9016#溜溜猴魔物蛋#
9017#兽人战士魔物蛋#
9018#殭尸魔物蛋#
9019#土人魔物蛋#
9020#鬼女魔物蛋#
9021#蛇女伊丝魔物蛋#
9022#毕帝特地龙魔物蛋#
9023#小恶魔魔物蛋#
9024#小巴风特魔物蛋#
9025#妖道魔物蛋#
10001#牛角骨盔#
10002#宠物防毒面具#
10003#潜水头盔#
10004#宠物奶嘴#
10005#三色假发#
10006#蛇饰发箍#
10007#宠物发带#
10008#体罚棒#
10009#野生花#
10010#变形锅子#
10011#宠物发夹#
10012#宠物蛋壳帽#
10013#宠物书包#
10014#蝗虫眼镜#
10015#宠物围兜兜#
10016#宠物铃铛#
10017#树皮裤#
10018#猴子发箍#
10019#红色领巾#
10020#灵幻道士之剑#

---------摘自99nets


RO魔物代码

//魔物ID，魔物名字
1001,蝎子
1002,波利
1003,盗虫卵
1004,蜂兵
1005,吸血蝙蝠
1006,小盗虫
1007,绿棉虫
1008,虫蛹
1009,秃鹰
1010,树精
1011,苍蝇
1012,罗达蛙
1013,狼
1014,魔菇
1015,腐尸
1016,邪骸弓箭手
1017,大盗虫
1018,克瑞米
1019,大嘴鸟
1020,曼陀萝魔花
1021,绿盗虫
1022,狼人
1023,兽人战士
1024,森灵
1025,青蛇
1026,殭尸
1027,RAPTICE
1028,邪骸士兵
1029,蛇女伊丝
1030,黄蛇
1031,波波利
1032,木乃伊犬
1033,长老树精
1034,达拉蛙
1035,赤苍蝇
1036,绿腐尸
1037,黑蛇
1038,俄塞里斯
1039,巴风特
1040,巨石怪
1041,木乃伊
1042,绿苍蝇
1043,海马
1044,人鱼
1045,马克
1046,死灵
1047,大嘴鸟蛋
1048,盗虫卵
1049,小鸡
1050,蛋壳小鸡
1051,小盗虫
1052,摇滚蝗虫
1053,浮勒盗虫
1054,玛勒盗虫
1055,摩卡
1056,狸猫
1057,溜溜猴
1058,重金属蝗虫
1059,蜂后
1060,大脚熊
1061,梦魇
1062,圣诞波利
1063,疯兔
1064,邪骸食人鱼
1065,海神
1066,螃蟹
1067,卡那多斯
1068,海葵
1069,异变鱼
1070,库克雷
1071,邪骸海盗
1072,卡浩
1073,卡拉蟹
1074,贝壳魔灵
1075,海龟
1076,邪骸战士
1077,毒魔菇
1078,红草
1079,蓝草
1080,绿草
1081,黄草
1082,白草
1083,光芒草
1084,黑菇
1085,红菇
1086,黄金虫
1087,兽人英雄
1088,蝗虫之王
1089,蛙王
1090,波利之王
1091,绿龙蝇
1092,流浪之狼
1093,疯兔王
1094,蜗牛
1095,白蚁
1096,天使波利
1097,白蚁幼虫
1098,安毕斯
1099,艾吉欧蜈蚣
1100,艾斯蜘蛛
1101,小巴风特
1102,巫婆
1103,刺猬虫
1104,松鼠
1105,兵蚁
1106,沙漠之狼
1107,沙漠幼狼
1108,狄奥斯
1109,小恶魔
1110,土人
1111,红蝙蝠
1112,海盗之王
1113,土波利
1114,猎蝇
1115,虎王
1116,转转蛋
1117,闇神官
1118,噬人花
1119,伞蜥蜴
1120,幽灵波利
1121,基尔瑟
1122,刺刀哥布灵(长男)
1123,链锤哥布灵(次男)
1124,大斧哥布灵(三男)
1125,榔头哥布灵(四男)
1126,刺锤哥布灵(五男)
1127,蚯蚓
1128,锹形虫
1129,鬼火
1130,南瓜先生
1131,裘卡
1132,卡利斯格
1133,大斧犬妖(长男)
1134,榔头犬妖(次男)
1135,刺锤犬妖(三男)
1136,犬妖四男
1137,犬妖五男
1138,魔锅蛋
1139,螳螂
1140,马尔杜克
1141,水母
1142,气泡虫
1143,傀儡娃娃
1144,乌贼
1145,土拨鼠
1146,黑狐
1147,蚁后
1148,米杜沙
1149,米洛斯
1150,月夜猫
1151,麦斯特
1152,邪骸兽人
1153,兽人腐尸
1154,帕莎纳
1155,毕帝特地龙
1156,毕帝特飞龙
1157,法老王
1158,剑鱼
1159,皮里恩
1160,工蚁
1161,漂浮虫
1162,草精
1163,幽灵剑士
1164,诺可伊
1165,泥人
1166,野猪
1167,小野猪
1168,蝎王
1169,邪骸矿工
1170,鬼女
1171,白蚁士兵
1172,兵蚁士兵
1173,工蚁士兵
1174,瓢虫
1175,白鼠
1176,黑蚁
1177,兹诺克
1178,杰洛米
1179,白幽灵
1180,九尾狐
1181,殭尸龙
1182,盗蘑菇
1183,苍蝇
1184,绿棉虫
1185,巨大白幽灵
1186,巨大白幽灵
1187,SWITCH
1188,妖道
1189,兽人弓箭手
1190,兽人领主
1191,邪恶箱
1192,恶灵
1193,钟怪
1194,卷甲虫
1195,飞行魔书
1196,邪骸战俘
1197,腐尸战俘
1198,暗黑祭司
1199,朽魔
1200,艾斯恩魔女
1201,瑞比欧
1202,阿修罗狂战士
1203,弒神者
1204,兽牙怪
1205,行刑者
1206,虎蜥人
1207,史汀
1208,邪骸浪人
1209,蓝鼠
1210,曼斯锹形虫
1211,伊特瓢虫
1212,铁蝎
1213,兽人战士长
1214,巧克猴
1215,灰森灵
1216,梅纳海葵
1219,深渊骑士
1220,M_DESERT_WOLF
1221,M_SAVAGE
1222,L_HIGH_ORC
1223,L_ORC
1224,L_POISON_SPORE
1225,L_CHOCO
1226,L_KOBOLD
1227,L_GOBLIN
1228,L_PHEN
1229,META_FABRE
1230,META_PUPA
1231,META_CREAMY
1232,META_PECOPECO_EGG
1233,CONCEIVE_PECOPECO
1234,PROVOKE_YOYO
1235,SMOKING_ORC
1236,META_ANT_EGG
1237,META_ANDRE
1238,META_PIERE
1239,META_DENIRO
1240,META_PICKY
1241,META_PICKY_
1242,冰波利
1243,雪熊
1244,圣诞南瓜先生
1245,圣诞哥布灵
1246,甜饼人
1247,邪恶老公公
1248,玩具士兵
1249,邪恶礼盒
1250,魔灵娃娃
1251,冰暴骑士
1252,卡仑
1253,蝙蝠弓箭手
1254,奈吉鸟
1255,奈利虫
1256,单眼虫
1257,邪恶使者
1258,弓箭哥布灵
1259,狮鹫兽
1260,镜妖
1261,狂暴野猫
1262,半龙人
1263,风魔巫师
1264,人鱼士兵
1265,绿饼人
1266,海星
1267,卡拉特小丑
1268,血腥骑士
1269,古钟魔
1270,钟塔守护者
1271,鳄鱼人
1272,黑暗之王
1273,兽人女战士
1274,邪恶摩艾
1275,艾丽斯女仆
1276,幽灵弓箭手
1277,将军魔碑
1278,钟乳巨石怪
1279,三叶虫
1280,喷射哥布灵
1281,贤者虫
1282,犬妖弓箭手
1283,凯美拉
1284,HUGELING
1285,外城,弓箭手,监护人
1287,内城,士兵,监护人
1286,内城,骑士,监护人
1288,华丽金属
1289,狂暴蚁后
1290,邪骸战士长
1291,狂暴恶灵
1292,狂暴小恶魔
1293,狂暴克瑞米
1394,狂暴螳螂
1295,鹗枭男爵
1296,犬妖首领
1297,狂暴木乃伊
1298,腐尸首领
1299,哥布灵首领
1300,狂暴绿棉虫
1301,狂暴小土人
1302,迷幻之王
1303,狂暴蜂兵
1304,狂暴蜘蛛
1305,狂暴蜈蚣
1306,狂暴大脚熊
1307,狂暴月夜猫
1308,狂暴哥布灵
1309,狂暴鬼火
1310,狂暴米洛斯
1311,狂暴野猪
1312,乌龟将军
1313,流氓
1314,果树龟
1315,风灵龟
1316,岩石龟
1317,海豹宝宝
1318,火焰龟
1319,水灵龟
1320,鹗枭首领
1321,刺尾蜻蜓
1322,弹簧兔
1323,海獭
1324~1363,宝箱
1364,风灵龟
1365,阿修罗机械战士
1366,熔岩巨石
1367,火焰妖
1368,邪恶向日葵
1369,七彩大嘴鸟
1370,恶魔女仆
1371,伪天使
1372,魔羌
1373,死灵骑士
1374,恶魔侍者
1375,纸妖
1376,鸟人哈比
1377,邪灵魔导士
1378,天邪鬼
1379,七彩梦魇
1380,爆钻伞蜥
1381,暴焰野熊
1382,赤焰小恶魔
1383,爆炎蝙蝠
1384,七彩飞龙
1385,七彩地龙
1386,沙妖
1387,沙漠毒蝎
1388,圣天使波利
1389,德古拉男爵
1390,薇欧莉
1391,啤酒企鹅
1392,直升机哥布灵
1393,G_MUMMY
1394,G_ZOMBIE
1395,黄水晶
1396,绿水晶
1397,蓝水晶
1398,红水晶
1399,周年庆巴风特
1400,伞妖
1401,火忍西怒毕
1402,牛蛙
1403,武士火枪兵
1404,米雅毕
1405,天狗
1406,钓鱼河童
1407,DOKEBI_
1408,血蝴蝶
1409,元宵童子
1410,猴桃木
1412,恶云仙人
1413,人蔘精
1415,小花豹
1416,妖仙女
1417,拉链熊
1418,墨蛇君
1419~1491,未知
1492,元灵武士
1493,树精
1494,幼甲虫
1495,石头射手
1497,木头人
1498,人猿弹弓手
1499,人猿战士
1500,寄生女孩
1502,火焰波利
1503,鬼娃树
1504,无颅武士
1505,银月魔女
1506,假面鬼
1507,嗜血怪
1508,万圣魔
1509,南瓜魂
1510,兔斯拉
1511,古埃及王
1512,腐尸王
1513,判官
1514,舞龙
1515,小卡仑
1516,黏土怪
1517,舞狮

--------摘自99nets


SQL版中数据表

cart_inventory -> 保存手推车资料的表

char -> 保存人物角色资料的表

globalse_reg_value -> 记录角色变量（标记）资料的表

ipbanlist -> 保存被屏蔽的IP地址列表

login -> 保存玩家帐号资料的表

loginlog -> 保存玩家帐号登陆记录的表

memo -> 保存玩家使用memo记录位置的表

pet -> 保存宠物资料信息的表

skill -> 保存玩家技能资料的表

sstatus -> 保存当前服务器在线人数的表

storeage -> 保存仓库资料的表

-------摘自99nets haoxiaoyuhao(多多の宝贝 美雨儿)


工会的相关说明

1。成立公会
将华丽金属放在道具栏内，再输入/guild [公会名称]就可以成立了！

2。踢除会员或退出工会
按Ctrl+G出现工公视窗，在想踢除的会员(或自己)的角色名上点右键，会出现“显示资讯”、

“退出工会”两个选项

3。解散公会
当公会中只剩下公会会长时输入/breakguild [公会名称]或输入/gocp [公会名称]即可。

4。公会图徽制作
图档规格：24x24(像素),256色，BMP档。放在仙境传说Emblem这个目录下，如果则新建此目录。

想让图档透明，请选R(红)255 G(绿)0 B(蓝)255。 工会图标可至

http://ro.17173.com/up/up.htm找寻。

5。工会超收人密技
一般工会只能收16人--有个方法可收超过16人
就是一个可以有收人权限的人~~~
在工会还有名额时~~~
把要入工会的人召集起来~~~~
然后一次送出~~对每个人做邀请的动做
等大家都收到邀请后~~~就可以请大家按确定了
先让工会成员在15人的状态
然后把所有要入工会的人聚集在一起
然后有权限收人的人 把要入会的通通邀请
这时候看到确认视窗先不要按下
等通通邀请完之后再按 这样就能超收了
事后要在收的话 可以 但是比较麻烦
例如你工会现在19个人
包括能收人的就要有5个人在线上
然后那五个人聚在一起加上新要入会的
四个人自己退会 然后有权限收人的那个人 在收一次就行噜.....
至于抽的经验倒是没有影响.....

6。工會會長刪除重創（作者：edl)
步驟1：將角色刪除(請先把裝備道具存入倉庫，金錢找朋友轉)；

步驟二：重新創立同樣名字的新角色；步驟三：找你工會的成員收你入工會

(請先設定您有開放收人的權利給該成員)；步驟四 ：切換地圖或重新登入；

這樣就大公告成，完全可以使用會長的功能。後遺症: 工會成員第一個位置還是之前的角色。

選擇您的職位後，第二個位置就是您新的角色；其他成員往後退一格。
青豆花了三个华金来做这个试验，证明可行。唯一不对的是新人物不能发行会公告，

其他会长功能都能使用。

-------摘自青豆网


Athena主要文件结构

Skill_tree.txt
建立技能树內容于技能威力、范围
內容:
JOB_ID,ID,SKILL_ID,SKILL_LV,Skill1,SkillLV1,Skill2,Skill2....Skill5,SkillLV5
使用职业,技能,技能最高等級,前置技能1,前置技能等1,前置技能2,前置技能等2.....
EX.1,3,10,2,1,0,0,0,0,0,0,0,0 //剑士,双手剑熟练,等級10,单手剑熟练,等級1,,,,,,

mob_db.txt
怪物资料库
內容:
ID,Name,JName,LV,HP,SP,EXP,JEXP,Range1,ATK1,ATK2,DEF,MDEF,STR,AGI,VIT,INT,DEX,LUK

,Range2,Range3,Scale,Race,Element,Mode,Speed

,ADelay,aMotion,dMotion,Drop1id,Drop1per,Drop2id,Drop2per,Drop3id,Drop3per,Drop4id,

Drop4per,Drop5id,Drop5per,Drop6id,Drop6per

,Drop7id,Drop7per,Drop8id,Drop8per,Item1,Item2,MEXP,ExpPer,MVP1id,MVP1per,MVP2id,

MVP2per,MVP3id,MVP3per
怪物ID,名字,日文名,等級,体力,魔力,经验值,职业经验值,锁定范围,攻击力1,攻击力2,

防御力,魔法防御力,力量....

Speed,ADelay,aMotion,dMotion,
移动速度,动作延遲,攻击時速度,被攻击時速度

Drop1id,Drop1per......
掉落物品1,物品1掉落机率......
MVP1id,MVP1per......
MVP物品1,MVP物品1掉落机率......

job_db1.txt
使用武器速度资料库
內容:
//weight,hp,sp,aspd*17(空手,短剑,单手剑,双手剑,单手枪,双手枪,单手斧,双手斧,

单手钝器,双手钝器,杖,弓,爪,乐器,鞭,书,拳刃)
重量,体力,魔力,武器aspd*17=实际攻速(毫秒)
//x NV,SW,MG,AC,AL,MC,TF,KN,PR,WZ,BS,HT,AS,KNp,CR,MO,SA,RG,AM,BA,DC,CRp
Y轴数值內容

Novice,Swordman,Mageic,Archer,Acolyte,Merchant,Thief,Knight,Priest,Wizard,

Blacksmith,Hunter,Assassin,Knight2,Crusader,Monk,Sa

ge,Rogue,Alchem,Bard,Dancer,Crusader2
PS.数字越小速度越快,100则是不能使用
EX.20000, 0,1, 50, 65, 70,100,100,100, 80,100, 70,100, 65,100,100,100,100,100,100

job_db2.txt
各职业各個base等級的素質加成
// job_bonus 0-non 1-str 2-agi 3-vit 4-int 5-dex 6-luk
X轴数值內容
//x NV,SW,MG,AC,AL,MC,TF,KN,PR,WZ,BS,HT,AS,KNp,CR,MO,SA,RG,AM,BA,DC,CRp
Y轴数值內容

Novice,Swordman,Mageic,Archer,Acolyte,Merchant,Thief,Knight,Priest,Wizard,

Blacksmith,Hunter,Assassin,Knight2,Crusader,Monk,Sa

ge,Rogue,Alchem,Bard,Dancer,Crusader2
EX.0,6,5,0,2,3,0,1,4,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,

0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
//初学者 等級2 LUK加成,等級3 DEX加成.....

const.txt
职业索引
EX.Job_Novice 0 //初学者代号为0

cast_db.txt
技能咏唱时间(毫秒)
技能代号 动画时间,动作时间
EX.156,1500,1000 //AL_HOLYLIGHT,1.5秒动画表現,1秒动作

exp.txt
升级所需经验值
base,初学者JOB,一转JOB,二转JOB
EX.9,10,30,144 //BaseLV1EXP 9,N_JobLV1EXP 10,1JobLV1EXP 30,2JobLV1EXP 144

battle_athena.cnf
// 是否支持PVP模式
pvp: off
// 怪物是否有爆击几率
enemy_critical: yes
// 咏唱时间（0无咏唱、100正常、200两倍）
casting_rate: 100
// 延迟时间（0无延迟、100正常）
delay_rate: 100
// 延迟时间是否受DEX影响
delay_dependon_dex: yes
// 防御ユニット（SW/ニューマ）が敵に効果を及ぼさないようにするかどうか
defunit_not_enemy: yes
// MVP血量倍率（100正常、200两倍....）
mvp_hp_rate: 100
// 物品掉落倍率（100正常、200两倍....）
item_rate: 600
// 基本经验所得倍率（100正常、200两倍....）
base_exp_rate: 2000
// 职业经验所得倍率（100正常、200两倍....）
job_exp_rate: 2000
// MVP物品所得倍率（100正常、200两倍....）
mvp_item_rate: 600
// MVP经验所得倍率（100正常、200两倍....）
mvp_exp_rate: 600
// GM命令是否专用
atcommand_gm_only: no
// GM是否会全部技能
gm_all_skill: yes
// 武器制造成功率（100正常、200两倍成功率....）
weapon_produce_rate: 200
// 宠物捕获几率(100正常、200两倍几率....)
pet_rate: 100
// 设定怪物行为方式的参数，具体效果不明
monster_loot_type: 0
// 是否打开怪物技能
mob_skill_use: yes
// 是否可以重复更改宠物名字
pet_rename: no
// 宠物饥饿时间的倍率（100正常、200两倍时间）
pet_hungry_delay_rate: 200
// 怪物数量的倍率（100正常、200两倍....）
mob_count_rate: 100

char_athena.cnf

server_name: 雅典娜 /服务器名
login_ip: 127.0.0.1 /注册服务器IP地址
login_port: 6900 /端口
char_ip: 127.0.0.1 /人物服务器IP地址
char_port: 6121 /端口
char_maintenance: 0
char_new: 0
char_txt: athena.txt /指定人物数据文件
stor_txt: storage.txt /指定仓库数据文件
start_point: new_5-1.gat,53,111 /初心者出生地点

map_athena.cnf

char_ip: 127.0.0.1 /人物服务器IP
char_port: 6121 /端口
map_ip: 127.0.0.1 /地图服务器IP
map_port: 5121 /端口

//加载npc路径
npc: conf/npc_reset.txt
npc: conf/job1.txt
npc: conf/job2.txt
............
//加载地图路径
map: alb2trea.gat
map: alb_ship.gat
............

mob_skill_db.txt

1016,DS@アチャスケ,attack,46,1,300,1500,10000,yes,target,myhpltmaxrate,30
怪物ID,技能介绍,使用状态,技能ID,技能等级,使用频率,咏唱时间,延迟时间,

是否造成伤害,目标,使用条件1,条件值1,,,,,,,,

使用状态:any/任何情况,idle/待机中,walk/移动中,attack/攻击中
目标:target/对手,self/自己,friend/队友
使用条件:always/无条件,myhpltmaxrate/自己hp低于条件值,friendhpltmaxrate/队友hp低于条件值,

attackpcgt/攻击对手超过条件值,closedattacked/对手接近条件值,longrangeattacked/对手远离条件值,

skillused/指定技能值,casttargeted/目标咏唱时

pet.txt

10015,1029,蛇女伊丝 704554,100000,43,9021,10006,900,99,0,0
编号,宠物ID,名字[Tab]拥有人ID,饥饿度,等级,亲密度,装饰品ID,,,,0(0为召唤状态，1为蛋的状态)

---------摘自99nets haoxiaoyuhao


DB文件夹内文件说明

attr_fix.txt 属性修正,改的时候请注意格式

castle_db.txt 工会城堡地图设置

cast_db.txt 技能魔法咏唱时间列表

class_equip_db.txt 道具使用限制设定

const.txt 没必要不要修改

create_arrow_db.txt ID建立设定,没必要不要修改

exp.txt 升级经验设置,不想玩99级想玩200级甚至更高的改这里,注意格式

exp_guild.txt 工会等级升级经验设置

item_bluebox.txt 蓝箱子能开出的道具设置

item_cardalbum.txt 老旧收集册开出卡片设置

item_db.txt 所有道具属性设置,也可以当作道具列表查看.如果你想把什么道具改的很BT,就是这里了..

item_giftbox.txt 礼物箱能开出道具设置,就是圣诞村那些怪掉的礼物箱

item_noequip.txt 工会战时不能装备道具物品设置

item_scroll.txt 古老书籍开出道具设置,目前为空,可以自己设置来玩,注意格式

item_value_db.txt 物品价格设定,我设置了这个似乎用处不大,还是在

item_db.txt里设置有用..

item_violetbox.txt 紫箱子开出的道具设置

job_db1.txt 攻击速度修正,就是设置你拿了武器或空手以后有多少攻击速度的设置

job_db2.txt job等级对基本属性的修正,就是那个job多少级可以加几点基本属性的那种

mob_branch.txt 枯树枝可召唤怪物设定.

mob_db.txt 所有怪物设置,怪物的经验,血量,基本属性,攻击防御力,以及掉什么东西都在这里设置..

mob_skill_db.txt 怪物技能设定,想玩BT怪物的可以改这个文件试试.

pet_db.txt 宠物设置,抓宠的各项设定都在这里.

produce_db.txt 锻造属性设置,这里可以设置锻造各种武器所需要的材料.

refine_db.txt 精练成功率设置.

size_fix.txt 体形修正,没必要不要修改,改了对你和怪都有效果噢

skill_db.txt 技能属性以及消耗SP点设置

skill_tree.txt 技能树设置...没必要不要乱改..

--------摘自99nets haoxiaoyuhao


RO小技巧与迷宫地图

1。進入北之森迷宮一层後 → → ↓ → ↑ 就可以快速到達二樓

2。在攻击怪物的时候，按下insert(坐下)，这时人物还是在攻击，

可是血的回复速度已经是和坐这一样了。在攻击结束后要再坐下站起一次才能行走。

3。alt+g 本来是用来编辑表情的，但也可以用来编辑说话的热键，

只要把 alt+1~x内改成要说的话就可以了。很实用哦。。

4。在中央城中央花圆右边里面的2层坐下来，HP和SP回复都是平常的两倍！

5。多人聊天室中如何密語：選右邊欄位(人名欄)你想密的人，

被選的人會變青綠色；直接打訊息；你會發現變密語了@_@!

不想用密時再點旁邊空白一下，取消選取就OK嘍^O^

6。枯樹枝的作用
在同個地點放一堆地雷 ，然後站在地雷上招怪 ，怪一生出來就死了 ，

道具是掉複數個的.... 5個地雷掉5次...

7。天津城1F迷宮

8。矿洞2F迷宮

-------摘自青豆网


RO中有用的新旧命令

/effect:关闭效果，让游戏进行更流畅。
/skip:双开会死机吗？用这个吧！

/doridori :若连续输入这指令, 玩家角色会摇头。
/bingbing : 若连续输入这指令, 玩家角色会逆时钟方向转身。
/bangbang : 若连续输入这指令, 玩家角色会顺时钟方向转身。

/noshift : 不用按shift键, 也可以用治愈术攻击魔物 。

/noshift的指令现在也可以用/ns代替。
/notalkmsg : 聊天的内容不显示在聊天窗口上 。

/notalkmsg的指令现在也可以用/nm代替。
/noctrl : 不用按ctrl键, 也可以自动攻击魔物 。

/noctrl的指令现在也可以用/nc代替。
/skillfail : 使用红色技能失败时,不会显示讯息 。

/skillfail的指令现在也可以用/官服代替。
/showname : 变更角色姓名的显示方式。
/set1 : /noctrl + /showname + /skillfail。

report : 储存报案用的整理档案，作为游戏内不礼貌或不正当行为的证据资料.。

/quickspell : 点选鼠标右键之后，可以使用 F9键里的储存技能。

现在也可以用/q1代替。
这个很有用，RO里无用的鼠标右键现在也派上了用场！

(GM可以当做没看到这句话^.^)
/quickspell2 :上下滚动鼠标滚轮之后，可以使用F7键和F8键里的储存技能。

现在也可以用/q2代替。
这个比较有意思，向上滚动是F8键里面的技能，向下滚动是F7键里面的技能。
/q3 : /quickspell (/q1) + /quickspell2 (/q2)。

/battlemode(也可以用/bm)：由于F1～F9 的九个快捷方式按键不足以使用，

因此追加了这个战斗模式。　Q～O 的按键可以使用快捷方式列2的技能，

A～L的按键可以使用快捷方式列3的技能。不用再按F12切换了。

-------摘自青豆网


用游戏手柄玩仙境传说

§ RO by 搖桿 (教學篇) §

標　題：[心得] RO by 搖桿 (教學篇)
時　間：Thu Sep 5 14:27:22 2002

前言︰由於遊戲中按鈕特別多，所以不能一一設定，
所以這裡只教設定移動、攻擊及熱鍵設定。

必要東西︰1.JoyToKey (這裡是用英文版來講)
http://home.pchome.com.tw/comics/lovecelia413/jtk373en.exe
2.這裡是以PS或PS2的搖桿為主
3.轉接器(就是能把PS或PS2的搖桿轉接到電腦上的)
4.以及耐力及毅力

教學︰1.先把轉接器 ＋ 搖桿弄好 (包括搖桿驅動程式)
2.下載JoyToKey英文版
3.解完壓縮後，點選裡面的JoyToKey.exe
4.之後選擇File -> Create new configuration file
(或者是按下面的 Create )
5.然後會要你為這個 new configuration 命名 (就叫 RO 好了)
6.再來看到右邊的橫字那裡，點選 Others
7.然後把 Regard diagonal input as special case 給打勾，
這樣就可以設定右上、右下、左上、左下
8.回來 Joysticks ，點選 Joystick1 裡的 Button 欄的 Left，
接著就會跳出一個視窗，然後選擇 Mouse
9.然後看到 Cursor Movements (有直條跟橫條兩個)，
選擇橫條， 向左點點到 -20 (可視自己的習慣而定)，好了後點選 OK
10.接著是 Right ，方法同上但這次是向右點點到 20
11.再來是 Up ，這裡就要選擇直條那個，向上點點到 -20
12.Down 的方法也一樣，只不過要向下點點到 20
13.再來設定右上、右下、左上、左下，由於方法都跟上面一樣，所以就簡略敘述

橫條 直條
右上 20 -20
右下 20 20
左上 -20 -20
左下 -20 20

------------------------------------------------------------

接下来是按鈕設定：

設定須知︰由於我是用PS2的搖桿，所以要先找出各按鈕所代表的數字

Button 1 = □ Button 2 = ╳ Button 3 = ○
Button 4 = △ Button 5 = L1 Button 6 = R1
Button 7 = L2 Button 8 = R2
Button 9 = selet Button 10 = start
Button 11 = L3 Button 12 = R3

教學︰15.假設如果要設 ○ 為滑鼠左鍵的話，就點選 Button 3 進入，
選擇 Mouse -> Use button click ，把 Left Button 給打勾，
然後 Automatic Shooting 設為每秒 6 次(可以自己習慣而定)

16.假如說要設 L1 為滑鼠右鍵的話，就點選 Button 5 進入，
同樣選擇 Mouse -> Use button click ，把 Right Button 給打勾，
然後 Automatic Shooting 設為每秒 0 次(千萬一定要設為 0 )

17.同樣的方法，你可以設一些你想要的按鈕，如 F12 鍵，若要設在 △ 上
同樣點選 Button 4 進入，選擇 Keyboard ，
在哪裡會看到三個 Disabled ，在第一個的 Disabled 按 F12 後，
就會出現 F12 ，再按 OK 就行了。

18.附帶一提，若是要設 Ctrl + Tab 的話，由於 Tab 會按不出來，
這時在右邊有個 assign 的選項，按下去後就會出來了

19.以上差不多把一些按鈕怎麼設的方法都教出來了，有興趣的人可以試試看。

-------摘自青豆网


RO中不太常见的快捷键

1。在公開發言模式下，打完要說的話之後:
Alt+Enter = 工會頻道
Ctrl+Enter = 隊伍頻道

2。alt+d:改變畫面精細程度；

3。ctrl+ 鍵盤最右邊的+,-:小型地圖放大,縮小；

4。按Alt加上F10後,可以把底下的聊天視窗馬上關閉
不管你的視窗開多大,都會馬上關掉；

5。移動RO視窗
  alt+空白鍵=>空白鍵放開但alt不要放=>按M=>放開所有按鍵=>
  用鍵盤的上下左右鍵移動=>移動到喜歡的地方後按Enter即可；

6。遊戲中可以使用 Shift + Delete 剪下 和 Shift + Insert 貼上；

-------摘自青豆网


完整bonus所有效果一覽

bonus bStr,n; STR+n
bonus bAgi,n; AGI+n
bonus bVit,n; VIT+n
bonus bInt,n; INT+n
bonus bDex,n; DEX+n
bonus bLuk,n; LUK+n

bonus bMaxHP,n; 最大HP+n
bonus bMaxSP,n; 最大SP+n
bonus bMaxHPrate,n; 最大HP+n%
bonus bMaxSPrate,n; 最大SP+n%
bonus bAtk,n; 攻撃力+n
bonus bAtk2,n; 攻撃力2+n
bonus bAtkRate 攻撃力+n%
bonus bBaseAtk,n; 基本攻撃力+n
bonus bMatk,n; 魔法攻撃力1+n、魔法攻撃力2+n
bonus bMatk1,n; 魔法攻撃力1+n
bonus bMatk2,n; 魔法攻撃力2+n
bonus bMatkRate,n; 魔法攻撃力+n%
bonus bMdef,n; 魔法防禦力+n
bonus bMdefRate,n; 魔法防禦力+n%(裝備)
bonus bMdef2Rate,n; 魔法防禦力+n%(自於int的東西？)
bonus bDef,n; 防禦力+n
bonus bDefRate,n; 防禦力+n%(裝備)
bonus bDef2Rate,n; 防禦力+n%(自於vit的東西？)
bonus bHit,n; 命中率+n
bonus bHitRate,n; 命中率+n%
bonus bCritical,n; 必殺攻擊率+n
bonus bCriticalRate,n; 必殺攻擊率+n%
bonus bFlee,n; 迴避率+n
bonus bFlee2,n; 完全迴避+n
bonus bFleeRate,n; 迴避率+n%
bonus bFlee2Rate,n; 完全迴避率+n%
bonus bAddSpeed,n; 移動速度+n
bonus bAspd,n; 攻撃速度+n
bonus bSpeedRate,n; 移動速度n%
bonus bAspdRate,n; 攻撃速度n%
bonus bSpeedAddRate,n; 移動速度+n%
bonus bAspdAddRate,n; 攻撃速度+n%
bonus bAtkRange,n; 攻撃射程+n
bonus bCastrate,n; 詠唱時間+n%
bonus bUseSPrate,n; SP消費量+n%
bonus bHPrecovRate,n; HP自然回復量+n%
bonus bSPrecovRate,n; SP自然回復量+n%
bonus bDoubleRate,n; 連擊發動率n%
bonus bDoubleAddRate,n; 連擊發動率+n%
bonus bPerfectHitRate,n; 必中攻撃率n%
bonus bPerfectHitAddRate,n; 必中攻撃率+n%
bonus bGetZenyNum,n; 物理攻撃打倒怪物得到怪物LV*10+rand()%n的Zeny
bonus bAddGetZenyNum,n; 物理攻撃打倒怪物得到怪物LV*10+rand()%n的Zeny
bonus bCriticalDef,n; 必殺攻擊防禦+n%？（不確定）
bonus bNearAtkDef,n; 減輕近距離攻撃的傷害n%
bonus bLongAtkDef,n; 減輕遠距離攻撃的傷害n%
bonus bMagicAtkDef,n; 減輕魔法攻撃的傷害n%
bonus bMiscAtkDef,n; 減輕其他攻撃(陷阱與獵鷹)的傷害n%

bonus bIgnoreDefRace,n; 無視n種族的防禦力
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus bIgnoreDefEle,n; 無視n屬性的防禦力
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus bIgnoreMDefRace,n; 無視n種族的魔法防禦力
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus bIgnoreMDefEle,n; 無視n屬性的魔法防禦力
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus bDefRatioAtkRace,n; n種族的防禦力越高造成的傷害越高(防禦無視)
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus bDefRatioAtkEle,n; n屬性的防禦力越高造成的傷害越高(防禦無視)
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus bAtkEle,n; 給予武器n屬性
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus bDefEle,n; 給予防具n屬性
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus bSplashRange,n; 普通的武器攻撃對目標週邊n格造成傷害

(1為3*3、2為5*5以此類推)
bonus bSplashAddRange,n; 普通的武器攻撃對目標週邊n格造成傷害

bonus bInfiniteEndure,n; 無限霸體(n無意義)
bonus bRestartFullRecover,n; 復活時HP和SP全部恢復(n無意義)
bonus bNoCastCancel,n; 受到攻擊不會詠唱魔法失敗(GVG會失敗、n無意義)
bonus bNoCastCancel2,n; 受到攻擊不會詠唱魔法失敗(GVG也不會失敗、n無意義)
bonus bNoSizeFix,n; 不受到怪物體型的傷害修正(n無意義)
bonus bNoWeaponDamage,n; 不受到物理攻擊傷害(n無意義)
bonus bNoMagicDamage,n; 不受到魔法傷害(包括治療術、n無意義)
bonus bNoGemStone,n; 使用技能的時候不消耗魔力礦石(n無意義)
bonus bShortWeaponDamageReturn,n; 近距離物理攻擊的n%反射給敵人(傷害不減少)
bonus bLongWeaponDamageReturn,n; 遠距離物理攻擊的n%反射給敵人(傷害不減少)

bonus2 bAddEff,Eff_Blind,n; 以n%的機率造成攻擊對象黑暗狀態(n為萬分率)
bonus2 bAddEff,Eff_Sleep,n; 以n%的機率造成攻擊對象睡眠狀態(n為萬分率)
bonus2 bAddEff,Eff_Poison,n; 以n%的機率造成攻擊對象中毒狀態(n為萬分率)
bonus2 bAddEff,Eff_Freeze,n; 以n%的機率造成攻擊對象冰凍狀態(n為萬分率)
bonus2 bAddEff,Eff_Silence,n; 以n%的機率造成攻擊對象沈默狀態(n為萬分率)
bonus2 bAddEff,Eff_Stan,n; 以n%的機率造成攻擊對象昏眩狀態(n為萬分率)
bonus2 bAddEff,Eff_Curse,n; 以n%的機率造成攻擊對象詛咒狀態(n為萬分率)
bonus2 bAddEff,Eff_Confusion,n; 以n%的機率造成攻擊對象混亂狀態(n為萬分率)
bonus2 bAddEff,Eff_Stone,n; 以n%的機率造成攻擊對象石化狀態(n為萬分率)

bonus2 bAddEff2,Eff_Blind,n; 以n%的機率造成自己黑暗狀態(n為萬分率)
bonus2 bAddEff2,Eff_Sleep,n; 以n%的機率造成自己睡眠狀態(n為萬分率)
bonus2 bAddEff2,Eff_Poison,n; 以n%的機率造成自己中毒狀態(n為萬分率)
bonus2 bAddEff2,Eff_Freeze,n; 以n%的機率造成自己冰凍狀態(n為萬分率)
bonus2 bAddEff2,Eff_Silence,n; 以n%的機率造成自己沈默狀態(n為萬分率)
bonus2 bAddEff2,Eff_Stan,n; 以n%的機率造成自己昏眩狀態(n為萬分率)
bonus2 bAddEff2,Eff_Curse,n; 以n%的機率造成自己詛咒狀態(n為萬分率)
bonus2 bAddEff2,Eff_Confusion,n; 以n%的機率造成自己混亂狀態(n為萬分率)
bonus2 bAddEff2,Eff_Stone,n; 以n%的機率造成自己石化狀態(n為萬分率)

bonus2 bResEff,Eff_Blind,n; 黑暗耐久度+n%(n為萬分率)
bonus2 bResEff,Eff_Sleep,n; 睡眠耐久度+n%(n為萬分率)
bonus2 bResEff,Eff_Poison,n; 毒性耐久度+n%(n為萬分率)
bonus2 bResEff,Eff_Freeze,n; 冰凍耐久度+n%(n為萬分率)
bonus2 bResEff,Eff_Silence,n; 沈默耐久度+n%(n為萬分率)
bonus2 bResEff,Eff_Stan,n; 昏眩耐久度+n%(n為萬分率)
bonus2 bResEff,Eff_Curse,n; 詛咒耐久度+n%(n為萬分率)
bonus2 bResEff,Eff_Confusion,n; 混亂耐久度+n%(n為萬分率)
bonus2 bResEff,Eff_Stone,n; 石化耐久度+n%(n為萬分率)

bonus2 bAddSize,n,x; n體型增加x%的物理攻撃傷害
0,小型　1,中型　2,大型
bonus2 bAddRace,n,x; n種族增加x%的物理攻撃傷害
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus2 bSubRace,n,x; n種族減少x%的物理攻撃傷害
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus2 bMagicAddRace,n,x; n種族增加x%的魔法攻撃傷害
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus2 bMagicSubRace,n,x; n種族減少x%的魔法攻撃傷害
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus2 bAddEle,n,x; n屬性增加x%的物理攻撃傷害
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus2 bMagicAddEle,n,x; n屬性增加x%的魔法攻撃傷害
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus2 bSubEle,n,x; n屬性減少x%的物理攻撃傷害
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus2 bAddDamageClass,n,x; 代號n的怪物增加x%的物理攻擊傷害、

玩家的場合則n職業增加x%的傷害
bonus2 bAddMagicDamageClass,n,x; 代號n的怪物增加x%的魔法傷害、

玩家的場合則n職業增加x%的魔法傷害
bonus2 bAddDefClass,n,x; 代號n的怪物減少x%的物理攻擊傷害、

玩家的場合則n職業減少x%的傷害
bonus2 bAddMDefClass,n,x; 代號n的怪物減少x%的魔法傷害、

玩家的場合則n職業減少x%的魔法傷害
bonus2 bHPDrainRate,n,x; 以n%機率對敵人造成的傷害x%吸收到HP
bonus2 bSPDrainRate,n,x; 以n%機率對敵人造成的傷害x%吸收到SP
bonus2 bWeaponComaEle,n,x; 對n屬性以x%機率發動瀕死之術(x為萬分率)
0,無　1,水　2,土　3,火　4,風　5,毒　6,聖　7,闇　8,念　9,不死
bonus2 bWeaponComaRace,n,x; 對n種族以x%機率發動瀕死之術(x為萬分率)
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)

bonus3 bAddMonsterDropItem,n,x,y; 物理攻擊打倒x種族的怪物有y%的機率掉落物品n

(y為萬分率)
0,無形　1,不死　2,動物　3,植物　4,昆蟲　5,魚貝　6,惡魔　7,人形

8,天使　9,龍族　10,BOSS　11,BOSS以外(普通的怪物)
bonus3 bAutoSpell,n,x,y; 自動唸咒以y%機率使用x等級的技能n

bAddDamageClass、bAddMagicDamageClass、bAddMonsterDropItem只能設定10個，

超過10個的都被無視
bAutoSpell只能設定一個，重複輸入的話只有最後一個有用

箭矢能設定的只有bCritical、bAtkEle、bHit、bAtkRange、bAddEle、

bAddRace、bAddSize、bAddEff，其他都被無視

bonus bStr,n; STR+n
bonus bAgi,n; AGI+n
bonus bVit,n; VIT+n
bonus bInt,n; INT+n
bonus bDex,n; DEX+n
bonus bLuk,n; LUK+n

bonus bMaxHP,n; 最大HP+n
bonus bMaxSP,n; 最大SP+n
bonus bMaxHPrate,n; 最大HP+n%
bonus bMaxSPrate,n; 最大SP+n%
bonus bAtk,n; 攻击力+n
bonus bAtk2,n; 攻击力2+n
bonus bAtkRate 攻击力+n%
bonus bBaseAtk,n; 基本攻击力+n
bonus bMatk,n; 魔法攻击力1+n、魔法攻击力2+n
bonus bMatk1,n; 魔法攻击力1+n
bonus bMatk2,n; 魔法攻击力2+n
bonus bMatkRate,n; 魔法攻击力+n%
bonus bMdef,n; 魔法防御力+n
bonus bMdefRate,n; 魔法防御力+n%(装备)
bonus bMdef2Rate,n; 魔法防御力+n%(自于int的东西？)
bonus bDef,n; 防御力+n
bonus bDefRate,n; 防御力+n%(装备)
bonus bDef2Rate,n; 防御力+n%(自于vit的东西？)
bonus bHit,n; 命中率+n
bonus bHitRate,n; 命中率+n%
bonus bCritical,n; 必杀攻击率+n
bonus bCriticalRate,n; 必杀攻击率+n%
bonus bFlee,n; 回避率+n
bonus bFlee2,n; 完全回避+n
bonus bFleeRate,n; 回避率+n%
bonus bFlee2Rate,n; 完全回避率+n%
bonus bAddSpeed,n; 移动速度+n
bonus bAspd,n; 攻击速度+n
bonus bSpeedRate,n; 移动速度n%
bonus bAspdRate,n; 攻击速度n%
bonus bSpeedAddRate,n; 移动速度+n%
bonus bAspdAddRate,n; 攻击速度+n%
bonus bAtkRange,n; 攻击射程+n
bonus bCastrate,n; 咏唱时间+n%
bonus bUseSPrate,n; SP消费量+n%
bonus bHPrecovRate,n; HP自然回复量+n%
bonus bSPrecovRate,n; SP自然回复量+n%
bonus bDoubleRate,n; 连击发动率n%
bonus bDoubleAddRate,n; 连击发动率+n%
bonus bPerfectHitRate,n; 必中攻击率n%
bonus bPerfectHitAddRate,n; 必中攻击率+n%
bonus bGetZenyNum,n; 物理攻击打倒怪物得到怪物LV*10+rand()%n的Zeny
bonus bAddGetZenyNum,n; 物理攻击打倒怪物得到怪物LV*10+rand()%n的Zeny
bonus bCriticalDef,n; 必杀攻击防御+n%？（不确定）
bonus bNearAtkDef,n; 减轻近距离攻击的伤害n%
bonus bLongAtkDef,n; 减轻远距离攻击的伤害n%
bonus bMagicAtkDef,n; 减轻魔法攻击的伤害n%
bonus bMiscAtkDef,n; 减轻其他攻击(陷阱与猎鹰)的伤害n%

bonus bIgnoreDefRace,n; 无视n种族的防御力
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus bIgnoreDefEle,n; 无视n属性的防御力
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus bIgnoreMDefRace,n; 无视n种族的魔法防御力
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus bIgnoreMDefEle,n; 无视n属性的魔法防御力
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus bDefRatioAtkRace,n; n种族的防御力越高造成的伤害越高(防御无视)
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus bDefRatioAtkEle,n; n属性的防御力越高造成的伤害越高(防御无视)
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus bAtkEle,n; 给予武器n属性
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus bDefEle,n; 给予防具n属性
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus bSplashRange,n; 普通的武器攻击对目标周边n格造成伤害(1为3*3、2为5*5以此类推)
bonus bSplashAddRange,n; 普通的武器攻击对目标周边n格造成伤害

bonus bInfiniteEndure,n; 无限霸体(n无意义)
bonus bRestartFullRecover,n; 复活时HP和SP全部恢复(n无意义)
bonus bNoCastCancel,n; 受到攻击不会咏唱魔法失败(GVG会失败、n无意义)
bonus bNoCastCancel2,n; 受到攻击不会咏唱魔法失败(GVG也不会失败、n无意义)
bonus bNoSizeFix,n; 不受到怪物体型的伤害修正(n无意义)
bonus bNoWeaponDamage,n; 不受到物理攻击伤害(n无意义)
bonus bNoMagicDamage,n; 不受到魔法伤害(包括治疗术、n无意义)
bonus bNoGemStone,n; 使用技能的时候不消耗魔力矿石(n无意义)
bonus bShortWeaponDamageReturn,n; 近距离物理攻击的n%反射给敌人(伤害不减少)
bonus bLongWeaponDamageReturn,n; 远距离物理攻击的n%反射给敌人(伤害不减少)

bonus2 bAddEff,Eff_Blind,n; 以n%的机率造成攻击对象黑暗状态(n为万分率)
bonus2 bAddEff,Eff_Sleep,n; 以n%的机率造成攻击对象睡眠状态(n为万分率)
bonus2 bAddEff,Eff_Poison,n; 以n%的机率造成攻击对象中毒状态(n为万分率)
bonus2 bAddEff,Eff_Freeze,n; 以n%的机率造成攻击对象冰冻状态(n为万分率)
bonus2 bAddEff,Eff_Silence,n; 以n%的机率造成攻击对象沈默状态(n为万分率)
bonus2 bAddEff,Eff_Stan,n; 以n%的机率造成攻击对象昏眩状态(n为万分率)
bonus2 bAddEff,Eff_Curse,n; 以n%的机率造成攻击对象诅咒状态(n为万分率)
bonus2 bAddEff,Eff_Confusion,n; 以n%的机率造成攻击对象混乱状态(n为万分率)
bonus2 bAddEff,Eff_Stone,n; 以n%的机率造成攻击对象石化状态(n为万分率)

bonus2 bAddEff2,Eff_Blind,n; 以n%的机率造成自己黑暗状态(n为万分率)
bonus2 bAddEff2,Eff_Sleep,n; 以n%的机率造成自己睡眠状态(n为万分率)
bonus2 bAddEff2,Eff_Poison,n; 以n%的机率造成自己中毒状态(n为万分率)
bonus2 bAddEff2,Eff_Freeze,n; 以n%的机率造成自己冰冻状态(n为万分率)
bonus2 bAddEff2,Eff_Silence,n; 以n%的机率造成自己沈默状态(n为万分率)
bonus2 bAddEff2,Eff_Stan,n; 以n%的机率造成自己昏眩状态(n为万分率)
bonus2 bAddEff2,Eff_Curse,n; 以n%的机率造成自己诅咒状态(n为万分率)
bonus2 bAddEff2,Eff_Confusion,n; 以n%的机率造成自己混乱状态(n为万分率)
bonus2 bAddEff2,Eff_Stone,n; 以n%的机率造成自己石化状态(n为万分率)

bonus2 bResEff,Eff_Blind,n; 黑暗耐久度+n%(n为万分率)
bonus2 bResEff,Eff_Sleep,n; 睡眠耐久度+n%(n为万分率)
bonus2 bResEff,Eff_Poison,n; 毒性耐久度+n%(n为万分率)
bonus2 bResEff,Eff_Freeze,n; 冰冻耐久度+n%(n为万分率)
bonus2 bResEff,Eff_Silence,n; 沈默耐久度+n%(n为万分率)
bonus2 bResEff,Eff_Stan,n; 昏眩耐久度+n%(n为万分率)
bonus2 bResEff,Eff_Curse,n; 诅咒耐久度+n%(n为万分率)
bonus2 bResEff,Eff_Confusion,n; 混乱耐久度+n%(n为万分率)
bonus2 bResEff,Eff_Stone,n; 石化耐久度+n%(n为万分率)

bonus2 bAddSize,n,x; n体型增加x%的物理攻击伤害
0,小型　1,中型　2,大型
bonus2 bAddRace,n,x; n种族增加x%的物理攻击伤害
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus2 bSubRace,n,x; n种族减少x%的物理攻击伤害
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus2 bMagicAddRace,n,x; n种族增加x%的魔法攻击伤害
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus2 bMagicSubRace,n,x; n种族减少x%的魔法攻击伤害
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)
bonus2 bAddEle,n,x; n属性增加x%的物理攻击伤害
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus2 bMagicAddEle,n,x; n属性增加x%的魔法攻击伤害
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus2 bSubEle,n,x; n属性减少x%的物理攻击伤害
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus2 bAddDamageClass,n,x; 代号n的怪物增加x%的物理攻击伤害、

玩家的场合则n职业增加x%的伤害
bonus2 bAddMagicDamageClass,n,x; 代号n的怪物增加x%的魔法伤害、

玩家的场合则n职业增加x%的魔法伤害
bonus2 bAddDefClass,n,x; 代号n的怪物减少x%的物理攻击伤害、

玩家的场合则n职业减少x%的伤害
bonus2 bAddMDefClass,n,x; 代号n的怪物减少x%的魔法伤害、

玩家的场合则n职业减少x%的魔法伤害
bonus2 bHPDrainRate,n,x; 以n%机率对敌人造成的伤害x%吸收到HP
bonus2 bSPDrainRate,n,x; 以n%机率对敌人造成的伤害x%吸收到SP
bonus2 bWeaponComaEle,n,x; 对n属性以x%机率发动濒死之术(x为万分率)
0,无　1,水　2,土　3,火　4,风　5,毒　6,圣　7,闇　8,念　9,不死
bonus2 bWeaponComaRace,n,x; 对n种族以x%机率发动濒死之术(x为万分率)
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物、包括玩家)

bonus3 bAddMonsterDropItem,n,x,y; 物理攻击打倒x种族的怪物有y%的机率掉落物品n

(y为万分率)
0,无形　1,不死　2,动物　3,植物　4,昆虫　5,鱼贝　6,恶魔　7,人形

8,天使　9,龙族　10,BOSS　11,BOSS以外(普通的怪物)
bonus3 bAutoSpell,n,x,y; 自动唸咒以y%机率使用x等级的技能n

bAddDamageClass、bAddMagicDamageClass、bAddMonsterDropItem只能设定10个，

超过10个的都被无视
bAutoSpell只能设定一个，重复输入的话只有最后一个有用

箭矢能设定的只有bCritical、bAtkEle、bHit、bAtkRange、bAddEle、

bAddRace、bAddSize、bAddEff，其他都被无视

-------摘自99nets


Sdata和Data文件里的文件对应列表

\data\texture\effect
绝大部分的显示效果和魔法技能效果

\data\texture\basepic
LONGDING画面

\data\texture\蜡历牢磐其捞胶\basic_interface
游戏时的基本面板（SKIN），游戏里的OPTION可以替换的那些

\data\texture\蜡历牢磐其捞胶\cardbmp
怪物卡片图案

\data\texture\蜡历牢磐其捞胶\collection
道具的大图案（游戏中右键点道具时看见的那种大图）

\data\texture\蜡历牢磐其捞胶\illust
卡普拉MM和宠物的大头像（ALT+J里的）

\data\texture\蜡历牢磐其捞胶\item
技能在技能栏的图标和全部道具在道具栏或者地上的小图

\data\texture\蜡历牢磐其捞胶\login_interface
最基本面板，登入画面，背景等等

\data\texture\蜡历牢磐其捞胶\map
游戏里右上显示的小地图样子，全梅红色的在游戏里就代表不可见的地图，

比如房间里，乌龟5、6等

\data\wav
游戏音效，用技能、攻击、怪物叫声等

\data\texture
这下面大部分都是游戏里使用在建筑、地面等背景上的2D贴图

\data
这下面的.GAT文件可以用MIC放出的GF来查看，是游戏里真实的地图，

包括没有小地图显示的地图

\data\sprite\牢埃练
武器拿在手上的样子

\data\sprite\捞蒲飘
游戏显示的数字字母，状态表现等，还有猎人的鸟，商人的车子等，

似乎是比较老的版本，还有老版的MVP效果

\data\sprite\阁胶磐
5.0的怪的SPR文件

\data\sprite\酒捞袍
大部分技能的图标和道具在道具栏和地上的样子（SPR格式，之前是BMP的）

\data\sprite\厩技荤府
头饰戴在头上的样子

职业:
放到data\sprite\牢埃练\个烹
男的后面加_巢
女的后面加_咯

职业武器:
data\sprite\牢埃练下各职业名字的文件夹
格式:绢技脚_咯_窜八_窜八.spr--------职业名_性别_武器名.spr

盾牌效果在 data\sprite\规菩 下。
文件名格式为： data\sprite\规菩\职业\职业_性别_盾牌类型.spr 和 act
如 data\sprite\规菩\八荤\八荤_巢_啊靛.spr 为男剑士的铁盾图，

data\sprite\规菩\八荤\八荤_巢_啊靛.act 为男剑士的铁盾动作。
下面是盾牌名称：
啊靛 铁盾
固矾蒋靛 镜盾
滚努矾 圆盾
蒋靛 刚盾

武器效果在 Data\sprite\牢埃练 下。
文件名格式：（1） \Data\sprite\牢埃练\职业\职业_性别_武器类型.spr 和 act。
如 \Data\sprite\牢埃练\八荤\八荤_巢_八.spr 为男剑士的长剑图，

相应的act档则是男剑士的长剑动作。（2）\Data\sprite\牢埃练\职业\职业_性别_武器类型_八堡.spr 和 act

是该武器挥动时的效果图和动作（如刀光）。那么 八荤_巢_八_八堡 就是男剑士长剑的剑光。
下面是武器名称：
八 长剑
窜八 短剑
档尝 斧头
芒 长枪
努反 锤子
劝 弓
吩靛 法杖（无把手）
胶懦 法杖（有把手）

人物发型（准确说是人头……） 在Data\sprite\牢埃练\赣府烹 下。
文件名格式： 在Data\sprite\牢埃练\赣府烹\性别\发型编号_性别.spr 和 act。
如 Data\sprite\牢埃练\赣府烹\巢\10_巢.spr 是男生10号发型。

杂乱效果在 Data\sprite\捞蒲飘 下。
Data\sprite\捞蒲飘\概.spr 和 act 为猎鹰效果
芒 为枪投效果
颊荐饭1 到颊荐饭4 为商人小车效果
orcface 为兽人脸效果.........

-------转自99nets


新宠制作

第一步

存放宠物数据的文件有pet_db.txt
打开后可以看到已有的宠物的信息。并且有相应位置的说明。现在例如我们要添加一个新宠物巴风特
将巴风特的信息按照上面的格式模仿其中一个。就用波利吧。写下来
1002,PORING,波利,619,9001,10013,531,80,20,50,100,250,20,2000,400,
1039,BAPHOMET,巴风特,750,9000,10013,607,80,20,50,100,250,20,2000,900
| | | |
| | | 宠物食品
| | 宠物装饰品id
| 自己加的宠物蛋id
巴风特娃娃的id
例如我们用巴风特娃娃抓巴风特 按照上面表示的地方改成你要修改的物品id
其中9000这个id在item_db.txt里面是没有的。是自己添加上去的新物品。
这里是第一个步骤。下一个我们要修改item_db.txt里面的数据。
－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－

第二步
打开item_db.txt 先修改巴风特娃娃作为抓宠道具。找到750可以看到如下
750,Baphomet_Doll,巴风特娃娃,3,18000,,100,,,,,,,,,,,{},{}
619,Unripe_Apple,青苹果,2,1000,,50,,,,,10477567,2,,,,,{ pet 1002; },{}
修改成
750,Baphomet_Doll,巴风特娃娃,2,1000,,50,,,,,10477567,2,,,,,{ pet 1039; },{}
对比不同之处
// 巴风特娃娃的种类是3。而青苹果的类是2。
//10477567 这个不是很清楚作用。根据经验似乎是跟使用者职业有关。10477567为任何职业都能使用。
//2是啥我也不清楚。不用管它照搬就是。
//最重要的来了。就是{ pet 1002; }和{ pet 1039; } 1002是波利的魔物id。1039是巴风特的魔物id
用第一步骤的方法类比波利的青苹果。
在任意位置添加"巴风特魔物蛋"的id，建议与其他魔物蛋放在一起。方便管理。
又是照葫芦画瓢的事了。找到波利魔物蛋。
9001,Poring_Egg,波利魔物蛋,7,20,,0,,,,,,,,,,,{},{}
9000,BAPHOMET,巴风特魔物蛋,7,20,,0,,,,,,,,,,,{},{}
照着改就是了。
编号要系统没有的。改英文名和中文名就ok了。
服务器端修改到此已经完成。这样你的巴风特娃娃就可以双击抓巴风特了(看他威风到什么时候）
这时在客户端还显示不出他的样子来。
下面修改客户端的显示问题。

－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－－

第三步 －－这里开始改客户端的文件。主要是显示上面的东西。
这里要改的东西都在data文件夹里面。
第一个
找到idnum2itemdesctable.txt 这个是在游戏中物品的说明储存的地方。
找到750显示如下
#
750#
按照魔物巴风特的模样所制作出来的玩偶。
^ffffff_^000000
重量 : ^77777710^000000
#
// 将其中文说明改为
#
750#
巴风特：这是我？好pp。我要~~~~。
^ffffff_^000000
重量 : ^77777710^000000
#
在游戏中右键点看巴风特娃娃的说明就变了哦！
同样要修改巴风特蛋的说明信息。
这个要直接添加。因为数据库里面没有这样东西。是我们另外加进去的。
#
9000#
巴风特栖息的蛋，用[携带用孵蛋器]，可叫醒它。
种类: ^777777魔物蛋^000000
重量: ^7777770^000000
#
第二个
找到idnum2itemdisplaynametable.txt 这个是改显示物品说明的标题名称的地方。
在里面可以看到
9001#波利魔物蛋#
在其前面添加上
9000#巴风特魔物蛋#
第三个
找到文件idnum2itemresnametable.txt 这个文件决定的是巴风特蛋蛋的图片类。
9000#荐加己舅#
9001#荐加己舅#
在9001（这是波利魔物蛋）前面加入 9000#荐加己舅# >>两个＃＃之间决定蛋的图像类型。
这里显示的是跟波利一样的有需要可以自己更改。
到此为止已经可以把大巴叫出来溜达了。只是它说的话都是波利的。有动作等。
第四个
最后一步了。写你的宠物要说的话。
在pettalktable.xml文件里之间是波利会说的话.前面的是触发条件.即喂食的时候说的话.要巴风特自己说话有特色就要改这里了.再例如之间是一种宠物饿的时候的对话内容.

附录:
宠物魔物蛋的显示.宠物魔物蛋可以告诉我们宠物属于什么系的怪物.
由于在data文件里面的是韩文.所以只有放乱码的出来了.在文件idnum2itemresnametable.txt里修改
例如:9001#荐加己舅#---波利魔物蛋为水属性
9002#拳加己舅#---土波利魔物蛋为火属性
9003#刀加己舅#---波波利魔物蛋为毒属性
9004#公加己舅#---疯兔魔物蛋为念属性
9006#浅加己舅#---苍蝇魔物蛋为风属性
9009#瘤加己舅#---小野猪魔物蛋为地属性
9018#攫单靛舅#---僵尸魔物蛋为不死属性
9024#鞠加己舅#---小巴风特魔物蛋恶魔属性
将##之间的字符替换成相对应的就可以了.

-------摘自多多の宝贝 美雨儿(99nets haoxiaoyuhao)


ACT文件格式

RO用一个SPR文件和一个ACT文件来描述一个物件（道具、武器、人物、头饰、怪物等）。

SPR文件中存放的是许多图片零件，像头饰的各个侧面、怪物的各种图片等等，

而ACT文件存放的则是让这些零件组合、运动起来的信息。一个ACT文件包含许多动画，

每个动画描述了物件的一种动作，比如angeling.act中0号动作是天使波利面朝左下方原地不动的动作

（当然它的翅膀还是在动的），之后的几个动作是它面对各个方向

静止、移动、攻击、被攻击、死亡的动作。一个动作由若干帧组成（就像Gif动画那样）。

而一帧又由若干子帧组成，大多数时候一帧只有一个子帧

（一个子帧就是SPR文件中的一张图片）；但是也有例外，

例如天使波利的一帧画面就是由一张波利的图片、2张翅膀图片和一张光环的图片组成的，

也就是说这一帧包含4个子帧。

关于ACT档文件格式

WORD HeadTAG; //0x4341
BYTE ActVersion;
Byte Unknown;
WORD nAnimations;
WORD Unknown;
for(i=0; i<nAnimations; i++)
{
DWORD nFrames;
for(j=0; j<nFrames; j++)
{
BYTE Unknown[32];
DWORD nSubFrames;
for(k=0; k<nSubFrames; k++)
{
DWORD offsetX;
DWORD offsetY;
DWORD imageNum;
DWORD direction;
BYTE red;
BYTE green;
BYTE blue;
BYTE alpha;
if(ActVersion >= 2)
float scaleX; //4 BYTES
if(ActVerstion >= 4)
float scaleY; //4 BYTES
else
scaleY=scaleX;
if(ActVersion >= 2)
DWORD unknown; //Rotation Angle?
DWORD jump;
if(jump)
BYTE unknown[12];
if(ActVersion >= 5)
{
DWORD sizeX;
DWORD sizeY;
}
}
DWORD Unknown; //0xFFFFFFFF?
if(ActVersion >= 2)
{
DWORD extraInfo;
if(extraInfo)
{
BYTE Unknown[4];
DWORD extraX;
DWORD extraY;
BYTE Unknown[4];
}
}
}
}
Some Bytes Left;

-------摘自RO另类


卡片制做方法

1、先在database里的item_db.txt里像普通物品一样写好信息

ID,名字,显示名字,类型,价格,卖出价格,重量,攻击,魔法攻击,防御,魔防,

攻击距离,洞数,STR,AGI,VIT,INT,DEX,LUK,命中,回避,暴击,完全回避,施法时间,

职业,性别,装备位置,武器等级,装备等级,外观,属性,特殊效果,HP变化1,HP变化2,

SP变化1,SP变化2,种族特效,特效数值,属性特效,特效数值,状态特效,特效数值,技能ID,技能等级

2、然后到客户端里的DATA里carditemnametable.txt，在里面添加你做的卡片的编号
如波利卡：4001#

3、然后到cardprefixnametable.txt，在里面添加你做的卡片的称号
如波利卡：4001#幸运的#

4、然后到idnum2itemdesctable.txt和num2itemdesctable.txt，在里面添加你做的卡片的说明
如波利卡：

4001#
Luk+2 Feel+1
系列 : ^777777卡片^000000
装置 : ^777777盔甲^000000
重量 : ^7777771^000000
#

5、然后到idnum2itemdisplaynametable.txt和num2itemdisplaynametable.txt，

在里面添加你做的卡片的中文名字

如波利卡：4001#波利卡片#

6、然后到num2cardillustnametable.txt，在里面添加你做的卡片的图画
如波利卡：4001#器傅墨靛#
*器傅墨靛——这个是波利卡的图画，也可以自己做图画放进去，

格式是300X400的BMP图象，放到data\texture\蜡历牢磐其捞胶\cardbmp里，无的话输入“sorry”

7、然后到idnum2itemresnametable.txt和num2itemresnametable.txt，

在里面添加你做的卡片的按右键显示的图标和装备在武器上和掉到地上或在道具栏里的图标
如波利卡：4001#捞抚绝绰墨靛#
*捞抚绝绰墨靛——这个是卡片的图标的名字，最好用这个
建议这2个都用——捞抚绝绰墨靛
右键的图标可以自己做，格式是75X100的BMP图象，放到data\texture\蜡历牢磐其捞胶\collection
在地上或在道具栏里的图标也可以自己做，格式是24X24的BMP图象，放到data\texture\蜡历牢磐其捞胶\item

-------摘自99nets haoxiaoyuhao(多多の宝贝 美雨儿)


99级光环的组成

99级圆满光环由3部分组成，底座使用的是data\texture\effect\pikapika2.bmp。
周围的小点是data\texture\effect\freezing_circle.bmp。
身边转动的光环是data\texture\effect\ring_blue.tga。

-------摘自RO另类


翅膀的添加教程

首先把下载后得到的安装包解压到data文件夹下的sprite\厩技荤府文件里面

巢对应的是男生...咯对应的是女生...

接下来要修改的就是服务器端的item_db.txt文件...找到任意你想替代的头饰

小丑鼻子 迷你眼镜...都可以(当然自己添加也可以 不过推荐新人先替换一下

做为一个尝试 如果没有出现错误 那么不久后RO就可以变成你自己想要变成的样子了 ^_^ )

例如:2262,Pierrot_Nose,小丑鼻子,5,20,,100,,0,,0,10477567,2,1,,0,49,{},{}

{}里就是你可以自己添加的属性...假设要替换的是天使之翼...

只要把小丑鼻子修改为天使之翼...{}里加上你希望的属性...具体可以在下面查找到...

================================================================
各种属性,状态速查

铠甲
bonus bDefEle,7; 暗属性
bonus bDefEle,6; 圣属性
bonus bDefEle,1; 水属性
bonus bDefEle,4; 风属性
bonus bDefEle,3; 火属性
bonus bDefEle,2; 地属性
bonus bDefEle,5; 毒属性
bonus bDefEle,8; 念属性
bonus bDefEle,9; 不死属性

PS:铠甲的属性好像不能修改属性等级,默认全部为等级1

bonus2 bSubEle,8,30; 躲过念属性攻击(最后的数字为百分比)
bonus2 bSubEle,0,15; 躲过无属性攻击
bonus2 bSubEle,7,15; 躲过暗属性攻击
bonus2 bSubEle,9,10; 躲过不死属性攻击
bonus2 bSubEle,6,10; 躲过圣属性攻击
bonus2 bSubEle,3,10; 躲过火属性攻击
bonus2 bSubEle,4,5; 躲过风属性攻击
bonus2 bSubEle,2,30; 躲过地属性攻击
bonus2 bSubEle,1,30; 躲过水属性攻击
bonus2 bSubEle,5,30; 躲过毒属性攻击

bonus bMaxHPrate,8; HP增加(最后数字为百分比)
bonus bMaxSPrate,8; MP增加

bonus2 bSubRace,3,10; 受到植物系攻击时,减少伤害度(最后数字为百分比)
bonus2 bSubRace,4,10; 受到昆虫系攻击时,减少伤害度
bonus2 bSubRace,6,3; 受到恶魔系攻击时,减少伤害度
bonus2 bSubRace,8,3; 受到飞行系攻击时,减少伤害度
bonus2 bSubRace,0,10; 受到无形系攻击时,减少伤害度
bonus2 bSubRace,1,10; 受到不死系攻击时,减少伤害度
bonus2 bSubRace,2,10; 受到动物系攻击时,减少伤害度
bonus2 bSubRace,5,10; 受到鱼贝系攻击时,减少伤害度
bonus2 bSubRace,7,10; 受到人形系攻击时,减少伤害度
bonus2 bSubRace,9,10; 受到龙系攻击时,减少伤害度

bonus2 bResEff,Eff_Blind,5; 增加对致盲的耐久度(最后数字为百分比)
bonus2 bResEff,Eff_Curse,10; 增加对诅咒的耐久度
bonus2 bResEff,Eff_Silence,20; 增加对沉默的耐久度
bonus2 bResEff,Eff_Sleep,20; 增加对睡眠的耐久度
bonus2 bResEff,Eff_Freeze,20; 增加对冰冻的耐久度
bonus2 bResEff,Eff_Stone,20; 增加对石化的耐久度
bonus2 bResEff,Eff_Confusion,100; 增加对混乱的耐久度
bonus2 bResEff,Eff_Poison,20; 增加对中毒的耐久度
bonus2 bResEff,Eff_Stan,10; 增加对眩晕的耐久度

武器武器
bonus2 bAddEle,7,20; 增加对暗属性的伤害

(最后的数字为增加伤害的百分比,20为20%,依次类推)
bonus2 bAddEle,4,20; 增加对风属性的伤害
bonus2 bAddEle,3,20; 增加对火属性的伤害
bonus2 bAddEle,5,20; 增加对毒属性的伤害
bonus2 bAddEle,2,20; 增加对地属性的伤害
bonus2 bAddEle,1,20; 增加对水属性的伤害
bonus2 bAddEle,6,20; 增加对圣属性的伤害
bonus2 bAddEle,8,20; 增加对念属性的伤害

bonus2 bAddSize,0,15; 增加对小型怪的伤害
bonus2 bAddSize,1,15; 增加对中型怪的伤害
bonus2 bAddSize,2,15; 增加对大型怪的伤害

bonus2 bAddRace,8,20; 增加对飞行系的伤害
bonus2 bAddRace,6,20; 增加对恶魔系的伤害
bonus2 bAddRace,9,20; 增加对龙系的伤害
bonus2 bAddRace,7,20; 增加对人形系的伤害
bonus2 bAddRace,2,20; 增加对动物系的伤害
bonus2 bAddRace,4,20; 增加对昆虫系的伤害
bonus2 bAddRace,3,20; 增加对植物系的伤害
bonus2 bAddRace,5,20; 增加对鱼贝系的伤害
bonus2 bAddRace,1,20; 增加对不死系的伤害
bonus2 bAddRace,0,20; 增加对无型系的伤害

bonus2 bAddEff,Eff_Stan,5; 眩晕效果(最后的数字为百分比)
bonus2 bAddEff,Eff_Blind,5; 致盲效果
bonus2 bAddEff,Eff_Sleep,5; 睡眠效果
bonus2 bAddEff,Eff_Poison,5; 中毒效果
bonus2 bAddEff,Eff_Freeze,5; 冰冻效果
bonus2 bAddEff,Eff_Silence,5; 沉默效果
bonus2 bAddEff,Eff_Curse,5; 诅咒效果
bonus2 bAddEff,Eff_Confusion,5; 混乱效果
bonus2 bAddEff,Eff_stone,5; 石化效果

================================================================

好了...服务器端修改好...接下来要修改的是客户端...

我们需要修改4个文件:idnum2itemdesctable(这个是物品的说明文件的目录)，

idnum2itemdisplaynametable(这个是物品名称显示文件)，idnum2itemresnametable

(这个是放物品的图片名称的)，itemslotcounttable(这个是显示物品洞数的)这4个文件

以天使之翼为例..

如:idnum2itemdesctable.txt里

我们修改后的天使之翼可以为

#
2260#
天上的天使们所带的大天使の翼，带上很帅气的感觉
系列 : ^777777头具^000000 防御 : ^7777775^000000
位置 : ^777777中^000000 重量 : ^77777710^000000
装备 : ^777777所有2转职业都可以装备（超级初心者除外）^000000
#

替换原来的就可以了...

同时把idnum2itemdisplaynametable.txt文件里相应的迷你眼镜换为天使之翼...

找到相同的代码即可
例如:2260#大天使の翼#

idnum2itemresnametable.txt里对应道具显示的图片...按照格式输入相应路径...
例如:2260#固聪臂贰胶#

itemslotcounttable.txt里修改显示的洞数...格式很简单 相信一看便能理解
例如:2260#0# 这里设置的是0洞 可以自己任意修改 当然对应的item_db.txt里也要修改洞数

才能正常插卡...

好了~ 大致就是这样替换...添加方法雷同...具体还可以看看如果添加新的物品一文

祝大家在RO里玩的愉快 ^_^

--------多多の宝贝 美雨儿


在游戏里添加新的道具

首先你需要知道的是添加的时候需要改的几个文件：
一个是服务器端的database目录下的Item_db文件，其他的都是客户端的data目录下的文件，

分别是：idnum2itemdesctable(这个是物品的说明文件的目录)，idnum2itemdisplaynametable

(这个是物品名称显示文件)，

idnum2itemresnametable(这个是放物品的图片名称的)，itemslotcounttable(这个是显示物品洞数的)这4个文件

接着我们开始添加了：先在item_db里加一个新的编号，你要确定这个编号没有被游戏里已有的东西使用过，

然后在编号后面添加道具的详细资料，格式是：ID(即编号),名字,显示名字,类型,价格,卖出价格,重量,攻击,

魔法攻击,防御,魔防,攻击距离，洞数,STR,AGI,VIT,INT,DEX,LUK,命中,回避,暴击,完全回避,施法时间,职业,

性别,装备位置,武器等级,装备等级,外观,属性,特殊效果,HP变化1,HP变化2,SP变化1,SP变化2,种族特效,

特效数值,属性特效,特效数值,状态特效,特效数值,技能ID,技能等级。

要是觉得太麻烦你可以任意拷贝一个其他道具的资料，

然后用iten_db编辑器再修改。这一步弄好了以后就可以保存退出了。

下来我们打开idnum2itemdesctable这个文件，在里面加上你刚才添加的物品编号，和他的说明文件，例如：
12007#
战争与智慧女神雅典娜的神杖，蕴藏着强大的魔力。MATK上升50%
系列 : ^777777杖^000000 攻击 : ^777777150^000000
重量 : ^77777745^000000 属性 : ^777777圣属性^000000
武器等级 : ^7777774^000000 洞数 : ^7777774^000000
要求等级 : ^77777776^000000
装备 : ^777777魔法师 服事^000000

每个道具的说明文件之间都用#来分隔开。加好了就存盘

再打开idnum2itemdisplaynametable文件，添加名字，这里我按照上面的例子说明添加的是：

12007#雅典娜之杖[4S]#，这样就可以保存了

打开idnum2itemresnametable文件，在里面添加你的道具的用的显示图，

我这里用的是游戏里已经有了的图片所以直接加名字就行，按上面的例子是：12007#胶怕橇坷宏家匡#
“胶怕橇坷宏家匡”其实就是游戏里的灵魂之杖（好象是这么叫的）的图片，

如果你想要自己做图片也可以，做好的图片记得要先放到data/texture/蜡历牢磐其捞胶/collection/里面，

然后就和上面一样如：12007#图片名称#

打开itemslotcounttable文件，在里面加上12007#4#，#后面的4就是显示的洞数，

当然这是你看道具图示的时候显示的洞，是不是真的有几个洞需要在服务器的item_db里面改

这样子基本上一件新的道具就做好了，要看看成果就进游戏用你的GM号把道具调出来吧,

按上面我说的例子就是#item 12007,1 这样你新做的东西就入手拉！ 当然我们这里说的是一般的武器，

防具的添加，如果你要添加头饰的话由于RO的纸娃娃系统，带上会在游戏里显示出来，

所以你还需要改相应的apr和act文件.

-------摘自多多の宝贝 美雨儿(99nets haoxiaoyuhao)


RO游戏里的背景音乐修改法

首先当然要找到自己喜欢听的歌啦,然后看那首歌是不是MP3格式的,

不是的话用一些转换格式工具转一下,成了MP3格式后就把这首歌放到客户端里面的BGM文件夹里面,

再进如data文件夹,找到个文本文件mp3nametable.txt,打开进入找到你想把歌放进去的地图名,如

:prontera.rsw#bgm\\08.mp3#这个是首都来的,把08.mp3换成你放在BGM文件夹里面的歌吧~

改变后如:prontera.rsw#bgm\\01.銀色.mp3#

然后就进入RO里~慢慢感受吧~(歌曲的大小不限的,只要是MP3文件)

-------摘自青豆网


与地图有关的各种文件的说明

关键词：RO地图 .rsm .rsw .gnd .gat

正文：
RO中与地图相关的文件格式主要有 *.rsm *.rsw *.gnd *.gat
====================================================
·rsm文件
rsm文件存放在Data\model下，它是资源模型文件（resource model），

用来描述一件3D模型，比如一棵树,一座建筑物,一

个酒桶等等。rsm文件除了包含多边形信息以外，还记录着使用到的材质贴图的文件名。

贴图文件为BMP格式，存放在

Data\texture下，大多为256色，但是根据我以前的试验，应该也可以使用24bit色。

另外，rsm文件也支持动态效果，也就

是说3D模型是可以活动的，比如钟楼地图中会转动的齿轮之类……

====================================================
·rsw文件
rsw文件存放在Data目录下，它是资源世界文件（resource world），用来描述一张地图中摆放的各个元素、

一些基本的几何形状以及一些声音效果。比如在地图的某个位置放一棵树，在rsw文件中应该会存储为某某座标

处放置一个某某目录下的某某rsm文件，还有当玩家走到这颗树附近时播放某个wav文件。

此外rsw还可以放置一些简单的几何形状，比如圆柱、立方体之类。我们可以使用UltraEdit之类的16进制编辑工具修改rsw文件，

比如打开data\prontera.rsw,把 公棱檬采\唱公01.rsm换成 公棱檬采\唱公07.rsm，就可以把首都道路边上的树换成椰子树。

同理，只要你能找到樱花树的rsm文件，也可把首都路边的树木换成樱花树。

====================================================
·gnd文件
gnd文件存放在Data目录下，是地面模型文件（ground model），用来描述一张地图的地面模型（不带其他元素），

比如prontera.gnd就是首都的地面模型，没有房屋、树木这些附加元素。

====================================================
·gat文件
gat文件存放在Data目录下，是地面高度表文件？（Ground Altitude Table？），

应该是用来描述地图中各个座标处的高度以及玩家是否可以走到这个位置。

-------摘自RO另类


人物-怪物-宠物ACT动作对应表

站立：1～8
1 ↓
2 ↙
3 ←
4 ↖
5 ↑
6 ↗
7 →
8 ↘

走路：9～16
9 ↓
10 ↙
11 ←
12 ↖
13 ↑
14 ↗
15 →
16 ↘

坐下：17～24
17 ↓
18 ↙
19 ←
20 ↖
21 ↑
22 ↗
23 →
24 ↘

捡东西：25～32
25，26 ↙
27，28 ↖
29，30 ↗
31，32 ↘

战斗准备状态：33～40
33，34 ↙
35，36 ↖
37，38 ↗
39，40 ↘

战斗方式1：41～48
41，42 ↙
43，44 ↖
45，46 ↗
47，48 ↘

被攻击：49～56
49，50 ↙
51，52 ↖
53，54 ↗
55，56 ↘

被攻击（停止状态？）：57～64
57，58 ↙
59，60 ↖
61，62 ↗
63，64 ↘

死亡：65～72
65，66 ↙
67，68 ↖
69，70 ↗
71，72 ↘

站立（？）:73～80
73～80 ↓

战斗方式2（短剑？）：81～88
81，82 ↙
83，84 ↖
85，86 ↗
87，88 ↘

战斗方式3（弓）：89～96
89，90 ↙
91，92 ↖
93，94 ↗
95，96 ↘

使用技能:97～104
97,98 ↙
99,100 ↖
101,102 ↗
103,104 ↘

有宠物动作的怪物act

1~8 靜止4方向
9~16 行走4方向
17~24 攻击4方向
25~32 受创4方向
33~40 死亡4方向
41~48 宠物动作1,4方向
49~56 宠物动作2,4方向
57~64 宠物动作3,4方向

=======================
Act no 状态
=======================
1 靜止↙
2 靜止↙
3 靜止↖
4 靜止↖
5 靜止↗
6 靜止↗
7 靜止↘
8 靜止↘

9 行走↙
10 行走↙
11 行走↖
12 行走↖
13 行走↗
14 行走↗
15 行走↘
16 行走↘

17 攻击↙
18 攻击↙
19 攻击↖
20 攻击↖
21 攻击↗
22 攻击↗
23 攻击↘
24 攻击↘

25 受创↙
24 受创↙
25 受创↖
28 受创↖
29 受创↗
30 受创↗
31 受创↘
32 受创↘

35 死亡↖
36 死亡↖
37 死亡↗
38 死亡↗
39 死亡↘
40 死亡↘

41 宠物动作1↙
42 宠物动作1↙
43 宠物动作1↖
44 宠物动作1↖
45 宠物动作1↗
46 宠物动作1↗
47 宠物动作1↘
48 宠物动作1↘

49 宠物动作2↙
50 宠物动作2↙
51 宠物动作2↖
52 宠物动作2↖
53 宠物动作2↗
54 宠物动作2↗
55 宠物动作2↘
56 宠物动作2↘

57 宠物动作3↙
58 宠物动作3↙
59 宠物动作3↖
60 宠物动作3↖
61 宠物动作3↗
62 宠物动作3↗
63 宠物动作3↘
64 宠物动作3↘

33---40战斗准备,也称待机

57-64被攻击,也称受创/受创硬直

73-80 具体对应哪个动作不明(位于死亡动作之后)

-------摘自RO另类


头饰的存放位置和名称及相应代码

其实对照着看data\idnum2itemdisplaynametable.txt和

idnum2itemresnametable.txt会比较方便。

在简体中文系统下用GRFIO把DATA.GRF解开以后，头饰放在 data\sprite\厩技荤府 下。

巢 是男生戴头饰的样子，咯 是女生戴头饰的样子。比如金属头盔，

女生戴着的样子是 咯\咯_秋抚.spr,男生戴着就是 巢\巢_秋抚.spr。

下面以女生版为例给出乱码和头饰名称的对应关系

咯_啊胶付胶农.spr 防毒面具
咯_埃龋葛.spr 护士帽
咯_芭矫扁.spr 大便帽
咯_绊臂.spr 防风眼镜帽
咯_绊鞭急臂贰胶.spr 太阳眼镜
咯_绊喉赴练啊搁.spr 哥布灵面具
咯_绊剧捞赣府鹅.spr 猫耳头饰
咯_绊剧捞规匡.spr 红红脸 *^_^*
咯_榜电庆靛扁绢.spr 黄金内裤
咯_堡措葛磊.spr 小丑帽
咯_堡措内.spr 猪鼻子
咯_堡魂秋镐.spr 矿工帽·改
咯_蓖付俺.spr 耳罩
咯_臂贰胶.spr 圆眼镜
咯_标判葛磊.spr 羽毛帽
咯_采.spr 小花朵头饰
咯_采赣府鹅.spr 花发圈
咯_采蕾.spr 咬花
咯_唱甸捞葛磊.spr 出游帽子
咯_唱厚啊搁.spr 蝴蝶假面
咯_呈备府葛磊.spr 狸猫帽子
咯_传啊府俺.spr 眼罩
咯_淬硅.spr 香烟
咯_档尝传.spr 野猪眼镜
咯_捣酪篮磊狼付澜.spr 钱袋头饰（破产之哀）
咯_滴扒.spr 方头巾
咯_嫡辟葛磊.spr 圆帽
咯_肺靛辑努复.spr 领导者头箍
咯_肺靛墨龋狼辉.spr 卡浩之角
咯_府夯.spr 紫蝶发带
咯_付过荤狼葛磊.spr 绿魔法师帽
咯_付贱荤狼葛磊.spr 高魔术师帽
咯_付胶农.spr 口罩
咯_付力胶平绊快飘.spr 大巴帽
咯_噶盔版.spr 望远镜
咯_噶磊狼赣府鹅.spr 亡者三角巾
咯_赣府馋.spr 粉纱
咯_赣府鹅.spr 头箍……
咯_赣府救版.spr 眼镜头饰
咯_赣府器磊扁.spr 春丽包子
咯_疙荤荐狼荤苞.spr 苹果头
咯_搁荤器.spr 婚纱
咯_公倡葛磊.spr 僵尸帽
咯_拱救版.spr 泳镜
咯_固聪臂贰胶.spr 迷你眼镜
咯_馆促唱.spr 头巾（黑）
咯_惯弊饭.spr 脸红红
咯_焊蝶府葛.spr 包袱头
咯_夯扒葛磊.spr 妖道帽
咯_夯秋抚.spr 骨盔
咯_厚饭鸥.spr 圣职之帽
咯_荤娇辉.spr 鹿角头饰
咯_魂家付胶农.spr 氧气面罩
咯_魂鸥葛磊.spr 圣诞帽
咯_货尝厩付葛磊.spr 小恶魔帽
咯_货窍踞辉.spr 白角
咯_获矮.spr 草帽
咯_箕橇庆靛扁绢.spr 尖角
咯_急臂贰胶.spr 墨镜
咯_辑努复.spr 发箍（蛇女）
咯_己流磊狼葛磊.spr 神圣之帽
咯_荐堪.spr 胡子？
咯_胶付老.spr 笑脸面具
咯_胶困飘哩撇.spr 绅士帽
咯_胶农贰摹付胶农.spr 整人面具
咯_胶鸥歹胶飘.spr 星星发夹
咯_胶器酒葛磊.spr 蘑菇帽子
咯_胶巧臂贰胶.spr 转圈眼镜
咯_胶俏农胶葛磊.spr 法老帽子
咯_绞磊赣府鹅.spr 十字架头饰
咯_矫困侩付胶农.spr 侍卫口罩
咯_脚厚茄凯概伯龙.spr 金色苹果帽
咯_缴瘤.spr 火线头饰
咯_酒捞攫纳牢.spr 金属口罩
咯_厩付狼朝俺.spr 红红脸
咯_厩付狼赣府鹅.spr 恶魔发夹
咯_救措.spr 钉子？？
咯_救傈葛.spr 矿工帽
咯_救抛唱.spr 天线头
咯_舅废崔废舅伯龙.spr 彩色蛋壳帽
咯_凯概伯龙.spr 苹果帽子
咯_楷必家档备.spr 戏剧头饰
咯_康去绊府.spr 光环
咯_坷农练秋抚.spr 兽人头盔
咯_坷其扼啊搁.spr 舞会面具
咯_坷其扼蜡飞啊搁.spr 歌剧院面具
咯_棵靛胶磐肺盖胶.spr 老人帽子
咯_空府夯.spr 大蝴蝶结
咯_寇传救版.spr 单眼眼镜
咯_夸府荤狼葛磊.spr 厨师帽子
咯_夸沥狼蓖.spr 妖精耳朵
咯_侩立付胶农.spr 钢铁面具
咯_盔林刮赣府鹅.spr 印第安发箍
咯_傀胶畔弊饭捞胶.spr 牛仔帽
咯_困历靛寝.spr 魔法师帽
咯_狼荤赣府鹅.spr 医生发圈
咯_狼利救措.spr 时髦眼罩
咯_厘肥扒.spr 葬礼帽
咯_厘侥侩舅伯龙.spr 蛋壳帽
咯_厘侥侩秦官扼扁.spr 向日葵帽子
咯_沥瘤钎瘤魄.spr STOP牌
咯_傈备赣府鹅.spr 灯泡头饰
咯_临公刺赣府鹅.spr 红白条纹发圈
咯_陵倔农扼款.spr 首领冠冕
咯_没祸赣府鹅.spr 斜发圈
咯_玫荤狼赣府鹅.spr 天使发夹
咯_玫荤狼捧备.spr 天使战盔
咯_檬废歹惦捞.spr 昆虫角
咯_檬铰崔赣府巧.spr 上弦月
咯_眯阂.spr 蜡烛头
咯_墨橇扼狼赣府鹅.spr 卡普拉发圈
咯_母.spr 无边帽
咯_目技绢.spr 船长帽
咯_内肺齿.spr 黄金冠冕（蜜蜂妈妈掉的）
咯_纳捞农葛磊.spr 蛋糕头
咯_泥荐堪.spr 胡子（下垂）
咯_农扼款.spr 王冠
咯_怕剧脚狼葛磊.spr 太阳神
咯_盼荐堪.spr 络腮胡子
咯_配尝赣府鹅.spr 兔耳
咯_萍酒扼.spr 后冠
咯_颇捞橇淬硅.spr 烟斗
咯_菩记急臂贰胶.spr 红色眼镜头
咯_埔歹磅葛磊.spr 熊猫头
咯_器傅葛磊.spr 波利头
咯_钱蕾.spr 咬草
咯_遣荤尔.spr 初恋发圈（花发圈，月夜花掉的~）
咯_橇沸抛扼焙葛.spr 普隆德拉军帽
咯_橇肺歧扼.spr 竹蜻蜓
咯_巧秋抚.spr 人鱼
咯_窍飘赣府巧.spr 爱心
咯_切荤葛.spr 学士帽
咯_切积葛.spr 学生帽
咯_秦利滴扒.spr 海盗三角巾
咯_寝.spr 渔夫帽
咯_庆靛迄.spr 耳机
咯_秋抚.spr 金属头盔
咯_闰荐堪.spr 白胡子

补完一下

(男性4311~~4519单数,女性4521~~4729, 其中的双数是对应的ACT,

如 防毒面具.spr 4311,那它的ACT档就是 4310)
以下代码是1102版的代码,其它版本不同,新版的更乱= =

~~从防毒面具开始 (新头饰的DATA代码不在这些范围内)
巢_啊胶付胶农.spr 防毒面具 4311 (女性 4521)
巢_埃龋葛.spr 护士帽 4313 (女性 4523)
巢_芭矫扁.spr 大便帽 4315 (女性 4525)
巢_绊臂.spr 防风眼镜帽 4317 (女性 4527)
巢_绊鞭急臂贰胶.spr 太阳眼镜 4319 (女性 4529)
巢_绊喉赴练啊搁.spr 哥布灵面具 4321 (女性 4531)
巢_绊剧捞赣府鹅.spr 猫耳头饰 4323 (女性 4533)

巢_榜电庆靛扁绢.spr 黄金内裤 4325 (女性 4535)
巢_堡措葛磊.spr 小丑帽 4327 (女性 4537)
巢_堡措内.spr 猪鼻子 4329 (女性 4539)

巢_蓖付俺.spr 耳罩 4331 (女性 4541)
巢_臂贰胶.spr 圆眼镜 4333 (女性 4543)
巢_标判葛磊.spr 羽毛帽 4335 (女性 4545)
巢_采.spr 小花朵头饰 4337 (女性 4547)
巢_采赣府鹅.spr 花发圈 4339 (女性 4549)
巢_采蕾.spr 咬花 4341 (女性 4551)

巢_唱厚啊搁.spr 蝴蝶假面 4343 (女性 4553)

巢_传啊府俺.spr 眼罩 4345 (女性 4555)
巢_淬硅.spr 香烟 4347 (女性 4557)
巢_档尝传.spr 野猪眼镜 4349 (女性 4559)

巢_滴扒.spr 方头巾 4351 (女性 4561)
巢_嫡辟葛磊.spr 圆帽 4353 (女性 4563)
巢_肺靛辑努复.spr 领导者头箍 4355 (女性 4565)
巢_肺靛墨龋狼辉.spr 卡浩之角 4357 (女性 4567)
巢_府夯.spr 紫蝶发带 4359 (女性 4569)

巢_付胶农.spr 口罩 4361 (女性 4571)
巢_付力胶平绊快飘.spr 大巴帽 4363 (女性 4573)
巢_噶盔版.spr 望远镜 4365 (女性 4575)
巢_噶磊狼赣府鹅.spr 亡者三角巾 4367 (女性 4577)
巢_赣府馋.spr 粉纱 4369 (女性 4579)
巢_赣府鹅.spr 头箍…… 4371 (女性 4581)
巢_赣府救版.spr 眼镜头饰 4373 (女性 4583)

巢_搁荤器.spr 婚纱 4375 (女性 4485)
巢_疙荤荐狼荤苞.spr 苹果头 4377 (女性 4587)
巢_公倡葛磊.spr 僵尸帽 4379 (女性 4589)
巢_拱救版.spr 泳镜 4381 (女性 4591)
巢_固聪臂贰胶.spr 迷你眼镜 4383 (女性 4593)
巢_馆促唱.spr 头巾（黑） 4385 (女性 4595)

巢_夯秋抚.spr 骨盔 4387 (女性 4597)
巢_厚饭鸥.spr 圣职之帽 4389 (女性 4599)
巢_荤娇辉.spr 鹿角头饰 4491 (女性 4601)
巢_魂家付胶农.spr 氧气面罩 4493 (女性 4603)
巢_魂鸥葛磊.spr 圣诞帽 4495 (女性 4605)

巢_获矮.spr 草帽 4497 (女性 4607)
巢_货窍踞辉.spr 白角 4499 (女性 4609)
巢_箕橇庆靛扁绢.spr 尖角 4401 (女性 4611)
巢_辑努复.spr 发箍（蛇女） 4403 (女性 4613)
巢_急臂贰胶.spr 墨镜 4405 (女性 4615)
巢_己流磊狼葛磊.spr 神圣之帽 4407 (女性 4617)
巢_荐堪.spr 胡子？ 4409 (女性 4619)
巢_胶付老.spr 笑脸面具 4411 (女性 4621)
巢_胶困飘哩撇.spr 绅士帽 4413 (女性 4623)
巢_胶农贰摹付胶农.spr 整人面具 4415 (女性 4625)
巢_胶鸥歹胶飘.spr 星星发夹 4417 (女性 4627)

巢_胶巧臂贰胶.spr 转圈眼镜 4419 (女性 4629)
巢_矫困侩付胶农.spr ?????? 4421 (女性 4631)
巢_缴瘤.spr 火线头饰 4423 (女性 4633)
巢_酒捞攫纳牢.spr 金属口罩 4425 (女性 4635)

巢_厩付狼赣府鹅.spr 恶魔发夹 4427 (女性 4637)
巢_救措.spr 钉子？？ 4429 (女性 4639)
巢_救傈葛.spr 矿工帽 4431 (女性 4641)
巢_救抛唱.spr 天线头 4433 (女性 4643)

巢_楷必家档备.spr 戏剧头饰 4435 (女性 4645)
巢_康去绊府.spr 光环 4437 (女性 4647)
巢_坷农练秋抚.spr 兽人头盔 4439 (女性 4649)
巢_坷其扼啊搁.spr 舞会面具 4441 (女性 4651)

巢_棵靛胶磐肺盖胶.spr 老人帽子 4443 (女性 4653)
巢_空府夯.spr 大蝴蝶结 4445 (女性 4655)
巢_寇传救版.spr 单眼眼镜 4447 (女性 4657)

巢_夸沥狼蓖.spr 妖精耳朵 4449 (女性 4659)
巢_侩立付胶农.spr 钢铁面具 4451 (女性 4661)
巢_盔林刮赣府鹅.spr 印第安发箍 4453 (女性 4663)
巢_傀胶畔弊饭捞胶.spr 牛仔帽 4455 (女性 4665)
巢_困历靛寝.spr 魔法师帽 4457 (女性 4667)
巢_狼荤赣府鹅.spr 医生发圈 4459 (女性 4669)
巢_狼利救措.spr 时髦眼罩 4461 (女性 4671)
巢_厘肥扒.spr 葬礼帽 4463 (女性 4673)
巢_厘侥侩舅伯龙.spr 蛋壳帽 4465 (女性 4675)
巢_厘侥侩秦官扼扁.spr 向日葵帽子 4467 (女性 4677)
巢_沥瘤钎瘤魄.spr STOP牌 4469 (女性 4679)

巢_陵倔农扼款.spr 首领冠冕 4471 (女性 4681)

巢_玫荤狼赣府鹅.spr 天使发夹 4473 (女性 4683)

巢_檬废歹惦捞.spr 昆虫角 4475 (女性 4685)

巢_母.spr 无边帽 4477 (女性 4687)
巢_目技绢.spr 船长帽 4479 (女性 4689)
巢_内肺齿.spr 黄金冠冕（蜜蜂妈妈掉的） 4481 (女性 4691)

巢_泥荐堪.spr ???? 4483 (女性 4693)
巢_农扼款.spr 王冠 4485 (女性 4695)
巢_盼荐堪.spr 络腮胡子 4487 (女性 4697)
巢_配尝赣府鹅.spr 兔耳 4489 (女性 4699)
巢_萍酒扼.spr 后冠 4491 (女性 4701)
巢_颇捞橇淬硅.spr 烟斗 4493 (女性 4703)
巢_钱蕾.spr 咬草 4495 (女性 4705)
巢_遣荤尔.spr 初恋发圈（花发圈，月夜花掉的~） 4497 (女性 4707)
巢_橇肺歧扼.spr 竹蜻蜓 4499 (女性 4709)
巢_橇沸抛扼焙葛.spr 普隆德拉军帽 4501 (女性 4711)
巢_巧秋抚.spr 人鱼 4503 (女性 4713)
巢_窍飘颇款单捞记.spr ??? 4505 (女性 4715)
巢_切荤葛.spr 学士帽 4507 (女性 4717)
巢_切积葛.spr 学生帽 4509 (女性 4719)
巢_秦利滴扒.spr 海盗三角巾 4511 (女性 4721)
巢_寝.spr 渔夫帽 4513 (女性 4723)
巢_庆靛迄.spr 耳机 4515 (女性 4725)
巢_秋抚.spr 金属头盔 4517 (女性 4727) <----------------金属头盔的正确位置,而不是在防毒面具的上面一个
巢_闰荐堪.spr 白胡子 4519 (女性 4729)

-------摘自RO另类


解决洞装在游戏中无法显示洞的方法

1、打开rodata文件夹下的 itemslotcounttable.txt

2、打开后会看到以下文字
1101#3#
1102#4#
1103#0#
1104#3#
1105#4#
1106#0#
1107#3#
1108#4#
1109#0#
1110#2#
1111#3#
1112#0#
……

解释：
物品代码#显示洞数#

把你要显示洞的物品的代码和洞数照这样子添加就可以了

-------摘自青豆网


通过制作.SPR文件自己做新怪物的方法

通过制作.SPR文件自己做新怪物的方法（新头饰、发型、武器、NPC通用）

需要用到的工具：
GRFIO 用来从DATA.GRF中提取文件
ROSPR 用来查看*.spr文件中的图像
SPR2BMP 用来从SPR文件中提取BMP图像
PHOTOSHOP 修改、制作自己的BMP图
SPRFROMBMP 把做好的BMP重新打包成SPR文件
XZVF 可以修改和制作动作文件（*.act），不一定要用到。
－－－－－－－－－－－－－－－－－－－－－－－－－－－－

第一步 从DATA.GRF中取得SPR文件和ACT文件

重力社把RO使用的资源文件全部打包放在DATA.GRF中（测试服务器用的放在SDATA.GRF中），我们要做的
就是把需要的文件从DATA.GRF中提取出来，放到RO下面的DATA目录中。全部解开的话DATA目录大概有2G多
，其实可以只提取自己需要的部分的，比如用GF.EXE可以使用过滤器，只释放出符合条件的文件。但是
GF.EXE会生成韩文目录名（GRFIO生成的是中文乱码目录名），对我来说韩文比乱码还要可怕啊(′д`)，
所以还是用GRFIO啦，再说全部解出来研究起来也比较方便 ^_^
好了，解出来以后，要去找到自己需要的文件。怪物的文件放在 data\sprite\阁胶磐 下面，比如我要做
出一种新的大蝴蝶结波利，那么就去 data\sprite\阁胶磐 下面找到poring.spr和poring.act,把它们复
制到工作目录，马上要用到。接下来要找大蝴蝶结，头饰放在 data\sprite\厩技荤府 ，那里有两个子目
录 巢 和 咯 ，分别是男和女的意思。也就是说同一种头饰戴在男生头上和戴在女生头上的效果是可以不
一样的（好像防风眼镜帽子就是这样的），进到 咯 下面，用ROSPR一个一个的看把，找到大蝴蝶结的文
件，也就是 咯_空府夯.spr和咯_空府夯.act，拷出来备用。
－－－－－－－－－－－－－－－－－－－－－－－－－－－－
第二步 从SPR中提取BMP图

先以波利为例解释一下*.SPR和*.act文件的作用。poring.spr中存放着49张BMP图。而poring.act中放的
则是波利的动作。你可以用xzvf来修改波利的动作（其实就是修改ACT文件），但是最好不要这样做……
一个ACT文件包含几十到上百个动作、一个动作包含N个Frame（N从一到几十不等）、一个Frame又包含N个
SubFrame，真要修改起来是会死人的……(;′д`)。

好了，言归正传，现在要从SPR文件中把BMP图提取出来，其实有好多工具都可以做到这一点，不过我手头
的几个都不是太好用，干脆自己写了一个SPR2BMP。用法很简单，在命令行方式下输入spr2bmp poring.spr,
然后就会在当前目录下生成poring000.bmp到poring048.bmp这一系列文件。
接着用同样的方法把大蝴蝶结的图提取出来。
－－－－－－－－－－－－－－－－－－－－－－－－－－－－

第三步 用PHOTOSHOP改图

开PHOTOSHOP，打开刚才解出来的波利图和大蝴蝶结图，好多啊，寒一下……
其实只是做新怪物比较麻烦一点，如果是做新头饰、新发型、新NPC的话工作量就少很多啦。
接下来就是比较枯燥的工作，CTRL+C和CTRL+V。就是把大蝴蝶结的正面图和背面图一个一个的贴到波利图
上面去。不过在贴图的时候会发现有些图太小了，放不下大蝴蝶结，那么就要扩大原图。但是放大图片的
时候要注意一点，要上下两边一起增加。这是因为在poring.act文件里面的图像位移是以BMP图的中心来
定位的。如果扩大的区域不对称的话，中心点就会偏离原来的位置，在RO里面看到的怪物的位置就不对了
。（其实也可以通过修改act档来修正偏移，但是改act档很麻烦……）

呼，贴上几十张以后全部完成了，接着就要把这些改好的图存下来，一张张的按Ctrl+S就行了，注意不要
把图像模式由“索引颜色”改成“RGB颜色”,因为我提取出来的BMP图都是256色的，每张图片都自带1024
个字节的调色板，在PHOTOSHOP里面就是所谓的“索引颜色”，如果按其他方式保存的话PHOTOSHOP可能不
会使用原来的调色板，那么在RO里面可能就会出现不透明的背景色了。
－－－－－－－－－－－－－－－－－－－－－－－－－－－－

第四步 重新生成SPR文件

刚才改好的图已经保存下来了，名字还是poring000.bmp到poring048.bmp，接着就要把它们重新做成SPR
文件。可以用BMP2SPR这个工具，使用方法还是很简单，输入sprfrombmp poring 49就可以了。poring表示要
读的是poring000.spr文件，而49表示一共有49张图，也就是要读的是poring000.bmp到poring048.bmp,然
后重新压成poring.spr.
OK,大功告成 ^o^,把改过的poring.spr放回到data\sprite\阁胶磐 下面（或者置换回data.grf），进RO
以后看到的波利就都戴大蝴蝶结了~~好可爱~~ （≧﹏≦）

-------摘自RO另类


如何读懂路由表

源码:--------------------------------------------------------------------------------
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 192.168.123.254 192.168.123.88 1
0.0.0.0 0.0.0.0 192.168.123.254 192.168.123.68 1
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
192.168.123.0 255.255.255.0 192.168.123.68 192.168.123.68 1
192.168.123.0 255.255.255.0 192.168.123.88 192.168.123.88 1
192.168.123.68 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.123.88 255.255.255.255 127.0.0.1 127.0.0.1 1
192.168.123.255 255.255.255.255 192.168.123.68 192.168.123.68 1
192.168.123.255 255.255.255.255 192.168.123.88 192.168.123.88 1
224.0.0.0 224.0.0.0 192.168.123.68 192.168.123.68 1
224.0.0.0 224.0.0.0 192.168.123.88 192.168.123.88 1
255.255.255.255 255.255.255.255 192.168.123.68 192.168.123.68 1
Default Gateway: 192.168.123.254 ----------------------------------------
======================================================================
当前的路由：
destination 目的网段
mask 子网掩码
interface 到达该目的地的本路由器的出口ip
gateway 下一跳路由器入口的ip，路由器通过interface和gateway定义一调到下一个路由器的链路，通常情况下，interface和gateway是同一网段的
metric 跳数，该条路由记录的质量，一般情况下，如果有多条到达相同目的地的路由记录，路由器会采用metric值小的那条路由

第一条
缺省路由：意思就是说，当一个数据包的目的网段不在你的路由记录中，那么，你的路由器该把那个数据包发送到哪里！缺省路由的网关是由你的连接上的default gateway决定的
该路由记录的意思是：当我接收到一个数据包的目的网段不在我的路由记录中，我会将该数据包通过192.168.123.88这个接口发送到192.168.123.254这个地址，这个地址是下一个路由器的一个接口，这样这个数据包就可以交付给下一个路由器处理，与我无关。该路由记录的线路质量 1

第二条
缺省路由：
该路由记录的意思是：当我接收到一个数据包的目的网段不在我的路由记录中，我会将该数据包通过192.168.123.68这个接口发送到192.168.123.254这个地址，这个地址是下一个路由器的一个接口，这样这个数据包就可以交付给下一个路由器处理，与我无关。该路由记录的线路质量 1

第三条
本地环路：127.0.0.0这个网段内所有地址都指向自己机器，如果收到这样一个数据，应该发向哪里 该路由记录的线路质量 1

第四条
直联网段的路由记录：当路由器收到发往直联网段的数据包时该如何处理，这种情况，路由记录的interface和gateway是同一个。
当我接收到一个数据包的目的网段是192.168.123.0时，我会将该数据包通过192.168.123.68这个接口直接发送出去，因为这个端口直接连接着192.168.123.0这个网段，该路由记录的线路质量 1

第五条
直联网段的路由记录
当我接收到一个数据包的目的网段是192.168.123.0时，我会将该数据包通过192.168.123.88这个接口直接发送出去，因为这个端口直接连接着192.168.123.0这个网段，该路由记录的线路质量 1

第六条
本地主机路由：当路由器收到发送给自己的数据包时将如何处理
当我接收到一个数据包的目的网段是192.168.123.68时，我会将该数据包收下，因为这个数据包时发送给我自己的，该路由记录的线路质量 1

第七条
本地主机路由：当路由器收到发送给自己的数据包时将如何处理
当我接收到一个数据包的目的网段是192.168.123.88时，我会将该数据包收下，因为这个数据包时发送给我自己的，该路由记录的线路质量 1

第八条
本地广播路由：当路由器收到发送给直联网段的本地广播时如何处理
当我接收到广播数据包的目的网段是192.168.123.255时，我会将该数据从192.168.123.68接口以广播的形势发送出去，该路由记录的线路质量 1

第九条
本地广播路由：当路由器收到发送给直联网段的本地广播时如何处理
当我接收到广播数据包的目的网段是192.168.123.255时，我会将该数据从192.168.123.88接口以广播的形势发送出去，该路由记录的线路质量 1

第十条
组播路由：当路由器收到一个组播数据包时该如何处理
当我接收到组播数据包时，我会将该数据从192.168.123.68接口以组播的形势发送出去，该路由记录的线路质量 1

第十一条
组播路由：当路由器收到一个组播数据包时该如何处理
当我接收到组播数据包时，我会将该数据从192.168.123.88接口以组播的形势发送出去，该路由记录的线路质量 1

第十二条
广播路由：当路由器收到一个绝对广播时该如何处理
当我接收到绝对广播数据包时，将该数据包丢弃掉

-------摘自多多の宝贝 美雨儿


ADSL上网常见问题集锦

Error 602 The port is already open
问题：拨号网络网络由于设备安装错误或正在使用，不能进行连接
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装
Error 605 Cannot set port information
问题：拨号网络网络由于设备安装错误不能设定使用端口
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装
Error 606 The port is not connected
问题：拨号网络网络不能连接所需的设备端口
原因：RasPPPoE没有完全和正确的安装，连接线故障，ADSL MODEM故障
解决：卸载干净任何PPPoE软件，重新安装，检查网线和 ADSL MODEM

Error 608 The device does not exist
问题：拨号网络网络连接的设备不存在
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装

Error 609 The device type does not exist
问题：拨号网络网络连接的设备其种类不能确定
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装

Error 611 The route is not available/612 The route is not allocated
问题：拨号网络网络连接路由不正确
原因：RasPPPoE没有完全和正确的安装，ISP服务器故障
解决：卸载干净任何PPPoE软件，重新安装，致电ISP询问

Error 617 The port or device is already disconnecting
问题：拨号网络网络连接的设备已经断开
原因：RasPPPoE没有完全和正确的安装，ISP服务器故障，连接线，ADSL MODEM故障
解决：卸载干净任何PPPoE软件，重新安装，致电ISP询问 ，检查网线和 ADSL MODEM

Error 619 问题：与ISP服务器不能建立连接
原因：ADSL ISP服务器故障，ADSL电话线故障
解决：检查ADSL信号灯是否能正确同步。致电ISP询问

Error 621 Cannot open the phone book file
Error 622 Cannot load the phone book file
Error 623 Cannot find the phone book entry
Error 624 Cannot write the phone book file
Error 625 Invalid information found in the phone book
问题：Windows NT或者Windows 2000 Server网络RAS网络组件故障
原因：卸载所有PPPoE软件，重新安装RAS网络组件和RasPPPoE

Error 630
问题：ADSL MODEM没有没有响应
原因：ADSL电话线故障，ADSL MODEM故障（电源没打开等）
解决：检查ADSL设备

Error 633
问题：拨号网络网络由于设备安装错误或正在使用，不能进行连接
原因：RasPPPoE没有完全和正确的安装
解决：卸载干净任何PPPoE软件，重新安装

Error 638
问题：过了很长时间，无法连接到ISP的ADSL接入服务器
原因：ISP服务器故障；在RasPPPoE所创建的不好连接中你错误的输入了一个电话号码
解决：运行其创建拨号的Raspppoe.exe检查是否能列出ISP服务，以确定ISP正常;

把所使用的拨号连接中的 电话号码清除或者只保留一个0。

Error 645
问题：网卡没有正确响应
原因：网卡故障，或者网卡驱动程序故障
解决：检查网卡，重新安装网卡驱动程序

Error 650
问题：远程计算机没有响应，断开连接
原因：ADSL ISP服务器故障，网卡故障，非正常关机造成网络协议出错
解决：检查ADSL信号灯是否能正确同步，致电ISP询问；检查网卡，

删除所有网络组件重新安装网络。

Error 651
问题：ADSL MODEM报告发生错误
原因：Windows处于安全模式下，或其他错误
解决：出现该错误时，进行重拨，就可以报告出新的具体错误代码

Error 691
问题：输入的用户名和密码不对，无法建立连接
原因：用户名和密码错误，ISP服务器故障
解决：使用正确的用户名和密码，并且使用正确的ISP账号格式(name@service),

致电ISP询问。

Error 718
问题：验证用户名时远程计算机超时没有响应，断开连接
原因：ADSL ISP服务器故障
解决：致电ISP询问

Error 720
问题：拨号网络无法协调网络中服务器的协议设置
原因：ADSL ISP服务器故障，非正常关机造成网络协议出错
解决：致电ISP询问，删除所有网络组件重新安装网络。

Error 734
问题：PPP连接控制协议中止
原因：ADSL ISP服务器故障，非正常关机造成网络协议出错
解决：致电ISP询问，删除所有网络组件重新安装网络。

Error 738
问题：服务器不能分配IP地址
原因：ADSL ISP服务器故障，ADSL用户太多超过ISP所能提供的IP地址
解决：致电ISP询问

Error 797
问题：ADSL MODEM连接设备没有找到
原因：ADSL MODEM电源没有打开，网卡和ADSL MODEM的连接线出现问题，

软件安装以后相应的协议没有正确邦定，在创立拨号连接时，建立了错误的空连接
解决：检查电源，连接线；检查网络属性，RasPPPoE相关的协议是否正确的安装并正确邦定

（相关协议），检查网卡是否出现?号或!号，把它设置为Enable;检查拨号连接的属性，

是否连接的设备使用了一个“ISDN channel-Adapter Name(xx)” 的设备，

该设备为一个空设备，如果使用了取消它，并选择正确的PPPoE设备代替它，

或者重新创立拨号连接。

--------摘自多多の宝贝论坛 美雨儿


端口映射的几种实现方法

采用端口映射（Port Mapping）的方法，可以实现从Internet到局域网内部机器的特定端口服务的访问。

笔者总结了在教学与组网实践中采用的几种端口映射方法，在此与大家交流探讨。
    利用IIS实现WWW和FTP服务的重定向
    Windows 2000和Windows XP都包含了IIS组件，其中的WWW和FTP服务具有主目录重定向设置，

与端口映射相比，虽名称不同但作用类似。本文以Windows 2000下IIS 5.0的WWW和FTP服务举例说明。

    1、WWW服务的重定向

    打开管理工具中的Internet服务管理器，进入“Internet信息服务”对话框，

选择Web站点名称，例如：“默认Web站点”，查看其属性，在属性页面的“主目录”标签下，

我们可以设置WWW服务器的主目录位置。设定主目录为“另一计算机上的共享位置”，

则可以在“网络目录”栏目内，以“\\{服务器}\{共享名}”格式填写局域网

内部的WWW服务器上已经设为共享的主目录，例如：\\Server6\www。

    我们也可以选择“重定向到URL”，然后在“重定向到”栏目输入局域网内部的

WWW服务器的链接，例如http://192.168.0.6。
2、FTP服务的重定向

    与WWW服务的重定向相似，打开管理工具中的Internet服务管理器，

进入“Internet信息服务”对话框，选择FTP站点名称，例如：“默认FTP站点”，

查看其属性，在属性页面的“主目录”标签下，我们可以设置FTP服务器的主目录位置。

    WinRoute Pro的端口映射功能

    WinRoute Pro是一个工作于NAT（网络地址翻译）方式的Internet共享软件。

它本身自带了端口映射功能。

    运行WinRoute Administration并登录，在主菜单上选择“Settings→ Advanced→Port Mapping”，

出现端口映射的设置界面。端口映射条目的添加、编辑界面如图所示。

可以设置的选项包括协议、监听端口、端口类型（单一端口还是某个范围的连续端口）、

目的主机、目的端口等。

    专用的端口映射工具PortTunnel

    PortTunnel是一个实现端口映射的专用工具。它是一个直接运行的软件。

如果操作系统为Windows NT/Windows 2000/Windows XP，第一次运行时选择Start，

PortTunnel会自动以服务方式运行。点击[Add]按钮添加条目，点击[Edit]按钮编辑现有条目，

点击[Delete]按钮删除条目。

    在这个“新建/编辑端口映射”对话框中，我们要给该条目命名，然后设定输入端口（Port In）、

绑定地址（Bind address）、输出端口（Port Out）和输出地址（Address Out）。其中，

“绑定地址”是指监听该主机的哪一个IP（内部IP还是外部IP）。设为“Any(0.0.0.0)”

则监听该主机的全部IP。

    PortTunnel专门针对HTTP、FTP、SMTP服务的端口映射，提供了较多的参数设置，

在相应的标签菜单下调整。此外，PortTunnel还提供了安全性设置和日志、统计等功能。

-------摘自多多の宝贝 美雨儿


动态IP申请花生壳域名转向图文教程

首先进入网域科技的主页:http://www.oray.net
如图上蓝圈所示，点击“我要.注册网域护照”

接下来填写注册信息，我这里填random255
注意，这里填写的只是你在该站的用户名称，并不是你的域名

一连串的注册页面点完以后，会出现这个信息，如果你想以后申请在线支付功能，

就一定要点“完成”继续填写个人详细信息，如果是免费用

户就不必填了

上一步如果选择了填写个人详细信息就会出现下面的页面

填写完毕以后按“完成”

然后你的注册就结束了，系统会进入用户管理页面（以后你登陆就直接到这个页面了）

如图所示，选择左上角“域名维护中心”的“注册域名记录”，就会出现右边的填写框，

第一项就是我们免费用户需要的。在这里填写的就是你的域名（也就是你开FTP时候，

应该在IP里填写的信息，比如这里填了random255，那么FTP里的IP栏里就填random255.vicp.net）

填完以后，下载花生壳客户端软件（下载看这里:http://www.oray.net/products/PeanutHull_Support.asp,

注意有98/NT两个不同的版本），在安装过程中，会出现如图所示的窗口，在这里填写你的网域护照

（就是你在网域的用户信息，第一次填的那个）

安装完成以后，下次运行该程序的时候，系统就会自动把你当前的IP信息提交给服务器，

并自动把你的当前IP和你的域名对应起来（这里我就不重新安装一遍了，若按刚才的步骤，

下图中上面显示的应该是RANDOM255，下面是你申请的域名）

如果域名解析成功，上图中的最下面一栏会自动显示你的域名（如果启动软件在先连网在后，就点右边的刷新）。

系统托盘里如果显示彩色立方体 [image] ，说明运行正常，如果立方体显示灰色，说明没有成功解析IP，

试试刷新吧。

---------摘自青豆网