脚本指令帮助文档(Athena.Net Script Document)

脚本指令帮助文档(Athena.Net Scripts Document)

制作时间： | 2007.2.9
最后更新： | 2009.5.7
简体版本制作人： | FPE(QQ:5454062)
繁体版本制作人： | likes080(MSN:likes080@yahoo.com)
Athena.Net 官方网站： | http://www.foxofice.net/bbs

注意：此脚本指令帮助文档以Athena.Net的脚本指令为基础，其他Athena慎用。

另外：我们将无限期鄙视SEA的恶劣抄袭行为！
We will disdain abominable plagiarizing behavior of SEA indefinitely!


类C语言语法

if-else if-else结构

作用：条件判断

格式： | if( <cond> ) <cmd_1> [ [else if(<cond_n>) <cmd_n> ]* else <cmd_z>]
说明： | 如果<cond>为真则执行<cmd_1>部分的代码，并结束if结构。 否则如果后面带有"else if(<cond_n>)"的话，则从上至下依此判断，如果为真则执行<cmd_n>，并结束if结构。 最后，如果之前的条件都不满足的话，则执行"else"后面的代码（如果有的话）。 <cmd_n>能用{ , }组成语句块。

<例>

// 如果@input变量为0，则跳到HOGE标签继续执行。
if(@input == 0) goto HOGE;

// 如果@input变量为0，则跳到HOGE标签继续执行，否则跳到FUGA标签继续执行。
if(@input == 0) goto HOGE;
else goto FUGA;

if(@input == 0)
mes "zero";
else if(@input == 1)
mes "one";
else if(@input == 2) {
mes "two";
} else {
mes "??unknown";
mes "请输入0,1,2这3个值的其中一个。";
}
如果if后没有括号，则只执行紧接其后的语句；如果有括号块，则执行块中的所有语句。

if(@temp <= 1) if(@temp <= 0) mes "<= 0"; else mes "1"; else mes ">= 2";
和
if(@temp <= 1) { if(@temp <= 0) mes "<= 0"; else mes "1"; } else mes ">= 2";
以相同的方法处理。

for循环

作用：循环执行代码

格式： for(initialization;test;action)
statement;

说明： initialization语句是用来初始化counter的值，或是为循环作好准备。
test语句可以是任何表达式，在每次进入循环时都要对它进行测试。
如果test为真，就执行for循环体，然后执行action语句（通常是对counter进行自增运算）。

<例>

for(set @i,0;@i < 5;set @i,@i+1) mes @i;

for(set @i,0;@i < 5;set @i,@i+1) {
mes @i;
next;
}

do-while结构

作用：循环执行代码

格式： | do <cmd> while(<val>);
说明： | 和"<cmd> while(<val>) <cmd>;"的语法相同，但是do...while会先执行一次<cmd>的代码。 当<val>为真则继续执行<cmd>。

switch-case结构

作用：多值判断

格式： | switch(<val_1>) { [case <val_n>: ....] [ default: ...] }
说明： | 判断<val_1>的值，如果和<val_n>一致，则跳到case <val_n>的地方执行；如果都没有匹配，则执行default后的代码。 跳到case <val_n>执行完代码后并不会退出switch块，要退出switch块请使用break;命令。

<例>

switch(@temp) {
default: mes("unknown FALLTHRU");
// 因为没有"break"，所以会继续执行代码
case 0: mes("零");
break;
case 1: mes("一");
break;
case 2: mes("二 FALLTHRU");
// 因为没有"break"，所以会继续执行代码
case 3: mes("三");
break;
case 4: mes("四");
break;
case 5: mes("五");
break;
}

break命令

作用：退出循环

格式： | break;
说明： | 强制退出for , while , switch , do - while循环。

continue命令

作用：终止本次循环

格式： | continue;
说明： | 终止for , while , do - while的本次循环，进入下一次循环。

function命令

作用：在同一脚本内声明/定义函数

格式： | function hoge; // 函数声明 function hoge { // 函数定义 mes getarg(0); } hoge "fuga"; // 调用函数
说明： | 调用未声明的函数将出错


脚本基础知识

1、坐标系

↑Y的增加
(0,200)--(200,200)
| |
| |
| |
| |
| |
(0, 0)--(200, 0)→X的增加

坐标从左下开始，向右上递增

2、NPC的定义

NPC类型： | 传送点
作用： | 把人物从一个坐标传送到另一个坐标
格式： | <gatname>,<x>,<y><tab>warp<tab><displayname><tab><dx>,<dy>,<destination_gatname>,<destination_x>,<destination_y>
说明： | <gatname> -- 原地图名（不要忘记加上.gat） <x>,<y> -- 原地图坐标 <displayname> -- NPC名字（DEBUG用） <dx>,<dy> -- 传送点x,y轴的影响范围 dx,dy举例（●表示x,y的位置）： 0,0 1,0 2,2 ＊ ＊＊＊＊＊ ＊＊＊＊＊＊＊ ＊●＊ ＊＊●＊＊ ＊＊＊＊＊＊＊ ＊ ＊＊＊＊＊ ＊＊＊＊＊＊＊ ＊＊＊●＊＊＊ ＊＊＊＊＊＊＊ ＊＊＊＊＊＊＊ ＊＊＊＊＊＊＊ <destination_gatname> -- 目标地图名（.gat可有可无） <destination_x>,<destination_y> -- 目标地图坐标
注意事项： | 如果在同一位置放置了多个传送点，则只有最后一个生效。 如果目标坐标是不可到达的坐标，则自动进行目标地图内的随机传送。

NPC类型： | 怪物
作用： | 使地图中出现怪物
格式： | <gatname>,<x>,<y>,<xs>,<ys><tab>monster<tab><displayname><tab><mob_id>,<amount>,<spawn_delay1>,<spawn_delay2>[,<event>] <gatname>,<x>,<y>,<xs>,<ys><tab>monster_big<tab><displayname><tab><mob_id>,<amount>,<spawn_delay1>,<spawn_delay2>[,<event>]（刷出大型化的怪物。VIP版专用） <gatname>,<x>,<y>,<xs>,<ys><tab>monster_small<tab><displayname><tab><mob_id>,<amount>,<spawn_delay1>,<spawn_delay2>[,<event>]（刷出小型化的怪物。VIP版专用）
说明： | <gatname> -- 地图名 <x>,<y> -- 坐标 <xs>,<ys> -- 怪物出现的x,y轴的范围 xs,ys举例（●表示x,y的位置）： 0,0 2,1 ● ＊＊＊＊＊ ＊＊●＊＊ ＊＊＊＊＊ <displayname> -- 显示怪物的名字 <mob_id> -- 怪物ID（请参考mob_db.txt） <amount> -- 怪物数量 <spawn_delay1> -- 刷新后多少毫秒再次刷新 <spawn_delay2> -- 死亡后多少毫秒再次刷新 <event> -- 怪物死亡后执行的事件（省略时填0） 。 也可以设置成数字，设置为2表示指定怪物为小型、设置为4表示大型、设置为8表示特殊AI怪物（默认为攻击怪物的怪物）。设置为数字时可叠加。
注意事项： | 根据<spawn_delay1>和<spawn_delay2>的数值，优先选择刷新较慢的那个。

NPC类型： | 商店/现金店
作用： | 出售物品
格式： | <gatname>,<x>,<y>,<direction><tab>shop/cashshop<tab><displayname><tab><npcid>,<item_id1>:<price1>[,<item_id2>:<price2>...]
说明： | <gatname> -- 地图名 <x>,<y> -- 坐标 <direction> -- 商店的方向 <direction> 的详情： １０７ ２ ６ ３４５ <displayname> -- 商店名字 <npcid> -- 商店的外观 <item_id?> -- 商品的物品ID（请参考item_db.txt） <price?> -- 商品价格
注意事项： | <item_id>:<price>可用,分割指定多个物品。 当「<gatname>,<x>,<y>,<direction><tab>」部分为「-<tab>」的时候，可作为复制源。

NPC类型： | NPC
作用： | 制作NPC
格式： | <gatname>,<x>,<y>,<direction><tab>script<tab><displayname><tab><npcid>,[<xs>,<ys>,]{ <script> ... }
说明： | <gatname> -- 地图名 <x>,<y> -- 坐标 <direction> -- NPC方向 <direction> 的详情： １０７ ２ ６ ３４５ <displayname> -- NPC名字。如果<npcid>为-1则为事件名。 <npcid> -- NPC的外观。如果是-1则表示地图内的事件。 <xs>,<ys> -- 触发NPC的x,y轴的范围。 {}（大括号内）包含NPC的所有代码。 不推荐集中在一行内编写代码，建议写成这样： gatname等, { //注释 script; label: script; } 单行注释请用//，多行注释请用/*,*/ 「<gatname>,<x>,<y>,<direction><tab>」部分改为「-<tab>」的 时候，可作为复制源。

NPC类型： | 复制传送点/NPC/商店/现金店
作用： | 复制已存在的传送点/NPC/商店/现金店
格式1（warp）： | <gatname>,<x>,<y>,<direction><tab>duplicate(<source>)<tab><displayname><tab><spanx>,<spany>
格式2（shop/cashshop/npc）： | -<tab>duplicate(<source>)<tab><displayname><tab><view_id>
格式3（shop/cashshop/npc）： | <gatname>,<x>,<y>,<direction><tab>duplicate(<source>)<tab><displayname><tab><view_id>
格式4（npc）： | -<tab>duplicate(<source>)<tab><displayname><tab><view_id>,<triggerX>,<triggerY>
格式5（npc）： | <gatname>,<x>,<y>,<direction><tab>duplicate(<source>)<tab><displayname><tab><view_id>,<triggerX>,<triggerY>
说明： | <source>以外的参数和脚本一样。 <source>为要复制的NPC的名字。 如果是复制没有指定地图的NPC，则可用于任意地图。否则只能复制同地图名字的NPC。

NPC类型： | 全局函数
作用： | 制作由脚本调用的用户自定义函数
格式： | function<tab>script<tab><name><tab>{ <script> ... }
说明： | <name> -- 函数名字 制作一个可用callfunc命令调用的函数。函数的参数可以用getarg函数获得。从函数中返回请使用return命令。

NPC类型： mapflag
作用： 设置地图标识
格式： <gatname><tab>mapflag<tab><const>
说明： <gatname> -- 地图名字
<const> -- 要设置的规则

如果把dummy改为off的话，则表示取消地图的标识
<const>一览表：
nosave<tab><gatname>,<x>,<y> | 重新登陆时，移动到<gatname>地图的(x,y)坐标。 如果是"nosave SavePoint"的话，则移动到人物的储存点。
autotrade<tab>dummy | 设置地图的autotrade属性（跟battleconf中的at_mapflag配合使用）
allowks<tab>dummy | 防抢怪
town<tab>dummy | 设置为城镇属性
nomemo<tab>dummy | 禁止记忆（禁止使用/nomemo）
noteleport<tab>dummy | 禁止使用指定了SavePoint或Random的warp段、传送之阵和瞬移
nowarp<tab>dummy | 不能从本地图瞬移（要设置battleconf中的any_warp_GM_min_level选项）
nowarpto<tab>dummy | 不能从其他地图瞬移到本地图（要设置battleconf中的any_warp_GM_min_level选项）
noreturn<tab>dummy | 禁止warp命令SavePoint回城，并且禁止使用蝴蝶翅膀
monster_noteleport<tab>dummy | 禁止怪物使用瞬移
nobranch<tab>dummy | 禁止召怪
nopenalty<tab>dummy | 禁止任何处罚
pvp<tab>dummy | 变成PVP地图（注意：gvg、gvg_dungeon、gvg_castle、battleground会自动取消）
pvp_noparty<tab>dummy | 变成PVP地图（不可攻击同队玩家）
pvp_noguild<tab>dummy | 变成PVP地图（不可攻击同公会玩家）
pvp_nightmaredrop<tab><drop_id>,<drop_type>,<drop_per> | 变成PVP地图（梦魇模式） <drop_id>--掉落物品ID。如果为random则表示随机掉落物品（random区分大小写） <drop_type>--掉落物品类型。inventory表示随身物品、equip表示装备、all表示以上类型均有可能（注意区分大小写） <drop_per>--掉率（万分率）
pvp_nocalcrank<tab>dummy | 变成PVP地图（不计算PVP点数和排行榜）
gvg<tab>dummy | 变成GVG地图（注意：pvp、battleground会自动取消）
gvg_noparty<tab>dummy | 变成GVG地图（不可攻击同队玩家）
gvg_dungeon<tab>dummy | 变成GVG地牢属性（注意：pvp会自动取消）
gvg_castle<tab>dummy | 变成GVG城堡属性（注意：pvp会自动取消）
battleground<tab><flag> | 战场属性（注意：pvp、gvg、gvg_dungeon、gvg_castle会自动取消） <flag>=2的时候更新分数？+特殊模式？
noexppenalty<tab>dummy | 死亡时不掉经验
nozenypenalty<tab>dummy | 死亡时不掉钱
notrade<tab>dummy | 禁止玩家间交易
novending<tab>dummy | 禁止开设露天商店
nodrop<tab>dummy | 不能扔物品
noicewall<tab>dummy | 禁止使用冰墙
snow<tab>dummy | 下雪
clouds<tab>dummy | 云景
clouds2<tab>dummy | 云景2
fog<tab>dummy | 雾
fireworks<tab>dummy | 烟火
sakura<tab>dummy | 樱花
leaves<tab>dummy | 落叶
rain<tab>dummy | 下雨
indoors<tab>dummy | 室内
nightenabled<tab>dummy | 允许夜晚模式
nogo<tab>dummy | 不能在本地图使用@go（要设置battleconf中的any_warp_GM_min_level选项）
noexp<tab>dummy | 不能获取经验（Base+Job）
nobaseexp<tab>dummy | 不能获取Base经验
nojobexp<tab>dummy | 不能获取Job经验
noloot<tab>dummy | 怪物不掉落物品
nomobloot<tab>dummy | 普通怪物不掉落物品
nomvploot<tab>dummy | MVP怪物不掉落物品
nocommand<tab><lv> | 设定GM等级在<lv>以下的GM不能使用命令。 不指定<lv>的情况为禁止使用所有GM指令。
restricted<tab><value> | 设定为受限区域 <value>为位运算，比如1、2、4……
jexp<tab><rate> | 设置Job经验的倍率。<rate>为百分率，100表示1倍。（优先于battle_athena.conf） 如果<rate>不为0，那么nojobexp会自动取消。
bexp<tab><rate> | 设置Base经验的倍率。<rate>为百分率，100表示1倍。（优先于battle_athena.conf） 如果<rate>不为0，那么nobaseexp会自动取消。
loadevent<tab>dummy | 执行OnPCLoadMapEvent事件
nochat<tab>dummy | 不能创建聊天室
partylock<tab>dummy | 锁定队伍（不能创建、离开、踢人、改变队长、邀请）
guildlock<tab>dummy | 锁定公会（不能创建、离开、踢人、改变会长、邀请、改变同盟、解散）
noskillall<tab>dummy | 禁止玩家使用所有技能
noitemall<tab>dummy | 禁止使用所有物品
noequipall<tab>dummy | 禁止装备所有武器/防具
nocardall<tab>dummy | 禁止装备所有卡片
noskill<tab><skill_id1>:<skill_id2>:<skill_id3>... | 禁止玩家使用某些技能
noitem<tab><item_id1>:<item_id2>:<item_id3>... | 禁止使用某些物品
noequip<tab><equip_id1>:<equip_id2>:<equip_id3>... | 禁止装备某些武器/防具
nocard<tab><card_id1>:<card_id2>:<card_id3>... | 禁止装备某些卡片
no_follow<tab>dummy | 设定本地图无法跟随（注意：双方只要其中一方的地图的no_follow生效，就无法跟随。）
show_mob_info<tab><type> | 设定地图显示怪物信息（show_mob_info、no_show_mob_info的mapflag优先于battle_athena.conf的show_mob_info开关。当show_mob_info、no_show_mob_info同时存在时，则以show_mob_info为优先） <type>列表： +1 显示HP/MaxHP +2 显示HP的% +4 显示Lv
no_show_mob_info<tab>dummy | 设定地图不显示怪物HP（show_mob_info、no_show_mob_info的mapflag优先于battle_athena.conf的show_mob_info开关。当show_mob_info、no_show_mob_info同时存在时，则以show_mob_info为优先）
no_char_pvp<tab>dummy | 禁止玩家使用#pvpon/#pvpoff（VIP版专用）
noequipexp<tab>dummy | 不能获取Equip经验
noequipexp<tab><rate> | 设置Equip经验的倍率。<rate>为百分率，100表示1倍。（优先于battle_athena.conf） 如果<rate>不为0，那么noequipexp会自动取消。
no_disguise<tab>dummy | 禁止玩家使用#disguise/#undisguise
autoloot<tab><value> | 设定本地图内是否自动捡物。 当<value>=1时，本地图强制自动捡物。 当<value>=2时，本地图强制不自动捡物。
Mob_Collision_Detection<tab><value> | 启用怪物碰撞检测系统。 当<value>=1时，怪物不会重叠到一个点上，但是那个点可以通行。 当<value>=2时，怪物不会重叠到一个点上，而且那个点也不能通行。
gvg_no_alliance<tab>dummy | 设置GVG时不能同盟（能打到同盟）
norevive<tab>dummy | 死亡时强制传送到储存点
no_create_party<tab>dummy | 禁止创建队伍
no_invite_party<tab>dummy | 禁止邀请玩家加入队伍
no_leave_party<tab>dummy | 禁止玩家离开队伍
mob_noskillall<tab>dummy | 禁止怪物使用所有技能
mob_noskill<tab><skill_id1>:<skill_id2>:<skill_id3>... | 禁止怪物使用某些技能

3、关于NPC的一些注意事项

3.1

在Eathena.Net中，所有NPC都必须有标识名来区分。
如果没有指定标识名，那么会自动使用显示名来代表标识名。
在显示名后加上#表示子名字的话，则子名字不会显示出来。
显示名和标识名都不能超过24个字节。

举例：
<displayname> | <显示名> | <标识名>
Ａ | Ａ | Ａ
Ａ::Ｂ | Ａ | Ｂ
Ａ#dummy | Ａ | Ａ#dummy

3.2

单行注释请使用//，（多行）文本注释注释请使用/* */。
服务端在解释脚本时，会忽略多余的空格、TAB、换行符。

下面举一些例子：

１．超出NPC范围的文字是错误的
prontera.gat,132,150,4 script Test1 120,{
end;
}
set @hoge,1; ← ×

２．注释OK
// 注释
prontera.gat,132,151,4 script Test2 121,{
end;
} /* 注释区域 */

３．可以使用以下多行注释
/* prontera.gat,132,152,4 script Test3 122,{
end;
} */

4、脚本说明和基本规则

＊数字
可使用有符号数和16进制数。
有符号数可请使用半角的数字，如123456等。
16进制数要以0x开头，例如0x12。

＊字符串
字符的表示要用""包含在其中。
如果要显示"字符，请使用\"代替。
如果要显示\字符，请使用\\代替。
字符串中也可以用^000000等显示颜色。
也可以使用：变量 + "字符串"这样的形式组合。

＊单目运算符
以下运算符仅需要一个操作数即可。
- 符号取反
~ 按位取反
! 逻辑非

＊双目运算符
以下运算符需要两个操作数。
+ 加法/字符串连接
既可以当作加法运算，也可以当作连接字符串符号。

- 减法
* 乘法
/ 除法
% 取模（余数）
& 按位与
| 按位或
^ 异或
&& 逻辑与
|| 逻辑或
>> 向右移位
<< 向左移位

以下双目运算符在关系成立时返回1，否则返回0。
== 等于
!= 不等于
> 大于
>= 大于等于
< 小于
<= 小于等于

＊三目运算符
?: 唯一一个三目运算符

举例：<cond> ? <ture> : <false>
如果<cond>为真，则返回<ture>部分，否则返回<false>部分。

＊变量
必须使用半角字符表示变量的前缀、后缀。
变量的生存期看前缀而定。

前缀 | 作用范围 | 生存期
(无前缀) | 人物 | 永久
@ | 人物 | 人物在线时
$ | Map服务器 | 永久
$@ | Map服务器 | 同一次Map服务器运行时
# | 帐号（个人） | 永久
## | 帐号（全服） | 永久
'或. | 单个NPC | 同一次Map服务器运行时
'@或.@ | 单个NPC+人物 | 同一次NPC触发时

简单来说，临时变量带有@、服务器变量带有$、帐号变量带有#。
还要注意的是，'@a和.@a是不同的变量。

'表示NPC变量。
同名的NPC变量，在NPC之间不会发生冲突；而且是跟玩家触发没有关系的（就是多个玩家共用一个'变量）。

'变量依赖于NPC，即使NPC结束后，其值也会被保存（Map服务器重启时才消失）。
虽然使用callfunc函数时，其参数不会影响到其他NPC变量；但是如果配合getarg()函数的话，仍然可以操作传递的参数（参数是以引用传递的）。举例：

function script func1 {
set 'var1, 'var1 + 1;
// func1::'var1 加１
set getarg(0),
getarg(0) + 1;
// func2::'var1 加１
}
function script
func2 {
callfunc "func1",
'var1;
}

'@变量是函数固有的变量，使用callfunc、callsub时，会重新分配内存空间给变量，return时则使分配的变量超出范围。
简单来说，就像是C语言的临时变量一样，还可以使用递归处理。当然，这种变量也可以使用getarg()函数操作。举例：

function script func3 {
set '@n, rand(5);
if( '@n == 0 ) {
return;
}
else {
// '@n 变量和其他变量不同，调用callfunc时变量的范围不同，
// 所以不会出现mes的结果全部为０的现象。
callfunc "func3";
}
mes '@n;
return;
}

此外，函数类型由后缀决定。
但是，字符串类型只适用于人物临时变量、NPC变量、临时/永久的服务器变量。（前缀为@、$、$@的）

后缀 | 类型
（无后缀） | 数值类型
$ | 字符串类型

<例> @hoge$ 字符串类型人物临时变量
hoge 数值类型人物永久变量
$hoge 数值类型服务器永久变量

不要过多的使用永久变量。
不需要时马上设置为0进行删除。
认真思考是否需用用到永久变量。
特别时人物/帐号变量是有数量限制的。

＊数组变量
变量名后紧跟[]则表示数组变量。
注意变量名与“[”之间不能留空。
也可以使用多维数组，维数没有限制。

<例> hoge[10] fuga[ @temp ] foo[5][@i][3]

数组元素的索引从0-127。索引为0时表示和同名变量。
比如说，hoge[0]和hoge是相同的变量。
同样的，fuga[0][1]和fuga[1]是相同的变量。
（但是要注意，foo[1][0][2]和foo[1][2]是不同的变量。）

数组变量可储存人物变量、服务器变量、NPC变量。数值类型或字符串类型均可。

下面列出哪些类型的变量可以使用数组：

变量类型 | 单个变量 | 数组
$Str$ | √ | √
$@Str$ | √ | √
@Str$ | √ | √
#Str$ | √ | ×
Str$ | √ | ×
$Int | √ | √
$@Int | √ | √
@Int | √ | √
#Int | √ | ×
Int | √ | ×
.Str$或'Str$ | √ | √
.Int或'Int | √ | √
.@Str$或'@Str$ | √ | √
.@Int或'@Int | √ | √

＊标签
标签名是以（半角的）字母或_开头、并且可包含数字的单词组成。
例如 L_hoge:。
用if或menu指令时可跳转到该标签。

＊Const属性
Athena的db/const.txt给出了这些Const属性。
只有在脚本内才可以使用。

＊表达式
在指令的参数为数值类型时使用。
不需要空格，为了便于阅读时也可以加上空格。
表达式为真时返回1，否则返回0。

＊事件
没有固定格式的脚本。
可用于制作与时间相关的脚本。
在调用时指定为“事件名::标签”的话，则从事件中指定的标签开始执行脚本。

＊命令语法
参数请用半角的空格来分割。
函数必须带()。如果是没有参数的函数，括号内不能带任何东西（包括0）。例如：checkcart()
命令必须在最后加上;。


Bonus效果一览表

bAddDamageClass、bAddMagicDamageClass、bAddMonsterDropItem 只能设定10个。超过10个的都被无视。
bAutoSpell,bAutoSelfSpell,bRevAutoSpell,bRevAutoSelfSpell 只能设定16个。超过16个的都被无视。

箭矢能使用的效果只有 bCritical、bAtkEle、bHit、bAtkRange、bAddEle、bAddRace、bAddEnemy, bAddSize、bAddEff，其他都被无视

·人物属性操作
bonus bStr,n; | STR+n
bonus bAgi,n; | AGI+n
bonus bVit,n; | VIT+n
bonus bInt,n; | INT+n
bonus bDex,n; | DEX+n
bonus bLuk,n; | LUK+n
bonus bAllStats,n; | 全能力+n
bonus bAgiVit,n; | Agi+n、Vit+n
bonus bAgiDexStr,n; | Agi+n、Dex+n、Str+n
bonus bMaxHP,n; | HP上限+n
bonus bMaxSP,n; | SP上限+n
bonus bMaxHPrate,n; | HP上限+n%
bonus bMaxSPrate,n; | SP上限+n%
bonus bAtk,n; | 物理攻击力+n（武器的Atk增加）
bonus bAtk2,n; | 物理攻击力2+n（武器精炼度增加）
bonus bAtkRate,n; | 物理攻击力+n%（伤害乘法）
bonus bBaseAtk,n; | 基本攻击力+n（BaseAtk增加）
bonus bLongAtkRate,n; | 远程攻击力+n%
bonus2 bWeaponAtk,n,x; | 装备类型n的武器时，攻击力+x（武器的BaseAtk增加）
bonus2 bWeaponAtkRate,n,x; | 装备类型n的武器时，攻击力+x%（伤害乘法）
0-空手、1-短剑、2-单手剑、3-双手剑、4-单手矛、5-双手矛、6-单手斧、7-双手斧、8-单手钝器、9-双手钝器、10-杖、11-弓、12-拳套、13-乐器、14-鞭子、15-书类、16-拳刃、17-左轮手枪、18-来福枪、19-格林机枪、20-雷鸣登、21-榴弹发射器、22-苦无、23-双手杖（EA中最多0-15）
bonus bMatk,n; | 魔法攻击力1+n、魔法攻击力2+n
bonus bMatk1,n; | 魔法攻击力1+n
bonus bMatk2,n; | 魔法攻击力2+n
bonus bMatkRate,n; | 魔法攻击力+n%（伤害乘法）
bonus bDef,n; | 物理防御力+n（装备影响）
bonus bDef2,n; | 物理防御力+n（Vit影响）
bonus bDefRate,n; | 物理防御力+n%（装备影响）
bonus bDef2Rate,n; | 物理防御力+n%（Vit影响）
bonus bMdef,n; | 魔法防御力1+n（装备影响）
bonus bMdef2,n; | 魔法防御力2+n（Int影响）
bonus bMdefRate,n; | 魔法防御力1+n%（装备影响）
bonus bMdef2Rate,n; | 魔法防御力2+n%（Int影响）
bonus bHit,n; | 命中率+n
bonus bHitRate,n; | 命中率+n%
bonus bCritical,n; | 爆击率+n
bonus bCriticalRate,n; | 爆击率+n%
bonus bFlee,n; | 回避率+n
bonus bFleeRate,n; | 回避率+n%
bonus bFlee2,n; | 完全回避+n
bonus bFlee2Rate,n; | 完全回避+n%
bonus bSpeedRate,n; | 移动速度=n%
bonus bSpeedAddRate,n; | 移动速度+n%
bonus bAspd,n; | 攻击速度=n
bonus bAspdRate,n; | 攻击速度=n%
bonus bAtkRange,n; | 攻击射程+n（不影响苍鹰之眼）
bonus bMaxWeight,n; | 人物负重增加n（VIP版专用）

·属性固定
bonus bFixDamage,n; | 物理攻击伤害固定为n
bonus bFixMaxHP,n; | 最大HP固定为n
bonus bFixMaxSP,n; | 最大SP固定为n
bonus bFixBaseAtk,n; | 攻击力固定为n
bonus bFixMatk,n; | 魔法攻击力固定为n
bonus bFixDef,n; | 防御力固定为n(装备)
bonus bFixMdef,n; | 魔法防御力固定为n(装备)
bonus bFixHit,n; | 命中率固定为n
bonus bFixCritical,n; | 爆击率固定为n
bonus bFixFlee,n; | 回避率固定为n
bonus bFixAspd,n; | 攻击速度固定为n
bonus bFixSpeed,n; | 移动速度固定为n

·属性赋予
bonus bAtkEle,n; | 给予武器n属性
bonus bDefEle,n; | 给予防具n属性
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死、10-随机

·HP/SP回复/消耗/吸收
bonus bUseSPrate,n; | SP消费量+n%
bonus bHPrecovRate,n; | HP自然回复速度+n%（除去技能效果）
bonus bSPrecovRate,n; | SP自然回复速度+n%（除去技能效果）
bonus bNoRegen,n; | 停止回复HP或SP（n=1:HP、n=2:SP）
bonus bRestartFullRecover,n; | 复活时HP/SP全部恢复（n无意义）
bonus bHPGainValue,n; | 杀死怪物后恢复n点HP
bonus bSPGainValue,n; | 杀死怪物后恢复n点SP
bonus2 bHPRegenRate,n,x; | 每隔 x毫秒恢复n点HP
bonus2 bHPLossRate,n,x; | 每隔 x毫秒消耗n点HP
bonus2 bSPRegenRate,n,x; | 每隔 x毫秒恢复n点SP
bonus2 bSPLossRate,n,x; | 每隔 x毫秒消耗n点SP
bonus2 bAddItemHealRate,n,x; | 使用n类型的物品时，恢复量+x%（也可以直接使用ItemID代替。n类型在item_group_db.txt中定义）
bonus2 bSPVanishRate,n,x; | 物理攻击时n机率（n为千分率）使敌人当前SP减少x%
bonus2 bHPDrainRate,n,x; | 攻击n种族的时候，以x的机率（x为千分率），对敌人造成的伤害吸收到HP中（x可叠加）
bonus2 bSPDrainRate,n,x; | 攻击n种族的时候，以x的机率（x为千分率），对敌人造成的伤害吸收到SP中（x可叠加）
bonus3 bSPDrainRate,n,x,y; | 攻击n种族的时候，以x的机率（x为千分率），对敌人造成的伤害吸收到SP中（x可叠加。y=0:获取SP、y=1吸收敌人的SP）
bonus bHPDrainValue,n; | 攻击时吸收n点HP
bonus bSPDrainValue,n; | 攻击时吸收n点SP
bonus2 bHPDrainValue,n,x; | 攻击时吸收n点HP（x=1:吸收时减少目标的HP、x=0:吸收时不减少目标的HP）
bonus2 bSPDrainValue,n,x; | 攻击时吸收n点SP（x=1:吸收时减少目标的SP、x=0:吸收时不减少目标的SP）
bonus2 bHPDrainValueRace,n,x; | 攻击n种族的时候，吸收x点HP（x可叠加）
bonus2 bSPDrainValueRace,n,x; | 攻击n种族的时候，吸收x点SP（x可叠加）
bonus3 bHPDrainRateRace,n,x,y; | 攻击n种族的时候，以x%的机率，对敌人造成的伤害的y点吸收到HP中（x和y可以叠加）
bonus3 bSPDrainRateRace,n,x,y; | 攻击n种族的时候，以x%的机率，对敌人造成的伤害的y点吸收到SP中（x和y可以叠加）
bonus2 bSPGainRace,n,x; | 物理攻击打倒n种族怪物时，恢复x点SP（n在mob_race2_db.txt中定义）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-全种族

·追加伤害
bonus2 bAddSize,n,x; | 增加对n体型x%的物理攻击伤害
bonus2 bMagicAddSize,n,x; | 增加对n体型x%的魔法攻击伤害
0-小型、1-中型、2-大型
bonus2 bAddRace,n,x; | 增加对n种族x%的物理攻击伤害
bonus2 bMagicAddRace,n,x; | 增加对n种族x%的魔法攻击伤害
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]
bonus2 bAddEle,n,x; | 增加对n属性x%的物理攻击伤害
bonus2 bMagicAddEle,n,x; | 增加对n属性x%的魔法攻击伤害
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死
bonus2 bAddDamageClass,n,x; | 对代码为n的怪物增加x%的物理伤害。对职业代码为n的玩家增加x%的物理伤害。
bonus2 bAddMagicDamageClass,n,x; | 对代码为n的怪物增加x%的魔法伤害。对职业代码为n的玩家增加x%的魔法伤害。
bonus2 bAddDamageByClass,n,x; | 被代码为n的怪物攻击时，增加x%的物理伤害。
bonus2 bAddRace2,n,x; | 对种族n的敌人的伤害增加x%（种族n在mob_race2_db.txt中定义）

·防御无视攻击
bonus bIgnoreDefRace,n; | 无视n种族的物理防御力
bonus bIgnoreMDefRace,n; | 无视n种族的魔法防御力
bonus bDefRatioAtkRace,n; | n种族的物理防御力越高造成的伤害越高（无视防御）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]
bonus bIgnoreDefEle,n; | 无视n属性的物理防御力
bonus bIgnoreMDefEle,n; | 无视n属性的魔法防御力
bonus bDefRatioAtkEle,n; | n属性的物理防御力越高造成的伤害越高（无视防御）
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死
bonus bIgnoreDefMob,n; | 无视怪物n的物理防御力
0-除了BOSS以外的所有普通怪物、1-所有怪物
bonus bIgnoreMdefRate,n; | 忽略目标n%的魔法防御力
bonus2 bIgnoreMdefRate,n,x; | 忽略n种族x%的魔法防御力
bonus2 bIgnoreDefRate,n,x; | 忽略n种族x%的物理防御力
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-全种族

·爆击伤害
*bonus bCritAtkRate,n; | 爆击伤害+n%
bonus2 bCriticalAddRace,n,x; | 攻击n种族时，Cri增加x
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS怪物、11-所有一般怪物

·必中攻击
bonus bPerfectHitRate,n; | 必中攻击率=n%
bonus bPerfectHitAddRate,n; | 必中攻击率+n%

·范围攻击
bonus bSplashRange,n; | 普通攻击对目标周围n格造成伤害（n=1为3*3、n=2为5*5……）
bonus bSplashAddRange,n; | 普通攻击对目标周围增加n格造成伤害

·减少伤害/防御
bonus bCriticalDef,n; | 爆击防御+n%
bonus bNearAtkDef,n; | 减少受到近距离攻击伤害n%（全部，包括物理、魔法、其他攻击）
bonus bLongAtkDef,n; | 减少受到远距离攻击伤害n%（全部，包括物理、魔法、其他攻击）
bonus bMagicAtkDef,n; | 减少受到魔法攻击伤害n%
bonus bMiscAtkDef,n; | 减少受到其他攻击伤害n%（陷阱与猎鹰）
bonus bNoWeaponDamage,n; | 不受到物理攻击伤害（n无意义）
bonus bNoMagicDamage,n; | 不受到魔法攻击伤害，包括治愈术（n无意义）
bonus bNoMiscDamage,n; | 不受到其他攻击伤害（n无意义）
bonus2 bSubSize,n,x; | 减少受到n体型x%的物理攻击伤害
0-小型、1-中型、2-大型
bonus2 bSubRace,n,x; | 减少受到n种族x%的物理攻击伤害
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]
bonus2 bSubEle,n,x; | 减少受到n属性x%的物理攻击伤害
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死
bonus2 bAddDefClass,n,x; | 减少代码为n的怪物x%的物理伤害。减少职业代码为n的玩家x%的物理伤害。
bonus2 bAddMDefClass,n,x; | 减少代码为n的怪物x%的魔法伤害。减少职业代码为n的玩家x%的魔法伤害。
bonus2 bSubRace2,n,x; | 受到n种族攻击时，减少x%的伤害（n在mob_race2_db.txt中定义）

·伤害反射
bonus bShortWeaponDamageReturn,n; | 反射n%受到的近距离物理伤害给敌人（伤害不减少）
bonus bLongWeaponDamageReturn,n; | 反射n%受到的远距离物理伤害给敌人（伤害不减少）
bonus bMagicDamageReturn,n; | 反射n%受到的魔法伤害给敌人（伤害不减少）

·技能相关
skill n,x; | 学会/删除人物技能n（等级x）
bonus bCastrate,n; | 咏唱时间+n%
bonus2 bCastrate,n,x; | 技能n的咏唱时间+n%（技能支持使用名字做参数）
bonus bDoubleRate,n; | 连击发动率=n%（无视武器）
bonus bDoubleAddRate,n; | 连击发动率+n%（无视武器）
bonus bNoCastCancel,n; | 咏唱魔法时不会因受到攻击而中断（GVG、竞速场地会失败。n无意义）
bonus bNoCastCancel2,n; | 咏唱魔法时不会因受到攻击而中断（GVG、竞速场地不会失败。n无意义）
bonus bNoGemStone,n; | 使用技能时不消耗魔力矿石（n无意义）
bonus bIntravision,n; | 总是看到伪装和隐身（n无意义）
bonus2 bSkillAtk,n,x; | 技能n增加x%的伤害（n可以是技能名字）
bonus2 bSkillHeal,n,x; | 技能n的回复量对自己增加x%（n可以是技能名字）
bonus2 bSkillHeal2,n,x; | 技能n的回复量对目标增加x%（n可以是技能名字）
bonus bAddStealRate,n; | 偷窃率+n（n为万分率）
bonus2 bAddSkillBlow,n,x; | 技能n有x格吹飞效果（n可以指定技能名字）
bonus bDelayrate,n; | 技能延迟率+n%

·自动念咒
bonus3 bAutoSpell,n,x,y; | 攻击时，自动念咒以y机率对敌人使用x等级的技能n（y为千分率）
bonus4 bAutoSpell,x,y,n,i; | 攻击时，自动念咒以n机率发动y等级的技能x（可指定技能名字，n为千分率） <i>列表： 0:对自己发动 +1:对敌人发动 +2:使用随机技能等级（1~y）
bonus5 bAutoSpell,x,y,n,t,i; | 攻击时，自动念咒以n机率发动y等级的技能x（可指定技能名字，n为千分率） <t>为发动条件（可复数）： BF_SHORT 近距离攻击 BF_LONG 远距离攻击 （默认：BF_SHORT+BF_LONG） BF_WEAPON 物理攻击 BF_MAGIC 魔法攻击 BF_MISC 其他攻击 （默认：BF_WEAPON） BF_NORMAL 普通攻击 BF_SKILL 技能攻击 （默认：如果是BF_MISC或BF_MAGIC，则为BF_SKILL；如果是BF_WEAPON，则为BF_NORMAL） <i>列表： 0:对自己发动 +1:对敌人发动 +2:使用随机技能等级（1~y）
bonus3 bAutoSpellWhenHit,x,y,n; | 被击中时，有n机率自动念咒发动y级的技能x（n为千分率）
bonus4 bAutoSpellWhenHit,x,y,n,i; | 被击中时，n机率发动y等级的技能x（可指定技能名字，n为千分率） <i>列表： 0:对自己发动 +1:对敌人发动 +2:使用随机技能等级（1~y）
bonus5 bAutoSpellWhenHit,x,y,n,t,i; | 被击中时，n机率发动y等级的技能x（可指定技能名字，n为千分率） <t>为发动条件（可复数）： BF_SHORT 近距离攻击 BF_LONG 远距离攻击 （默认：BF_SHORT+BF_LONG） BF_WEAPON 物理攻击 BF_MAGIC 魔法攻击 BF_MISC 其他攻击 （默认：BF_WEAPON） BF_NORMAL 普通攻击 BF_SKILL 技能攻击 （默认：如果是BF_MISC或BF_MAGIC，则为BF_SKILL；如果是BF_WEAPON，则为BF_NORMAL） <i>列表： 0:对自己发动 +1:对敌人发动 +2:使用随机技能等级（1~y）
bonus4 bAutoSpellOnSkill,n,x,y,z; | 当使用n技能时，有z机率发动y等级的x技能（z为千分率）
bonus5 bAutoSpellOnSkill,n,x,y,z,i; | 当使用n技能时，有z机率发动y等级的x技能（z为千分率） <i>列表： 当i&1时，技能id为-x，否则为x 当i&2时，技能lv为-y，否则为y（技能等级<0时，为1~y的随机等级）

·装备相关

bonus bUnstripableWeapon,n; | 不能使用卸除装备技能来卸除武器（n无意义）
bonus bUnstripableArmor,n;
或
bonus bUnstripable,n; 		不能使用卸除装备技能来卸除铠甲（n无意义）
bonus bUnstripableHelm,n; | 不能使用卸除装备技能来卸除头盔（n无意义）
bonus bUnstripableShield,n; | 不能使用卸除装备技能来卸除盾牌（n无意义）
bonus bUnbreakable,n; | 减少装备损坏率n%
bonus bUnbreakableWeapon,n; | 武器绝对不会被破坏（n无意义）
bonus bUnbreakableArmor,n; | 铠甲绝对不会被破坏（n无意义）
bonus bUnbreakableHelm,n; | 头具绝对不会被破坏（n无意义）
bonus bUnbreakableShield,n; | 盾牌绝对不会被破坏（n无意义）
bonus bBreakWeaponRate,n; | 以n机率破坏玩家的武器（n为万分率，机率可叠加）
bonus bBreakArmorRate,n; | 以n机率破坏玩家的铠甲（n为万分率，机率可叠加）

·状态异常
bonus2 bAddEff,e,n; | 以n机率造成目标e状态（n为万分率）
bonus3 bAddEff,e,x,y; | 以 x机率造成 目标e状态（n为万分率） <y>条件： ATF_SELF 效果在自己身上 ATF_TARGET 效果在目标身上（默认） ATF_SHORT 只对近距离攻击有效 ATF_LONG 只对远距离攻击有效（默认：近距离+远距离）
bonus2 bAddEffWhenHit,n,e; | 物理攻击并击中时，以n机率造成敌人e状态（n为万分率）
bonus3 bAddEffWhenHit,n,x,y; | 物理攻击并击中时，以n机率造成目标e状态（n为万分率） <y>条件： ATF_SELF 效果在自己身上 ATF_TARGET 效果在目标身上（默认） ATF_SHORT 只对近距离攻击有效 ATF_LONG 只对远距离攻击有效（默认：近距离+远距离）
bonus2 bResEff,e,n; | e状态的耐久度+n（n为万分率）
bonus3 bAddEffOnSkill,n,x,y; | 在使用n技能时，有y机率造成异常状态x（n技能可以指定技能名字。y为万分率）
bonus4 bAddEffOnSkill,n,x,y,z; | 在使用n技能时，有y机率造成目标z的异常状态x（n技能可以指定技能名字。y为万分率） <z>目标定义如下： +1 自己 +2 目标
Eff_Blind - 黑暗 Eff_Sleep - 睡眠 Eff_Poison - 中毒 Eff_Freeze - 冰冻 Eff_Silence - 沉默 Eff_Stun - 昏眩 Eff_Curse - 诅咒 Eff_Confusion - 混乱 Eff_Stone - 石化 Eff_Bleed - 出血

·即死/濒死
bonus2 bWeaponComaEle,n,x; | 对n属性以x机率发动濒死之术[HP=1,SP=1]（x为万分率，可叠加）
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死
bonus2 bWeaponComaRace,n,x; | 对n种族以x机率发动濒死之术[HP=1,SP=1]（x为万分率，可叠加）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]

·Zeny获得
bonus2 bGetZenyNum,n,x; | 物理攻击打倒怪物得到怪物 时，有x%机率取得1~n的Zeny（如果n<0，能获得的最大zeny为-n*lv）
bonus2 bAddGetZenyNum,n,x; | 物理攻击打倒怪物得到怪物时，有x%机率取得1~n的Zeny（如果n<0，能获得的最大zeny为-n*lv）（可叠加）

·物品获得
bonus2 bAddMonsterDropItem,n,x; | 物理攻击打倒怪物时，有x机率掉落物品n（x为万分率，与怪物掉落物品无关系）
bonus3 bAddMonsterDropItem,n,x,y; | 物理攻击打倒x种族的怪物，有y机率掉落物品n（y为万分率，与怪物掉落物品无关系）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]
bonus2 bAddMonsterDropItemGroup,n,x; | 杀死怪物时，有x机率获得组n的物品（组n在item_group_db.txt中定义。x为万分率，与怪物掉落物品无关系 。当x为负值时，机率=-x*(怪物等级/10)+1）
bonus3 bAddMonsterDropItemGroup,n,x,y; | 杀死x 种族的怪物 时，有y机率掉落组n的物品（组n在item_group_db.txt中定义。y为万分率，与怪物掉落物品无关系 。当y为负值时，机率=-y*(怪物等级/10)+1） 0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]

·追加经验值

bonus2 bExpAddRace,n,x; 杀死n种族怪物时，增加x%的Base经验（可叠加）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-全种族

·其他
bonus bNoSizeFix,n; | 不受到怪物体型的伤害修正（n无意义）
bonus bPerfectHide,n; | 叶隐（n无意义）
bonus bClassChange,n; | 攻击时以n机率把当前怪物变为其他怪物（n为万分率）
bonus2 bRandomAttackIncrease,n,x; | x%机率增加攻击系数n（比如狂击技能，增加的攻击系数为30*skill_lv，就是Lv1的时候攻击力是130%。此bonus效果只对非技能有效）

·无视敌人的bonus效果
bonus bDisregardCriticalDef,n; | 无视目标玩家的bCriticalDef效果（n无意义）
bonus bDisregardNearAtkDef,n; | 无视目标玩家的bNearAtkDef效果（n无意义）
bonus bDisregardLongAtkDef,n; | 无视目标玩家的bLongAtkDef效果（n无意义）
bonus bDisregardMagicAtkDef,n; | 无视目标玩家的bMagicAtkDef效果（n无意义）
bonus bDisregardMiscAtkDef,n; | 无视目标玩家的bMiscAtkDef效果（n无意义）
bonus bDisregardNoWeaponDamage,n; | 无视目标玩家的bNoWeaponDamage效果（n无意义）
bonus bDisregardNoMagicDamage,n; | 无视目标玩家的bNoMagicDamage效果（n无意义）
bonus bDisregardNoMiscDamage,n; | 无视目标玩家的bNoMiscDamage效果（n无意义）
bonus bDisregardSubSize,n; | 无视目标玩家的bSubSize效果（n无意义）
bonus bDisregardSubRace,n; | 无视目标玩家的bSubRace效果（n无意义）
bonus bDisregardSubRace2,n; | 无视目标玩家的bSubRace2效果（n无意义）
bonus bDisregardSubEle,n; | 无视目标玩家的bSubEle效果（n无意义）
bonus bDisregardAddDefClass,n; | 无视目标玩家的bAddDefClass效果（n无意义）
bonus bDisregardAddMdefClass,n; | 无视目标玩家的bAddMdefClass效果（n无意义）


事件/特殊标签一览表

事件/特殊标签 格式 说明
OnInit OnInit: 当脚本加载后执行（包括reload）
OnInterIfInit OnInterIfInit: Map连接到Char服务器时执行的事件
OnInterIfInitOnce OnInterIfInitOnce: Map连接到Char服务器时执行的事件 （只执行一次，Map重连到Char服务器时不执行）
OnSecond OnSecondSS: 每分钟的SS秒执行的事件
OnMinute OnMinuteMM: 每小时的MM分钟执行的事件
OnClock OnClockHHMM: 每天的HH时MM分执行的事件
OnHour OnHourHH: 每天的HH时执行的事件
OnWeekTime或On OnWeekTimeDDHHMM:或OnDDHHMM: 星期DD（00-日、01-一…06-六）的HH时MM分执行的事件
OnDateTime OnDateTimeMMDDHHMM: MM月DD日HH时MM分执行的事件
OnDayTime OnDayTimeDDHHMM: DD日HH时MM分执行的事件
OnDay OnDayMMDD: MM月DD日执行的事件
OnTimer OnTimerX: NPC计时器经过X毫秒时执行的事件
OnAgitInit OnAgitInit: 在服务器请求公会城堡的相关信息时执行的事件。用于初始化与公会城堡相关的NPC。
OnAgitStart OnAgitStart: 公会战开始时执行的事件
OnAgitEnd OnAgitEnd: 公会战结束时执行的事件
OnAgitStart2 OnAgitStart2: 公会战SE开始时执行的事件
OnAgitEnd2 OnAgitEnd2: 公会战SE结束时执行的事件
OnAgitInit2 OnAgitInit2: 在服务器请求公会城堡SE的相关信息时执行的事件。用于初始化与公会城堡SE相关的NPC。
OnTouch OnTouch: 进入范围NPC的有效范围内时执行的事件。设置OnTouch的NPC名字必须在服务器内唯一。
OnPCDieEvent OnPCDieEvent: 人物死亡时执行的事件。死亡玩家的PC_DIE_COUNTER会增加1；并且会把杀人者（不限于PC）的unit_id放在killerrid变量中。
OnPCKillEvent OnPCKillEvent: 玩家PK时，杀人者执行的事件。并且把被杀者的unit_id放在killedrid变量中。
OnPCMoveMap OnPCMoveMap: 玩家过图时执行的事件
OnPCLoginEvent OnPCLoginEvent: 玩家登陆时执行的事件
OnPCLogoutEvent OnPCLogoutEvent: 玩家登出时执行的事件
OnPCBaseLvUpEvent OnPCBaseLvUpEvent: 人物Base等级提升时执行的事件
OnPCJobLvUpEvent OnPCJobLvUpEvent: 人物Job等级提升时执行的事件
OnNPCKillEvent OnNPCKillEvent: 人物杀死怪物时执行的事件
OnPCLoadMapEvent OnPCLoadMapEvent: 当人物踏入地图时并且mapflag包含loadevent时执行的事件。
On On<事件名>: 这种用法主要用于怪物死亡事件。例如：

monster "prontera",123,42,"Poringz0rd",2341,23,"Master::OnThisMobDeath";

amatsu,13,152,4 script Master 767,{
mes "Hi there";
close;

OnThisMobDeath:
announce "Hey, "+strcharinfo(0)+" just killed a Poringz0rd!",bc_blue|bc_all;
end;
}

当每次杀死Poringz0rd怪物时，就会自动执行公告。

OnPCSave OnPCSave: 自动储存人物数据时执行的事件
OnPCAfterWeaponAtk OnPCAfterWeaponAtk: 人物进行物理攻击后执行的事件
OnPCAfterMagicAtk OnPCAfterMagicAtk: 人物进行魔法攻击后执行的事件
OnPCAfterMiscAtk OnPCAfterMiscAtk: 人物进行其他攻击后执行的事件


脚本基础知识

1、坐标系

↑Y的增加
(0,200)--(200,200)
| |
| |
| |
| |
| |
(0, 0)--(200, 0)→X的增加

坐标从左下开始，向右上递增

2、NPC的定义

NPC类型： | 传送点
作用： | 把人物从一个坐标传送到另一个坐标
格式： | <gatname>,<x>,<y><tab>warp<tab><displayname><tab><dx>,<dy>,<destination_gatname>,<destination_x>,<destination_y>
说明： | <gatname> -- 原地图名（不要忘记加上.gat） <x>,<y> -- 原地图坐标 <displayname> -- NPC名字（DEBUG用） <dx>,<dy> -- 传送点x,y轴的影响范围 dx,dy举例（●表示x,y的位置）： 0,0 1,0 2,2 ＊ ＊＊＊＊＊ ＊＊＊＊＊＊＊ ＊●＊ ＊＊●＊＊ ＊＊＊＊＊＊＊ ＊ ＊＊＊＊＊ ＊＊＊＊＊＊＊ ＊＊＊●＊＊＊ ＊＊＊＊＊＊＊ ＊＊＊＊＊＊＊ ＊＊＊＊＊＊＊ <destination_gatname> -- 目标地图名（.gat可有可无） <destination_x>,<destination_y> -- 目标地图坐标
注意事项： | 如果在同一位置放置了多个传送点，则只有最后一个生效。 如果目标坐标是不可到达的坐标，则自动进行目标地图内的随机传送。

NPC类型： | 怪物
作用： | 使地图中出现怪物
格式： | <gatname>,<x>,<y>,<xs>,<ys><tab>monster<tab><displayname><tab><npcid>,<number>,<spawn_delay1>,<spawn_delay2>[,<event>] <gatname>,<x>,<y>,<xs>,<ys><tab>monster_big<tab><displayname><tab><npcid>,<number>,<spawn_delay1>,<spawn_delay2>[,<event>]（刷出大型化的怪物。VIP版专用） <gatname>,<x>,<y>,<xs>,<ys><tab>monster_small<tab><displayname><tab><npcid>,<number>,<spawn_delay1>,<spawn_delay2>[,<event>]（刷出小型化的怪物。VIP版专用）
说明： | <gatname> -- 地图名 <x>,<y> -- 坐标 <xs>,<ys> -- 怪物出现的x,y轴的范围 xs,ys举例（●表示x,y的位置）： 0,0 2,1 ● ＊＊＊＊＊ ＊＊●＊＊ ＊＊＊＊＊ <displayname> -- 显示怪物的名字 <npcid> -- 怪物ID（请参考mob_db.txt） <number> -- 怪物数量 <spawn_delay1> -- 刷新后多少毫秒再次刷新 <spawn_delay2> -- 死亡后多少毫秒再次刷新 <event> -- 怪物死亡后执行的事件（省略时填0）
注意事项： | 根据<spawn_delay1>和<spawn_delay2>的数值，优先选择刷新较慢的那个。

NPC类型： | 商店/现金店
作用： | 出售物品
格式： | <gatname>,<x>,<y>,<direction><tab>shop/cashshop<tab><displayname><tab><npcid>,<item_id1>:<price1>[,<item_id2>:<price2>...]
说明： | <gatname> -- 地图名 <x>,<y> -- 坐标 <direction> -- 商店的方向 <direction> 的详情： １０７ ２ ６ ３４５ <displayname> -- 商店名字 <npcid> -- 商店的外观 <item_id?> -- 商品的物品ID（请参考item_db.txt） <price/> -- 商品价格
注意事项： | <item_id>:<price>可用,分割指定多个物品。 当「<gatname>,<x>,<y>,<direction><tab>」部分为「-<tab>」的时候，可作为复制源。

NPC类型： | 复制店
作用： | 复制已存在的商店
格式： | <gatname>,<x>,<y>,<direction><tab>substore(<source>)<tab><displayname><tab><npcid>
说明： | <source>以外的参数和商店一样。 <source>为要复制的商店的名字。 如果是复制没有指定地图的商店，则可用于任意地图。否则只能复制同地图名字的商店。

NPC类型： | NPC
作用： | 制作NPC
格式： | <gatname>,<x>,<y>,<direction><tab>script<tab><displayname><tab><npcid>,[<xs>,<ys>,]{ <script> ... }
说明： | <gatname> -- 地图名 <x>,<y> -- 坐标 <direction> -- NPC方向 <direction> 的详情： １０７ ２ ６ ３４５ <displayname> -- NPC名字。如果<npcid>为-1则为事件名。 <npcid> -- NPC的外观。如果是-1则表示地图内的事件。 <xs>,<ys> -- 触发NPC的x,y轴的范围。 {}（大括号内）包含NPC的所有代码。 不推荐集中在一行内编写代码，建议写成这样： gatname等, { //注释 script; label: script; } 单行注释请用//，多行注释请用/*,*/ 「<gatname>,<x>,<y>,<direction><tab>」部分改为「-<tab>」的 时候，可作为复制源。

NPC类型： | 复制NPC
作用： | 复制已存在的NPC
格式： | <gatname>,<x>,<y>,<direction><tab>duplicate(<source>)<tab><displayname><tab><npcid>,<xs>,<ys>
说明： | <source>以外的参数和脚本一样。 <source>为要复制的NPC的名字。 如果是复制没有指定地图的NPC，则可用于任意地图。否则只能复制同地图名字的NPC。

NPC类型： | 全局函数
作用： | 制作由脚本调用的用户自定义函数
格式： | function<tab>script<tab><name><tab>{ <script> ... }
说明： | <name> -- 函数名字 制作一个可用callfunc命令调用的函数。函数的参数可以用getarg函数获得。从函数中返回请使用return命令。

NPC类型： mapflag
作用： 设置地图标识
格式： <gatname><tab>mapflag<tab><const>
说明： <gatname> -- 地图名字
<const> -- 要设置的规则
<const>一览表：
nosave<tab><gatname>,<x>,<y> | 重新登陆时，移动到<gatname>地图的(x,y)坐标。 如果是"nosave SavePoint"的话，则移动到人物的储存点。
nomemo<tab>dummy | 禁止记忆（禁止使用/nomemo）
noteleport<tab>dummy | 禁止使用指定了SavePoint或Random的warp段、传送之阵和瞬移
noportal<tab>dummy | 禁止传送之阵（battle_athena.conf的noportal_flag为1时有效）
noreturn<tab>dummy | 禁止warp命令SavePoint回城，并且禁止使用蝴蝶翅膀
nobranch<tab>dummy | 禁止召怪
nopenalty<tab>dummy | 禁止任何处罚
nozenypenalty<tab>dummy | 死亡时不掉钱
notrade<tab>dummy | 禁止玩家间交易
norevive<tab>dummy | 死亡时强制传送到储存点
noskill<tab><skill_id1>:<skill_id2>:<skill_id3>... | 禁止使用<skill_id>技能
noskillall<tab>dummy | 禁止使用所有技能
nodrop<tab>dummy | 怪物死亡后不掉落物品
noabra<tab>dummy | 禁止使用随机技能
noicewall<tab>dummy | 禁止使用冰墙
snow<tab>dummy | 下雪
fog<tab>dummy | 雾
sakura<tab>dummy | 樱花
leaves<tab>dummy | 落叶
rain<tab>dummy | 下雨
base_exp_rate<tab><rate> | 设置Base经验倍率（优先于battle_athena.conf）
job_exp_rate<tab><rate> | 设置Job经验倍率（优先于battle_athena.conf）
monster_noteleport<tab>dummy | 禁止怪物使用瞬移
pvp<tab>dummy | 变成PVP地图
pvp_noparty<tab>dummy | 变成PVP地图（不可攻击同队玩家）
pvp_noguild<tab>dummy | 变成PVP地图（不可攻击同公会玩家）
pvp_nightmaredrop<tab><drop_id>,<drop_type>,<drop_per> | 变成PVP地图（梦魇模式） <drop_id>--掉落物品ID。如果为random则表示随机掉落物品（random区分大小写） <drop_type>--掉落物品类型。inventory表示随身物品、equip表示装备、all表示以上类型均有可能（注意区分大小写） <drop_per>--掉率（万分率）
pvp_nocalcrank<tab>dummy | 变成PVP地图（不计算PVP点数和排行榜）
gvg<tab>dummy | 变成GVG地图
gvg_noparty<tab>dummy | 变成GVG地图（不可攻击同队玩家）
pk<rab>dummy | 变成PK地图
pk_noparty<tab>dummy | 变成PK地图（不可攻击同队玩家）
pk_noguild<tab>dummy | 变成PK地图（不可攻击同公会玩家）
pk_nightmaredrop<tab><drop_id>,<drop_type>,<drop_per> | 变成PK地图（梦魇模式） <drop_id>--掉落物品ID。如果为random则表示随机掉落物品（random区分大小写） <drop_type>--掉落物品类型。inventory表示随身物品、equip表示装备、all表示以上类型均有可能（注意区分大小写） <drop_per>--掉率（万分率）
pk_nocalcrank<tab>dummy | 变成PK地图（不计算PK点数和排行榜）
turbo<tab>dummy | 变为竞速模式
noitem<tab><item_id1>:<item_id2>:<item_id3>... | 禁止使用某个物品
noitemall<tab>dummy | 禁止使用所有物品
no_char_pvp<tab>dummy | 禁止玩家使用#pvpon/#pvpoff（VIP版专用）
no_disguise<tab>dummy | 禁止玩家使用#disguise/#undisguise
nodropitem<tab>dummy | 禁止玩家丢弃物品
no_create_party<tab>dummy | 禁止创建队伍
no_invite_party<tab>dummy | 禁止邀请玩家加入队伍
no_leave_party<tab>dummy | 禁止玩家离开队伍
potion_drop_rate<tab><rate> | 设置恢复品掉率
expend_drop_rate<tab><rate> | 设置消耗品掉率
refine_drop_rate<tab><rate> | 设置精炼材料掉率
etc_drop_rate<tab><rate> | 设置收集品掉率
weapon_drop_rate<tab><rate> | 设置武器掉率
equip_drop_rate<tab><rate> | 设置防具掉率
card_drop_rate<tab><rate> | 设置卡片掉率
petequip_drop_rate<tab><rate> | 设置宠物装备掉率
arrow_drop_rate<tab><rate> | 设置箭矢掉率
other_drop_rate<tab><rate> | 设置其他物品掉率
noequip<tab><equip_id1>:<equip_id2>:<equip_id3>... | 设定地图上不能装备的物品，如果有装备上，则自动卸下
nocard<tab><card_id1>:<card_id2>:<card_id3>... | 设定地图上不能装备插有指定卡片的物品，如果有装备上，则自动卸下
gvg_cannot_see_hide<tab>dummy | 设定地图不能利用GM模式看到隐身（但狂暴蚁后卡等等仍然效果正常）
gvg_cannot_see_damage<tab>dummy | 设定地图不能看到伤害值（包括GM模式）
show_mob_hp<tab><type> | 设定地图显示怪物HP，type为1则用HP/MaxHP显示，type为2则用%显示（show_mob_hp、no_show_mob_hp的mapflag优先于battle_athena.conf的show_mob_hp开关。当show_mob_hp、no_show_mob_hp同时存在时，则以show_mob_hp为优先）
no_show_mob_hp<tab>dummy | 设定地图不显示怪物HP（show_mob_hp、no_show_mob_hp的mapflag优先于battle_athena.conf的show_mob_hp开关。当show_mob_hp、no_show_mob_hp同时存在时，则以show_mob_hp为优先）
autoloot<tab><value> | 设定本地图内是否自动捡物。 当<value>=1时，本地图强制自动捡物。 当<value>=2时，本地图强制不自动捡物。
no_called<tab>dummy | 设定本地图的人物不能被技能召唤
no_follow<tab>dummy | 设定本地图无法跟随（注意：双方只要其中一方的地图的no_follow生效，就无法跟随。）
Mob_Collision_Detection<tab><value> | 启用怪物碰撞检测系统。 当<value>=1时，怪物不会重叠到一个点上，但是那个点可以通行。 当<value>=2时，怪物不会重叠到一个点上，而且那个点也不能通行。
gvg_no_alliance<tab>dummy | 设置GVG时不能同盟（能打到同盟）
mob_noskillall<tab>dummy | 禁止怪物使用所有技能
mob_noskill<tab><skill_id1>:<skill_id2>:<skill_id3>... | 禁止怪物使用某些技能

3、关于NPC的一些注意事项

3.1

Jathena++以NPC的标识名来区别NPC，而不是显示名。
如果省略了子名字的话，则使用显示名来代表识别名。
在显示名后加上#表示子名字的话，则子名字不会显示出来。

举例：
<displayname> | <显示名> | <标识名>
Ａ | Ａ | Ａ
Ａ::Ｂ | Ａ | Ｂ
Ａ#dummy | Ａ | Ａ#dummy

3.2

单行注释请使用//，（多行）文本注释注释请使用/* */。
服务端在解释脚本时，会忽略多余的空格、TAB、换行符。

下面举一些例子：

１．超出NPC范围的文字是错误的
prontera.gat,132,150,4 script Test1 120,{
end;
}
set @hoge,1; ← ×

２．注释OK
// 注释
prontera.gat,132,151,4 script Test2 121,{
end;
} /* 注释区域 */

３．可以使用以下多行注释
/* prontera.gat,132,152,4 script Test3 122,{
end;
} */

4、脚本说明和基本规则

＊数字
可使用有符号数和16进制数。
有符号数可请使用半角的数字，如123456等。
16进制数要以0x开头，例如0x12。

＊字符串
字符的表示要用""包含在其中。
如果要显示"字符，请使用\"代替。
如果要显示\字符，请使用\\代替。
字符串中也可以用^000000等显示颜色。
也可以使用：变量 + "字符串"这样的形式组合。

＊单目运算符
以下运算符仅需要一个操作数即可。
- 符号取反
~ 按位取反
! 逻辑非

＊双目运算符
以下运算符需要两个操作数。
+ 加法/字符串连接
既可以当作加法运算，也可以当作连接字符串符号。

- 减法
* 乘法
/ 除法
% 取模（余数）
& 按位与
| 按位或
^ 异或
&& 逻辑与
|| 逻辑或
>> 向右移位
<< 向左移位

以下双目运算符在关系成立时返回1，否则返回0。
== 等于
!= 不等于
> 大于
>= 大于等于
< 小于
<= 小于等于

＊三目运算符
?: 唯一一个三目运算符

举例：<cond> ? <ture> : <false>
如果<cond>为真，则返回<ture>部分，否则返回<false>部分。

＊变量
必须使用半角字符表示变量的前缀、后缀。
变量的生存期看前缀而定。

前缀 | 作用范围 | 生存期
(无前缀) | 人物 | 永久
@ | 人物 | 人物在线时
$ | Map服务器 | 永久
$@ | Map服务器 | 同一次Map服务器运行时
# | 帐号（个人） | 永久
## | 帐号（全服） | 永久
' | 单个NPC | 同一次Map服务器运行时
'@ | 单个NPC+人物 | 同一次NPC触发时

简单来说，临时变量带有@、服务器变量带有$、帐号变量带有#。

'表示NPC变量。
同名的NPC变量，在NPC之间不会发生冲突；而且是跟玩家触发没有关系的（就是多个玩家共用一个'变量）。

'变量依赖于NPC，即使NPC结束后，其值也会被保存（Map服务器重启时才消失）。
虽然使用callfunc函数时，其参数不会影响到其他NPC变量；但是如果配合getarg()函数的话，仍然可以操作传递的参数（参数是以引用传递的）。举例：

function script func1 {
set 'var1, 'var1 + 1;
// func1::'var1 加１
set getarg(0),
getarg(0) + 1;
// func2::'var1 加１
}
function script
func2 {
callfunc "func1",
'var1;
}

'@变量是函数固有的变量，使用callfunc、callsub时，会重新分配内存空间给变量，return时则使分配的变量超出范围。
简单来说，就像是C语言的临时变量一样，还可以使用递归处理。当然，这种变量也可以使用getarg()函数操作。举例：

function script func3 {
set '@n, rand(5);
if( '@n == 0 ) {
return;
}
else {
// '@n 变量和其他变量不同，调用callfunc时变量的范围不同，
// 所以不会出现mes的结果全部为０的现象。
callfunc "func3";
}
mes '@n;
return;
}

此外，函数类型由后缀决定。
但是，字符串类型只适用于人物临时变量、NPC变量、临时/永久的服务器变量。（前缀为@、$、$@的）

后缀 | 类型
（无后缀） | 数值类型
$ | 字符串类型

<例> @hoge$ 字符串类型人物临时变量
hoge 数值类型人物永久变量
$hoge 数值类型服务器永久变量

不要过多的使用永久变量。
不需要时马上设置为0进行删除。
认真思考是否需用用到永久变量。
特别时人物/帐号变量是有数量限制的。

＊数组变量
变量名后紧跟[]则表示数组变量。
注意变量名与“[”之间不能留空。
也可以使用多维数组，维数没有限制。

<例> hoge[10] fuga[ @temp ] foo[5][@i][3]

数组元素的索引从0-127。索引为0时表示和同名变量。
比如说，hoge[0]和hoge是相同的变量。
同样的，fuga[0][1]和fuga[1]是相同的变量。
（但是要注意，foo[1][0][2]和foo[1][2]是不同的变量。）

数组变量可储存人物变量、服务器变量、NPC变量。数值类型或字符串类型均可。

＊标签
标签名是以（半角的）字母或_开头、并且可包含数字的单词组成。
例如 L_hoge:。
用if或menu指令时可跳转到该标签。

＊Const属性
Athena的db/const.txt给出了这些Const属性。
只有在脚本内才可以使用。

＊表达式
在指令的参数为数值类型时使用。
不需要空格，为了便于阅读时也可以加上空格。
表达式为真时返回1，否则返回0。

＊事件
没有固定格式的脚本。
可用于制作与时间相关的脚本。
在调用时指定为“事件名::标签”的话，则从事件中指定的标签开始执行脚本。

＊命令语法
参数请用半角的空格来分割。
函数必须带()。如果是没有参数的函数，括号内不能带任何东西（包括0）。例如：checkcart()
命令必须在最后加上;。


Bonus效果一览表

bAddDamageClass、bAddMagicDamageClass、bAddMonsterDropItem 只能设定10个。超过10个的都被无视。
bAutoSpell,bAutoSelfSpell,bRevAutoSpell,bRevAutoSelfSpell 只能设定16个。超过16个的都被无视。

箭矢能使用的效果只有 bCritical、bAtkEle、bHit、bAtkRange、bAddEle、bAddRace、bAddEnemy, bAddSize、bAddEff，其他都被无视

·人物属性操作
bonus bStr,n; | STR+n
bonus bAgi,n; | AGI+n
bonus bVit,n; | VIT+n
bonus bInt,n; | INT+n
bonus bDex,n; | DEX+n
bonus bLuk,n; | LUK+n
bonus bMaxHP,n; | HP上限+n
bonus bMaxSP,n; | SP上限+n
bonus bMaxHPrate,n; | HP上限+n%
bonus bMaxSPrate,n; | SP上限+n%
bonus bAtk,n; | 物理攻击力+n（武器的Atk增加）
bonus bAtk2,n; | 物理攻击力2+n（武器精炼度增加）
bonus bAtkRate,n; | 物理攻击力+n%（伤害乘法）
bonus2 bWeaponAtk,n,x; | 装备类型n的武器时，攻击力+x（武器的BaseAtk增加）
bonus2 bWeaponAtkRate,n,x; | 装备类型n的武器时，攻击力+x%（伤害乘法）
0-空手、1-短剑、2-单手剑、3-双手剑、4-单手矛、5-双手矛、6-单手斧、7-双手斧、8-单手钝器、9-双手钝器、10-杖、11-弓、12-拳套、13-乐器、14-鞭子、15-书类、16-拳刃
bonus bBaseAtk,n; | 基本攻击力+n（BaseAtk增加）
bonus bMatk,n; | 魔法攻击力1+n、魔法攻击力2+n
bonus bMatk1,n; | 魔法攻击力1+n
bonus bMatk2,n; | 魔法攻击力2+n
bonus bMatkRate,n; | 魔法攻击力+n%（伤害乘法）
bonus bDef,n; | 物理防御力+n
bonus bDefRate,n; | 物理防御力+n%（装备影响）
bonus bDef2Rate,n; | 物理防御力+n%（Vit影响）
bonus bMdef,n; | 魔法防御力1+n（装备影响）
bonus bMdef2,n; | 魔法防御力2+n（Int影响）
bonus bMdefRate,n; | 魔法防御力1+n%（装备影响）
bonus bMdef2Rate,n; | 魔法防御力2+n%（Int影响）
bonus bHit,n; | 命中率+n
bonus bHitRate,n; | 命中率+n%
bonus bCritical,n; | 爆击率+n
bonus bCriticalRate,n; | 爆击率+n%
bonus bFlee,n; | 回避率+n
bonus bFleeRate,n; | 回避率+n%
bonus bFlee2,n; | 完全回避+n
bonus bFlee2Rate,n; | 完全回避+n%
bonus bAspd,n; | 攻击速度=n
bonus bAspdRate,n; | 攻击速度=n%
bonus bAspdAddRate,n; | 攻击速度+n%
bonus bAddSpeed,n; | 移动速度=n
bonus bSpeedRate,n; | 移动速度=n%
bonus bSpeedAddRate,n; | 移动速度+n%
bonus bAtkRange,n; | 攻击射程+n（不影响苍鹰之眼）
bonus bAtkRangeRate,n; | 攻击射程=n%（不影响苍鹰之眼）
bonus bAtkRange2,n; | 攻击射程+n（影响苍鹰之眼）
bonus bAtkRangeRate2,n; | 攻击射程=n%（影响苍鹰之眼）
bonus bRace,n; | 变成n种族
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族
bonus bMaxWeight,n; | 人物负重增加n（VIP版专用）

·属性固定
bonus bFixDamage,n; | 物理攻击伤害固定为n
bonus bFixMaxHP,n; | 最大HP固定为n
bonus bFixMaxSP,n; | 最大SP固定为n
bonus bFixBaseAtk,n; | 攻击力固定为n
bonus bFixMatk,n; | 魔法攻击力固定为n
bonus bFixDef,n; | 防御力固定为n(装备)
bonus bFixMdef,n; | 魔法防御力固定为n(装备)
bonus bFixHit,n; | 命中率固定为n
bonus bFixCritical,n; | 爆击率固定为n
bonus bFixFlee,n; | 回避率固定为n
bonus bFixAspd,n; | 攻击速度固定为n
bonus bFixSpeed,n; | 移动速度固定为n

·属性赋予
bonus bAtkEle,n; | 给予武器n属性
bonus bDefEle,n; | 给予防具n属性
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死、10-随机

·HP/SP回复/消耗/吸收
bonus bUseSPrate,n; | SP消费量+n%
bonus bHPrecovRate,n; | HP自然回复速度+n%（除去技能效果）
bonus bSPrecovRate,n; | SP自然回复速度+n%（除去技能效果）
bonus bHPrecovStop,n; | HP不会自动回复（n无意义，除去技能效果）
bonus bSPrecovStop,n; | SP不会自动回复（n无意义，除去技能效果）
bonus bHPPenaltyUnrig,n; | 装备解除时减少n点HP
bonus bSPPenaltyUnrig,n; | 装备解除时减少n点SP
bonus bHPRatePenaltyUnrig,n; | 装备解除时减少MaxHP的n%
bonus bSPRatePenaltyUnrig,n; | 装备解除时减少MaxSP的n%
bonus bRestartFullRecover,n; | 复活时HP/SP全部恢复（n无意义）
bonus bHPGainValue,n; | 杀死怪物后恢复n点HP
bonus bSPGainValue,n; | 杀死怪物后恢复n点SP
bonus2 bItemHealRate,n,x; | 使用n类物品时，恢复量+x%
1-药水（红、黄、白）、2-药草、3-糖果、4-果汁、5-肉、6-魔物饲料、7-生鱼片(寿司、生鱼片)、8-香蕉、9-冰淇淋、10-美味的鱼、11-红色药水[参考item_group_db.txt]
bonus2 bHPVanish,n,x; | 物理攻击时n%机率使敌人当前SP减少x%
bonus2 bSPVanish,n,x; | 物理攻击时n%机率使敌人当前SP减少x%
bonus2 bRaise,n,x; | 死亡时n机率以MaxHP的x%复活（n为万分率）
bonus3 bRaise,n,x,y; | 死亡时n机率以MaxHP的x%和MaxSP的y%复活（n为万分率）
bonus3 bHPDrainRate,n,x,y; | 攻击n种族的时候，以x%的机率，对敌人造成的伤害的y%吸收到HP中（x和y可以叠加）
bonus3 bSPDrainRate,n,x,y; | 攻击n种族的时候，以x%的机率，对敌人造成的伤害的y%吸收到SP中（x和y可以叠加）
bonus3 bHPDrainValue,n,x,y; | 攻击n种族的时候，以x%的机率，对敌人造成的伤害的y吸收到HP中（x和y可以叠加）
bonus3 bSPDrainValue,n,x,y; | 攻击n种族的时候，以x%的机率，对敌人造成的伤害的y吸收到SP中（x和y可以叠加）
bonus2 bHPPenaltyTime,n,x; | 每隔n毫秒消耗x点HP
bonus2 bSPPenaltyTime,n,x; | 每隔n毫秒消耗x点SP
bonus3 bDefeatHPDrainValue,n,x,y; | 打倒n种族怪物时，x机率恢复y点HP（x为万分率）
bonus3 bDefeatSPDrainValue,n,x,y; | 打倒n种族怪物时，x机率恢复y点SP（x为万分率）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-全种族

·追加伤害
bonus bAddShortWeaponDamage,n; | 近距离攻击时伤害增加n%
bonus bAddLongWeaponDamage,n; | 远距离攻击时伤害增加n%
bonus2 bAddSize,n,x; | 增加对n体型x%的物理攻击伤害
0-小型、1-中型、2-大型
bonus2 bAddRace,n,x; | 增加对n种族x%的物理攻击伤害
bonus2 bMagicAddRace,n,x; | 增加对n种族x%的魔法攻击伤害
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]
bonus2 bAddEle,n,x; | 增加对n属性x%的物理攻击伤害
bonus2 bMagicAddEle,n,x; | 增加对n属性x%的魔法攻击伤害
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死
bonus2 bAddEnemy,n,x; | 增加对敌人n的x%的物理攻击伤害
bonus2 bMagicAddEnemy,n,x; | 增加对敌人n的x%的魔法攻击伤害
0-其他、1-玩家、2-BOSS以外的怪物、3-人工生命体
bonus2 bAddDamageClass,n,x; | 对代码为n的怪物增加x%的物理伤害。对职业代码为n的玩家增加x%的物理伤害。
bonus2 bAddMagicDamageClass,n,x; | 对代码为n的怪物增加x%的魔法伤害。对职业代码为n的玩家增加x%的魔法伤害。
bonus2 bAddGroup,n,x; | 增加对n类别怪物x%的物理伤害
（0-未分类、1-哥布灵、2-兽人(BOSS以外)、3-犬妖、4-巨石怪、5-监护人、6-卡拉蟹、7-蛤蜊、8-海星、9-殭尸[参考mob_group_db.txt]）

·防御无视攻击
bonus2 bIgnoreDefRace,n,x; | 无视n种族x%的物理防御力
bonus2 bIgnoreMDefRace,n,x; | 无视n种族x%的魔法防御力
bonus bDefRatioAtkRace,n; | n种族的物理防御力越高造成的伤害越高（无视防御）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]
bonus2 bIgnoreDefEle,n,x; | 无视n属性x%的物理防御力
bonus2 bIgnoreMDefEle,n,x; | 无视n属性x%的魔法防御力
bonus bDefRatioAtkEle,n; | n属性的物理防御力越高造成的伤害越高（无视防御）
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死
bonus2 bIgnoreDefEnemy,n,x; | 无视敌人n的x%的物理防御力
bonus2 bIgnoreMDefEnemy,n,x; | 无视敌人n的x%的魔法防御力
bonus bDefRatioAtkEnemy,n; | 敌人n的物理防御力越高造成的伤害越高（无视防御）
0-其他、1-玩家、2-BOSS以外的怪物、3-人工生命体

·爆击伤害
bonus bAddCriticalDamage,n; | 爆击伤害+n%
bonus2 bCriticalRace,n,x; | 攻击n种族时，Cri增加x
bonus2 bCriticalRaceRate,n,x; | 攻击n种族时，Cri增加x%
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-全种族

·必中攻击
bonus bPerfectHitRate,n; | 必中攻击率=n%
bonus bPerfectHitAddRate,n; | 必中攻击率+n%
bonus bBonusDamage,n; | 必中伤害=n（显示出爆击的星星）

·范围攻击
bonus bSplashRange,n; | 普通攻击对目标周围n格造成伤害（n=1为3*3、n=2为5*5……）
bonus bSplashAddRange,n; | 普通攻击对目标周围增加n格造成伤害

·减少伤害/防御
bonus bCriticalDef,n; | 爆击防御+n%
bonus bNearAtkDef,n; | 减少受到近距离攻击伤害n%（全部，包括物理、魔法、其他攻击）
bonus bLongAtkDef,n; | 减少受到远距离攻击伤害n%（全部，包括物理、魔法、其他攻击）
bonus bMagicAtkDef,n; | 减少受到魔法攻击伤害n%
bonus bMiscAtkDef,n; | 减少受到其他攻击伤害n%（陷阱与猎鹰）
bonus bNoWeaponDamage,n; | 不受到物理攻击伤害（n无意义）
bonus bNoMagicDamage,n; | 不受到魔法攻击伤害，包括治愈术（n无意义）
bonus2 bSubSize,n,x; | 减少受到n体型x%的物理攻击伤害
bonus2 bMagicSubSize,n,x; | 减少受到n体型x%的魔法攻击伤害
0-小型、1-中型、2-大型
bonus2 bSubRace,n,x; | 减少受到n种族x%的物理攻击伤害
bonus2 bMagicSubRace,n,x; | 减少受到n种族x%的魔法攻击伤害
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]
bonus2 bSubEle,n,x; | 减少受到n属性x%的物理攻击伤害
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死
bonus2 bSubEnemy,n,x; | 减少受到敌人n的x%的物理/魔法伤害
0-其他、1-玩家、2-BOSS以外的怪物、3-人工生命体
bonus2 bAddDefClass,n,x; | 减少代码为n的怪物x%的物理伤害。减少职业代码为n的玩家x%的物理伤害。
bonus2 bAddMDefClass,n,x; | 减少代码为n的怪物x%的魔法伤害。减少职业代码为n的玩家x%的魔法伤害。
bonus2 bSubGroup,n,x; | 减少受到n类别怪物x%的伤害
0-未分类、1-哥布灵、2-兽人(BOSS以外)、3-犬妖、4-巨石怪、5-监护人、6-卡拉蟹、7-蛤蜊、8-海星、9-殭尸[参考mob_group_db.txt]

·伤害反射
bonus bShortWeaponDamageReturn,n; | 反射n%受到的近距离物理伤害给敌人（伤害不减少）
bonus bLongWeaponDamageReturn,n; | 反射n%受到的远距离物理伤害给敌人（伤害不减少）
bonus bMagicDamageReturn,n; | 反射n%受到的魔法伤害给敌人（伤害不减少）

·技能相关
skill n,x; | 学会/删除人物技能n（等级x）
bonus bCastrate,n; | 咏唱时间+n%
bonus bDoubleRate,n; | 连击发动率=n%（无视武器）
bonus bDoubleAddRate,n; | 连击发动率+n%（无视武器）
bonus bAddStealRate,n; | 偷窃率+n%
bonus bNoCastCancel,n; | 咏唱魔法时不会因受到攻击而中断（GVG、竞速场地会失败。n无意义）
bonus bNoCastCancel2,n; | 咏唱魔法时不会因受到攻击而中断（GVG、竞速场地不会失败。n无意义）
bonus bNoGemStone,n; | 使用技能时不消耗魔力矿石（n无意义）
bonus bSkillDelayRate,n; | 技能使用后延迟+n%
bonus2 bAddSkillDamageRate,n,x; | 技能n增加x%的伤害
bonus2 bAddSkillBlow,n,x; | 技能n有x格吹飞效果
bonus2 bAddFixCastRate,n,x; | 技能n的固定咏唱时间减少x%
bonus2 bAddSkillHealRate,n,x; | 技能n的回复量增加x%
bonus2 bAddCastRate,n,x; | 技能n的咏唱时间减少x%

·自动念咒

bonus3 bAutoSpell,n,x,y; | 自动念咒以y机率对敌人使用x等级的技能n（y为万分率）
bonus3 bAutoSpell2,n,x,y; | 自动念咒以y机率对敌人使用x等级的技能n（y为万分率）。优先使用高等级技能
bonus3 bAutoSelfSpell,n,x,y; | 自动念咒以y机率对自己使用x等级的技能n（y为万分率）
bonus3 bAutoSelfSpell2,n,x,y; | 自动念咒以y机率对自己使用x等级的技能n（y为万分率）。优先使用高等级技能
bonus3 bRevAutoSpell,n,x,y; | 受到物理伤害时，自动念咒以y机率对敌人使用x等级的技能n（y为万分率）
bonus3 bRevAutoSpell2,n,x,y; | 受到物理伤害时，自动念咒以y机率对敌人使用x等级的技能n（y为万分率）。优先使用高等级技能
bonus3 bRevAutoSelfSpell,n,x,y; | 受到物理伤害时，自动念咒以y机率对自己使用x等级的技能n（y为万分率）
bonus3 bRevAutoSelfSpell2,n,x,y; | 受到物理伤害时，自动念咒以y机率对自己使用x等级的技能n（y为万分率）。优先使用高等级技能

bonus4 bAutoSpell,n,x,y,z; 达成z条件后，以y机率使用x等级的技能n（y为万分率）
即使没有指定条件也能使用，但是不推荐。

发动条件（可复数）：
动作1：不指定的情况是攻击
EAS_ATTACK 攻击（直接输出伤害的时候）
EAS_REVENGE 反击（受到了伤害的时候）
动作2：不指定的情况是物理攻击
EAS_WEAPON 物理攻击（输出或接受）
EAS_SHORT 近距离物理攻击（输出或接受）
EAS_LONG 远距离物理攻击（输出或接受）
EAS_MAGIC 魔法攻击（输出或接受）
EAS_MISC 其他攻击[陷阱、猎鹰、火烟瓶等]（输出或接受）
※火烟瓶投掷是武器攻击，为了方便使用而归类到其他攻击
动作3：不指定的情况是普通攻击
EAS_NORMAL 普通攻击（输出或接受）
EAS_SKILL 技能攻击（输出或接受）
※在指定了EAS_MAGIC和EAS_MISC时忽略
对象：不指定的情况是攻击对象
EAS_TARGET 攻击对象
EAS_SELF 对自己使用
EAS_TARGET_RAND 对自己或攻击对象使用
使用等级：不指定的情况是最高等级
EAS_FLUCT 旧AS用途1～3(LV1:50% LV2:35% LV3:15%)
EAS_RANDOM 1～指定随机抽样（所有等级的机率一样）
最大使用等级：不指定的情况是x值
EAS_USEMAX MAX等级
EAS_USEBETTER 当前等级
SP消费量：没有指定的话是1倍
EAS_NOSP SP0
EAS_SPCOST1 SP2/3倍
EAS_SPCOST2 SP1/2倍
EAS_SPCOST3 SP1.5倍
物品消费：不指定的情况下，消耗必要的物品
EAS_ITEMNOCOST 不消耗物品

例：攻击时消费2/3的SP，使用FB1～3(旧火焰之壁)
bonus4 bAutoSpell,19,3,2500,EAS_ATTACK|EAS_FLUCT|EAS_SPCOST1;
攻击时不消耗SP，使用FB3(新火焰之壁)
bonus4 bAutoSpell,19,3,2500,EAS_ATTACK|EAS_NOSP;

·装备相关
bonus bBreakWeaponRate,n; | 以n的机率破坏玩家的武器（n为万分率，机率可叠加）
bonus bBreakArmorRate,n; | 以n的机率破坏玩家的铠甲（n为万分率，机率可叠加）
bonus bUnbreakableWeapon,n; | 武器绝对不会被破坏（n无意义）
bonus bUnbreakableArmor,n; | 铠甲绝对不会被破坏（n无意义）
bonus bUnbreakableHelm,n; | 头具绝对不会被破坏（n无意义）
bonus bUnbreakableShield,n; | 盾牌绝对不会被破坏（n无意义）
bonus bLossEquipWhenDie,n; | 死亡时n机率装备消失（n为万分率）
bonus bLossEquipWhenAttack,n; | 攻击时n机率装备消失（n为万分率）
bonus bLossEquipWhenHit,n; | 受到攻击时n机率装备消失（n为万分率）
bonus bBreakMyEquipWhenAttack,n; | 攻击时n机率装备损坏（n为万分率）
bonus2 bBreakMyEquipWhenAttack,n,x; | 攻击时x机率损坏n位置的装备（x为万分率）（456-头具、7-铠甲、8-左手、9-右手、其他位置-无意义）
bonus bBreakMyEquipWhenHit,n; | 受到攻击时n机率装备损坏（n为万分率）
bonus2 bBreakMyEquipWhenHit,n,x; | 受到攻击时x机率损坏n位置的装备（x为万分率）（456-头具、7-铠甲、8-左手、9-右手、其他位置-无意义）
bonus2 bRefineryType,n,x; | 根据n部位的装备精炼度，提升人物的x类型的状态。 （n：256=头上、512=头中、1=头下、32=盾牌、16=身体、4=披挂、64=鞋子、136=装饰品） （x：1=MDEF、2=DEF和MDEF、3=什么都不上升） （ps.默认装备是根据精炼度提升DEF，所以x中并没有DEF选择，不加这个bonus就表示提升DEF）

·状态异常
bonus2 bAddEff,e,n; | 以n的机率造成攻击对象e状态（n为万分率）
bonus2 bAddRevEff,e,n; | 受到近身物理攻击时，n机率让攻击对象陷入e状态（n为万分率）
bonus2 bAddEff2,e,n; | 以n机率造成自己e状态（n为万分率）
bonus2 bAddEffShort,e,n; | 近距离物理攻击时，n机率造成攻击对象e状态（n为万分率）
bonus2 bAddEffLong,e,n; | 远距离物理攻击时，n机率造成攻击对象e状态（n为万分率）
bonus2 bAddEffMagic,e,n; | 魔法攻击时，n机率造成攻击对象e状态（n为万分率）
bonus2 bResEff,e,n; | e状态的耐久度+n（n为万分率）
Eff_Blind - 黑暗 Eff_Sleep - 睡眠 Eff_Poison - 中毒 Eff_Freeze - 冰冻 Eff_Silence - 沉默 Eff_Stun - 昏眩 Eff_Curse - 诅咒 Eff_Confusion - 混乱 Eff_Stone - 石化 Eff_Bleed - 出血
bonus bCurseByMuramasa,n; | Lv>Luk时，n机率被诅咒（n为万分率）

·即死/濒死
bonus2 bWeaponComaEle,n,x; | 对n属性以x机率发动濒死之术[HP=1,SP=1]（x为万分率，可叠加）
bonus2 bWeaponComaEle2,n,x; | 对n属性以x机率发动濒死之术[HP=1]（x为万分率，可叠加）
0-无、1-水、2-土、3-火、4-风、5-毒、6-圣、7-暗、8-念、9-不死
bonus2 bWeaponComaRace,n,x; | 对n种族以x机率发动濒死之术[HP=1,SP=1]（x为万分率，可叠加）
bonus2 bWeaponComaRace2,n,x; | 对n种族以x机率发动濒死之术[HP=1]（x为万分率，可叠加）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]

·Zeny获得
bonus bGetZenyNum,n; | 物理攻击打倒怪物得到怪物Lv*10+rand()%n的Zeny
bonus bAddGetZenyNum,n; | 物理攻击打倒怪物得到怪物Lv*10+rand()%n的Zeny（可叠加）
bonus bGetZenyNum2,n; | 物理攻击打倒怪物时，n%的机率得到怪物Lv*10的Zeny
bonus bAddGetZenyNum2,n; | 物理攻击打倒怪物时，n%的机率得到怪物Lv*10的Zeny（可叠加）

·物品获得

bonus3 bAddMonsterDropItem,n,x,y; 物理攻击打倒x种族的怪物，有y机率掉落物品n（y为万分率，与怪物掉落物品无关系）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-BOSS、11-BOSS以外[普通的怪物，包括玩家]

·追加经验值
bonus2 bExpRate,n,x; | 杀死n种族怪物时，增加x%的Base经验（可叠加）
bonus2 bJobRate,n,x; | 杀死n种族怪物时，增加x%的Job经验（可叠加）
bonus2 bExpRate,n,x; | 杀死n种族怪物时，增加x%的Base经验（可叠加）
bonus2 bJobRate,n,x; | 杀死n种族怪物时，增加x%的Job经验（可叠加）
0-无形、1-不死、2-动物、3-植物、4-昆虫、5-鱼贝、6-恶魔、7-人形、8-天使、9-龙族、10-全种族

·其他
bonus bNoSizeFix,n; | 不受到怪物体型的伤害修正（n无意义）
bonus bMobClassChange,n; | 攻击时以n机率把当前怪物变为其他怪物（n为万分率）
bonus bInfiniteEndure,n; | 无限霸体（n无意义）
bonus bTigereye,n; | 可以看到隐匿或伪装的怪物和玩家（n无意义）
bonus bItemNoUse,n; | 无法使用物品（n无意义）
bonus bNoKnockback,n; | 无法被吹飞或击退（n无意义）

·特殊
bonus bAutoStatusCalcPc,n; | 强制设置状态n 例：装备其间处于圣母的祈福状态 ,{},{ bonus bAutoStatusCalcPc,110; sc_start 110,1000,0; } ※bAutoStatusCalcPc和bEternalStatusChange的不同：bEternalStatusChange能实现永久的效果。
bonus2 bEternalStatusChange,n,x; | 强制设置状态n持续x毫秒（x的范围是1-30000，超出范围时自动初始化为1000） 例：装备其间处于圣母的祈福状态 ,{},{ bonus2 bEternalStatusChange,110,1000; sc_start 110,1000,0; } ※bAutoStatusCalcPc和bEternalStatusChange的不同：bEternalStatusChange能实现永久的效果。

·无视敌人的bonus效果
bonus bDisregardCriticalDef,n; | 无视目标玩家的bCriticalDef效果（n无意义）
bonus bDisregardNearAtkDef,n; | 无视目标玩家的bNearAtkDef效果（n无意义）
bonus bDisregardLongAtkDef,n; | 无视目标玩家的bLongAtkDef效果（n无意义）
bonus bDisregardMagicAtkDef,n; | 无视目标玩家的bMagicAtkDef效果（n无意义）
bonus bDisregardMiscAtkDef,n; | 无视目标玩家的bMiscAtkDef效果（n无意义）
bonus bDisregardNoWeaponDamage,n; | 无视目标玩家的bNoWeaponDamage效果（n无意义）
bonus bDisregardNoMagicDamage,n; | 无视目标玩家的bNoMagicDamage效果（n无意义）
bonus bDisregardSubSize,n; | 无视目标玩家的bSubSize效果（n无意义）
bonus bDisregardMagicSubSize,n; | 无视目标玩家的bMagicSubSize效果（n无意义）
bonus bDisregardSubRace,n; | 无视目标玩家的bSubRace效果（n无意义）
bonus bDisregardMagicSubRace,n; | 无视目标玩家的bMagicSubRace效果（n无意义）
bonus bDisregardSubEle,n; | 无视目标玩家的bSubEle效果（n无意义）
bonus bDisregardSubEnemy,n; | 无视目标玩家的bSubEnemy效果（n无意义）
bonus bDisregardAddDefClass,n; | 无视目标玩家的bAddDefClass效果（n无意义）
bonus bDisregardAddMdefClass,n; | 无视目标玩家的bAddMdefClass效果（n无意义）
bonus bDisregardSubGroup,n; | 无视目标玩家的bSubGroup效果（n无意义）


事件/特殊标签一览表

事件/特殊标签 | 格式 | 说明
OnInit | OnInit: | Map启动后执行的事件
OnInterIfInit | OnInterIfInit: | Map连接到Inter服务器时执行的事件
OnCharIfInit | OnCharIfInit: | Map连接到Char服务器时执行的事件
OnSecond | OnSecondSS: | 每分钟的SS秒执行的事件
OnMinute | OnMinuteMM: | 每小时的MM分钟执行的事件
OnClock | OnClockHHMM: | 每天的HH时MM分执行的事件
OnHour | OnHourHH: | 每天的HH时执行的事件
OnWeekTime | OnWeekTimeDDHHMM: | 星期DD（00-日、01-一…06-六）的HH时MM分执行的事件
OnDateTime | OnDateTimeMMDDHHMM: | MM月DD日HH时MM分执行的事件
OnDayTime | OnDayTimeDDHHMM: | DD日HH时MM分执行的事件
OnDay | OnDayDD: | 每月DD日执行的事件
OnTimer | OnTimerX: | NPC计时器经过X毫秒时执行的事件
OnAgitInit | OnAgitInit: | 在服务器请求公会城堡的相关信息时执行的事件。用于初始化与公会城堡相关的NPC。
OnAgitStart | OnAgitStart: | 公会战开始时执行的事件
OnAgitEnd | OnAgitEnd: | 公会战结束时执行的事件
OnAgitBreak | <npc_name>::OnAgitBreak | 破坏华丽金属时执行的事件。这个事件以破坏华丽金属的玩家为主体来执行。
OnAgitEliminate | OnAgitEliminate: | 破坏华丽金属后，公会城主改变时执行的事件。
OnGuildBreak | <npc_name>::OnGuildBreak | 解散公会时执行的事件。
OnTouch | OnTouch: | 进入范围NPC的有效范围内时执行的事件。设置OnTouch的NPC名字必须在服务器内唯一。
OnTouchNPC | OnTouchNPC: | 当NPC进入范围NPC的有效范围内时执行的事件（目前只有Mob）。设置OnTouch的NPC名字必须在服务器内唯一。
OnPCDie | OnPCDie: | 人物死亡时执行的事件
OnPCKill | OnPCKill: | 玩家PK时，死亡人物执行的事件
OnPCKill2 | OnPCKill2: | 玩家PK时，杀人者执行的事件
OnPCMoveMap | OnPCMoveMap: | 玩家过图时执行的事件
OnPCLogin | OnPCLogin: | 玩家登陆时执行的事件
OnPCLogout | OnPCLogout: | 玩家登出时执行的事件
OnPCBaseLvup | OnPCBaseLvup: | 人物Base等级提升时执行的事件
OnPCJobLvup | OnPCJobLvup: | 人物Job等级提升时执行的事件
OnPCKillMob | OnPCKillMob: | 人物杀死怪物时执行的事件
OnPCSave | OnPCSave: | 自动储存人物数据时执行的事件
OnPCAfterWeaponAtk | OnPCAfterWeaponAtk: | 人物进行物理攻击后执行的事件
OnPCAfterMagicAtk | OnPCAfterMagicAtk: | 人物进行魔法攻击后执行的事件
OnPCAfterMiscAtk | OnPCAfterMiscAtk: | 人物进行其他攻击后执行的事件


accountid2charid

accountid2charid函数

作用：account_id -> char_id

格式： | accountid2charid(<account_id>)
参数：
<account_id> | 人物的account_id（数值类型）
说明： | 人物不存在时返回-1


accountid2name

accountid2name函数

作用：account_id -> 玩家名字

格式： | accountid2name(<account_id>)
参数：
<account_id> | 人物帐号ID（数值类型）
说明： | 玩家不存在时返回空字符串。


addtimer

addtimer命令

作用：添加计时器

格式： | addtimer <tick>,<event>;
参数：
<tick> | 时间（数值类型，单位为ms）
<event> | 事件名（字符串类型）
说明： | 经过<tick>毫秒后执行<event>事件。<event>事件的格式为<NPC object name>::<label>。 这个计时器可以读取玩家的信息。 请注意，玩家登出后，计时器就会失效。 在竞技场地图请不要使用这个NPC计时器。


addtimercount

addtimercount命令

作用：增加计时器时间

格式： | addtimercount <event>,<tick>;
参数：
<event> | 事件名（字符串类型）
<tick> | 时间（数值类型，单位为ms）
说明： | 为<event>计时器在添加<time>毫秒。<event>事件的格式为<NPC object name>::<label>。


adopt

adopt函数

格式和作用：（和adoption命令一样）


adoption

adoption函数

作用：成为养子

格式： | adoption(<parent1>[,<parent2>])
参数：
<parent1> | 双亲的名字（字符串类型）
<parent2> | 双亲的名字（字符串类型，省略时为<parent1>的伴侣）
说明： | 成为<parent1>、<parent2>的养子。 成功则返回1，否则返回0。


agitcheck

agitcheck函数

作用：检查是否开启了攻城战

格式： | agitcheck()
说明： | 开启了攻城战则返回1，否则返回0。


agitend

agitend命令

作用：关闭攻城战

格式： | agitend;
说明： | 关闭攻城战，并执行OnAgitEnd标签的事件。


agitstart

agitstart命令

作用：开启攻城战

格式： | agitstart;
说明： | 开启攻城战，并执行OnAgitStart标签的事件。


allowuseitem

allowuseitem命令

作用：允许在NPC会话中使用物品

格式： | allowuseitem[<item_id>[,<char_id>]];
参数：
<item_id> | 物品ID或名字（数值/字符串类型，可省略）
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： | 允许玩家在NPC会话中使用物品ID为<item_id>的物品。 <item_id>为0时或者省略时表示所有物品均可使用。 <item_id>为-1时为通常情况，表示所有物品均不可使用。


announce

announce命令

作用：发布广播信息

格式： | announce <string>,<flag>[,<color>];
参数：
<string> | 公告内容（字符串类型）
<flag> | 标识（数值类型）
<color> | 颜色（数值类型，可省略）
说明： | <flag>含义（注意，bc_xxxx这些在const.txt中有定义）： [范围] 0x00或bc_all 所有地图 0x01或bc_map 相同地图 0x02或bc_area 相同画面 0x03或bc_self 只有自己 0x04 相同Map-Server [颜色] 0x00或bc_yellow 黄色 0x10或bc_blue 蓝色 [特殊] 0x00或bc_pc 无特殊用途 0x08或bc_npc 活动用途 [范围]、[颜色]、[特殊]标识可叠加使用。 如果指定了<color>，则[颜色]标识被忽略。


areaannounce

areaannounce命令

作用：区域公告

格式： | areaannounce <gatname>,<x0>,<y0>,<x1>,<y1>,<string>,<flag>[,<color>];
参数：
<gatname> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 区域范围（数值类型）
<string> | 公告内容（字符串类型）
<flag> | 标识（数值类型）
<color> | 颜色（数值类型，可省略）
说明： | <flag> = 0：黄色文字 <flag> = 16：蓝色文字 如果指定了<color>，则<flag>会被忽略。


areakillmonster

areakillmonster命令

作用：区域杀怪

格式： | areakillmonster <gatname>,<x0>,<y0>,<x1>,<y1>;
参数：
<gatname> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 区域坐标（数值类型）
说明： | 杀死区域范围内的怪物，会一起杀死一开始就放置的怪物。 <gatname>为this（区分大小写）的话，则表示当前地图。


areamonster

areamonster命令

作用：区域召怪

格式： | areamonster <gatname>,<x0>,<y0>,<x1>,<y1>,<mobname>,<mobid>,<count>[,<event>];
参数：
<gatname> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 怪物出现的范围（数值类型）
<mobname> | 怪物名字（字符串类型）
<mobid> | 怪物ID（数值类型）
<count> | 怪物数量（数值类型）
<event> | 怪物死亡后执行的事件（字符串类型，可省略）
说明： | 如果<gatname>为this（区分大小写）的话，则表示当前地图。 <x0>,<y0>小于0的话，表示随机坐标。 <mobname>为--en--的话为英文名，<mobname>为--ja--的话为日文（中文）名。 <mobid>为-1表示随机怪物。


areapercentheal

areapercentheal命令

作用：范围恢复HP/SP

格式： | areapercentheal <map_name>,<x0>,<y0>,<x1>,<y1>,<hp>,<sp>;
参数：
<map_name> | 地图名（字符串类型）
x0>,<y0>,<x1>,<y1> | 坐标范围（数值类型）
<sp> | 恢复的SP量（数值类型）
<hp> | 恢复的HP量（数值类型）


areawarp

areawarp命令

作用：区域传送

格式： areawarp <from_map>,<x0>,<y0>,<x1>,<y1>,<to_map>,<x>,<y>;
参数：

<from_map> | 原地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 区域内的坐标（数值类型）
<to_map> | 目标地图（字符串类型）
<x>,<y> | 目标地图坐标
说明： 把<from_map>地图指定区域内的玩家传送到<to_map>地图的(x,y)坐标。

（Eathena.Net）
如果<to_map>为Random（区分大小写）的话，则表示当前地图的随机坐标。

（Jathena.Net）
如果<from_map>为this（区分大小写）的话，则表示当前地图。


arrayselect

arrayselect函数

作用：显示菜单（以数组为菜单项）

格式： | arrayselect(<menuitem>[,<count>])
参数：
<menuitem> | 数组中的一项（作为首个菜单项）
<count> | 个数（数值类型，省略时表示从<menuitem>开始到数组结尾的所有项）
说明： | 以数组为菜单项显示菜单，并返回选项的号码。 如果选择了第1项，则返回0。并把返回值保存在@menu变量中。 如果数组为"test1","","test2"，则菜单只显示2项，如果选择了"test2"则返回2，因为"test2"是第3项，只是中间一项没显示出来。


atcommand

atcommand命令

格式和作用：（和gmcommand命令一样）


athenatype

athenatype函数

作用：返回Athena版本信息

格式： athenatype()
说明：
（Eathena.Net）
返回字符串"EA.NET"。

（Jathena.Net）
返回字符串"JA.NET"。


atoi

atoi函数

作用：把字符串转换为数值

格式： | atoi(<string>)
参数：
<string> | 字符串（字符串类型）
说明： | <例> atoi("123") -> 返回数值123


attachrid

attachrid函数

作用：把人物关联到脚本

格式： | attachrid(<account_id>)
参数：
<account_id> | 人物的帐号ID（数值类型）
说明： | 把帐号ID为<account_id>的人物关联到执行脚本。 以后关于人物的命令或函数的对象全部变成新人物。 有效时间到脚本的结束或中断为止(close,end,menu,next,input等)。 主要用于事件执行的脚本内使用地图变量之后来关联人物。 要附加RID，可以用getcharid(3)取得人物的帐号ID。 如果要解除关联RID，可以使用detachrid命令。 要注意的是，使用了这个指令关联人物的话，不能使用mes,menu,next等显示窗口或按钮的命令。 当人物和其他NPC会话时，这些命令不能正常工作。 应尽量使用其他获得信息的命令。 如果关联成功，则返回1。如果关联失败（人物不存在时），则返回0。


autoequip

autoequip命令

作用：设置某种物品的自动装备属性

格式： | autoequip <item_id>,<option>;
参数：
<item_id> | 物品ID（数值类型）
<option> | 设定（数值类型。1:开启自动装备、0:关闭自动装备）
说明： | 当人物获得物品<item_id>时，则自动装备上这个物品。


awake

awake命令

作用：唤醒执行了sleep指令的NPC

格式： | awake <npc_name>;
参数：
<npc_name> | NPC名字（字符串类型）
说明： | 恢复所有在堆栈中使用了sleep指令的NPC继续执行脚本。


axtoi

axtoi函数

作用：把16进制字符串转换为数值

格式： | axtoi(<string>)
参数：
<string> | 字符串（字符串类型）
说明： | <例> axtoi("FF") -> 返回数值255


basicskillcheck

basicskillcheck函数

作用：返回battle_athena.conf的basic_skill_check的设定值

格式： basicskillcheck()


bonus

bonus命令

作用：单参数bonus

格式：
（Eathena.Net）
bonus <type>,<val1>;

（Jathena.Net）
bonus <type>,<val1>[,<char_id>];
参数：

<type> | bonus类型的参数
<val1> | 数值
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 详细请参考bonus效果说明文档。


bonus2

bonus2命令

作用：双参数bonus

格式：
（Eathena.Net）
bonus2 <type>,<val1>,<val2>;

（Jathena.Net）
bonus2 <type>,<val1>,<val2>[,<char_id>];
参数：

<type> | bonus2类型的参数
<val1>,<val2> | 数值
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 详细请参考bonus效果说明文档。


bonus3

bonus3命令

作用：三参数bonus

格式：
（Eathena.Net）
bonus3 <type>,<val1>,<val2>,<val3>;

（Jathena.Net）
bonus3 <type>,<val1>,<val2>,<val3>[,<char_id>];
参数：

<type> | bonus3类型的参数
<val1>,<val2>,<val3> | 数值
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 详细请参考bonus效果说明文档。


bonus4

bonus4命令

作用：四参数bonus

格式：
（Eathena.Net）
bonus4 <type>,<val1>,<val2>,<val3>,<val4>;

（Jathena.Net）
bonus4 <type>,<val1>,<val2>,<val3>,<val4>[,<char_id>];
参数：

<type> | bonus4类型的参数
<val1>,<val2>,<val3>,<val4> | 数值
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 详细请参考bonus效果说明文档。

（Eathena.Net）
当<type>为bAutoSpellOnSkill的时候，val1可以是字符串表示技能名字）


bpet

bpet命令

作用：打开宠物蛋孵化列表

格式： bpet;


callfunc

callfunc命令/函数

作用：调用函数

格式： | callfunc <func>[,<arg0>[,<arg1> ...]];
参数：
<func> | 函数名
<arg0>,<arg1>... | 参数（数值/字符串类型，可省略）
说明： | 执行用户定义函数<func>。 arg0,arg1...为参数，可在函数内用getarg函数取得。 从函数中返回时请使用return命令。 这个命令根据return命令的运行情况也能作为函数使用。 如果传递的参数是变量，还可以使用像set getarg(0),1;这种用法。


callsub

callsub命令/函数

作用：调用标签

格式： | callsub <label>[,<arg0>[,<arg1> ...]];
参数：
<label> | 标签
<arg0>,<arg1>... | 参数（数值/字符串类型，可省略）
说明： | 执行同一脚本内的标签为<label>的子处理。 arg0,arg1...为参数，可在子处理内用getarg函数取得。 从子处理中返回时请使用return命令。 这个命令根据return命令的运行情况也能作为函数使用。 如果传递的参数是变量，还可以使用像set getarg(0),1;这种用法。


cardscnt

cardscnt函数

作用：检查人物当前武器中插入了多少张指定的卡片

格式： | cardscnt(<card1>[,<card2>[,<card3>....[,<cardn>]]])
参数：
<card1>,<card2>,<card3>...<cardn> | 卡片ID（数值类型）


changebase

changebase命令

作用：改变职业形象

格式：
（Eathena.Net）
changebase <job>[,<account_id>];

（Jathena.Net）
changebase <job>[,<upper>[,<account_id>]];
参数：

<job> | 职业代码（数值类型）
<upper> | 进阶标识（数值类型）
<account_id> | 人物的帐号ID（数值类型，省略时为自己）
说明： <job>可以参考db/const.txt。<job>为22(结婚造型)或26(圣诞装)的时候，会自动卸下装备。

（Jathena.Net）
<upper>：0=未转生、1=转生、2=宝宝、-1或没有指定=人物当前upper。


changelook

changelook命令

作用：临时改变角色造型（过图后消失）

格式： | changelook <type>,<value>[,<char_id>];
参数：
<type> | 外观类型（数值类型）
<value> | 数值（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <type> = 0：基本造型 <type> = 1：发型 <type> = 2：武器 <type> = 3：头下 <type> = 4：头上 <type> = 5：头中 <type> = 6：发色 <type> = 7：服色 <type> = 8：盾牌 <type> = 9：鞋子 注意，<type> = 9不会发生任何效果，只是客户端保留了。


changesex

changesex命令

作用：改变人物的性别

格式： | changesex[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


changeviewsize

changeviewsize命令

作用：改变对象的大小

格式： | changeviewsize <type>,<size>;
参数：
<type> | 对象类型（数值类型） 1 - PC 2 - PET 3 - HOM 4 - NPC
<size> | 大小（数值类型） -1 : 小 0 : 恢复原始大小 1 : 大


charcommand

charcommand命令

作用：执行玩家指令

格式： | charcommand <command>[,<char_id>];
参数：
<command> | 玩家指令（字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）


charid2accountid

charid2accountid函数

作用：char_id -> account_id

格式： | charid2accountid(<char_id>)
参数：
<char_id> | 人物的char_id（数值类型）
说明： | 人物不存在时返回-1


charid2name

charid2name函数

作用：char_id -> 玩家名字

格式： | charid2name(<char_id>)
参数：
<char_id> | 人物的char_id（数值类型）
说明： | 人物不存在时返回空字符串。


charisalpha

charisalpha函数

作用：检查字符串中的字符是否字母

格式： | charisalpha(<string>,<position>)
参数：
<string> | 字符串（字符串类型）
<position> | 字符串中的位置（数值类型，从0开始）
说明： | 如果是字母，则返回1。 如果不是字母，是数字或者空格，则返回0。


checkcart

checkcart函数

作用：检查人物是否在使用手推车

格式： | checkcart([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 如果人物在使用手推车，则返回1。如果没使用则返回0。 如果指定人物不存在，则返回-1。


checkcell

checkcell函数

作用：检查指定地图指定坐标的单元的类型

格式： checkcell(<map_name>,<x>,<y>,<type>)
参数：

<map_name> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<type> | 要检查的类型（数值类型）
说明：
（Eathena.Net）
<type>列表（在const.txt中以"cell_"开头的定义）：
cell_chkwall 1（墙壁）
cell_chkwater 2（水场）
cell_chkcliff 3（悬崖）
cell_chkpass 4（可通过）
cell_chkreach 5（可站立）
cell_chknopass 6（不可通过）
cell_chknoreach 7（不可站立）
cell_chknpc 9（NPC）
cell_chkbasilica 10（神圣殿堂）
cell_chklandprotector 11（地元素领域）
cell_chknovending 12（不能开放露天商店）
cell_chknochat 13（不能开放聊天室）

地图不存在时，返回0。

（Jathena.Net）
<type>列表：
0:检查是否墙壁
1:检查是否水场
2:检查是否障碍物
3:检查是否可以通过
4:检查是否不能通过
5:直接返回坐标单元的数值

地图不存在时，返回-1


checkchatting

checkchatting函数

作用：检查玩家是否开启了聊天室

格式： checkchatting([<char_name>])
参数：

<char_name> 玩家名字（字符串类型，省略时为自己）
说明：
（Eathena.Net）
玩家不存在时，返回0。

（Jathena.Net）
玩家不存在时，返回-1。


checkdead

checkdead函数

格式和作用：（和pc_isdead函数一样）


checkequipedcard

checkequipedcard函数

作用：检查随身物品中是否存在插有指定卡片的装备

格式： | checkequipedcard(<card_id>[,<char_id>])
参数：
<card_id> | 卡片ID（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 如果人物随身物品插上了ID为<card_id>卡片，则返回1。否则返回0。 人物不存在时，返回0。


checkfalcon

checkfalcon函数

作用：检查人物是否在使用猎鹰

格式： | checkfalcon([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 如果人物在使用猎鹰，则返回1。如果没使用则返回0。 如果指定人物不存在，则返回-1。


checkoption

checkoption函数

作用：检查玩家状态

格式： checkoption(<num>[,<char_id>])
参数：

<num> | 状态（数值类型，0以上的数值）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 如果处于<num>指定的状态则返回1，否则返回0。
指定人物不存在时，则返回-1。

状态一览：
1：火狩
2：隐匿
4：伪装
8：手推车等级1
16：带鹰
32：骑鸟
64：GM隐身
128：手推车等级2
256：手推车等级3
512：手推车等级4
1024：手推车等级5
2048：变身为怪兽
4096：变为结婚造型
8192：光猎
16384：足迹

（Eathena.Net）
32768：飞行或圣诞装
65536：Sighttrasher

（Jathena.Net）
29：死亡
128：石化
129：冻结
130：昏眩
131：睡眠
132：中毒
133：诅咒
134：沉默
135：混乱
136：黑暗
137：出血
187：结婚状态
188：禁言状态
5035：重量超过50%
9036：重量超过90%

其他状态参考skill.h


checkoption1

checkoption1函数

作用：检查人物的<x> <y> <z>状态中的<x>状态

格式： | checkoption1(<option>[,<char_id>])
参数：
<option> | 状态ID（数值类型） 1 石化 2 冰冻 3 昏眩 4 睡眠 6 黑暗
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： | 返回0时，表示人物不处于<option>状态。 返回1时，表示人物处于<option>状态。 返回-1时，表示人物不存在。


checkoption2

checkoption2函数

作用：检查人物的<x> <y> <z>状态中的<y>状态

格式： | checkoption2(<option>[,<char_id>])
参数：
<option> | 状态ID（数值类型） 1 中毒 2 诅咒 4 沉默 8 玩家复活声音 16 黑暗 128 猛毒
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： | 返回0时，表示人物不处于<option>状态。 返回1时，表示人物处于<option>状态。 返回-1时，表示人物不存在。


checkoption3

checkoption3函数

作用：检查人物的<x> <y> <z>状态中的<z>状态

格式： | checkoption3(<option>[,<char_id>])
参数：
<option> | 状态ID（数值类型） 1 火狩 2 隐匿 4 伪装 8 手推车Lv1 16 猎鹰 32 骑鸟 64 GM隐身 128 手推车Lv2 256 手推车Lv3 512 手推车Lv4 1024 手推车Lv5 2048 兽人头 4096 变为结婚造型 8192 光猎 16384 足迹 32768 拳圣飞行 65536 圣诞服 262144 泳衣
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： | 返回0时，表示人物不处于<option>状态。 返回1时，表示人物处于<option>状态。 返回-1时，表示人物不存在。


checkriding

checkriding函数

作用：检查人物是否在骑鸟

格式： | checkriding([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 如果人物在骑鸟，则返回1。如果没使用则返回0。 如果指定人物不存在，则返回-1。


checkvending

checkvending函数

作用：检查玩家是否开启了露天商店

格式： checkvending([<char_name>])
参数：

<char_name> 玩家名字（字符串类型，省略时为自己）
说明：
（Eathena.Net）
玩家不存在时，返回0。

（Jathena.Net）
玩家不存在时，返回-1。


checkweight

checkweight函数

作用：检查人物负重

格式： | checkweight(<item_id|item_name>,<count>[,<char_id>])
参数：
<item_id|item_name> | 物品ID|名字（数值|字符串类型）
<count> | 数量（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 检查人物能否持有<count>个<item_id|item_name>物品不超出负重，能的话返回1，不能则返回0。 <count>如果超过MAX_AMOUNT，或者玩家的物品种类已经达到MAX_INVENTORY时也返回0。 <item_id|item_name>可以为字符串类型（name,jname）。 但是物品名字是根据item_db.txt等文件，所以除测试目的外不要使用。 返回-1时，表示指定人物不存在


classchange

classchange命令

作用：改变外观

格式： | classchange <class>,<type>[,<unit_id>];
参数：
<class> | 外观ID（数值类型）
<type> | Mob是1，其他情况是0（数值类型）
<unit_id> | 单位ID（数值类型，省略时表示当前NPC）


cleanmap

cleanmap命令

作用：清理某地图上某个范围的地上物品

格式： | cleanmap <map>,<x>,<y>,<range>;
参数：
<map> | 地图名（字符串类型）
<x>,<y> | 中心坐标（数值类型）
<range> | 范围（数值类型）


cleararray

cleararray命令

作用：初始化数组

格式： | cleararray <variable>,<value>,<count>;
参数：
<variable> | 变量
<value> | 要填充的值（数值/字符串类型）
<count> | 数量（数值类型）
说明： | 把<count>个<value>值传入从<variable>开始的数组。 如果<variable>指定为数组名，则从第1个元素开始代入，否则从指定的元素开始代入。 <例> cleararray @hoge[3],0,6; 把@hoge[3]到@hoge[8]的值初始化为0。


clearitem

clearitem命令

作用：清空所有随身物品

格式： | clearitem[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


clicknpc

clicknpc命令

作用：点击NPC（只在有效范围内生效）

格式： | clicknpc <npc_name>;
参数：
<npc_name> | NPC名字（字符串类型）


close

close命令

作用：显示close按钮

格式： | close;
说明： | 在消息窗口上显示close按钮并结束脚本。


close2

close2命令

作用：显示close按钮

格式： | close2;
说明： | 在消息窗口上显示close按钮，但不结束脚本。要结束脚本时请使用end命令。


compare

compare函数

格式和作用：（和findstring函数一样）


cooking

cooking命令

作用：制作料理

格式：
（Eathena.Net）
cooking <Item_Lv>;

（Jathena.Net）
cooking <Item_Lv>,<making_base_success_per>;
参数：

<Item_Lv> | 制作物品的等级（数值类型，在produce_db.txt中定义）
<making_base_success_per> | 制作的基本成功率（数值类型）
说明： <例> “野外用烹调器具”的代码：cooking 11;


copyarray

copyarray命令

作用：复制数组

格式： | copyarray <var1>,<var2>,<count>;
参数：
<var1> | 目标数组/元素
<var2> | 被复制的数组/元素
<count> | 数量（数值类型）
说明： | 从一个数组的<var2>开始<count>个元素，被复制到从<var1>开始的数组中。 如果<var1>,<var2>指定为数组名的话，则表示从第一个元素开始。


countcartitem

countcartitem函数

作用：取得手推车某物品数量

格式： | countcartitem(<itemid>[,<char_id>])
参数：
<itemid> | 指定的物品ID（数值/字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 取得人物手推车上物品ID为<itemid>的物品数量。 <itemid>可以为字符串类型（name,jname）。 但是物品名字是根据item_db.txt等文件，所以除测试目的外不要使用。 返回-1时，表示指定人物不存在


countitem

countitem函数

作用：取得某随身物品数量

格式： countitem(<item_id|item_name>[,<char_id>])
参数：

<item_id|item_name> | 指定的物品ID|名字（数值|字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 返回人物身上指定物品的数量。
<item_id|item_name>可以为字符串类型（name,jname）。
但是物品名字是根据item_db.txt等文件，所以除测试目的外不要使用。

（Eathena.Net）
指定的人物不存在时返回0。

（Jathena.Net）
指定的人物不存在时返回-1。


countitem2

countitem2函数

作用：取得某随身物品数量

格式： countitem2(<item_id|item_name>,<identify>,<refine>,<attribute>,<card1>,<card2>,<card3>,<card4>[,<char_id>])
参数：

<item_id|item_name> | 指定的物品ID|名字（数值|字符串类型）
<identify> | 鉴定（数值类型）
<refine> | 精炼度（数值类型）
<attribute> | 属性（数值类型）
<card1>-<card4> | 卡片（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 返回人物身上指定物品的数量。
<item_id|item_name>可以为字符串类型（name,jname）。
但是物品名字是根据item_db.txt等文件，所以除测试目的外不要使用。

如果物品ID错误，则返回0。

（Eathena.Net）
指定的人物不存在时返回0。

（Jathena.Net）
指定的人物不存在时返回-1。


cutin

cutin命令

作用：出现一个图片

格式： | cutin <filename>,<position>[,<char_id>];
参数：
<filename> | 文件名（字符串类型）
<position> | 出现的位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 显示卡普拉等插图。 <position> = 0：左下 <position> = 1：中下 <position> = 2：右下 <position> = 3：屏幕中央（带标题栏，可移动的窗口中） <position> = 4：屏幕中央（不带标题栏，可移动的窗口中） <position> = 255：取消显示图片


cutincard

cutincard命令

作用：显示卡片对应的图片

格式： | cutincard <item_id>[,<char_id>];
参数：
<item_id> | 物品ID（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）


day

day命令

作用：设置为白天

格式： day;


debugmes

debugmes命令

作用：在Map-Server控制台上显示信息

格式： | debugmes <message>;
参数：
<message> | 要输出的信息（字符串类型）


deletearray

deletearray命令

作用：删除数组元素

格式： | deletearray <variable>,<count>;
参数：
<variable> | 数组/元素
<count> | 数量（数值类型）
说明： | 删除从<variable>开始的<count>个元素。 这里的删除不是初始化为0，而是把元素从数组中移除，就是说后面的元素会向前移。 如果<variable>指定为数组名的话，则从第1个元素开始删除。


delitem

delitem命令

作用：删除物品

格式：
（Eathena.Net）
delitem <item_id|item_name>,<count>[,<account_id>];

（Jathena.Net）
delitem <item_id>,<count>[,<char_id>];
参数：

<item_id|item_name> | 物品ID|名字（数值|字符串类型）
item_id> | 物品ID（数值类型）
<count> | 数量（数值类型）
<account_id> | 人物的account_id（数值类型，省略时表示自己）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 删除人物指定的随身物品<count>个。


delitem2

delitem2命令

作用：删除物品

格式： | delitem2 <item_id|item_name>,<amount>,<identify>,<refine>,<attribute>,<card1>,<card2>,<card3>,<card4>[,<account_id>];
参数：
<item_id|item_name> | 物品ID|名字（数值|字符串类型）
<amount> | 数量（数值类型）
<identify> | 鉴定（数值类型）
<refine> | 精炼度（数值类型）
<attribute> | 属性（数值类型）
<card1>-<card4> | 卡片（数值类型）
<account_id> | 人物的帐号ID（数值类型，省略时表示自己）
说明： | 删除人物身上符合条件的物品<amount>个。


deltimer

deltimer命令

作用：删除计时器

格式： | deltimer <event>;
参数：
<event> | 事件名（字符串类型）
说明： | 删除执行命令的玩家的<event>计时器。<event>事件的格式为<NPC object name>::<label>。


delwaitingroom

delwaitingroom命令

作用：关闭一个聊天室

格式： | delwaitingroom[<npc_name>];
参数：
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）


detachrid

detachrid命令

作用：清除关联到脚本的人物

格式： | detachrid;
说明： | 清除NPC的RID，即清除关联到脚本的人物。 以后关于人物的脚本指令将无法执行。


disableitems

disableitems命令

作用：禁止人物使用所有物品

格式： | disableitems[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


disablenpc

disablenpc命令

作用：关闭NPC

格式： | disablenpc[<npcname>];
参数：
<npcname> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | 让一个NPC无效。


disablewaitingroomevent

disablewaitingroomevent命令

作用：让指定NPC聊天室的事件无效

格式： | disablewaitingroomevent[<npc_name>];
参数：
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）


disable_equip

disable_equip命令

作用：禁止人物装备所有物品

格式： | disable_equip[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


disable_unequip

disable_unequip命令

作用：禁止人物卸除所有物品

格式： | disable_unequip[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


disguise

（Jathena.Net）disguise命令
（Eathena.Net）disguise函数

作用：把指定玩家变身为怪物/NPC/人工生命体的外观

格式：
（Eathena.Net）
disguise(<id>[,<char_id>])

（Jathena.Net）
disguise <id>[,<char_id>];
参数：

<id> | 怪物ID/NPC ID/人工生命体ID（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明：
（Eathena.Net）
人物不存在时，返回-1。成功变身时返回<id>，否则返回0。


dispbottom

dispbottom命令

作用：把消息显示在人物的聊天栏中

格式： | dispbottom <message>[,<char_id>];
参数：
<message> | 消息（字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）


distance

distance函数

作用：计算距离

格式：
（Eathena.Net + Jathena.Net）
distance(<account_id>[,<npc_name>])

（Eathena.Net）
distance(<x0>,<y0>,<x1>,<y1>)
参数：

<account_id> | 帐号ID（数值类型）
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
<x0>,<y0>,<x1>,<y1> | 两个坐标（数值类型）
说明：
（Eathena.Net + Jathena.Net）
用法1：返回玩家和NPC之间的距离
如果玩家和NPC不在同一地图上，则返回-1。

（Eathena.Net）
用法2：计算2点之间的距离。


divorce

divorce函数

作用：离婚处理

格式：
（Eathena.Net）
divorce()

（Jathena.Net）
divorce([<type>])
参数：

<type> 类型（数值类型，省略时为0）
说明：
（Eathena.Net）
如果离婚失败，则返回0。
如果离婚成功，则删除双方的结婚戒指，并返回1。

（Jathena.Net）
<type> = 0
进行离婚处理。对象为执行脚本的玩家，返回另一方的char_id。
未结婚的话会离婚失败，此时返回0。
如果离婚成功，则删除双方的结婚戒指。

<type> = 1
只返回另一方的char_id，而不进行离婚处理。


doevent

doevent命令

作用：执行事件

格式： | doevent <event>;
参数：
<event> | 事件名（字符串类型）
说明： | 执行事件名为<event>的事件。 玩家和其他NPC在会话的情况，则把事件放入队列，待会话结束后再执行。 队列的大小很小，所以可能会忽略掉连续触发的事件。 也可指定带有标签的事件，但此时不能忽略NPC名字。


donpcevent

donpcevent命令

作用：执行NPC事件

格式： | donpcevent <event>;
参数：
<event> | 事件名（字符串类型）
说明： | 执行无玩家触发的NPC事件。 也可指定带有标签的事件。如果忽略NPC名字的话，则能广播事件（执行所有NPC的这个事件。<例> "::OnEvent"）。


dropitem

dropitem命令

作用：使地面上出现物品

格式：
（Eathena.Net）
dropitem <item_id|item_name>,<count>,<map_name>,<x>,<y>;

（Jathena.Net）
dropitem <item_id>,<count>,<map_name>,<x>,<y>;
参数：

<item_id> | 物品ID（数值类型）
<item_id|item_name> | 物品ID|名字（数值|字符串类型）
<count> | 数量（数值类型）
<map_name> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
说明： <map_name>为this（区分大小写）时表示当前地图。


emotion

emotion命令

作用：出现一个表情

格式：
（Eathena.Net）
emotion <type>[,<target>];

（Jathena.Net）
emotion <type>[,<npc_name>];
参数：

<type> | 表情代码（数值类型。在const.txt中定义的"e_"开头的枚举）
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
<target> | 使用目标（数值类型。0:NPC、1:触发的玩家。默认为0）
说明： <type>可参考“表情代码一览表”。

（Jathena.Net）
注意：当指定的NPC不存在时，则变成触发NPC的玩家使用表情。


enableitems

enableitems命令

作用：允许人物使用所有物品

格式： | enableitems[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


enablenpc

enablenpc命令

作用：开启NPC

格式： | enablenpc[<npcname>];
参数：
<npcname> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | 让一个NPC有效，并同时让附近玩家执行OnTouch事件。


enablewaitingroomevent

enablewaitingroomevent命令

作用：让指定NPC聊天室的事件有效

格式： | enablewaitingroomevent[<npc_name>];
参数：
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | 如果达到了触发事件的人数，则马上执行事件。


enable_equip

enable_equip命令

作用：允许人物装备所有物品

格式： | enable_equip[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


enable_unequip

enable_unequip命令

作用：允许人物卸除所有物品

格式： | enable_unequip[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


end

end命令

作用：结束脚本

格式： end;


equip

equip命令

作用：装备上指定物品

格式： | equip <item_id>[,<char_id>];
参数：
<item_id> | 物品ID（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 当人物的随身物品存在物品<item_id>时，则装备上这个物品。


equippeditem

equippeditem函数

（Eathena.Net）格式和作用：（和isequipped函数一样）
（Jathena.Net）作用：检查人物是否装备了指定的装备或卡片

以下部分只适用于Jathena.Net：

格式： | equippeditem(<item_id>[,<charname>])
参数：
<item_id> | 物品ID（数值类型）
<charname> | 玩家名字（字符串类型，省略时表示自己）
说明： | 检查人物是否装备了物品ID为<item_id>的装备或卡片。 如果有装备上，则返回数量。如果人物不存在或没装备上，则返回0。


execsql

execsql命令

作用：执行无返回的SQL语句/存储过程

格式： | execsql <string>;
参数：
<string> | SQL语句/存储过程（字符串类型）


failedrefitem

failedrefitem命令

作用：把装备作精炼失败处理

格式： | failedrefitem <pos>[,<char_id>];
参数：
<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下 把装备作精炼失败处理，丢失此装备。


failedremovecards

failedremovecards命令

作用：拆除卡片失败

格式：
（Eathena.Net）
failedremovecards <pos>,<type>[,<char_id>];

（Jathena.Net）
failedremovecards <pos>,<type>[,<num>[,<char_id>]];
参数：

<pos> | 位置（数值类型）
<type> 如何处理（数值类型）
0 卡片和装备都损失
1 卡片损失
2 装备损失
3 没有任何损失
<num> | 卡片位置（数值类型。默认为0，表示全部卡片。1-4表示第几张卡片）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：铠甲
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下
<pos> = 11：箭矢


fakenpcname

fakenpcname命令

（Eathena.Net）格式和作用：（和setnpcdisplay函数一样）
（Jathena.Net）作用：改变NPC的名字和样子

以下部分只适用于Jathena.Net：

格式： | fakenpcname <npc_name>,<new_name>,<look>;
参数：
<npc_name> | NPC名字（字符串类型）
<new_name> | NPC新名字（字符串类型）
<look> | NPC外观代码（数值类型）


findstring

findstring函数

作用：检查<string>中是否包含<substring>

格式： | findstring(<string>,<substring>)
参数：
<string> | 字符串（字符串类型）
<substring> | 子字符串（字符串类型）
说明： | 如果<string>中包含了<substring>，则返回1。否则返回0。


flagemblem

flagemblem命令

作用：设置公会图标

格式： | flagemblem <guild_id>;
参数：
<guild_id> | 公会ID（数值类型）
说明： | 此命令仅对外观为722编号的NPC有效。


flagemblem_code

flagemblem_code命令

作用：设置某公会的图标为某验证码

格式： | flagemblem_code <guild_id>,<code>[,<style>];
参数：
<guild_id> | 公会ID（数值类型）
<code> | 6位验证码（字符串类型）
<style> | 生成验证码的样式（可叠加）： +1 加3条横向干扰线


getareadropitem

getareadropitem函数

（Eathena.Net）作用：取得指定区域地上的指定掉落物品数量
（Jathena.Net）作用：取得指定区域地上的掉落物品数量

格式：
（Eathena.Net）
getareadropitem(<map>,<x0>,<y0>,<x1>,<y1>,<item_id>)

（Jathena.Net）
getareadropitem(<map>,<x0>,<y0>,<x1>,<y1>)
参数：

<map> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 范围（数值类型）
<item_id> | 物品ID（数值类型）
说明： 地图名不存在时，返回-1。


getareamobs

getareamobs函数

作用：返回指定范围内的怪物数量

格式： | getareamobs(<gatname>,<x0>,<y0>,<x1>,<y1>)
参数：
<gatname> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 范围内的坐标（数值类型）
说明： | 如果<gatname>为this（区分大小写）的话，则表示当前地图。


getareausers

getareausers函数

作用：取得指定区域的人数

格式： getareausers(<gatname>,<x0>,<y0>,<x1>,<y1>)
参数：

<gatname> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 范围（数值类型）
说明： 地图名不存在时，返回-1。

（Jathena.Net）
<gatname>为this（区分大小写）的话，表示当前地图。


getarg

getarg函数

作用：取得参数

格式：
（Eathena.Net）
getarg(<index>[<default_value>])

（Jathena.Net）
getarg(<index>)
参数：

<index> | 参数的索引（数值类型，从0开始）
<default_value> | 默认值（数值/字符串类型）
说明： 取得参数。

在函数或子处理中取得参数。
<例> callsub L_SUB01,""hoge"",500,999;
则getarg(0)=""hoge"", getarg(1)=500, getarg(2)=999。

（Eathena.Net）
如果设置了默认值的情况下，则超出参数范围的时候，返回默认值的内容。
<例> callfunc "funcNPC",5,4,3;
则getarg(2,-1)=3, getarg(3,-1)=-1


getargcount

getargcount函数

作用：获取函数/子处理中参数的数量

格式： getargcount()


getarraysize

getarraysize命令

作用：取得数组的元素个数

格式： | getarraysize(<variable>)
参数：
<variable> | 数组/元素
说明： | 取得数组的元素个数。 如果不指定数组名，而指定数组元素的话，则假定在那个元素为止前的元素都有效。 <例> 数组@hoge为 1,2,3,4,5 的话，则： getarraysize(@hoge)=5, getarraysize(@hoge[10])=10


getbrokenid

getbrokenid函数

作用：取得损坏装备的物品ID

格式： | getbrokenid(<index>[,<char_id>])
参数：
<index> | 索引值（数值类型）
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： | 第1件损坏装备的<index>为0，第2件的<index>为1…… 如果没有损坏的装备，则返回0。 返回-1时，表示人物不存在。


getcartlist

getcartlist命令

作用：获取玩家手推车物品的详细资料

格式： | getcartlist[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 把玩家手推车物品的详细资料记录在以下变量数组中： @cartlist_id[] : 物品ID @cartlist_amount[] : 物品数量 @cartlist_equip[] : 如果装备了物品，则记录装备位置 @cartlist_refine[] : 物品精炼度 @cartlist_identify[] : 物品鉴定情况 @cartlist_attribute[] : 物品损坏情况 @cartlist_card1[] : 物品插入的卡片(第1张) @cartlist_card2[] : 物品插入的卡片(第2张) @cartlist_card3[] : 物品插入的卡片(第3张) @cartlist_card4[] : 物品插入的卡片(第4张) @cartlist_timestamp$[] : 物品时间戳 @cartlist_count : 物品种类


getcastledata

getcastledata函数

作用：取得公会秘密基地数据

格式： | getcastledata(<map>,<index>[,<event_name>])
参数：
<map> | 地图名字（字符串类型）
<index> | 数据库guild_castle表中列索引值（数值类型） 0 城堡ID 1 公会ID 2 商业度 3 防御度 4 商业投资次数 5 防御投资次数 6 nextTime 7 payTime 8 createTime 9 是否设置了卡普拉（未设置0, 已设置1） 10 是否设置了监护人1（未设置0, 已设置1） 11 是否设置了监护人2 12 是否设置了监护人3 13 是否设置了监护人4 14 是否设置了监护人5 15 是否设置了监护人6 16 是否设置了监护人7 17 是否设置了监护人8
<event_name> | 请求信息时执行的事件（字符串类型，可省略）
说明： | 如果指定了无效的<index>则返回0。


getcastlename

getcastlename函数

作用：取得公会秘密基地名称

格式： | getcastlename(<map>)
参数：
<map> | 地图名字（字符串类型）
说明： | 公会秘密基地的名字在castle_db.txt中定义。


getcharid

getcharid函数

作用：取得人物各种ID

格式： getcharid(<type>[,<charname>])
参数：

<type> | 参数（数值类型）
<charname> | 玩家名字（字符串类型，省略时表示自己）
说明： <type> = 0：char_id
<type> = 1：party_id
<type> = 2：guild_id
<type> = 3：account_id

（Eathena.Net）
<type> = 4：战场ID

指定的人物不存在时，返回0。

（Jathena.Net）
指定的人物不存在时，返回-1。


getcharname

getcharname函数

作用：取得人物名字

格式： | getcharname(<char_id>)
参数：
<char_id> | 人物的char_id（数值类型）
说明： | 根据人物的char_id取得人物名字。 人名不存在时则向char-server查询，使用next;后再次调用脚本的话，即可取得名字。 如果人物不存在，则返回空字符串。


getchildid

getchildid函数

作用：返回人物养子的char_id

格式： | getchildid([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


getelementofarray

getelementofarray函数

作用：取得数组元素的值

格式： | getelementofarray(<variable>,<index>)
参数：
<variable> | 数组
<index> | 元素索引（从0开始）
说明： | 取得数组<variable>中，索引为<index>的元素。 <例> 数组@hoge为 1,2,3,4,5 的话，则： getelementofarray(@hoge,0) = 1，作用跟@hoge[0]一样。


geteqdure

geteqdure函数

作用：返回装备耐久度（装备升级系统）

格式： | geteqdure(<pos>[,<char_id>])
参数：
<pos> | 位置（数值类型，从1-10）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下 返回-1时，表示<pos>错误或指定位置没有装备。


geteqexp

geteqexp函数

作用：返回装备经验（装备升级系统）

格式： | geteqexp(<pos>[,<char_id>])
参数：
<pos> | 位置（数值类型，从1-10）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下 返回-1时，表示<pos>错误或指定位置没有装备。


geteqlv

geteqlv函数

作用：返回装备等级（装备升级系统）

格式： | geteqlv(<pos>[,<char_id>])
参数：
<pos> | 位置（数值类型，从1-10）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下 返回-1时，表示<pos>错误或指定位置没有装备。


geteqmaxdure

geteqmaxdure函数

作用：返回装备耐久度上限（装备升级系统）

格式： | geteqmaxdure(<pos>[,<char_id>])
参数：
<pos> | 位置（数值类型，从1-10）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下 返回-1时，表示<pos>错误或指定位置没有装备。


getequipcardcnt

getequipcardcnt函数

作用：取得指定装备的卡片数

格式： getequipcardcnt(<pos>[,<char_id>])
参数：

<pos> | 位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：铠甲
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下
（Jathena.Net）
<pos> = 11：箭矢

返回-1时，表示指定人物不存在。


getequipcardid

getequipcardid函数

作用：返回指定位置装备的卡片ID

格式： getequipcardid(<pos>,<slot>[,<char_id>])
参数：

<pos> | 位置（数值类型）
<slot> | 第几洞（数值类型，从1-4）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下
（Jathena.Net）
<pos> = 11：箭矢

返回-1时，表示指定的人物不存在。
<pos>或<slot>超出范围时，返回0。


getequipid

getequipid函数

作用：取得装备的物品ID

格式： getequipid(<pos>[,<char_id>])
参数：

<Pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下

（Eathena.Net）
如果物品不存在，则返回0。
如果<pos>超出范围、指定位置没有装备、指定的人物不存在时，则返回-1。

（Jathena.Net）
<pos> = 11：箭矢

如果指定位置没有装备，则返回0。
如果指定人物不存在，则返回-1。


getequipisenableref

getequipisenableref函数

作用：判断装备能否精炼

格式： getequipisenableref(<pos>[,<char_id>])
参数：

<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下
（Jathena.Net）
<pos> = 11：箭矢

能精炼，则返回1，否则返回0。
如果人物不存在，则返回-1。


getequipisequiped

getequipisequiped函数

作用：检查指定位置是否有装备

格式： getequipisequiped(<pos>[,<char_id>])
参数：

<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下
（Jathena.Net）
<pos> = 11：箭矢

如果指定位置有装备，则返回1，没有装备则返回0。
如果人物不存在，则返回-1。


getequipisidentify

getequipisidentify函数

作用：判断装备是否已经鉴定

格式： getequipisidentify(<pos>[,<char_id>])
参数：

<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下

如果已经鉴定，则返回1，否则返回0。
如果人物不存在，则返回-1。

（Eathena.Net）
如果物品不存在，则返回0。

（Jathena.Net）
<pos> = 11：箭矢


getequipname

getequipname函数

作用：返回装备物品的名字

格式： getequipname(<pos>[,<char_id>])
参数：

<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下

如果指定位置没有装备、人物不存在、<pos>超出范围时，则返回""。

（Eathena.Net）
如果指定位置没有装备，则返回-1。
如果物品不存在时，则返回""。

（Jathena.Net）
<pos> = 11：箭矢


getequippercentrefinery

getequippercentrefinery函数

作用：取得装备精炼成功率

格式： getequippercentrefinery(<pos>[,<char_id>])
参数：

<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下

返回装备成功精炼到下一级的成功率（0-100）。
如果人物不存在，则返回-1。

（Eathena.Net）
如果物品不存在，则返回0。

（Jathena.Net）
<pos> = 11：箭矢


getequiprefinerycnt

getequiprefinerycnt函数

作用：取得装备的精炼值

格式： getequiprefinerycnt(<pos>[,<char_id>])
参数：

<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下

如果人物不存在，则返回-1。

（Eathena.Net）
如果物品不存在，则返回0。

（Jathena.Net）
<pos> = 11：箭矢


getequipweaponlv

getequipweaponlv函数

作用：取得装备等级

格式： getequipweaponlv(<pos>[,<char_id>])
参数：

<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下

返回武器等级，防具则返回0。
如果人物不存在，则返回-1。

（Eathena.Net）
如果物品不存在，则返回0。

（Jathena.Net）
<pos> = 11：箭矢


getexp

getexp命令

作用：获得Base/Job/Equip经验值

格式： | getexp <BaseExp>,<JobExp>[,<EquipExp>[,<char_id>]];
参数：
<BaseExp> | Base经验（数值类型）
<JobExp> | Job经验（数值类型）
<EquipExp> | Equip经验（数值类型，默认为0）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 注意：<BaseExp>、<JobExp>、<EquipExp>必须大于等于0。


getfatherid

getfatherid函数

作用：返回父亲的char_id

格式： getfatherid([<char_id>])
参数：

<char_id> 人物的char_id（数值类型，省略时表示自己）
说明： 没有父亲时，返回0。

（Eathena.Net）
人物不存在时，返回0。

（Jathena.Net）
人物不存在时，返回-1。


getgdavglv

getgdavglv函数

作用：返回公会成员平均等级

格式： | getgdavglv(<guild_id>)
参数：
<guild_id> | 公会ID（数值类型）
说明： | 公会不存在时返回-1。


getgdlv

getgdlv函数

作用：返回公会等级

格式： | getgdlv(<guild_id>)
参数：
<guild_id> | 公会ID（数值类型）
说明： | 公会不存在时返回-1。


getgdskilllv

getgdskilllv函数

作用：取得公会技能等级

格式：
（Eathena.Net）
getgdskilllv(<guild_id>,<skill_id|skill_name>)

（Jathena.Net）
getgdskilllv(<guild_id>,<skillid>)
参数：

<guild_id> | 公会ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skillid> | 技能ID（数值类型）
说明： 如果没有学会技能，则返回0。
如果指定公会不存在，则返回-1。


getgmlevel

getgmlevel函数

作用：取得人物GM等级

格式： | getgmlevel([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 指定人物不存在时，则返回-1。


getguildmaster

getguildmaster函数

作用：取得公会会长的名字

格式： getguildmaster(<guild_id>)
参数：

<guild_id> 公会ID（数值类型）
说明：
（Eathena.Net）
如果公会不存在，则返回"null"

（Jathena.Net）
如果公会不存在，则返回""


getguildmasterid

getguildmasterid函数

作用：取得公会会长的char_id

格式： | getguildmasterid(<guild_id>)
参数：
<guild_id> | 公会ID（数值类型）
说明： | 如果公会不存在或会长不存在，则返回0。


getguildname

getguildname函数

作用：取得公会名字

格式： getguildname(<guild_id>)
参数：

<guild_id> 公会ID（数值类型）
说明：
（Eathena.Net）
如果公会不存在，则返回"null"

（Jathena.Net）
如果公会不存在，则返回""


getinventorylist

getinventorylist命令

作用：获取玩家随身物品的详细资料

格式： | getinventorylist[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 把玩家随身物品的详细资料记录在以下变量数组中： @inventorylist_id[] : 物品ID @inventorylist_amount[] : 物品数量 @inventorylist_equip[] : 如果装备了物品，则记录装备位置 @inventorylist_refine[] : 物品精炼度 @inventorylist_identify[] : 物品鉴定情况 @inventorylist_attribute[] : 物品损坏情况 @inventorylist_card1[] : 物品插入的卡片(第1张) @inventorylist_card2[] : 物品插入的卡片(第2张) @inventorylist_card3[] : 物品插入的卡片(第3张) @inventorylist_card4[] : 物品插入的卡片(第4张) @inventorylist_timestamp$[] : 物品时间戳 @inventorylist_count : 物品种类


getitem

getitem命令

作用：取得物品

格式：
（Eathena.Net）
getitem <item_id|item_name>,<count>[,<account_id>];

（Jathena.Net）
getitem <itemid>,<count>[,<identify>,<account_id>];
参数：

<item_id|item_name> | 物品ID|名字（数值|字符串类型）
<count> | 取得数量（数值类型）
<identify> | 鉴定状态（0或1，可省略）
<account_id> | 人物的帐号ID（数值类型，省略时表示自己）
说明： 让人物获得指定物品。
<item_id|item_name>可以为字符串类型（name,jname）。
但是物品名字是根据item_db.txt等文件，所以除测试目的外不要使用。


getitem2

getitem2命令

作用：取得物品

格式： | getitem2 <item_id|item_name>,<count>,<identify>,<refine>,<attribute>,<card1>,<card2>,<card3>,<card4>[,<account_id>];
参数：
<item_id|item_name> | 物品ID|名字（数值|字符串类型）
<count> | 取得数量（数值类型）
<identify> | 鉴定状态（0或1，可省略）
<refine> | 精炼度（数值类型）
<attribute> | 物品状态（数值类型）
<card1> | 第一张卡片的代码（如果是制作物品，是装备则为255，是非装备则为254）
<card2> | 第二张卡片的代码（如果是制作武器，则为星星的角的数量和属性。公式：星星的角的数量(0~3)*5*256+属性(无:0 水:1 土:2 火:3 风:4)）
<card3> | 第三张卡片的代码（如果是制作物品，则为者的char_id的低位2字节）
<card4> | 第四张卡片的代码（如果是制作物品，则为者的char_id的高位2字节）
<account_id> | 人物的帐号ID（数值类型，省略时表示自己）
如果要获得刻有自己名字的物品，那么card3填写getcharid(0)&0xffff，card4填写(getcharid(0)>>16)&0xffff。
说明： | 让人物获得物品。 <item_id|item_name>可以为字符串类型（name,jname）。 但是物品名字是根据item_db.txt等文件，所以除测试目的外不要使用。


getitemexp

getitemexp函数

作用：返回某种物品升级到item_lv时需要的经验值

格式： | getitemexp(<item_id>,<item_lv>)
参数：
<item_id> | 物品ID（数值类型）
<item_lv> | 装备等级（数值类型）
说明： | 返回-1时，表示人物不存在或<item_lv>超出范围。


getiteminfo

getiteminfo函数

作用：取得指定物品的详细资料

格式： getiteminfo(<item_id>,<type>)
参数：

<item_id> 物品ID（数值类型）
<type> 情报类型（数值类型）

（Eathena.Net）
0 - value_buy（购买价格）
1 - value_sell（卖价）
2 - type（类型）
3 - maxchance（最大掉率。单位为0.01%。如果是0，表示怪物不掉落此物品。如果是10000，表示此物品在NPC商店有出售）
4 - sex（性别）
5 - loc（位置）
6 - weight（重量）
7 - ATK（攻击力）
8 - DEF（防御力）
9 - Range（射程）
10 - Slot（洞数）
11 - View（外观）
12 - wLV（武器等级）
13 - eLV（装备等级）
14 - view_id（在item_avail.txt中设定的替换外观。没有设定的话为0）

（Jathena.Net）
1 - Name（英文名称）
2 - Jname（日文名字/中文名称）
3 - Type（类型）
4 - Price（买价）
5 - Sell（卖价）
6 - Weight（负重）
7 - ATK（攻击力）
8 - DEF（防御力）
9 - Range（射程）
10 - Slot（洞数）
11 - Job（职业）
12 - Gender（性别）
13 - Loc（位置）
14 - wLV（武器等级）
15 - eLV（装备等级）
16 - View（外观）
17 - Refine（可否精炼）
18 - Type2（Athena.Net的type属性）
19 - CustomRate（Athena.Net的自定义掉率）
说明： 返回-1时，表示物品不存在或<type>错误。


getitemmaxdure

getitemmaxdure函数

作用：返回某种物品在item_lv级时的最大耐久度

格式： | getitemmaxdure(<item_id>,<item_lv>)
参数：
<item_id> | 物品ID（数值类型）
<item_lv> | 装备等级（数值类型）
说明： | 返回-1时，表示人物不存在或<item_lv>超出范围。


getitemname

getitemname函数

作用：取得物品名字

格式： getitemname(<itemid>)
参数：

<itemid> 物品ID（数值类型）
说明： 返回item_db.txt的jname列的名字。

（Eathena.Net）
物品不存在时，返回"null"

（Jathena.Net）
物品不存在时，返回""


getitemslot

getitemslot函数

作用：返回指定id物品的洞数

格式： | getitemslot(<itemid>)
参数：
<itemid> | 物品ID（数值类型）
说明： | 物品不存在时，返回-1。


getlook

getlook函数

作用：获取角色造型

格式： | getlook(<type>[,<char_id>])
参数：
<type> | 外观类型（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 查看指定类型的人物外观。 <type> = 1：发型 <type> = 2：武器 <type> = 3：头下 <type> = 4：头上 <type> = 5：头中 <type> = 6：发色 <type> = 7：服色 <type> = 8：盾牌 <type> = 9：鞋子 指定人物不存在或<type>超出范围时，返回-1。 注意，<type> = 9不会发生任何效果，只是客户端保留了。


getmapmobs

getmapmobs函数

作用：返回指定地图的怪物数量

格式： | getmapmobs(<gatname>)
参数：
<gatname> | 地图名（字符串类型）
说明： | 如果<gatname>为this（区分大小写）的话，则表示当前地图。


getmapname

getmapname函数

作用：返回人物所在的地图名

格式： | getmapname(<char_name>)
参数：
<char_name> | 玩家名字（字符串类型）
说明： | 人物不存在时，则返回""


getmapusers

getmapusers函数

作用：取得指定地图的人数

格式： getmapusers(<gatname>)
参数：

<gatname> 地图名（字符串类型）
说明： 地图名不存在时，返回-1。

（Jathena.Net）
<gatname>为this（区分大小写）的话，表示当前地图。


getmapxy

getmapxy函数

作用：取得对象的地图名和坐标

格式： getmapxy(<output_mapname>,<output_x>,<output_y>,<type>[,<object_name>])
参数：

<output_mapname> | 用于储存对象地图名的变量（字符串类型的变量）
<output_x>,<output_y> | 用于储存对象坐标的变量（数值类型的变量）
<type> 类型（数值类型）
0 - 玩家
1 - NPC
2 - PET
3 - MOB（未实装）
4 - 人工生命体
<object_name> | 单位的名字（字符串类型，省略时表示当前PC、NPC、PET或人工生命体）
说明： 如果成功获取，则返回0，否则返回-1。
特别是对设置为duplicate而没有放入地图的NPC使用需要地图情报的命令或函数的话会导致服务器当掉，请务必使用这个函数前对<output_mapname>进行条件判断

（Jathena.Net）
如果NPC不在任何地图上，则把“-”保存在<output_mapname>中。


getmobassistcount

getmobassistcount函数

作用：返回魔魂数量

格式： | getmobassistcount(<char_id>)
参数：
<char_id> | 主人的char_id（数值类型）
说明： | 人物不存在时返回-1


getmobassistid

getmobassistid函数

作用：返回召唤的魔魂的单位ID（unit_id）

格式： | getmobassistid(<char_id>,<index>)
参数：
<char_id> | 主人的char_id（数值类型）
<index> | 魔魂的索引（数值类型。从0开始）
说明： | 人物不存在或数量为0时，返回-1


getmobdata

getmobdata函数

作用：取得指定怪物的属性

格式： getmobdata(<unit_id>,<type>)
参数：

<unit_id> | 每个单位的唯一ID，就是用GM外观点右键看到的GID（数值类型）
<type> | 类型（数值类型）
说明：
（Eathena.Net）
<type>列表：
1 : class
2 : name
3 : hp
4 : max_hp
5 : master_id
6 : map_name
7 : x
8 : y
9 : speed
10 : mode
11 : ai
12 : size
13 : option
14 : opt1
15 : opt2
16 : opt3
17 : view_sex
18 : view_class
19 : view_hair_style
20 : view_hair_color
21 : view_head_bottom
22 : view_head_mid
23 : view_head_top
24 : view_cloth_color
25 : view_shield
26 : view_weapon
27 : view_dead_sit
28 : dir
29 : aggressive

（Jathena.Net）
<type>列表：
1 : class
2 : name
3 : hp
4 : master_id
5 : map_name
6 : x
7 : y
8 : speed
9 : mode
10 : view_size
11 : option
12 : option1
13 : option2
14 : option3

注意：name和map_name是字符串类型，其他class、hp等是数值类型。
怪物不存在时返回-1


getmobinfo

getmobinfo函数

作用：取得指定怪物的详细资料

格式： getmobinfo(<mob_id>,<type>)
参数：

<mob_id> | 怪物ID（数值类型）
<type> | 情报类型（数值类型）
说明：
（Eathena.Net）
<type>列表：
1：sprite（客户端文件名）
2：name（英文名字）
3：jname（中文名字）
4：lv（等级）
5：max_hp（最大HP）
6：max_sp（最大SP）
7：base_exp（Base经验）
8：job_exp（Job经验）
9：range（射程距离1）
10：atk1（攻击力1）
11：atk2（攻击力2）
12：DEF（物理防御）
13：MDEF（魔法防御）
14：Str
15：Agi
16：Vit
17：Int
18：Dex
19：Luk
20：range2（指定人物攻击技能的范围）
21：range3（指定地面攻击技能的范围）
22：Scale（体型[0:小、1:中、2:大]）
23：Race（种族[0:无形、1:不死、2:动物、3:植物、4:昆虫、5:鱼贝、6:恶魔、7:人形、8:天使、9:龙族]）
24：Element（属性[0:无、1:水、2:地、3:火、4:风、5:毒、6:圣、7:暗、8:念、9:不死；20:属性等级1、40:等级2、60:等级3、80:等级4]）
25：Mode（模式[0:固定、+1:移动、+2:捡物、+4:看到隐身、+8:群攻、+16:咏唱反击、+32:BOSS属性、+64:草类、+128:主动攻击]）
26：Speed（速度）
27：ADelay（基本攻击速度，数值越小速度越快）
28：aMotion（攻击前延迟）
29：dMotion（攻击后延迟）
30：mexp（MVP经验）
31：mexpper（MVP经验取得机率[万分率]）
32：MVP1id（MVP物品1）
33：MVP1per（MVP物品1的掉率）
34：MVP2id（MVP物品2）
35：MVP2per（MVP物品2的掉率）
36：MVP3id（MVP物品3）
37：MVP3per（MVP物品3的掉率）
38：Drop1id（掉落物品1）
39：Drop1per（掉落物品1的掉率）
40：Drop2id（掉落物品2）
41：Drop2per（掉落物品2的掉率）
42：Drop3id（掉落物品3）
43：Drop3per（掉落物品3的掉率）
44：Drop4id（掉落物品4）
45：Drop4per（掉落物品4的掉率）
46：Drop5id（掉落物品5）
47：Drop5per（掉落物品5的掉率）
48：Drop6id（掉落物品6）
49：Drop6per（掉落物品6的掉率）
50：Drop7id（掉落物品7）
51：Drop7per（掉落物品7的掉率）
52：Drop8id（掉落物品8）
53：Drop8per（掉落物品8的掉率）
54：Drop9id（掉落物品9）
55：Drop9per（掉落物品9的掉率）
56：DropCardid（掉卡）
57：DropCardper（掉卡掉率）
58：EquipExp（Athena.Net的装备经验）

（Jathena.Net）
<type>列表：
1：Name（英文名称）
2：Jname（日文名字/中文名称）
3：Lv（等级）
4：MaxHP（最大HP）
5：MaxSP（最大SP）
6：BaseExp（Base经验）
7：JobExp（Job经验）
8：Range1（射程距离1）
9：ATK1（攻击力1）
10：ATK2（攻击力2）
11：DEF（物理防御）
12：MDEF（魔法防御）
13：Str
14：Agi
15：Vit
16：Int
17：Dex
18：Luk
19：Range2（指定人物攻击技能的范围）
20：Range3（指定地面攻击技能的范围）
21：Scale（体型[0:小、1:中、2:大]）
22：Race（种族[0:无形、1:不死、2:动物、3:植物、4:昆虫、5:鱼贝、6:恶魔、7:人形、8:天使、9:龙族]）
23：Element（属性[0:无、1:水、2:地、3:火、4:风、5:毒、6:圣、7:暗、8:念、9:不死；20:属性等级1、40:等级2、60:等级3、80:等级4]）
24：Mode（模式[0:固定、1:移动、2:捡物、4:看到隐身、8:群攻、16:咏唱反击、32:BOSS属性、64:草类、128:主动攻击]）
25：Speed（速度）
26：ADelay（基本攻击速度，数值越小速度越快）
27：aMotion（攻击前延迟）
28：dMotion（攻击后延迟）
29：Drop1id（掉落物品1）
30：Drop1per（掉落物品1的掉率）
31：Drop2id（掉落物品2）
32：Drop2per（掉落物品2的掉率）
33：Drop3id（掉落物品3）
34：Drop3per（掉落物品3的掉率）
35：Drop4id（掉落物品4）
36：Drop4per（掉落物品4的掉率）
37：Drop5id（掉落物品5）
38：Drop5per（掉落物品5的掉率）
39：Drop6id（掉落物品6）
40：Drop6per（掉落物品6的掉率）
41：Drop7id（掉落物品7）
42：Drop7per（掉落物品7的掉率）
43：Drop8id（掉落物品8）
44：Drop8per（掉落物品8的掉率）
45：Drop9id（掉落物品9）
46：Drop9per（掉落物品9的掉率）
47：Drop10id（掉落物品10）
48：Drop10id（掉落物品10的掉率）
49：MEXP（MVP经验）
50：MExpPer（MVP经验取得机率[万分率]）
51：MVP1id（MVP物品1）
52：MVP1per（MVP物品1的掉率）
53：MVP2id（MVP物品2）
54：MVP2per（MVP物品2的掉率）
55：MVP3id（MVP物品3）
56：MVP3per（MVP物品3的掉率）
57：Equip_Exp（Athena.Net的装备经验）

返回-1时，表示怪物不存在或<type>不正确。


getmotherid

getmotherid函数

作用：返回母亲的char_id

格式： getmotherid([<char_id>])
参数：

<char_id> 人物的char_id（数值类型，省略时表示自己）
说明： 没有母亲时，返回0。

（Eathena.Net）
人物不存在时，返回0。

（Jathena.Net）
人物不存在时，返回-1。


getnpcid

getnpcid函数

作用：取得npcid

格式： | getnpcid([<npc_name>])
参数：
<npc_name> | NPC名字（字符串类型。省略时为当前NPC）
说明： | NPC不存在时，返回-1。


getnpctimer

getnpctimer函数

作用：取得NPC计时器的信息

格式： | getnpctimer(<type>[,<npc_name>])
参数：
<type> | 类型（数值类型）
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | <type> = 0：当前NPC计时器的数值 <type> = 1：当前的计时状态（0-停止、1-运行） <type> = 2：返回OnTimerXXXX标签的数量


getpartnerid

getpartnerid函数

作用：返回人物伴侣的char_id

格式： | getpartnerid([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


getpartyleader

getpartyleader函数

（Eathena.Net）作用：取得队长的信息
 （Jathena.Net）作用：取得队长的名字

格式：
（Eathena.Net）
getpartyleader(<party_id>[,<type>])

（Jathena.Net）
getpartyleader(<party_id>)
参数：

<party_id> | 队伍ID（数值类型）
<type> | 类型（数值类型，默认为0）
说明：
（Eathena.Net）
<type> = 1：返回队长的account_id
<type> = 2：返回队长的char_id
<type> = 3：返回队长的职业代码
<type> = 4：返回队长所在地图的名字
<type> = 5：返回队长的等级
<type> = 其他：返回队长的名字

队伍不存在或队长不存在时，如果指定了<type>返回-1，如果没指定<type>则返回"null"字符串。

（Jathena.Net）
队伍不存在、或队长不存在时返回""


getpartymaster

getpartymaster函数

格式和作用：（和getpartyleader函数一样）


getpartymember

getpartymember命令

作用：获取队伍里队员的信息

格式：
（Eathena.Net）
getpartymember <party_id>[,<type>];

（Jathena.Net）
getpartymember <party_id>;
参数：

<party_id> | 队伍ID（数值类型）
<type> | 类型（数值类型，默认为0）
说明：
（Eathena.Net）
<type> = 1：把队员的char_id记录到$@partymembercid[]数组中
<type> = 2：把队员的account_id记录到$@partymemberaid[]数组中
其他情况：把队员的名字记录到$@partymembername$[]数组中

（Jathena.Net）
把队员的名字记录到$@partymembername$[]数组中

队伍人数则储存在$@partymembercount变量中。


getpartyname

getpartyname函数

作用：取得队伍名字

格式： getpartyname(<party_id>)
参数：

<party_id> 队伍ID（数值类型）
说明：
（Eathena.Net）
如果队伍不存在，则返回"null"

（Jathena.Net）
如果队伍不存在，则返回""


getpcxy

getpcxy函数

作用：取得玩家的位置

格式： | getpcxy(<char_id>,<type>)
参数：
<char_id> | 玩家的char_id（数值类型）
<type> | 参数类型（数值类型）
说明： | <type> = 1：返回地图名 <type> = 2：返回x坐标 <type> = 3：返回y坐标 人物不存在或<type>错误时，返回-1。


getpetinfo

getpetinfo函数

作用：获取携带宠物详细信息

格式： getpetinfo(<type>[,<char_id>])
参数：

<type> 类型（数值类型）
0 - pet_id（宠物唯一的ID）
1 - pet_class（mob_id）
2 - pet_name（宠物名字）
3 - friendly（亲密度）
4 - hungry（饥饿度）

（Eathena.Net）
5 - rename_flag（更名标识。0表示可以为宠物改名）
<char_id> 人物的char_id（数值类型，省略时表示自己）
说明：
（Eathena.Net）
如果<type>不为2时，人物没有携带宠物或者人物不存在时，返回0。
如果<type>为2时，人物没有携带宠物或者人物不存在时，返回"null"字符串。
<type>超出范围时，返回0。

（Jathena.Net）
人物没有携带宠物、或者人物不存在时，返回0。


getrepairableitemcount

getrepairableitemcount函数

作用：获取损坏装备的数量

格式： | getrepairableitemcount([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


getsavepoint

getsavepoint函数

作用：返回玩家的储存点

格式： getsavepoint(<type>[,<char_id>])
参数：

<type> 类型（数值类型）
0 - 返回地图名
1 - 返回x坐标
2 - 返回y坐标
<char_id> 人物的char_id（数值类型，省略时表示自己）
说明：
（Eathena.Net）
人物不存时或<type>超出范围时，返回0。

（Jathena.Net）
人物不存在或<type>超出范围时，返回-1。


getscrate

getscrate函数

作用：获取异常状态机率

格式： getscrate(<type>,<rate>[,<target_id>])
参数：

<type> 异常状态的编号（数值类型）

（Eathena.Net）
请参考skill.h或check_option的项目

（Jathena.Net）
请参考skill.h或check_option的项目
<rate> | 基本概率（数值类型）
<target_id> | 单位ID（数值类型，省略时为自己）
说明： 计算玩家以<rate>为基本概率，陷入异常状态的机率。


getskilllist

getskilllist命令

作用：获取玩家技能的详细资料

格式： | getskilllist[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 把玩家技能的详细资料记录在以下变量数组中： @skilllist_id[] : 技能ID @skilllist_lv[] : 技能最高等级 @skilllist_flag[] : 技能的标识（0-永久学会技能、1-暂时取得） @skilllist_count : 技能种类数 当技能超过128的时候，会变成以2维数组排列。 <例> @skilllist_count为132时，会被赋值到@skilllist_id[1][3]。


getskilllv

getskilllv函数

作用：取得人物技能等级

格式：
（Eathena.Net）
getskilllv(<skill_id|skill_name>[,<char_id>])

（Jathena.Net）
getskilllv(<skillid>[,<char_id>])
参数：

<skillid> | 技能ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 如果没有学会技能，则返回0。
如果指定人物不存在，则返回-1。


getsqlcols

getsqlcols函数

作用：返回SQL缓存的列数

格式： | getsqlcols([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型）
说明： | 如省略了<char_id>或指定的人物不存在，则返回全局SQL缓存，否则返回个人SQL缓存。


getsqlinfo

getsqlinfo函数

作用：返回SQL缓存信息

格式： | getsqlinfo(<type>[,<char_id>])
参数：
<type> | 情报类型（字符串类型）
<char_id> | 人物的char_id（数值类型）
说明： | <type> = 1：返回SQL结果的行数 <type> = 2：返回SQL结果的列数 如果没有缓存或<type>超出范围，则返回-1。 如果指定了<char_id>，则从个人SQL缓存中查询，否则会从全局SQL缓存中查询。


getsqlrows

getsqlrows函数

作用：返回SQL缓存的行数

格式： | getsqlrows([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型）
说明： | 如省略了<char_id>或指定的人物不存在，则返回全局SQL缓存，否则返回个人SQL缓存。


getstrlen

getstrlen函数

作用：返回字符串的长度

格式： | getstrlen(<string>)
参数：
<string> | 字符串（字符串类型）


gettime

gettime函数

作用：取得当前时间

格式： | gettime(<type>)
参数：
<type> | 类型（数值类型） 1 - Sec（0～59） 2 - Min（0～59） 3 - Hour（0～23） 4 - WeekDay（0～6） 5 - MonthDay（01～31） 6 - Month（01～12） 7 - Year（20xx） 8 - Year Day（1-366）
说明： | <type>超出范围时，返回-1。


gettimestr

gettimestr函数

作用：取得时间字串

格式： | gettimestr(<format>,<maxlen>)
参数：
<format> | 格式
<maxlen> | 字符串最大长度
说明： | 以特定格式返回当前时间。 格式一览： %a 转换为所在地区的星期几的省略名称。 %A 转换为所在地区的星期几的未省略名称。 %b 转换为所在地区的月份的省略名称。 %B 转换为所在地区的月份的未省略名称。 %c 转换为所在地区所适合表达的日期及事件的表现形式。 %d 转换为用10进制数表示的月内的日期（01～31）。 %H 转换为用10进制数表达的（24小时制）时间（00～23）。 %I 转换为用10进制数表达的（12小时制）时间（01～12）。 %j 转换为用10进制数表达的年内的日期(001～366）。 %m 转换为用10进制数表达的月份（01～12）。 %M 转换为用10进制数表达的分钟（00～59）。 %p 转换为所在地区用12小时制时表示上午还是下午时所用的记号。 %S 转换为用10进制数表达的秒数（00～61）。 %U 转换为用10进制数表达的年内的第几周（00～53）（最初的星期天为第一周的第一天）。 %w 转换为用10进制数表达的星期几（0～6），星期天为0。 %W 转换为用10进制数表达的年内的第几周（00～53）（最初的星期一为第一周的第一天）。 %x 转换为所在地区最适合的日期表现形式。 %X 转换为所在地区最适合的时间表现形式。 %y 转换为用10进制数表示的西历年份的下2位。 %Y 转换为用10进制数表示的西历年份。 %Z 转换为本地时间的名字或缩写，或者没有本地时间的话转换为文字以外的东西。转换为%% %。 <format>指定的格式和C语言的strftime函数一样。在http://www.delorie.com/gnu/docs/glibc/libc_437.html有详细解释。 <例> 假设时间日期为1999/12/15 23:35.55的话 gettimestr("%Y/%m/%D %p %I:%M.%s",100)=1999/12/15 PM 11:35.55


gettimetick

gettimetick函数

作用：取得时间周期

格式： | gettimetick(<type>)
参数：
<type> | 类型（数值类型） 0 - 返回系统经过的毫秒数 1 - 把当前时间转换为秒 2 - 从1970-01-01 00:00到现在经过了多少秒
说明： | 如果<type>不正确，则<type>自动变为0。


getusers

getusers函数

作用：统计人数

格式： | getusers(<type>)
参数：
<type> | 类型（数值类型）
说明： | <type> = 0：玩家所在地图的在线人数 <type> = 1：服务器人数（即登陆人数） <type> = 8：NPC所在地图的在线人数


getusersname

getusersname命令

（Eathena.Net）作用：列出在线玩家名单在NPC对话窗口中（类似@who）
（Jathena.Net）作用：列出在线玩家名单（类似@who）

格式： getusersname;
说明：
（Eathena.Net）
每屏显示10名玩家，然后按next显示下一页。

（Jathena.Net）
显示在聊天信息窗口中


getvariableofnpc

getvariableofnpc函数

作用：返回NPC变量的引用

格式： getvariableofnpc(<variable>,<npc_name>)
参数：

<variable> NPC变量

（Eathena.Net）
'变量或.变量

（Jathena.Net）
'变量
<npc_name> NPC名字（字符串类型）
说明： 这个函数可以与getelementofarray函数配合使用。

<例>
set 'v,getvariableofnpc('var,"TargetNPC"); //设置'v变量的值为NPC：TargetNPC的变量'var
set getvariableofnpc('var,"TargetNPC"),1; //设置NPC：TargetNPC的变量'var的值为1

<例> 将名字为"test"的NPC的变量'flag[1]设置为3的方法有：
[1]: set getelementofarray(getvariableofnpc('flag,"test"),1), 2;
[2]: set getvariableofnpc(getelementofarray('flag,1),"test"), 2;
[3]: set getvariableofnpc('flag[1],"test"), 2;


getwaitingpcid

getwaitingpcid命令

作用：获取聊天室内玩家的account_id

格式： | getwaitingpcid <array>[,<npc_name>];
参数：
<array> | 数组变量（数值类型）
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | 把聊天室内的玩家的account_id（帐号ID）保存在<array>的数组中。 如果指定了<array>的索引号，则从指定索引处开始保存。


getwaitingroomstate

getwaitingroomstate函数

作用：取得聊天室状态

格式： | getwaitingroomstate(<type>,[<npc_name>])
参数：
<type> | 类型（数值类型）
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | <type> = 0：进入聊天室的人数（数值类型） <type> = 1：聊天室的人数上限（数值类型） <type> = 2：触发聊天室事件的人数（数值类型） <type> = 3：聊天室事件是否有效（数值类型） <type> = 4：聊天室标题（字符串类型） <type> = 5：聊天室密码（字符串类型） <type> = 6：聊天室zeny条件（数值类型） <type> = 7：聊天室BaseLv下限（数值类型） <type> = 8：聊天室BaseLv上限（数值类型） <type> = 9：可进入聊天室的职业（数值类型） <type> = 10：可进入聊天室的进阶标识(upper)（数值类型） <type> = 16：聊天室的事件名（字符串类型） <type> = 32：聊天室是否满人（数值类型） <type> = 33：是否达到了触发聊天室事件的人数（数值类型） <type>不正确时返回-1。


getweaponinfo

getweaponinfo函数

作用：获得制作武器的信息

格式： getweaponinfo(<pos>,<type>[,<char_id>])
参数：

<pos> | 位置（数值类型）
<type> 类型（数值类型）
1 - 返回制作者的char_id
2 - 返回星星的角的数量
3 - 返回武器属性(无-0、水-1、土-2、火-3、风-4)
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下
（Jathena.Net）
<pos> = 11：箭矢

返回-1时，表示人物不存在或<pos>范围错误。


get_db_savetype

get_db_savetype函数

作用：取得数据库储存方式

格式： | get_db_savetype()
说明： | 返回1：MySQL储存 返回2：MSSQL储存 返回3：Access储存


get_maxrefine

get_maxrefine函数

作用：获取battle_athena.conf中的max_refine选项的设定值

格式： get_maxrefine()


globalmes

globalmes命令

作用：让NPC说话

格式： | globalmes <mes>[,<npc_name>];
参数：
<mes> | 信息（字符串类型）
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）


gmcommand

gmcommand命令

作用：强制使用GM指令

格式： | gmcommand <command>[,<char_id>];
参数：
<command> | 完整的命令（字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <例> gmcommand "@who",2000001;


goto

goto命令

作用：跳转命令

格式： | goto <label>;
参数：
<label> | 标签
说明： | 从<label>开始执行脚本。


guildgetexp

guildgetexp命令

作用：获得公会经验

格式： | guildgetexp <exp>[,<guild_id>];
参数：
<exp> | 经验值（数值类型）
<guild_id> | 公会ID（数值类型，省略时表示当前玩家的公会）


guildid2name

guildid2name函数

作用：guild_id -> 公会名字

格式： | guildid2name(<guild_id>)
参数：
<guild_id> | 公会ID（数值类型）
说明： | 公会不存在时返回空字符串。


guildopenstorage

guildopenstorage函数

作用：打开公会仓库

格式： guildopenstorage([<char_id>])
参数：

<char_id> 人物的char_id（数值类型，省略时表示自己）
说明： 返回2：人物不属于公会
返回1：公会的其他成员正在使用仓库
返回0：成功打开公会仓库
返回-1：指定的人物不存在

（Eathena.Net）
GM权限不允许打开时，返回1


guildskill

guildskill命令

（Eathena.Net）作用：学会公会技能
（Jathena.Net）作用：学会/删除公会技能

格式：
（Eathena.Net）
guildskill <skill_id|skill_name>,<skilllv>[,<char_id>];

（Jathena.Net）
guildskill <skillid>,<skilllv>[,<flag>[,<guild_id>]];
参数：

<skillid> | 技能ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skilllv> | 技能LV（数值类型）
<flag> | 标识（数值类型，省略时为0）
<guild_id> | 公会ID（数值类型，省略时表示当前使用脚本的公会）
<char_id> | 人物ID（数值类型，省略时表示当前人物的公会）
说明： <flag> = 0：消耗公会技能点
<flag> = 1：不消耗公会技能点

<skilllv>设置为0时，表示删除技能。


gvgoff

gvgoff命令

作用：关闭GVG模式

格式： | gvgoff <gatname>;
参数：
<gatname> | 地图名（字符串类型）
说明： | 把<gatname>地图的GVG模式关闭。


gvgon

gvgon命令

作用：开启GVG模式

格式： | gvgon <gatname>;
参数：
<gatname> | 地图名（字符串类型）
说明： | 把<gatname>地图设置为GVG模式。


heal

heal命令

作用：恢复HP/SP

格式： | heal <hp>,<sp>[,<char_id>];
参数：
<hp> | 恢复的HP量（数值类型）
<sp> | 恢复的SP量（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）


hideoffnpc

hideoffnpc命令

作用：开启NPC

格式： | hideoffnpc[<npcname>];
参数：
<npcname> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | 显示隐匿状态的NPC，并同时让附近玩家执行OnTouch事件。


hideonnpc

hideonnpc命令

作用：让NPC变成隐匿状态

格式： | hideonnpc[<npcname>];
参数：
<npcname> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | 让NPC变成隐匿状态，同时让NPC无效。


homunid2name

homunid2name函数

作用：homun_id -> 人工生命体名字

格式： | homunid2name(<homun_id>)
参数：
<homun_id> | 人工生命体ID（数值类型）
说明： | 人工生命体不存在时返回空字符串。


initnpctimer

initnpctimer命令

作用：初始化NPC计时器

格式：
（Eathena.Net）
initnpctimer <npc_name>,<flag>;
initnpctimer <npc_name>;
initnpctimer <flag>;

（Jathena.Net）
initnpctimer[<npc_name>];
参数：

<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
<flag> | 是否触发玩家（数值类型。默认为0）
说明： 初始化NPC计时器的时间为0。
NPC计时器是用OnTimerXXXX这种标签形式的。
<例> OnTimer1000: <= 1秒后, OnTimer30000: <= 30秒后


input

input命令

作用：输入

格式：
（Eathena.Net）
input <variable>[,<min>[,<max>]];

（Jathena.Net）
input[<variable>];
参数：

<variable> | 变量（可省略）
<min> | input时可输入的最小数值（可省略。默认为script_athena.conf中的input_min_value设置）
<max> | input时可输入的最大数值（可省略。默认为script_athena.conf中的input_max_value设置）
说明： 打开输入窗口，把值传入<variable>中。
根据变量类型（数值或字符串）的不同，自动打开相应的输入窗口。

（Eathena.Net）
如果输入的数值大于<max>则返回1。如果输入的数值小于<min>则返回-1。返回0表示其他情况。
对于字符串来说，如果字符串比<max>长则返回1，比<min>小则返回-1，其他情况返回0。

（Jathena.Net）
在省略<variable>的情况下，会打开数值类型的输入窗口。输入完毕后会自动丢弃输入数据。


isday

isday函数

作用：检查现在是否早上

格式： | isday()
说明： | 如果是早上，则返回1。否则返回0。


isequipped

isequipped函数

作用：检查人物是否装备了所有指定的装备或卡片

格式： | isequipped(<item1>[,<item2>[,<item3>....[,<itemn>]]])
参数：
<item1>,<item2>,<item3>...<itemn> | 装备/卡片ID（数值类型）


isloggedin

isloggedin函数

作用：检查人物是否在线

格式：
（Eathena.Net）
isloggedin(<account_id>[,<char_id>])

（Jathena.Net）
isloggedin(<account_id>)
参数：

<account_id> | 人物的帐号ID（数值类型）
<char_id> | 人物的char_id（数值类型）
说明： 检查指定ID的人物是否登陆到这个MAP服务器。

（Eathena.Net）
如果指定了<char_id>，则增加判断人物的char_id。


isnight

isnight函数

作用：检查现在是否夜晚

格式： | isnight()
说明： | 如果是夜晚，则返回1。否则返回0。


ispartneron

ispartneron函数

作用：检查人物的伴侣是否在线

格式： ispartneron([<char_id>])
参数：

<char_id> 人物的char_id（数值类型，省略时表示自己）
说明： 返回1时，表示人物的伴侣在线。
返回0时，表示人物的伴侣不在线。

（Eathena.Net）
人物未婚或指定人物不存在 时，返回0

（Jathena.Net）
人物未婚或指定人物不存在 时，返回-1


itemheal

itemheal命令

作用：恢复HP/SP

格式： | itemheal <hp>,<sp>[,<char_id>];
参数：
<hp> | 恢复的HP量（数值类型）
<sp> | 恢复的SP量（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 与heal不同的是，<hp>、<sp>恢复量会受vit、int和技能的补正。


itemid2name

itemid2name函数

作用：item_id -> 物品名字

格式： | itemid2name(<item_id>)
参数：
<item_id> | 物品ID（数值类型）
说明： | 物品不存在时返回空字符串。


itemskill

itemskill命令

作用：用物品使用技能

格式：
（Eathena.Net）
itemskill <skill_id|skill_name>,<skilllv>;

（Jathena.Net）
itemskill <skillid>,<skilllv>,<str>[,<flag>];
参数：

<skillid> | 技能ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skilllv> | 技能Lv（数值类型）
<str> | 物品名字（字符串类型）
<flag> | 检查（数值类型。0=有，1=没有。省略时为1）
说明：
（Jathena.Net）
指定的道具名引发技能，咏唱中不能使用。
<flag>为1时表示无条件发动。<flag>为0时则检查发动技能的条件。


jobchange

jobchange命令

作用：转职

格式： | jobchange <job>[,<upper>[,<char_id>]];
参数：
<job> | 职业代码（数值类型）
<upper> | 进阶标志（数值类型，可省略）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 改变职业。<job>可参照db/const.txt。 <upper>：0=未转生、1=转生、2=宝宝、-1或没有指定=人物当前upper。 职业等级会自动变为Lv1。 转职为诗人或舞娘时要注意性别。 转职时不会解除骑鸟、猎鹰、手推车状态。


jump_zero

jump_zero命令

作用：条件跳转

格式： | jump_zero <cond>,<label>;
参数：
<cond> | 表达式
<label> | 标签名
说明： | 如果表达式<cond>为假，则跳到<label>继续执行脚本。否则什么也不做。


kick

kick命令

作用：踢出指定玩家

格式： | kick <char_name>;
参数：
<char_name> | 玩家名字（字符串类型）


kick2

kick2命令

作用：踢出指定玩家，回到登录界面

格式： | kick2 <char_name>;
参数：
<char_name> | 玩家名字（字符串类型）


kick2id

kick2id命令

作用：踢出指定玩家，回到登录界面

格式： | kick2id <char_id>;
参数：
<char_id> | 玩家的char_id（数值类型）


kickid

kickid命令

作用：踢出指定玩家

格式： | kickid <char_id>;
参数：
<char_id> | 玩家的char_id（数值类型）


kickmap

kickmap命令

作用：踢出指定地图的所有人物

格式： | kickmap <mapname>;
参数：
<mapname> | 地图名字（字符串类型）


kickwaitingroom

kickwaitingroom命令

作用：从聊天室踢出指定的玩家

格式： | kickwaitingroom <account_id>;
参数：
<account_id> | 玩家的帐号ID（数值类型，省略时表示自己）
说明： | 从聊天室踢出指定的玩家（玩家聊天室或NPC聊天室都有效）。


kickwaitingroomall

kickwaitingroomall命令

作用：从聊天室踢出所有玩家

格式： | kickwaitingroomall[<npc_name>];
参数：
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）


kill

kill命令

作用：杀死指定人物

格式： | kill <char_name>;
参数：
<char_name> | 人物名字（字符串类型）


killid

killid命令

作用：杀死指定人物

格式： | killid <char_id>;
参数：
<char_id> | 人物的char_id（数值类型）


killmonster

killmonster命令

作用：杀死指定地图的怪物

格式：
（Eathena.Net）
killmonster <gatname>,<event>[,<type>];

（Jathena.Net）
killmonster <gatname>,<event>;
参数：

<gatname> | 地图名（字符串类型）
<event> | 怪物死亡后执行的事件（字符串类型）
<type> | 类型（数值类型）
说明： 杀死<gatname>地图所在的所有怪物。
<gatname>为this（区分大小写）的话，则表示当前地图。
如果指定了<event>，则只对怪物死亡事件为<event>的怪物有效。如果<event>为All（区分大小写）的话，将杀掉临时召唤的怪物。

（Eathena.Net）
如果<type>为1的时候，所有怪物将强制执行"OnMyMobDead"事件。


killmonsterall

killmonsterall命令

作用：杀死指定地图的所有怪物

格式： killmonsterall <gatname>[,<type>];
参数：

<gatname> | 地图名（字符串类型）
<type> | 类型（数值类型）
说明： 与killmonster不同的是，killmonsterall会一起杀死一开始就放置的怪物。
<gatname>为this（区分大小写）的话，则表示当前地图。

（Eathena.Net）
使用旧方法的话，当没触发玩家的时候将不会杀死怪物。因为兼容性问题，强制使用新方法。
如果你希望使用新标签类型使用此指令，请把<type>设置为1。


mailbox

mailbox命令

作用：打开邮箱

格式： | mailbox[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时为自己）


makeitem

makeitem命令

格式和作用：（和dropitem命令一样）


makepet

makepet命令

作用：制作宠物蛋

格式： | makepet <petid>[,<char_id>];
参数：
<petid> | 宠物ID（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 制作怪物ID为<petid>的宠物蛋。


making

making命令

格式和作用：（和cooking命令一样）


mapannounce

mapannounce命令

作用：地图公告

格式： | mapannounce <gatname>,<string>,<flag>[,<color>];
参数：
<gatname> | 地图名（字符串类型）
<string> | 公告内容（字符串类型）
<flag> | 标识（数值类型）
<color> | 颜色（数值类型，可省略）
说明： | <flag> = 0：黄色文字 <flag> = 16：蓝色文字 如果指定了<color>，则<flag>会被忽略。


maprespawnguildid

maprespawnguildid命令

作用：使特定的玩家移动到储存点，并且删除地图中的一部分怪物

格式： | maprespawnguildid <mapname>,<guild_id>,<flag>;
参数：
<mapname> | 地图名（字符串类型）
<guild_id> | 公会ID（数值类型）
<flag> | 标识（数值类型） +1 传送所有公会会员到到他们各自的储存点 +2 传送所有非公会会员到到他们各自的储存点 +4 移除不是公会监护人或华丽金属的所有怪物


mapwarp

mapwarp命令

作用：地图传送

格式：
（Eathena.Net）
mapwarp <from_map>,<to_map>,<x>,<y>[,<type>,<id>];

（Jathena.Net）
mapwarp <from_map>,<to_map>,<x>,<y>;
参数：

<from_map> | 原地图名（字符串类型）
<to_map> | 目标地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<type> 类型（数值类型）
<type> = 0：所有人
<type> = 1：公会
<type> = 2：队伍
<id> | 对应于<type>的ID（数值类型。仅当<type>为1或2的时候有效）
说明： 把<from_map>地图中的玩家传送到<to_map>地图上的(x,y)坐标。


marriage

marriage函数

作用：让两个玩家成为伴侣

格式： marriage(<partner_name>[,<char_id>])
参数：

<partner_name> | 伴侣名字（字符串类型）
<char_id> | 玩家的char_id（数值类型，省略时为自己）
说明： 让名字为<partner_name>的玩家成为指定玩家的伴侣。
结婚失败时，返回0。

（Eathena.Net）
如果结婚成功，则返回1。

（Jathena.Net）
如果结婚成功，则返回伴侣的char_id。

注意这个函数不派发结婚戒指。


max

max函数

作用：返回N个数中的最大值

格式： | max(<num1>,<num2>[,<num3>[,<num4>...[,<numn>]]])
参数：
<num1>,<num2>...<numn> | 数字（数值类型）


md5

md5函数

作用：计算一个字符串的MD5校检和字符串

格式： | md5(<string>)
参数：
<string> | 要计算MD5值的字符串（字符串类型）


menu

menu命令

作用：显示菜单

格式： | menu <string1>,<label1>[,<stringN>,<labelN>...];
参数：
<stringN> | 字符串
<labelN> | 标签
说明： | 显示菜单。并且把选择项的号码记入@menu变量（号码从1开始）。


mes

mes命令

作用：输出信息

格式： | mes <string>;
参数：
<string> | 字符串
说明： | 把<string>的内容显示到消息窗口中。


message

message命令

作用：显示信息在人物的头上（只有自己可以看到）

格式：
（Eathena.Net）
message <char_name>,<msg>;

（Jathena.Net）
message <msg>[,<char_id>];
参数：

<msg> | 显示内容（字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
<char_name> | 玩家名字（字符串类型）


min

min函数

作用：返回N个数中的最小值

格式： | min(<num1>,<num2>[,<num3>[,<num4>...[,<numn>]]])
参数：
<num1>,<num2>...<numn> | 数字（数值类型）


misceffect

misceffect命令

作用：显示各种效果

格式： | misceffect <type>[,<name>];
参数：
<type> | 效果代码（数值类型）
<name> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | <type>可参考“各种效果一览表（misceffect）”。 如果NPC不存在时，则会把效果显示在触发NPC的人物的身上。


mobassist

mobassist命令

作用：召唤魔魂为玩家战斗

格式： | mobassist <mob_name>,<class>,<char_id>[,<time>[,<event>]];
参数：
<mob_name> | 怪物名字（字符串类型）
<class> | 怪物ID（数值类型）
<char_id> | 主人的char_id（数值类型）
<time> | 时限（数值类型。默认为-1）。time<0时，表示不限时（单位为秒）
<event> | 事件（字符串类型）
说明： | 魔魂会自动跟随主人（包括切换地图），而且不会随便飞走，也不会召唤怪物或奴隶。 魔魂都会自动攻击，并且都不会捡物。 主人下线或死亡时，魔魂自动消失。 此指令会把怪物的unit_id记录到$@monster_id变量中。


mobid2name

mobid2name函数

作用：mob_id -> 怪物名字

格式： | mobid2name(<mob_id>)
参数：
<mob_id> | 怪物ID（数值类型）
说明： | 怪物不存在时返回空字符串。


monster

monster命令

作用：召唤怪物

格式： | monster <gatname>,<x>,<y>,<mobname>,<mobid>,<count>[,<event>];
参数：
<gatname> | 地图名（字符串类型）
<x>,<y> | 怪物出现的坐标（数值类型）
<mobname> | 怪物名字（字符串类型）
<mobid> | 怪物ID（数值类型）
<count> | 怪物数量（数值类型）
<event> | 怪物死亡后执行的事件（字符串类型，可省略）
说明： | 如果<gatname>为this（区分大小写）的话，则表示当前地图。 <x>,<y>为0的话，表示随机坐标；<x>,<y>为-1的话，表示执行脚本的玩家的坐标。 <mobname>为--en--的话为英文名，<mobname>为--ja--的话为日文（中文）名。 <mobid>为-1表示随机怪物。 执行命令后，会把对象ID记录在$@monster_id中


name2accountid

name2accountid函数

作用：玩家名字 -> account_id

格式： | name2accountid(<char_name>)
参数：
<char_name> | 玩家名字（字符串类型）
说明： | 玩家不存在时返回-1。


name2charid

name2charid函数

作用：玩家名字 -> char_id

格式： | name2charid(<char_name>)
参数：
<char_name> | 人物名字（字符串类型）
说明： | 玩家不存在时返回-1。


name2guildid

name2guildid函数

作用：公会名字 -> guild_id

格式： | name2guildid(<guild_name>)
参数：
<guild_name> | 公会名字（字符串类型）
说明： | 公会不存在时返回-1。


name2homunid

name2homunid函数

作用：人工生命体名字 -> homun_id

格式： | name2homunid(<homun_name>)
参数：
<homun_name> | 人工生命体名字（字符串类型）
说明： | 人工生命体不存在时返回-1。


name2itemid

name2itemid函数

作用：物品名字 -> item_id

格式： | name2itemid(<item_name>)
参数：
<item_name> | 物品名字（字符串类型）
说明： | 物品不存在时返回-1。


name2mobid

name2mobid函数

作用：怪物名字 -> mob_id

格式： | name2mobid(<mob_name>)
参数：
<mob_name> | 怪物名字（字符串类型）
说明： | 怪物不存在时返回-1。


name2npcid

name2npcid函数

作用：NPC名字 -> npc_id

格式： | name2npcid(<npc_name>)
参数：
<npc_name> | NPC名字（字符串类型）
说明： | NPC不存在时返回-1。


name2partyid

name2partyid函数

作用：队伍名字 -> party_id

格式： | name2partyid(<party_name>)
参数：
<party_name> | 队伍名字（字符串类型）
说明： | 队伍不存在时返回-1。


next

next命令

作用：显示next按钮

格式： | next;
说明： | 在消息窗口上显示next按钮并等待。


night

night命令

作用：设置为夜晚

格式： night;


npcid2name

npcid2name函数

作用：npc_id -> NPC名字

格式： | npcid2name(<npc_id>)
参数：
<npc_id> | NPC的ID（数值类型。注意不是外观ID，是NPC唯一的ID）
说明： | NPC不存在时返回空字符串。


npcskillsupport

npcskillsupport命令

（Eathena.Net）格式和作用：（和skilleffect命令一样）
（Jathena.Net）作用：给玩家显示恢复效果

以下部分只适用于Jathena.Net：

格式： | npcskillsupport <skillid>,<val>;
参数：
<skillid> | 技能ID（数值类型）
<val> | 显示的恢复量（数值类型）
说明： | 被命令的NPC给玩家造成技能为<skillid>的恢复效果，恢复值显示为<val>（没有进行实际恢复）。 此命令仅限于指定的支援/恢复技能的效果。


npcspeed

npcspeed命令

作用：设置NPC移动速度

格式： | npcspeed <speed>[,<npc_name>];
参数：
<speed> | 移动速度（数值类型）
<npc_name> | NPC名字（字符串类型）
说明： | 注意：<speed>越大，移动速度越慢。


npcstop

npcstop命令

作用：让NPC停止移动

格式： | npcstop[<npc_name>];
<npc_name> | NPC名字（字符串类型）


npctalk

npctalk命令

作用：让NPC说话

格式： | npctalk <mes>[,<npcname>];
参数：
<mes> | 信息（字符串类型）
<npcname> | NPC名字（字符串类型，省略时表示当前NPC）


npcwalkto

npcwalkto命令

作用：让NPC移动到指定坐标

格式： | npcwalkto <x>,<y>[,<npc_name>];
参数：
<x>,<y> | 坐标（数值类型）
<npc_name> | NPC名字（字符串类型）


openstorage

openstorage命令

作用：打开个人仓库

格式： | openstorage[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


partyid2name

partyid2name函数

作用：party_id -> 队伍名字

格式： | partyid2name(<party_id>)
参数：
<party_id> | 队伍ID（数值类型）
说明： | 队伍不存在时返回空字符串。


pcblockmove

pcblockmove命令

作用：阻止/允许玩家移动

格式： | pcblockmove <account_id>,<value>;
参数：
<account_id> | 指定人物的account_id（数值类型）
<value> | 要设置的值（数值类型）
说明： | <value> = 1：阻止玩家移动。 <value> = 0：允许玩家移动。


pcfollow

pcfollow命令

作用：让一名玩家跟随另一名玩家

格式： | pcfollow <id>,<target_id>[,<type>[,<autostop>]];
参数：
<id> | 跟随玩家的account_id（数值类型）
<target_id> | 被跟随玩家的account_id（数值类型）
<type> | 跟随类型（数值类型。默认为0）
<autostop> | 是否自动停止（数值类型。默认为0）
说明： | <type> = 0：一直跟随目标人物。目标人物在过图时，人物仍然会自动过图继续跟随。 <type> = 1：人物只在相同地图上跟随目标人物，目标人物过图时不会跟随。 <type> = 2：人物只在有效距离内跟随目标人物，目标人物过图或超出有效距离时不会跟随。 <autostop> = 0：当跟随失败时，不会自动停止跟随目标人物。（比如超出了有效距离而跟随失败时，当再次达到有效距离时，继续自动跟随） <autostop> = 1：当跟随失败时，自动停止跟随目标人物。


pcstopfollow

pcstopfollow命令

作用：让指定人物停止跟随

格式： | pcstopfollow <id>;
参数：
<id> | 人物的account_id（数值类型）
说明： | 让account_id为<id>的玩家停止跟随


pctalk

pctalk命令

作用：让指定人物说话

格式： | pctalk <msg>[,<char_id>];
参数：
<mes> | 信息（字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示当前人物）


pc_isdead

pc_isdead函数

作用：判断玩家是否死亡

格式： | pc_isdead([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示当前人物）
说明： | 人物不存在时返回-1


percentheal

percentheal命令

作用：恢复HP/SP

格式： | percentheal <hp_percent>,<sp_percent>[,<char_id>];
参数：
<hp_percent> | 恢复的HP的百分比（数值类型）
<sp_percent> | 恢复的SP的百分比（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）


pet

pet命令

作用：捕捉宠物

格式： | pet <pet_id>;
参数：
<pet_id> | 宠物ID（数值类型。在pet_db.txt中定义）
说明： | 捕捉ID为<pet_id>的宠物。 <例> 物品“青苹果”的代码：pet 1002;


petskillattack

petskillattack命令

作用：宠物使用技能攻击

格式：
（Eathena.Net）
petskillattack <skill_id|skill_name>,<skill_lv>,<rate>,<bonusrate>;

（Jathena.Net）
petskillattack <skill_id>,<skill_lv>,<rate>,<bonusrate>;
参数：

<skill_id> | 技能ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skill_lv> | 技能LV（数值类型）
<rate> | 发动率（数值类型。单位是1%）
<bonusrate> | 根据好感度增加的发动率（好感度 * 0.01% * <bonusrate>）


petskillsupport

petskillsupport命令

作用：宠物使用技能支援

格式：
（Eathena.Net）
petskillsupport <skill_id|skill_name>,<skill_lv>,<delay>,<percent_hp>,<percent_sp>;

（Jathena.Net）
petskillsupport <skill_id>,<skill_lv>,<delay>,<percent_hp>,<percent_sp>;
参数：

<skill_id> | 技能ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skill_lv> | 技能LV（数值类型）
<delay> | 使用技能的时间间隔（数值类型，单位为秒）
<percent_hp> | 主人的HP在这个百分率以下发动（数值类型）
<percent_sp> | 主人的SP在这个百分率以下发动（数值类型）


pow

pow函数

作用：返回a的b次方

格式： | pow(<a>,<b>)
参数：
<a>,<b> | 数字（数值类型）


produce

produce命令

作用：制作物品

格式： | produce <Item_Lv>;
参数：
<Item_Lv> | 物品等级（数值类型，在produce_db.txt中定义）
说明： | <例> “携带用熔矿炉”的代码：produce 16;


pvpoff

pvpoff命令

作用：关闭PVP模式

格式： | pvpoff <gatname>;
参数：
<gatname> | 地图名（字符串类型）
说明： | 把<gatname>地图的PVP模式关闭。


pvpon

pvpon命令

作用：开启PVP模式

格式： | pvpon <gatname>;
参数：
<gatname> | 地图名（字符串类型）
说明： | 把<gatname>地图设置为PVP模式。


querysql

querysql命令

作用：执行有返回的SQL语句/存储过程，并缓存查询结果

格式： | querysql <SQL_String>[,<char_id>];
参数：
<SQL_String> | SQL语句/存储过程（字符串类型）
<char_id> | 人物的char_id（数值类型）
说明： | 注意：指定了<char_id>的话，则查询结果会缓存到全局+个人SQL缓存中。如果没指定，则只缓存到全局SQL缓存。


rand

rand函数

作用：产生随机数

格式： rand([<min>,]<max>)
参数：

<min> | 随机数的最小值（数值类型，忽略时为0，并且最大值不包括<max>本身）
<max> | 随机数的最大值（数值类型）

说明： rand(2,10) //2,3,4,5,6,7,8,9,10
rand(10) //0,1,2,3,4,5,6,7,8,9


rand2

rand2函数

作用：产生随机数

格式： | rand2(<min>, <max>)
参数：
<min> | 随机数的最小值（数值类型）
<max> | 随机数的最大值（数值类型，最大可达2147483647）
说明： | 随机数不能取上界值<max>


readparam

readparam函数

作用：读取参数

格式： readparam(<param>[,<char_name>])
参数：

<param> | 参数（请参考const.txt，用数字记述）
<char_name> | 玩家名字（字符串类型，省略时表示自己）
说明： 返回指定为<param>的人物参数。
返回-1时，表示指定人物不存在。

（Eathena.Net）
取得状态补正值，请指定STR:32 AGI:33 VIT:34 INT:35 DEX:36 LUK:37

（Jathena.Net）
取得状态补正值，请指定STR:70 AGI:71 VIT:72 INT:73 DEX:74 LUK:75


readsql

readsql函数

作用：读取SQL缓存的数据

格式： | readsql(<row>,<col>[,<char_id>])
参数：
<row> | 行号（数值类型）
<col> | 列号（数值类型）
<char_id> | 人物的char_id（数值类型）
说明： | 读取SQL缓冲中的第<row>行、第<col>列的内容，并以字符串形式返回这个内容。 如果SQL缓冲为空、<row>和<col>超出SQL缓冲的范围、读取的内容为空，则返回""。 如果指定了<char_id>，则从个人SQL缓存中查询，否则会从全局SQL缓存中查询。 注意：<row>和<col>是从1开始。


recallmob

recallmob命令

作用：召回魔魂到主人身边

格式： | recallmob[<char_id>];
参数：
<char_id> | 主人的char_id（数值类型）


recovery

recovery命令

作用：服务器所有在线玩家复活、HP/SP全回复

格式： recovery;


refitem

refitem命令

作用：精炼装备

格式： refitem <pos>,<val>[,<char_id>];
参数：

<pos> | 位置（数值类型）
<val> | 精炼值（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下
（Jathena.Net）
<pos> = 11：箭矢

把指定位置的装备精炼到指定的等级（可降）。


releaseall

releaseall命令

作用：卸除所有装备回物品栏

格式： | releaseall[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


removemapflag

removemapflag命令

作用：移除地图的mapflag

格式： | removemapflag <gatname>,<mapflag>;
参数：
<gatname> | 地图名字（字符串类型）
<mapflag> | mapflag标识（数值类型。在const.txt中定义为"mf_xxxx"的枚举，例如mf_nomemo）
说明： | 仅对于只有0和1值的mapflag生效，把指定的mapflag设置为0。


repair

repair命令

作用：修复损坏的装备

格式： | repair <index>[,<char_id>];
参数：
<index> | 索引值（数值类型）
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： | 第1件损坏装备的<index>为0，第2件的<index>为1……


repairitem

repairitem命令

作用：修理所有损坏装备

格式： | repairitem[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


requestguildinfo

requestguildinfo命令

（Eathena.Net）作用：从Char服务器上请求公会情报
（Jathena.Net）作用：从Inter服务器上请求公会情报

格式： | requestguildinfo <guild_id>[,<event_name>];
参数：
<guild_id> | 公会ID（数值类型）
<event_name> | 执行命令时触发的事件名（字符串类型，可省略）


resetlvl

resetlvl命令

作用：转生重置功能

格式： resetlvl <type>[,<char_id>];
参数：

<type> | 参数类型（数值类型）
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： <type> = 1：重置技能点、设置Base/Job等级为1、Base/Job经验为0、清除状态（骑鸟等）、素质点全部1、送100属性点、学会[紧急治疗]和[装死]技能
<type> = 2：重置技能点、设置Base/Job等级为1、Base/Job经验为0
<type> = 3：设置Base等级为1、Base经验为0
<type> = 4：设置Job等级为1、Job经验为0

（Eathena.Net）
使用该指令后，会自动卸下所有装备、检查组队平分经验设置、并设置CLONE_SKILL（抄袭技能ID）、CLONE_SKILL_LV（抄袭技能等级）变量为0。

（Jathena.Net）
使用该指令后，会自动卸下所有装备、检查组队平分经验设置、并设置PC_CLONESKILL_ID（抄袭技能ID）、PC_CLONESKILL_LV（抄袭技能等级）变量为0。


resetskill

resetskill命令

作用：重置技能点

格式： | resetskill[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


resetstatus

resetstatus命令

作用：重置属性点

格式： | resetstatus[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


return

return命令

作用：从函数中返回

格式： | return[<retval>];
参数：
<retval> | 返回值（字符串/数值/变量类型，可省略）
说明： | 立刻从函数中返回调用处。 <retval>是返回值。callsub或callfunc被当作函数使用时使用它。 如果callsub或callfunc被当作命令使用时则省略<retval>。 如果返回值是变量的话，还可以使用像set callfunc(""func""),1;这种用法。


savepoint

savepoint命令

作用：设置储存点

格式： | savepoint <gatname>,<x>,<y>[,<char_id>];
参数：
<gatname> | 地图名（字符串类型）
<x>,<y> | 储存点的(x,y)坐标（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）


sc_end

sc_end命令

作用：结束指定对象的异常状态

格式： sc_end <type>[,<target>];
参数：

<type> 异常状态的编号（数值类型）

（Eathena.Net）
请参考status.h。也可以参考在const.txt中的"SC_xxxx"字样的定义

（Jathena.Net）
请参考skill.h或check_option的项目
<target_id> 单位ID（数值类型，省略时为自己）


sc_start

sc_start命令

作用：造成指定对象异常状态

格式： sc_start <type>,<tick>,<val1>[,<target_id>];
参数：

<type> 异常状态的编号（数值类型）

（Eathena.Net）
请参考status.h。也可以参考在const.txt中的"SC_xxxx"字样的定义

（Jathena.Net）
请参考skill.h或check_option的项目
<tick> | 异常状态持续的时间（数值类型，单位为ms）
<val1> | 造成异常状态对应的技能的等级（数值类型）
<target_id> | 单位ID（数值类型，省略时为自己）


sc_start2

sc_start2命令

作用：造成指定对象异常状态

格式： sc_start2 <type>,<tick>,<val1>,<percentage>[,<target_id>];
参数：

<type> 异常状态的编号（数值类型）

（Eathena.Net）
请参考status.h。也可以参考在const.txt中的"SC_xxxx"字样的定义

（Jathena.Net）
请参考skill.h或check_option的项目
<tick> | 异常状态持续的时间（数值类型，单位为ms）
<val1> | 造成异常状态对应的技能的等级（数值类型）
<percentage> | 万分率（数值类型）
<target_id> | 单位ID（数值类型，省略时为自己）


sc_start3

sc_start3命令

作用：造成指定对象异常状态

格式： | sc_start3 <type>,<val1>,<val2>,<val3>,<val4>,<tick>,<flag>,[,<target_id>];
参数：
<type> | 异常状态的编号（数值类型，请参考skill.h或check_option的项目）
<val1> | 造成异常状态对应的技能的等级（数值类型）
<val2> | 不作详细解释（数值类型）
<val3> | 不作详细解释（数值类型）
<val4> | 不作详细解释（数值类型）
<tick> | 异常状态持续的时间（数值类型，单位为ms）
<flag> | ※通常为0 +1: 对不死系和BOSS属性可冰冻和石化 +2: 效果持续时间不受状态影响 +4: 不调用status_calc_pc（相当于sc_starte命令） +8: 不计算完全耐性及卡片带来的耐性
<target_id> | 单位ID（数值类型，省略时为自己）


select

select函数

作用：显示菜单，并返回选项的号码

格式： | select(<string1>[,<string2>,<string3>...])
参数：
<string1>,<string2>... | 菜单项（字符串类型）
说明： | 显示菜单，并返回选择了的菜单项。 如果选择了第1项，则返回1。并把返回值保存在@menu变量中。


set

set命令

作用：设置变量的值

格式： | set <variable>,<value>[,<char_id>];
参数：
<variable> | 变量名
<value> | 要设置的值（数值/字符串类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 把<value>的值传入<variable>。 值为字符串类型时，不要忘记变量名的$后缀。


setarray

setarray命令

作用：数组赋值

格式： | setarray <variable>[,<n0>[,<n1>…]];
参数：
<variable> | 变量
<n0>,<n1>...<nx> | 值（数值/字符串类型）
说明： | 把<n0>,<n1>...<nx>依此代入从<variable>开始的数组。 如果为<variable>指定索引的话，则从数组指定索引处开始代入。 <例> setarray @hoge[2],16,24,32; 2-4号元素的值分别为16、24、32


setcart

setcart命令

作用：设置手推车

格式：
（Eathena.Net）
setcart[,<type>[,<char_id>]];

（Jathena.Net）
setcart[<char_id>];
参数：

<char_id> | 人物的char_id（数值类型，省略时表示自己）
<type> | 设置状态（数值类型，范围是0-5。0表示清除，1-5表示手推车等级。默认为1）


setcastledata

setcastledata命令

作用：设置公会秘密基地数据

格式： | setcastledata <map>,<index>,<value>;
参数：
<map> | 地图名字（字符串类型）
<index> | 数据库guild_castle表中列索引值（数值类型） 0 城堡ID 1 公会ID 2 商业度 3 防御度 4 商业投资次数 5 防御投资次数 6 nextTime 7 payTime 8 createTime 9 是否设置了卡普拉（未设置0, 已设置1） 10 是否设置了监护人1（未设置0, 已设置1） 11 是否设置了监护人2 12 是否设置了监护人3 13 是否设置了监护人4 14 是否设置了监护人5 15 是否设置了监护人6 16 是否设置了监护人7 17 是否设置了监护人8
<value> | 要设置的值（数值类型）
说明： | 把指定的公会秘密基地数据的值设置为<value>。


setcell

setcell命令

作用：改变指定坐标范围单元的类型

格式：
（Eathena.Net）
setcell <map_name>,<x1>,<y1>,<x2>,<y2>,<type>,<flag>;

（Jathena.Net）
setcell <map_name>,<x1>,<y1>,<x2>,<y2>,<type>;
参数：

<map_name> | 地图名（字符串类型）
<x1>,<y1>,<x2>,<y2> | 坐标范围（数值类型）
<type> | 要设置的类型（数值类型）
<flag> | 设置标识（数值类型。0:清除、1:设置）
说明：
（Eathena.Net）
<type>列表（在const.txt中以"cell_"开头的定义）：
cell_chkwall 1（墙壁）
cell_chkwater 2（水场）
cell_chkcliff 3（悬崖）
cell_chkpass 4（可通过）
cell_chkreach 5（可站立）
cell_chknopass 6（不可通过）
cell_chknoreach 7（不可站立）
cell_chknpc 9（NPC）
cell_chkbasilica 10（神圣殿堂）
cell_chklandprotector 11（地元素领域）
cell_chknovending 12（不能开放露天商店）
cell_chknochat 13（不能开放聊天室）

（Jathena.Net）
<type>列表：
0:通常单元
1:墙壁
2:水场
3:障碍物


seteqdure

seteqdure命令

作用：设置装备耐久度（装备升级系统）

格式： | seteqdure <pos>,<dure>[,<char_id>];
参数：
<pos> | 位置（数值类型）
<dure> | 耐久度（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下


seteqexp

seteqexp命令

作用：设置装备经验（装备升级系统）

格式： | seteqexp <pos>,<exp>[,<char_id>];
参数：
<pos> | 位置（数值类型）
<exp> | 装备经验（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下


seteqlv

seteqlv命令

作用：设置装备等级（装备升级系统）

格式： | seteqlv <pos>,<lv>[,<char_id>];
参数：
<pos> | 位置（数值类型）
<lv> | 等级（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下


seteqmaxdure

seteqmaxdure命令

作用：设置装备耐久度上限（装备升级系统）

格式： | seteqmaxdure <pos>,<maxdure>[,<char_id>];
参数：
<pos> | 位置（数值类型）
<maxdure> | 耐久度上限（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下


setfalcon

setfalcon命令

作用：设置猎鹰

格式：
（Eathena.Net）
setfalcon[,<flag>[,<char_id>]];

（Jathena.Net）
setfalcon[<char_id>];
参数：

<char_id> | 人物的char_id（数值类型，省略时表示自己）
<flag> | 设置状态（数值类型。默认为1。0的时候表示解除猎鹰状态）


setlook

setlook命令

作用：定义角色造型

格式： setlook <type>,<value>[,<char_id>];
参数：

<type> | 外观类型（数值类型）
<value> | 数值（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明：
（Eathena.Net）
<type> = 0：基本造型

<type> = 1：发型
<type> = 2：武器
<type> = 3：头下
<type> = 4：头上
<type> = 5：头中
<type> = 6：发色
<type> = 7：服色
<type> = 8：盾牌
<type> = 9：鞋子

注意，<type> = 9不会发生任何效果，只是客户端保留了。


setmapflag

setmapflag命令

作用：设置地图的mapflag

格式：
（Eathena.Net）
setmapflag <gatname>,<mapflag>[,<value>];

（Jathena.Net）
setmapflag <gatname>,<flag>;
参数：

<gatname> | 地图名字（字符串类型）
<flag> | mapflag标识（数值类型。在const.txt中定义为"mf_xxxx"的枚举，例如mf_nomemo）
<value> | 设定值（数值类型）
说明： 对于只有0和1值有效的mapflag，则把指定的mapflag设置为1。

（Eathena.Net）
<value>对只有0/1值有效的bool类型的mapflag无效，只对mf_jexp等需要设置实际数值的mapflag有效。


setmapflagnosave

setmapflagnosave命令

作用：设置地图nosave的mapflag

格式： | setmapflagnosave <gatname>,<savegatname>,<x>,<y>;
参数：
<gatname> | 地图名字（字符串类型）
<savegatname> | 储存的地图名（字符串类型）
<x>,<y> | 储存的坐标（数值类型）


setmobdata

setmobdata命令

作用：设置指定怪物的属性

格式： setmobdata <unit_id>,<type>,<value>;
参数：

<unit_id> | 单位ID，就是用GM外观点右键看到的GID（数值类型）
<type> | 类型（数值类型）
<value> | 要设置的值（数值/字符串类型）
说明：
（Eathena.Net）
<type>列表：
1 : class
2 : name
3 : hp
4 : max_hp
5 : master_id
6 : map_name
7 : x
8 : y
9 : speed
10 : mode
11 : ai
12 : size
13 : option
14 : opt1
15 : opt2
16 : opt3
17 : view_sex
18 : view_class
19 : view_hair_style
20 : view_hair_color
21 : view_head_bottom
22 : view_head_mid
23 : view_head_top
24 : view_cloth_color
25 : view_shield
26 : view_weapon
27 : view_dead_sit
28 : dir
29 : aggressive

（Jathena.Net）
<type>列表：
1 : class
2 : name
3 : hp
4 : master_id
5 : map_name
6 : x
7 : y
8 : speed
9 : mode
10 : view_size
11 : option
12 : option1
13 : option2
14 : option3

注意：name和map_name是字符串类型，其他class、hp等是数值类型。


setnocard

setnocard命令

作用：把指定卡片添加/删除到nocard的mapflag

格式： | setnocard <card_id>,<value>,<map_name>;
参数：
<card_id> | 卡片ID（数值类型）
<value> | 添加/删除（数值类型，1-添加、0-删除）
<map_name> | 地图名（字符串类型）


setnoequip

setnoequip命令

作用：把指定装备添加/删除到noequip的mapflag

格式： | setnoequip <equip_id>,<value>,<map_name>;
参数：
<equip_id> | 装备ID（数值类型）
<value> | 添加/删除（数值类型，1-添加、0-删除）
<map_name> | 地图名（字符串类型）


setnoitem

setnoitem命令

作用：把指定物品添加/删除到noitem的mapflag

格式： | setnoitem <item_id>,<value>,<map_name>;
参数：
<item_id> | 物品ID（数值类型）
<value> | 添加/删除（数值类型，1-添加、0-删除）
<map_name> | 地图名（字符串类型）


setnoskill

setnoskill命令

作用：把指定技能添加/删除到noskill的mapflag

格式： | setnoskill <skill_id>,<value>,<map_name>;
参数：
<skill_id> | 技能ID（数值类型）
<value> | 添加/删除（数值类型，1-添加、0-删除）
<map_name> | 地图名（字符串类型）


setnpctimer

setnpctimer命令

作用：设置NPC计时器的时间

格式： | setnpctimer <tick>[,<npc_name>];
参数：
<tick> | 时间（数值类型，单位为ms）
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | 改变NPC计时器的计数。 配合getnpctimer命令，能进行增减计算。


setoption

setoption命令

作用：设置状态

格式： setoption <val>[,<char_id>];
参数：

<val> | 状态（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 状态一览：
0：清除效果
1：火狩
2：隐匿
4：伪装
8：手推车等级1
16：带鹰
32：骑鸟
64：GM隐身
128：手推车等级2
256：手推车等级3
512：手推车等级4
1024：手推车等级5
2048：变身为怪兽
4096：变为结婚造型
8192：光猎
16384：足迹

（Eathena.Net）
32768：飞行或圣诞装
65536：Sighttrasher

由于设置状态的时候是先清除所有状态，所以如果要设置多个状态的话，先把状态叠加起来。


setriding

setriding命令

作用：设置骑鸟

格式：
（Eathena.Net）
setriding[,<flag>[,<char_id>]];

（Jathena.Net）
setriding[<char_id>];
参数：

<char_id> | 人物的char_id（数值类型，省略时表示自己）
<flag> | 设置状态（数值类型。默认为1。0的时候表示解除骑鸟状态）


skill

skill命令

作用：学会/删除人物技能

格式：
（Eathena.Net）
skill <skill_id|skill_name>,<skilllv>[,<flag>[,<char_id>]];

（Jathena.Net）
skill <skillid>,<skilllv>[,<flag>[,<char_id>]];
参数：

<skillid> | 技能ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skilllv> | 技能LV（数值类型）
<flag> | 标识（数值类型，省略时为1）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <flag> = 0：永久学会技能（不存在于技能树则无效）
<flag> = 1：暂时取得（一般是装备上物品时才能使用）

<skilllv>设置为0时，表示删除技能。

（Eathena.Net）
<flag> = 2：在原来技能的等级上加上<skilllv>

注意：skill和addtoskill的不同只是<flag>的默认值不同，其他都一样。


skillpointcount

skillpointcount函数

作用：计算人物的技能点（技能占用的技能点+未使用的技能点）

格式： | skillpointcount([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 人物不存在时返回-1


sleep

sleep命令

作用：脚本取消与玩家关联后，指定时间内停止执行脚本

格式： | sleep <tick>;
参数：
<tick> | 等待时间（数值类型，单位为ms）


sleep2

sleep2函数

作用：指定时间内停止执行脚本

格式： | sleep2(<tick>)
参数：
<tick> | 等待时间（数值类型，单位为ms）
说明： | 重新执行前先尝试和玩家关联，成功的话返回1，否则返回0。 注意：本函数执行期间，玩家的行动会受到限制。


soundeffect

soundeffect命令

作用：打开/关闭声音

格式： | soundeffect <filename>,<type>;
参数：
<filename> | 文件名（字符串类型，最大24个字符）
<type> | 重复模式（数值类型） 0 - 播放1次 1 - 反复播放 2 - 停止播放


sql_escape

sql_escape函数

作用：返回防止注入的SQL字符串

格式： | sql_escape(<string>)
参数：
<string> | 字符串（字符串类型）


sqrt

sqrt函数

作用：返回num的平方根

格式： | sqrt(<num>)
参数：
<num> | 数字（数值类型）


startnpctimer

startnpctimer命令

作用：开始NPC计时器

格式：
（Eathena.Net）
startnpctimer <npc_name>,<flag>;
startnpctimer <npc_name>;
startnpctimer <flag>;

（Jathena.Net）
startnpctimer[<npc_name>];
参数：

<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
<flag> | 是否触发玩家（数值类型。默认为0）
说明： 恢复NPC计时器。
和initnpctimer不同，startnpctimer是从停止时刻继续，而不是清0。
请与stopnpctimer配合使用。


statusup

statusup命令

作用：增加角色属性（需要从属性点扣除）

格式： | statusup <st>[,<char_id>];
参数：
<st> | 属性
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 从属性点中扣除相应的点数然后把属性增加1。 <st>可指定为bStr, bVit, bInt, bAgi, bDex, bLuk。


statusup2

statusup2命令

（Eathena.Net）作用：无条件修改属性值（不需要检查属性点）
（Jathena.Net）作用：增加角色属性（不需要从属性点扣除，无条件增加）

格式：
（Eathena.Net）
statusup2 <st>,<amount>[,<char_id>];

（Jathena.Net）
statusup2 <st>[,<char_id>];
参数：

<st> | 属性
<char_id> | 人物的char_id（数值类型，省略时表示自己）
<amount> | 数值（数值类型，可以为负值）
说明：
（Eathena.Net）
不需要判断属性点，无条件修改属性值。

（Jathena.Net）
不需要从属性点中扣除相应的点数，无条件把属性增加1。

<st>可指定为bStr, bVit, bInt, bAgi, bDex, bLuk。


stopnpctimer

stopnpctimer命令

作用：停止NPC计时器

格式：
（Eathena.Net）
stopnpctimer <npc_name>,<flag>;
stopnpctimer <npc_name>;
stopnpctimer <flag>;

（Jathena.Net）
stopnpctimer[<npc_name>];
参数：

<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
<flag> | 是否取消触发玩家（数值类型。默认为0）


strcharinfo

strcharinfo函数

作用：取得人物各种名字

格式： | strcharinfo(<type>[,<char_id>])
参数：
<type> | 类型（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <type> = 0：人物名字 <type> = 1：队伍名字 <type> = 2：公会名字 如果人物不存在、队伍不存在、公会不存在时，则返回""


strcut

strcut函数

作用：取得字符串中的某个字符

格式： | strcut(<string>,<index>)
参数：
<string> | 字符串（字符串类型）
<index> | 字符索引（数值类型）
说明： | 返回<string>字符串中索引为<index>的一个字节。 <例> strcut("test",2) -> "s" strcut("测试",2) + strcut("测试",3) -> "试" 使用这个函数可以进行大范围的文字处理。


string_format

string_format函数

作用：格式化字符串

格式： string_format(<format>,<arg0>[,<arg1>[,<arg2>......]])
参数：

<format> | 格式化字符串格式（字符串类型）
<arg0>,<arg1>,<arg2>... | 参数（数值/字符串类型）
说明： 注：这个脚本指令的格式跟.NET中的String.Format一样。

string_format中的<format>为格式化字符串格式，<format>中的{0}为第1个参数、{1}为第2个参数、{2}为第3个参数……以此类推。可以直接写{0}，程序自动识别类型。也可以在后面加“:”跟类型说明符。例如{0:d}或{0:D}表示把第一个参数格式化为十进制数；{3:s}或{3:S}表示把第4个参数格式化为字符串；{9:x}或{9:X}表示把第10个参数格式化为16进制。

如果我要把十进制数255格式化为4为的16进制数，那么就写成{0:X4}，X后面的4表示数位，当数位不足则在前面补0，显示为“00FF”。如果写成{0:X1}，那么跟{0:X}一样，显示“FF”。

如果要匹配左右大括号“{}”，则重复输入左右大括号，例如：
string_format("{{TEST}}{0:d}",1)返回结果为“{TEST}1”

除了在类型说明符后面可以加入数字确定字符个数以外，还有很多用于模式定义的格式说明符，例如“0”是“零占位符”，“#”是“空占位符”，“%”是“以数字的百分比显示比值”等等，不过一般在Athena编写脚本中都不会用到，如有兴趣可以上网查找相关资料。
范例： prontera.gat,147,171,6 script 测试人员 703,{
set @R1$[2],"test4";
set @R2$,"test5";
set @R3,6;
set @R4[5],7;
mes string_format("[TEST {0:d}] : 测试{0:d}",1);
mes string_format("[TEST {0:d}] : {1:S}",2,charid2name(getcharid(0)));
mes string_format("[TEST {0:d}] : {1:S}",3,"test3");
mes string_format("[TEST {0:d}] : {1:S}",4,@R1$[2]);
mes string_format("[TEST {0:d}] : {1:S}",5,@R2$);
mes string_format("[TEST {0:d}] : 0x{1:X6}",@R3,rand2(0,256*256*256));
mes string_format("[TEST {0:d}] : 0x{1:X2}{2:X2}{3:X2}",@R4[5],10,99,255);
close;
}

输出结果为：


strnpcinfo

strnpcinfo函数

作用：取得NPC各种名字

格式： strnpcinfo(<type>)
参数：

<type> 信息类型（数值类型）
说明： <type> = 0：NPC名字
<type> = 1：不包含#部分的NPC名字
<type> = 2：#部分的NPC名字
<type> = 3：识别名
<type> = 4：不包含#部分的识别名
<type> = 5：#部分的识别名

（Jathena.Net）
<type> = 6：NPC职位

取得NPC相关信息。
<type>为2或5的时候，如果NPC名字没有带#的话，则返回""


successrefitem

successrefitem命令

作用：把装备作精炼成功处理

格式： | successrefitem <pos>[,<char_id>];
参数：
<pos> | 装备位置（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <pos> = 1：头上 <pos> = 2：身体 <pos> = 3：左手 <pos> = 4：右手 <pos> = 5：披挂 <pos> = 6：鞋子 <pos> = 7：装饰品1 <pos> = 8：装饰品2 <pos> = 9：头中 <pos> = 10：头下 把装备精炼到下一级。


successremovecards

successremovecards命令

作用：成功摘下卡片

格式： successremovecards <pos>[,<card_num>[,<char_id>]];
参数：

<pos> | 位置（数值类型）
<card_num> | 卡片位置（数值类型。默认为0，表示全部卡片。1-4表示第几张卡片）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：铠甲
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下

（Jathena.Net）
<pos> = 11：箭矢


summon

summon命令

（Eathena.Net）作用：召唤怪物作为奴隶
 （Jathena.Net）作用：召唤怪物作为奴隶，持续60秒

格式：
（Eathena.Net）
summon <mob_name>,<mob_id>[,<timeout>[,<event>[,<char_id>]]];

（Jathena.Net）
summon <mob_name>,<mob_id>[,<event_name>[,<char_id>]];
参数：

<mob_name> | 要显示的怪物名字（字符串类型）
<mob_id> | 怪物ID（数值类型。为-1时，表示随机召唤怪物种类。）
<timeout> | 时间限制（数值类型。单位为秒。默认为60秒）
<event_name> | 怪物死亡后的事件（字符串类型，不需要时可省略或者填""）
<char_id> | 人物的char_id（数值类型，省略时表示自己）


undisguise

（Eathena.Net）undisguise函数
 （Jathena.Net）undisguise命令

作用：把指定玩家取消变身

格式：
（Eathena.Net）
undisguise([<char_id>])

（Jathena.Net）
undisguise[<char_id>];
参数：

<char_id> 人物的char_id（数值类型，省略时表示自己）
说明：
（Eathena.Net）
成功时返回0，否则返回1。


unequip

unequip命令

作用：卸下指定的装备

格式： unequip[<pos>[,<char_id>]];
参数：

<pos> | 装备位置（数值类型，省略时或-1时表示所有装备）
<char_id> | 玩家的char_id（数值类型，省略时表示自己）
说明： <pos> = 1：头上
<pos> = 2：身体
<pos> = 3：左手
<pos> = 4：右手
<pos> = 5：披挂
<pos> = 6：鞋子
<pos> = 7：装饰品1
<pos> = 8：装饰品2
<pos> = 9：头中
<pos> = 10：头下

（Jathena.Net）
<pos> = 11：箭矢


unitattack

unitattack命令

作用：让指定单位攻击目标

格式：
（Eathena.Net）
unitattack(<unit_id>,<target_id>[,<action_type>])

（Jathena.Net）
unitattack <unit_id>,<target_id>;
参数：

<unit_id> | 单位ID（数值类型）
<target_id> | 目标单位ID（数值类型）
<action_type> | 攻击类型（数值类型。0:一次攻击、1:连续攻击）
说明： 对NPC无效

（Eathena.Net）
单位或目标单位不存在时，返回0。
如果单位的类型是PC时，返回1。如果单位的类型不是PC、MOB、PET时，返回0。
攻击成功时返回1。


unitemote

unitemote命令

作用：让指定单位出现表情

格式： | unitemote <unit_id>,<emotion>;
参数：
<unit_id> | 单位ID（数值类型）
<emotion> | 表情代码（数值类型）


unitid2name

unitid2name命令

作用：unit_id -> 名字

格式： | unitid2name(<unit_id>)
参数：
<unit_id> | 单位ID（数值类型）
说明： | 只对PC、MOB、NPC、PET有效 当单位不存在时，返回""


unitkill

unitkill命令

作用：杀死指定单位

格式： unitkill <unit_id>;
参数：

<unit_id> 单位ID（数值类型）
说明：
（Eathena.Net）
只对PC、MOB、HOMUN、佣兵有效

（Jathena.Net）
只对PC、MOB、HOMUN有效


unitskilluseid

unitskilluseid命令

作用：让指定单位对某目标使用技能

格式：
（Eathena.Net）
unitskilluseid <unit_id>,<skill_id|skill_name>,<skill_lv>[,<target_id>[,<casttime>,<castcancel>]];

（Jathena.Net）
unitskilluseid <unit_id>,<skill_id>,<skill_lv>[,<target_id>[,<casttime>,<castcancel>]];
参数：

<unit_id> | 单位ID（数值类型）
<skill_id> | 技能ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skill_lv> | 技能LV（数值类型）
<target_id> | 目标单位ID（数值类型，默认时跟unit_id一样）
<casttime> | 咏唱时间（单位为毫秒，默认为发动技能所需要的时间）
<castcancel> | 可否中断（默认为技能的可否中断）
说明： 对NPC无效


unitskillusepos

unitskillusepos命令

作用：让指定单位对某坐标使用技能

格式：
（Eathena.Net）
unitskillusepos <unit_id>,<skill_id|skill_name>,<skill_lv>,<target_x>,<target_y>[,<casttime>,<castcancel>];

（Jathena.Net）
unitskillusepos <unit_id>,<skill_id>,<skill_lv>,<target_x>,<target_y>[,<casttime>,<castcancel>];
参数：

<unit_id> | 单位ID（数值类型）
<skill_id> | 技能ID（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skill_lv> | 技能LV（数值类型）
<target_x>,<target_y> | 目标坐标（数值类型）
<casttime> | 咏唱时间（单位为毫秒，默认为发动技能所需要的时间）
<castcancel> | 可否中断（默认为技能的可否中断）
说明： 对NPC无效


unitstop

unitstop命令

作用：让指定单位停止攻击&停止移动

格式： | unitstop <unit_id>;
参数：
<unit_id> | 单位ID（数值类型）


unittalk

unittalk命令

作用：让指定单位说话

格式： | unittalk <unit_id>,<msg>;
参数：
<unit_id> | 单位ID（数值类型）
<msg> | 信息（字符串类型）


unitwalk

（Eathena.Net）unitwalk函数
 （Jathena.Net）unitwalk命令

作用：移动指定单位

格式：
（Eathena.Net）
unitwalk(<unit_id>,<x>,<y>)
unitwalk(<unit_id>,<map_id>)

（Jathena.Net）
unitwalk <unit_id>,<map_id>;
参数：

<unit_id> | 单位ID（数值类型）
<x>,<y> | 坐标（数值类型）
<map_id> | 地图ID（数值类型。在db/map_index.txt中定义）
说明： 用法1：让单位移动到当前地图的(x,y)坐标
用法2：让单位移动到目标地图

（Eathena.Net）
单位不存在时，返回0。
移动成功时返回1，否则返回0。


unitwarp

（Eathena.Net）unitwarp函数
（Jathena.Net）unitwarp命令

作用：传送指定单位

格式：
（Eathena.Net）
unitwarp(<unit_id>,<map_name>,<x>,<y>)

（Jathena.Net）
unitwarp <unit_id>,<map_name>,<x>,<y>;
参数：

<unit_id> | 单位ID（数值类型）
<map_name> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
说明：
（Eathena.Net）
由于EA内部的错误，此函数成功或失败均返回0。


unloadnpc

unloadnpc命令

作用：卸载指定的NPC

格式： | unloadnpc <map>,<x>,<y>,<npc_name>;
参数：
<map> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<npc_name> | NPC名字（字符串类型）
说明： | 卸载名字为npc_name、所在地图为map、坐标为(x,y)的NPC。


viewpoint

viewpoint命令

作用：小地图出现一个标志

格式： | viewpoint <type>,<x>,<y>,<id>,<color>[,<char_id>];
参数：
<type> | 标识（数值类型。1:显示、2:删除。）
<x>,<y> | 显示的坐标（数值类型）
<id> | 顺序编号（数值类型）
<color> | 颜色（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）


waitingroom

waitingroom命令

作用：开启一个聊天室

格式： | waitingroom <title>,<limit>[,<event>[,<trigger>[,<zeny>,<lowlv>,<highlv>,[<job>,<upper>]]]];
参数：
<title> | 标题（字符串类型）
<limit> | 人数上限（数值类型）
<event> | 事件名（字符串类型，可省略）
<trigger> | 触发条件（数值类型，可省略）
<zeny> | 金钱条件（数值类型，可省略，默认为0）
<lowlv> | 最低等级条件（数值类型，可省略，默认为0）
<highlv> | 最高等级条件（数值类型，可省略，默认为MAX_LEVEL）
<job> | 职业条件（数值类型，可省略）
<upper> | 进阶标识条件（数值类型，可省略）
说明： | 开启一个标题为<title>的聊天室。 如果满足了<trigger>，则执行<event>事件。 如果省略了<trigger>，则<limit>会生效。 所携带的金钱不足<zeny>，则无法进入聊天室。 如果设置了<lowlv>和<highlv>，则等级在<lowlv>到<highlv>之间才能进入。 如果指定了<job>和<upper>，则满足职业为<job>并且进阶标识为<upper>才能进入。


warp

warp命令

作用：传送

格式： warp <gatname>,<x>,<y>[,<char_id>];
参数：

<gatname> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： 移动到<gatname>地图的(x,y)坐标。
如果<gatname>是Random的话，则在本地图内随机移动。此时<x>,<y>无意义。

（Eathena.Net）
如果<gatname>是SavePoint或Save的话，则移动到人物储存点。此时<x>,<y>无意义。

（Jathena.Net）
如果<gatname>是SavePoint的话，则移动到人物储存点。此时<x>,<y>无意义。

注意：SavePoint、Random区分大小写。


warpguild

warpguild命令

作用：公会传送

格式：
（Eathena.Net）
warpguild <map_name>,<x>,<y>,<guild_id>;

（Jathena.Net）
warpguild <map_name>,<x>,<y>[,<guild_id>];
参数：

<map_name> | 目标地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<guild_id> 公会ID（数值类型）

（Jathena.Net）
省略时表示自己的公会
说明： 把指定公会的所有玩家传送到<map_name>地图中的(x,y)坐标。

如果<map_name>为Random（区分大小写），则在本地图上进行随机传送。
如果<map_name>为SavePointAll（区分大小写），则把公会中的玩家传送到各自的储存点。
如果<map_name>为SavePoint（区分大小写），则把公会中的玩家传送到触发脚本者的储存点。


warpmap

warpmap命令

格式和作用：（和mapwarp命令一样）


warpnpc

warpnpc命令

作用：传送NPC到指定坐标

格式： | warpnpc <map_name>,<x>,<y>[,<npc_name>];
参数：
<map_name> | 地图名字（字符串类型）
<x>,<y> | 坐标（数值类型）
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）


warpnpc2

warpnpc2命令

作用：传送指定NPC到指定坐标

格式： | warpnpc2 <from_map>,<from_x>,<from_y>,<to_map>,<to_x>,<to_y>,<npc_name>;
参数：
<from_map> | 原地图（字符串类型）
<from_x>,<from_y> | 原坐标（数值类型）
<to_map> | 目标地图（字符串类型）
<to_x>,<to_y> | 目标坐标（数值类型）
<npc_name> | NPC名字（字符串类型）
说明： | 传送名字为npc_name、所在地图为from_map、坐标为(from_x,from_y)的NPC到to_map地图的(to_x,to_y)坐标


warpparty

warpparty命令

作用：队伍传送

格式：
（Eathena.Net）
warpparty <map_name>,<x>,<y>,<party_id>;

（Jathena.Net）
warpparty <map_name>,<x>,<y>[,<party_id>];
参数：

<map_name> | 目标地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<party_id> 队伍ID（数值类型）

（Jathena.Net）
省略时表示自己的队伍
说明： 把指定队伍的所有玩家传送到<map_name>地图中的(x,y)坐标。

如果<map_name>为Random（区分大小写），则在本地图上进行随机传送。
如果<map_name>为SavePointAll（区分大小写），则把队伍中的玩家传送到各自的储存点。
如果<map_name>为SavePoint（区分大小写），则把队伍中的玩家传送到触发脚本者的储存点。

（Eathena.Net）
如果<map_name>为Leader（区分大小写），则把队伍中的玩家传送到队长的储存点。


warpwaitingpc

warpwaitingpc命令

作用：传送聊天室玩家

格式： | warpwaitingpc <gatname>,<x>,<y>[,<count>];
参数：
<gatname> | 地图名字（字符串类型）
<x>,<y> | 坐标（数值类型）
<count> | 人数（数值类型，省略时使用waitingroom的<trigger>指定的人数）
说明： | 把聊天室中的<count>个人传送到<gatname>的(x,y)坐标。 地图名为Random（区分大小写）时表示随机传送，为SavePoint（区分大小写）时表示人物储存点。 被传送的人数会记录在$@warpwaitingpcnum变量中。 被传送的人的account_id（帐号ID）将被记录在$@warpwaitingpc[]数组中。


wedding

wedding命令

作用：显示结婚效果

格式： | wedding[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时为自己）


addtoskill

addtoskill命令

作用：学会/删除人物技能

格式： | addtoskill <skill_id|skill_name>,<skilllv>[,<flag>[,<char_id>]];
参数：
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<skilllv> | 技能LV（数值类型）
<flag> | 标识（数值类型，省略时为2）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | <flag> = 0：永久学会技能（不存在于技能树则无效） <flag> = 1：暂时取得（一般是装备上物品时才能使用） <flag> = 2：在原来技能的等级上加上<skilllv> <skilllv>设置为0时，表示删除技能。 注意：skill和addtoskill的不同只是<flag>的默认值不同，其他都一样。


agitcheck2

agitcheck2函数

作用：检查是否开启了攻城战SE

格式： | agitcheck2()
说明： | 开启了攻城战SE则返回1，否则返回0。


agitend2

agitend2命令

作用：关闭攻城战SE

格式： | agitend2;
说明： | 关闭攻城战SE，并执行OnAgitEnd2标签的事件。


agitstart2

agitstart2命令

作用：开启攻城战SE

格式： | agitstart2;
说明： | 开启攻城战SE，并执行OnAgitStart2标签的事件。


alive

alive命令

作用：复活人物

格式： | alive[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型。省略时表示自己）


attachnpctimer

attachnpctimer函数

作用：关联NPC计时器的触发玩家

格式： | attachnpctimer([<char_name>])
参数：
<char_name> | 玩家名字（字符串类型，省略时表示当前玩家）
说明： | 成功附加的话返回0，NPC或玩家不存在时返回1。


bg_destroy

bg_destroy命令

作用：解散指定的战场队伍

格式： | bg_destroy <bg_id>;
参数：
<bg_id> | 战场队伍ID（数值类型）


bg_getareausers

bg_getareausers函数

作用：获取指定战场队伍的在线人数

格式： | bg_getareausers(<bg_id>,<map_name>,<x0>,<y0>,<x1>,<y1>)
参数：
<bg_id> | 战场队伍ID（数值类型）
<map_name> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 坐标范围（数值类型）
说明： | 战场队伍不存在时，返回0。


bg_get_data

bg_get_data函数

作用：获取指定战场队伍的信息

格式： | bg_get_data(<bg_id>,<type>)
参数：
<bg_id> | 战场队伍ID（数值类型）
<type> | 类型（数值类型） <type> = 0：人数
说明： | 战场队伍不存在时，返回0。


bg_leave

bg_leave命令

作用：让指定玩家退出战场队伍

格式： | bg_leave[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型。省略时表示自己）


bg_monster

bg_monster函数

作用：召唤怪物并设定为属于某战场队伍

格式： | bg_monster(<bg_id>,<map_name>,<x>,<y>,<mob_name>,<mob_id>[,<event>])
参数：
<bg_id> | 战场队伍ID（数值类型）
<map_name> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<mob_name> | 显示的怪物名字（字符串类型）
<mob_id> | 怪物ID（数值类型。在mob_db.txt中定义）
<event> | 怪物死亡事件（字符串类型）
说明： | 成功时返回怪物的单位ID，否则返回0。


bg_monster_set_team

bg_monster_set_team命令

作用：设置怪物所属的战场队伍

格式： | bg_monster_set_team <unit_id>,<bg_id>;
参数：
<unit_id> | 单位ID（数值类型）
<bg_id> | 战场队伍ID（数值类型）


bg_team_setxy

bg_team_setxy命令

作用：设置战场队伍的出生坐标

格式： | bg_team_setxy <bg_id>,<x>,<y>;
参数：
<bg_id> | 战场队伍ID（数值类型）
<x>,<y> | 坐标（数值类型）


bg_updatescore

bg_updatescore命令

作用：更新战场分数

格式： | bg_updatescore <map_name>,<lion>,<eagle>;
参数：
<map_name> | 地图名字（字符串类型）
<lion> | 狮队分数（数值类型）
<eagle> | 鹰队分数（数值类型）


bg_warp

bg_warp命令

作用：把指定战场队伍的玩家传送到指定的坐标

格式： | bg_warp <bg_id>,<map_name>,<x>,<y>;
参数：
<bg_id> | 战场队伍ID（数值类型）
<map_name> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）


bonus5

bonus5命令

作用：五参数bonus

格式： | bonus5 <type>,<val1>,<val2>,<val3>,<val4>,<val5>;
参数：
<type> | bonus5类型的参数
<val1>-<val5> | 数值（当<type>为bAutoSpellOnSkill的时候，val1可以是字符串表示技能名字）
说明： | 详细请参考bonus效果说明文档。


bonusautoscript

bonusautoscript命令

作用：执行攻击的时候，自动发动bonus效果

格式： | bonusautoscript <script>,<rate>[,<flag>[,<target>]];
参数：
<script> | 执行的脚本代码（字符串类型）。推荐使用bonus效果一览表里的效果
<rate> | 千分率（数值类型）
<flag> | 攻击类型（数值类型，可省略。默认为0。跟bAutoSpell共同的标记）： 发动条件（可复数）： 距离条件： BF_SHORT 近距离攻击 BF_LONG 远距离攻击 默认为：BF_SHORT+BF_LONG 攻击类型条件： BF_WEAPON 武器攻击 BF_MAGIC 魔法攻击 BF_MISC 其他攻击 默认为：BF_WEAPON 技能条件： BF_NORMAL 普通攻击 BF_SKILL 技能攻击 默认为：如果攻击类型条件是BF_WEAPON（只有这个）时为BF_NORMAL，否则为BF_SKILL+BF_NORMAL
<target> | 目标（数值类型。0:脚本作用于自己、1:脚本作用于目标）
说明： | 这个指令可以让指定玩家发动独立于物品效果的物品代码，但都不是一直持续发动的。 以<flag>条件、<rate>概率、在<target>上执行<script>代码。


bonusautoscript2

bonusautoscript2命令

作用：当被攻击的时候，自动发动bonus效果

格式： | bonusautoscript2 <script>,<rate>[,<flag>[,<target>]];
参数：
<script> | 执行的脚本代码（字符串类型）。推荐使用bonus效果一览表里的效果
<rate> | 千分率（数值类型）
<flag> | 攻击类型（数值类型，可省略。默认为0。跟bAutoSpell共同的标记）： 发动条件（可复数）： 距离条件： BF_SHORT 近距离攻击 BF_LONG 远距离攻击 默认为：BF_SHORT+BF_LONG 攻击类型条件： BF_WEAPON 武器攻击 BF_MAGIC 魔法攻击 BF_MISC 其他攻击 默认为：BF_WEAPON 技能条件： BF_NORMAL 普通攻击 BF_SKILL 技能攻击 默认为：如果攻击类型条件是BF_WEAPON（只有这个）时为BF_NORMAL，否则为BF_SKILL+BF_NORMAL
<target> | 目标（数值类型。0:脚本作用于自己、1:脚本作用于目标）
说明： | 这个指令可以让指定玩家发动独立于物品效果的物品代码，但都不是一直持续发动的。 以<flag>条件、<rate>概率、在<target>上执行<script>代码。


bonusautoscript3

bonusautoscript3命令

作用：当被使用技能的时候，自动发动bonus效果

格式： | bonusautoscript3 <script>,<rate>,<skill_id|skill_name>[,<target>];
参数：
<script> | 执行的脚本代码（字符串类型）。推荐使用bonus效果一览表里的效果
<rate> | 千分率（数值类型）
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<target> | 目标（数值类型。0:脚本作用于自己、1:脚本作用于目标）
说明： | 这个指令可以让指定玩家发动独立于物品效果的物品代码，但都不是一直持续发动的。 以<skill_id|skill_name>条件、<rate>概率、在<target>上执行<script>代码。


callshop

callshop命令

作用：打开商店

格式： | callshop <name>,<option>;
参数：
<name> | 商店名字（字符串类型）
<option> | 选项（数值类型） <option> = 0：正常窗口（购买/出售/取消） <option> = 1：购买窗口 <option> = 2：出售窗口
说明： | 这个指令用于创建动态商店。 callshop命令让玩家点击隐藏的商店（view值为-1的）。 可以参考例子：npc/sample/npc_dynamic_shop.txt


clone

clone函数

作用：克隆玩家

格式： | clone(<map name>,<x>,<y>,<event>,<char_id>[,<master_id>[,<mode>[,<flag>[,<duration>]]]])
参数：
<map_name> | 目标地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<event> | 死亡时事件（字符串类型）
<char_id> | 要复制的人物ID（数值类型，玩家必须在线）
<master_id> | 主人ID（数值类型，必须是在线玩家的char_id）
<mode> | 模式（数值类型，作用跟mob_db的mode相同）
<flag> | 标识（数值类型。0的时候会攻击所有玩家，1的话会让主人设定生效。默认为0）
<duration> | 持续时间（数值类型。单位为秒。默认为0，表示无时间限制）
说明： | 克隆成功时返回单位ID，失败时返回0。


cmdothernpc

cmdothernpc命令

作用：执行NPC的OnCommand事件

格式： | cmdothernpc <npc_name>,<command>;
参数：
<npc_name> | NPC名字（字符串类型）
<command> | 命令（字符串类型）
说明： | 这个指令相当于执行： donpcevent <npc name>::OnCommand<command>


deletequest

deletequest命令

作用：删除任务

格式： | deletequest <quest_id>;
参数：
<quest_id> | 任务ID（数值类型）


delwall

delwall命令

作用：删除指定墙壁

格式： | delwall <wall_name>;
参数：
<wall_name> | 墙壁识别名字（字符串类型。必须唯一）


detachnpctimer

detachnpctimer函数

作用：移除关联到NPC计时器的触发玩家

格式： | detachnpctimer([<npc_name>])
参数：
<npc_name> | NPC名字（字符串类型，省略时表示当前NPC）
说明： | 成功移除的话返回0，NPC不存在时返回1。


disablearena

disablearena命令

格式和作用：（和disablewaitingroomevent命令一样）


disable_items

disable_items命令

作用：禁止人物在使用NPC的期间使用物品

格式： | disable_items[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


eaclass

eaclass函数

作用：返回EA的职业代码

格式： eaclass([<job_number>])
参数：

<job_number> RO的职业编号（数值类型。省略时为当前玩家的职业编号）
说明： 作用跟roclass指令相反。

<例>
set @eac, eaclass();
if ((@eac&EAJ_BASEMASK) == EAJ_SWORDMAN)
mes "你可以成为剑士、骑士、十字军、圣殿十字军、进阶剑士、骑士领主、剑士宝宝、骑士宝宝、十字军宝宝。";
if (@eac&EAJL_UPPER)
mes "你的是转生职业。";
if ((@eac&EAJ_UPPERMASK) == EAJ_SWORDMAN)
mes "你可以成为剑士、剑士宝宝、进阶剑士。";


enablearena

enablearena命令

格式和作用：（和enablewaitingroomevent命令一样）


enable_items

enable_items命令

作用：允许人物在使用NPC的期间使用物品

格式： | enable_items[<char_id>];
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


getbattleflag

getbattleflag函数

作用：获取battleconf选项的值

格式： | getbattleflag(<battle_flag>)
参数：
<battle_flag> | 选项的名字（字符串类型）
说明： | 返回值为数值类型。


getd

getd函数

作用：返回一个变量的引用（主要作用是可以动态改变变量名）

格式： getd(<variable_name>)
参数：

<variable_name> 变量名（字符串类型）
说明： <例>

set getd("$varRefence"), 1;
set @i, getd("$pikachu");


gethominfo

gethominfo函数

作用：获取携带人工生命体的详细信息

格式： | gethominfo(<type>[,<char_id>])
参数：
<type> | 类型（数值类型） 0 - homun_id（人工生命体唯一的ID） 1 - class（在homunculus_db.txt中对应的人工生命体ID） 2 - name（名字） 3 - friendly（亲密度。最高100000） 4 - hungry（饥饿度。最高100，表示最饱） 5 - rename_flag（更名标识。0表示可以为人工生命体改名） 6 - level（等级）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 如果<type>不为2时，人物没有携带人工生命体或者人物不存在时，返回0。 如果<type>为2时，人物没有携带人工生命体或者人物不存在时，返回"null"字符串。 <type>超出范围时，返回0。


getitem3

getitem3命令

作用：取得物品

格式： | getitem3 <item_id>,<dure>,<max_dure>,<exp>,<lv>,<rent_seconds>[,<char_id>];
参数：
<item_id> | 物品ID（数值类型）
<dure> | 当前耐久度（数值类型）
<max_dure> | 最大耐久度（数值类型）
<exp> | 装备经验（数值类型）
<lv> | 装备等级（数值类型）
<rent_seconds> | 租赁时间（数值类型）
<char_id> | 人物的char_id（数值类型。省略时表示自己）


getiteminfo2

getiteminfo2函数

作用：取得指定物品的详细资料

格式： | getiteminfo2(<item_id>,<type>)
参数：
<item_id> | 物品ID（数值类型）
<type> | 情报类型（数值类型） <type>=1：Name（英文名称） <type>=2：Jname（日文名字/中文名称） <type>=3：Type（类型） <type>=4：Price（买价） <type>=5：Sell（卖价） <type>=6：Weight（负重） <type>=7：ATK（攻击力） <type>=8：DEF（防御力） <type>=9：Range（射程） <type>=10：Slot（洞数） <type>=11：Job（职业，16进制字符串表示） <type>=12：Upper（进阶） <type>=13：Gender（性别） <type>=14：Loc（位置） <type>=15：wLV（武器等级） <type>=16：eLV（装备等级） <type>=17：Refine（可否精炼） <type>=18：View（外观） <type>=19：type2（类型2——EA.Net特有） <type>=20：CustomRate（自定义掉率——EA.Net特有）
说明： | 返回-1时，表示物品不存在或<type>错误。


getitemslots

getitemslots函数

格式和作用：（和getitemslot命令一样）


getmapflag

getmapflag函数

作用：获取地图对应mapflag的设定值

格式： | getmapflag(<map_name>,<mapflag>)
参数：
<map_name> | 地图名字（字符串类型）
<mapflag> | mapflag标识（数值类型。在const.txt中定义为"mf_xxxx"的枚举，例如mf_nomemo）


getmapguildusers

getmapguildusers函数

作用：获取指定公会在指定地图的在线人数

格式： | getmapguildusers(<mapname>,<guild_id>)
参数：
<mapname> | 地图名（字符串类型）
<guild_id> | 公会ID（数值类型）
说明： | 地图不存在时，返回-1。


getmobdrops

getmobdrops函数

作用：获取怪物掉落物品的详细资料

格式： | getmobdrops(<mob_id>)
参数：
<mob_id> | 怪物ID（数值类型）
说明： | 当怪物存在的时候，把掉落物品信息储存到以下数组中： $@MobDrop_item[]：掉落物品的ID $@MobDrop_rate[]：掉率物品的机率 $@MobDrop_count：掉落物品的数量 并且返回1。 怪物不存在的时候返回0。


getmonsterinfo

getmonsterinfo函数

作用：获取mobdb中的怪物信息

格式： | getmonsterinfo(<mob_id>,<type>)
参数：
<mob_id> | 怪物ID（数值类型。在mob_db.txt中定义）
<type> | 要显示的信息类型（数值类型）
说明： | <type> = 0：jname（中文名字） <type> = 1：lv（怪物等级） <type> = 2：max_hp（HP上限） <type> = 3：base_exp（Base经验） <type> = 4：job_exp（Job经验） <type> = 5：atk（最低攻击力） <type> = 6：atk2（最高攻击力） <type> = 7：def（防御力） <type> = 8：mdef（魔法防御力） <type> = 9：str <type> = 10：agi <type> = 11：vit <type> = 12：int <type> = 13：dex <type> = 14：luk <type> = 15：range（攻击距离） <type> = 16：range2（技能距离） <type> = 17：range3（地面技能距离） <type> = 18：size（大小） <type> = 19：race（种族） <type> = 20：def_ele（属性） <type> = 21：mode（模式） <type>在const.txt中有定义： MOB_NAME 0 MOB_LV 1 MOB_MAXHP 2 MOB_BASEEXP 3 MOB_JOBEXP 4 MOB_ATK1 5 MOB_ATK2 6 MOB_DEF 7 MOB_MDEF 8 MOB_STR 9 MOB_AGI 10 MOB_VIT 11 MOB_INT 12 JOB_DEX 13 MOB_LUK 14 MOB_RANGE 15 MOB_RANGE2 16 MOB_RANGE3 17 MOB_SIZE 18 MOB_RACE 19 MOB_ELEMENT 20 MOB_MODE 21 <type>超出范围时，返回-1。 怪物不存在时，如果<type>为0则返回"null"字符串，如果<type>不为0则返回-1。


getnameditem

getnameditem函数

作用：取得制作物品

格式： | getnameditem(<item_id|item_name>,<char_name|char_id>)
参数：
<item_id|item_name> | 物品ID|名字（数值|字符串类型）
<char_name|char_id> | 要刻上名称的人物ID|名字（数值|字符串类型）
说明： | 获得刻有指定名字的物品。 <item_id|item_name>可以为字符串类型（name,jname）。 但是物品名字是根据item_db.txt等文件，所以除测试目的外不要使用。 成功时返回1，失败时返回0。


getquest

getquest命令

作用：添加任务

格式： | getquest <quest_id>,<time>[,<name1>,<count1>[,<name2>,<count2>[,<name3>,<count3>]]];
参数：
<quest_id> | 任务ID（数值类型）
<time> | 时间（数值类型。单位为秒？）
<name1>,<name2>,<name3>... | 任务目标名字（字符串类型）
<count1>,<count2>,<count3>... | 任务目标数量？（数值类型）


getrefine

getrefine函数

作用：获取人物当前武器的精炼值

格式： | getrefine([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型，省略时表示自己）


groupranditem

groupranditem函数

作用：从物品分组里取得随机物品ID

格式： | groupranditem(<group>)
参数：
<group> | 分组ID（数值类型）
说明： | 物品分组在item_group_db.txt中定义。


guardian

guardian函数

作用：召唤监护人

格式： | guardian(<map_name>,<x>,<y>,<mob_name>,<mob_id>[,<event>[,<guardian_index>]])
参数：
<map_name> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<mob_name> | 显示名字（字符串类型）
<mob_id> | 怪物ID（数值类型，在mob_db.txt中定义）
<event> | 死亡时执行事件（字符串类型）
<guardian_index> | 监护人索引（数值类型。默认为0。范围从0～MAX_GUARDIANS-1，MAX_GUARDIANS在源代码中定义，默认为8）
说明： | <type> = 1：name <type> = 2：jname <type> = 3：Lv <type> = 4：MaxHP <type> = 5：MaxSP <type> = 6：Base经验 <type> = 7：Job经验 地图不存在、怪物不存在、<guardian_index>超出范围、坐标值不正确时，返回0。 成功时，返回怪物的单位ID(unit_id)。


guardianinfo

guardianinfo函数

作用：获取指定监护人的信息

格式： | guardian(<map_name>,<index>,<type>)
参数：
<map_name> | 地图名（字符串类型）
<index> | 监护人索引（数值类型。默认为0。范围从0～MAX_GUARDIANS-1，MAX_GUARDIANS在源代码中定义，默认为8）
<type> | 类型（数值类型）
说明： | <type> = 0：是否设置了监护人 <type> = 1：MaxHP <type> = 2：HP 地图不存在、怪物不存在、<guardian_index>超出范围、<type>超出范围时，返回-1。


guildchangegm

guildchangegm函数

作用：改变公会会长

格式： | guildchangegm(<guild_id>,<new_master_name>)
参数：
<guild_id> | 公会ID（数值类型）
<new_master_name> | 新公会会长的名字（字符串类型）
说明： | 成功时返回1，否则返回0。


hasquest

hasquest函数

作用：检查玩家是否接受了某任务

格式： | hasquest(<quest_id>)
参数：
<quest_id> | 任务ID（数值类型）


homevolution

homevolution命令

作用：让人工生命体进化

格式： | homunevolution[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时表示自己）


homshuffle

homshuffle命令

作用：重新计算人工生命体的属性

格式： | homunevolution[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时表示自己）


isequippedcnt

isequippedcnt函数

作用：检查人物装备了多少指定的装备或卡片

格式： | isequippedcnt(<item1>[,<item2>[,<item3>....[,<itemn>]]])
参数：
<item1>,<item2>,<item3>...<itemn> | 装备/卡片ID（数值类型）


jobname

jobname函数

作用：取得职业名字

格式： | jobname(<job_number>)
参数：
<job_number> | 职业编号（数值类型）
说明： | 职业名称在msg_athena.conf中的550->650编号中定义。


logmes

logmes命令

作用：记录信息到npclog表

格式： | logmes <message>;
参数：
<message> | 信息（字符串类型）
说明： | 要在log/npclog.log中设置为记录才会生效。


mercenary_create

mercenary_create命令

作用：雇用佣兵

格式： | mercenary_create <class>,<contract_time>[,<char_id>];
参数：
<class> | 佣兵ID（数值类型。在mercenary_db.txt中定义）
<contract_time> | 契约时间（数值类型。单位为ms）
<char_id> | 人物的char_id（数值类型。省略时表示自己）


mercenary_get_calls

mercenary_get_calls函数

作用：获取某佣兵公会的佣兵的雇用次数

格式： | mercenary_get_calls(<guild>[,<char_id>])
参数：
<guild> | 佣兵的公会编号（数值类型。0:弓佣兵公会、1:矛佣兵公会、2:剑佣兵公会）
<char_id> | 人物的char_id（数值类型。省略时表示自己）


mercenary_get_faith

mercenary_get_faith函数

作用：获取某佣兵公会的佣兵的忠诚度

格式： | mercenary_get_faith(<guild>[,<char_id>])
参数：
<guild> | 佣兵的公会编号（数值类型。0:弓佣兵公会、1:矛佣兵公会、2:剑佣兵公会）
<char_id> | 人物的char_id（数值类型。省略时表示自己）


mercenary_heal

mercenary_heal命令

作用：恢复佣兵的HP/SP

格式： | mercenary_create <hp>,<sp>[,<char_id>];
参数：
<hp> | 要恢复的HP（数值类型）
<sp> | 要恢复的SP（数值类型）
<char_id> | 人物的char_id（数值类型。省略时表示自己）


mercenary_sc_start

mercenary_sc_start命令

作用：造成指定人物的佣兵陷入异常状态

格式： | mercenary_sc_start <type>,<tick>,<val1>[,<char_id>];
参数：
<type> | 异常状态的编号（数值类型。请参考status.h。也可以参考在const.txt中的"SC_xxxx"字样的定义）
<tick> | 异常状态持续的时间（数值类型，单位为ms）
<val1> | 造成异常状态对应的技能的等级（数值类型）
<char_id> | 人物的char_id（数值类型。省略时表示自己）


mercenary_set_calls

mercenary_set_calls命令

作用：设置某佣兵公会的佣兵的雇用次数

格式： | mercenary_set_calls <guild>,<value>[,<char_id>];
参数：
<guild> | 佣兵的公会编号（数值类型。0:弓佣兵公会、1:矛佣兵公会、2:剑佣兵公会）
<value> | 设定值（数值类型）
<char_id> | 人物的char_id（数值类型。省略时表示自己）
说明： | 注意：雇用次数不是直接设置为<value>，是在原有的基础上加上<value>的值。最终值必须大于等于0。


mercenary_set_faith

mercenary_set_faith命令

作用：设置某佣兵公会的佣兵的忠诚度

格式： | mercenary_set_faith <guild>,<value>[,<char_id>];
参数：
<guild> | 佣兵的公会编号（数值类型。0:弓佣兵公会、1:矛佣兵公会、2:剑佣兵公会）
<value> | 设定值（数值类型）
<char_id> | 人物的char_id（数值类型。省略时表示自己）
说明： | 注意：忠诚度不是直接设置为<value>，是在原有的基础上加上<value>的值。最终值必须大于等于0。


mobcount

mobcount函数

作用：取得指定地图指定死亡事件的怪物数量

格式： | mobcount(<map_name>,<event>)
参数：
<map_name> | 地图名（字符串类型）
<event> | 事件名（字符串类型）


movenpc

movenpc命令

作用：移动NPC到指定坐标

格式： | movenpc <npc_name>,<x>,<y>;
参数：
<npc_name> | NPC名字（字符串类型）
<x>,<y> | 坐标（数值类型）


npcshopadditem

npcshopadditem函数

作用：添加NPC商店的出售物品及价钱

格式： | npcshopadditem(<name>,<item_id1>,<price1>[,<item_id2>,<price2>[,<item_id3>,<price3>...]])
参数：
<name> | NPC名字（字符串类型）
<item_id1>,<item_id2>....<item_idN> | 物品ID（数值类型）
<price1>,<price2>...<priceN> | 价钱（数值类型。使用-1时，表示默认价格）
说明： | 成功时返回1。否则返回0。


npcshopattach

npcshopattach函数

作用：把商店NPC关联（或取消关联）到当前脚本

格式： | npcshopattach(<name>[,<flag>])
参数：
<name> | 商店的NPC名字（字符串类型）
<flag> | 标识（数值类型。默认为1。1:关联、0:取消关联。）
说明： | 当商店NPC关联到当前脚本，每当玩家购买/出售物品时，就会执行"OnBuyItem"和"OnSellItem"事件。 另外，@bought_nameid[]、@bought_quantity[]、@sold_nameid[]、@sold_quantity[]数组将会记录购买/出售的物品ID和数量。 注意：当把商店NPC关联到当前脚本时，将会取消关联之前关联过的脚本。 成功时返回1。否则返回0。


npcshopdelitem

npcshopdelitem函数

作用：删除NPC商店的出售物品

格式： | npcshopadditem(<name>,<item_id1>[,<item_id2>[,<item_id3>...]])
参数：
<name> | NPC名字（字符串类型）
<item_id1>,<item_id2>....<item_idN> | 物品ID（数值类型）
说明： | 成功时返回1。否则返回0。


npcshopitem

npcshopitem函数

作用：重写NPC商店的出售物品及价钱

格式： | npcshopitem(<name>,<item_id1>,<price1>[,<item_id2>,<price2>[,<item_id3>,<price3>...]])
参数：
<name> | NPC名字（字符串类型）
<item_id1>,<item_id2>....<item_idN> | 物品ID（数值类型）
<price1>,<price2>...<priceN> | 价钱（数值类型。使用-1时，表示默认价格）
说明： | 成功时返回1。否则返回0。


npcskilleffect

npcskilleffect命令

作用：在指定坐标显示技能效果

格式： | npcskilleffect <skill_id|skill_name>,<level>,<x>,<y>;
参数：
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<level> | 技能Lv（数值类型）
<x>,<y> | 坐标（数值类型）


nude

nude命令

格式和作用：（和releaseall命令一样）


openauction

openauction命令

作用：打开拍卖窗口

格式： | openauction[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时为自己）


openmail

openmail命令

格式和作用：（和mailbox命令一样）


petheal

petheal命令

作用：重复技能回复HP/SP

格式： | petheal <level>,<delay>,<percent_hp>,<percent_sp>;
参数：
<level> | 治愈术等级（数值类型）
<delay> | 延迟时间（数值类型，单位为秒）
<percent_hp> | 回复的HP百分比（数值类型）
<percent_sp> | 回复的SP百分比（数值类型）


petloot

petloot命令

作用：设置宠物最大捡物数量

格式： | petloot <max_items>;
参数：
<max_items> | 最大捡物数量（数值类型。最大为30）


petrecovery

petrecovery命令

作用：宠物技能恢复效果

格式： | petrecovery <status_type>,<delay>;
参数：
<bonus_type> | 状态类型（数值类型。请参考const.txt中以"SC_"开头的定义）
<delay> | 延迟时间（数值类型，单位为秒）


petskillattack2

petskillattack2命令

作用：宠物使用技能攻击

格式： | petskillattack2 <skill_id|skill_name>,<damage>,<hit>,<rate>,<bonusrate>;
参数：
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<damage> | 固定伤害值（数值类型）
<hit> | hit数（数值类型）
<rate> | 发动率（数值类型。单位是1%）
<bonusrate> | 根据好感度增加的发动率（好感度 * 0.01% * <bonusrate>）


petskillbonus

petskillbonus命令

作用：宠物技能bonus效果

格式： | petskillbonus <bonus_type>,<value>,<duration>,<delay>;
参数：
<bonus_type> | bonus类型（数值类型。bInt,bVit,bDex,bAgi,bLuk,bStr,bSpeedRate等等，请参考const.txt中以"b"开头的定义）
<value> | 增加的数值（数值类型）
<duration> | 持续时间（数值类型，单位为秒）
<delay> | 延迟时间（数值类型，单位为秒）


petstat

petstat函数

作用：获取携带宠物详细信息

格式： | petstat(<flag>)
参数：
<flag> | 标识（数值类型） <flag> = 1：宠物ID（在pet_db.txt中定义） <flag> = 2：宠物名字 <flag> = 3：Lv <flag> = 4：饥饿度 <flag> = 5：亲密度
说明： | 如果<flag>不为2时，人物没有携带宠物或者人物不存在时，返回0。 如果<flag>为2时，人物没有携带宠物或者人物不存在时，返回空字符串。 <flag>超出范围时，返回0。


playerattached

playerattached函数

作用：返回当前触发玩家的account_id

格式： | playerattached()
说明： | 玩家不存在或没有触发玩家时，返回0。


prompt

prompt函数

作用：显示菜单，并返回选项的号码

格式： | prompt(<string1>[,<string2>,<string3>...])
参数：
<string1>,<string2>... | 菜单项（字符串类型）
说明： | 显示菜单，并返回选择了的菜单项。 如果选择了第1项，则返回1。并把返回值保存在@menu变量中。 用法跟select一样。 使用了select的菜单，如果按cancel，直接结束脚本。 使用了prompt的菜单，如果按cancel，并不结束脚本，并且返回255后继续运行脚本。


readbook

readbook命令

作用：阅读书本

格式： | readbook <book_id>,<page>[,<char_id>];
参数：
<book_id> | 书本ID（数值类型。即物品ID）
<page> | 页数（数值类型）
<char_id> | 人物的char_id（数值类型。省略时表示自己）


rentitem

rentitem命令

作用：租用物品

格式： | rentitem <item_id|item_name>,<seconds>;
参数：
<item_id|item_name> | 物品ID|名字（数值|字符串类型）
<seconds> | 秒数（数值类型）
说明： | 让人物租用指定的物品，到期自动消失。


rid2name

rid2name函数

作用：获取单位对象的名字

格式： | rid2name(<rid>)
参数：
<rid> | 单位ID（数值类型）
说明： | 单位类型可以是：怪物、玩家、NPC、宠物、人工生命体、佣兵。 如果单位的类型不正确，则返回空字符串。 如果单位不存在，则返回"(null)"字符串。


roclass

roclass函数

作用：返回RO的职业代码

格式： eaclass(<class>,[<gender>])
参数：

<class> | EA的职业代码（数值类型）
<gender> | 性别（数值类型。1:男、2:女。省略时为触发玩家的性别。如果没有触发玩家，则自动使用1。）
说明： 作用跟eaclass指令相反。

<例>
set @eac, eaclass();
//检查是否已经转生
if (@eac&EAJL_UPPER) {
mes "你好像很强哦";
close;
}
set @eac, roclass(@eac|EAJL_UPPER);
//检查进阶标识
if (@eac != -1) {
mes "你肯定迫不及待的想成为"+jobname(@eac)+"吧!";
close;
}


save

save命令

格式和作用：（和savepoint命令一样）


sc_start4

sc_start4命令

作用：造成指定对象异常状态

格式： | sc_start4 <type>,<tick>,<val1>,<val2>,<val3>,<val4>[,<target_id>];
参数：
<type> | 异常状态的编号（数值类型。请参考status.h。也可以参考在const.txt中的"SC_xxxx"字样的定义）
<tick> | 异常状态持续的时间（数值类型，单位为ms）
<val1> | 第一属性（数值类型）
<val2> | val1属性的抗性（数值类型）
<val3> | 第二属性（数值类型）
<val4> | val2属性的抗性（数值类型）
<target_id> | 单位ID（数值类型，省略时为自己）
说明： | <例> sc_start4 SC_DefEle,60000,Ele_Fire,20,Ele_Water,-15;


setbattleflag

setbattleflag命令

作用：设置battleconf选项的值

格式： | setbattleflag <battle_flag>,<value>;
参数：
<battle_flag> | 选项的名字（字符串类型）
<value> | 设定值（字符串类型）


setd

setd命令

作用：设置一个变量的值（主要作用是可以动态改变变量名）

格式： | setd <variable_name>,<value>;
参数：
<variable_name> | 变量名（字符串类型）
<value> | 设定值（数值|字符串类型）
说明： | <例> set $var$, "Poring"; setd "$var$", "Poporing"; mes $var$; //返回"Poporing" setd "$" + $var$ + "123$", "Poporing is cool"; mes $Poporing123$; //返回"Poporing is cool"


setiteminfo

setiteminfo函数

作用：设置指定物品的详细属性

格式： | setiteminfo(<item_id>,<type>,<value>)
参数：
<item_id> | 物品ID（数值类型）
<type> | 情报类型（数值类型） 0 - value_buy（购买价格） 1 - value_sell（卖价） 2 - type（类型） 3 - maxchance（最大掉率。单位为0.01%。如果是0，表示怪物不掉落此物品。如果是10000，表示此物品在NPC商店有出售） 4 - sex（性别） 5 - loc（位置） 6 - weight（重量） 7 - ATK（攻击力） 8 - DEF（防御力） 9 - Range（射程） 10 - Slot（洞数） 11 - View（外观） 12 - wLV（武器等级） 13 - eLV（装备等级） 14 - view_id（在item_avail.txt中设定的替换外观。没有设定的话为0）
<value> | 设定值（数值|字符串类型）
说明： | 成功时返回<value>值。 如果<type>超出范围时，返回-1。


setiteminfo2

setiteminfo2命令

作用：设置指定物品的详细资料

格式： | setiteminfo2 <item_id>,<type>,<value>;
参数：
<item_id> | 物品ID（数值类型）
<type> | 情报类型（数值类型） <type>=1：Name（英文名称） <type>=2：Jname（日文名字/中文名称） <type>=3：Type（类型） <type>=4：Price（买价） <type>=5：Sell（卖价） <type>=6：Weight（负重） <type>=7：ATK（攻击力） <type>=8：DEF（防御力） <type>=9：Range（射程） <type>=10：Slot（洞数） <type>=11：Job（职业，16进制字符串表示） <type>=12：Upper（进阶） <type>=13：Gender（性别） <type>=14：Loc（位置） <type>=15：wLV（武器等级） <type>=16：eLV（装备等级） <type>=17：Refine（可否精炼） <type>=18：View（外观） <type>=19：type2（类型2——EA.Net特有） <type>=20：CustomRate（自定义掉率——EA.Net特有）
<value> | 设定值（数值|字符串类型）


setitemscript

setitemscript函数

作用：设置物品的脚本

格式： | setitemscript(<item_id>,<script>[,<n>])
参数：
<item_id> | 物品ID（数值类型）
<script> | 要设置的脚本代码（字符串类型）
<n> | 类型（数值类型。默认为0） <n> = 0：使用效果 <n> = 1：装备效果 <n> = 2：卸载效果 <n> = 3：装备升级效果
说明： | 成功时返回1，否则返回0。


setnpcdisplay

setnpcdisplay函数

作用：改变NPC的名字和样子

格式： setnpcdisplay(<npc_name>,<new_display_name>[,<class>[,<size>]])
setnpcdisplay(<npc_name>,<class>)
参数：

<npc_name> | NPC名字（字符串类型）
<new_display_name> | NPC新的显示名字（字符串类型）
<class> | NPC外观代码（数值类型）
<size> | 大小（数值类型。0:正常、1:小、2:大）
说明： NPC不存在时，返回1。
成功时返回0。


setquestobjective

setquestobjective命令

作用：修改任务

格式： | setquestobjective <quest_id>,<num>,<name>,<count>;
参数：
<quest_id> | 任务ID（数值类型）
<num> | 任务目的编号（数值类型。0-MAX_QUEST_OBJECTIVES。MAX_QUEST_OBJECTIVES默认为3。）
<name> | 任务目标名字（字符串类型）
<count> | 任务目标数量？（数值类型）


setqueststatus

setqueststatus命令

作用：修改任务状态

格式： | setqueststatus <quest_id>,<active>;
参数：
<quest_id> | 任务ID（数值类型）
<active> | 是否开启（数值类型。0:关闭、1:开启）


setwall

setwall命令

作用：创建隐形墙壁

格式： | setwall <map_name>,<x>,<y>,<size>,<dir>,<shootable>,<wall_name>;
参数：
<map_name> | 地图名字（字符串类型）
<x>,<y> | 坐标（数值类型）
<size> | 大小（数值类型。就是墙壁的格数）
<dir> | 方向（数值类型。跟NPC的方向一样的定义）
<shootable> | 是否可以射击（数值类型）
<wall_name> | 墙壁识别名字（字符串类型。必须唯一）


skilleffect

skilleffect命令

作用：给玩家显示恢复效果

格式： | skilleffect <skill_id|skill_name>,<level>;
参数：
<skill_id|skill_name> | 技能ID|名字（数值|字符串类型）
<level> | 技能Lv（数值类型。表示要显示的恢复量）
说明： | 被命令的NPC给玩家造成技能为<skill_id|skill_name>的恢复效果，恢复值显示为<level>（没有进行实际恢复）。 此命令仅限于指定的支援/恢复技能的效果。


soundeffectall

soundeffectall命令

作用：打开/关闭声音

格式： | soundeffectall <filename>,<type>[,<map_name>[,<x0>,<y0>,<x1>,<y1>]];
参数：
<filename> | 文件名（字符串类型）
<type> | 重复模式（数值类型） 0 - 播放1次 1 - 反复播放 2 - 停止播放
<map_name> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 坐标范围（数值类型。省略时表示全地图）


specialeffect

specialeffect命令

作用：NPC显示特殊效果

格式： specialeffect <effect_number>[,<send_target>];
参数：

<effect_number> | 特殊效果的代码（数值类型。请参考“各种效果一览表（misceffect）”）
<send_target> | 发送封包的范围（数值类型。默认为2，表示AREA）
说明 <send_target> = 0：ALL_CLIENT（所有玩家）
<send_target> = 1：ALL_SAMEMAP（相同地图）
<send_target> = 2：AREA,（一定区域内）
<send_target> = 3：AREA_WOS,（一定区域内，除了自己）
<send_target> = 4：AREA_WOC,（一定区域内，除了所有聊天室）
<send_target> = 5：AREA_WOSC,（一定区域内，除了自己的聊天室）
<send_target> = 6：AREA_CHAT_WOC,（可见区域内，除了所有聊天室）
<send_target> = 7：CHAT,（当前聊天室）
<send_target> = 8：CHAT_WOS,（当前聊天室，除了自己）
<send_target> = 9：PARTY,（当前队伍）
<send_target> = 10：PARTY_WOS,（当前队伍，除了自己）
<send_target> = 11：PARTY_SAMEMAP,（当前队伍，相同地图）
<send_target> = 12：PARTY_SAMEMAP_WOS,（当前队伍，相同地图，除了自己）
<send_target> = 13：PARTY_AREA,（当前队伍，一定区域内）
<send_target> = 14：PARTY_AREA_WOS,（当前队伍，一定区域内，除了自己）
<send_target> = 15：GUILD,（当前公会）
<send_target> = 16：GUILD_WOS,（当前公会，除了自己）
<send_target> = 17：GUILD_SAMEMAP,（当前公会，相同地图）
<send_target> = 18：GUILD_SAMEMAP_WOS,（当前公会，相同地图，除了自己）
<send_target> = 19：GUILD_AREA,（当前公会，一定区域内）
<send_target> = 20：GUILD_AREA_WOS,（当前公会，一定区域内，除了自己）
<send_target> = 21：DUEL,（决斗）
<send_target> = 22：DUEL_WOS,（决斗，除了自己）
<send_target> = 23：CHAT_MAINCHAT,（世界聊天）
<send_target> = 24：SELF,（自己）


specialeffect2

specialeffect2命令

作用：玩家显示特殊效果

格式： specialeffect2 <effect_number>[,<send_target>];
参数：

<effect_number> | 特殊效果的代码（数值类型。请参考“各种效果一览表（misceffect）”）
<send_target> | 发送封包的范围（数值类型。默认为2，表示AREA）
说明 <send_target> = 0：ALL_CLIENT（所有玩家）
<send_target> = 1：ALL_SAMEMAP（相同地图）
<send_target> = 2：AREA,（一定区域内）
<send_target> = 3：AREA_WOS,（一定区域内，除了自己）
<send_target> = 4：AREA_WOC,（一定区域内，除了所有聊天室）
<send_target> = 5：AREA_WOSC,（一定区域内，除了自己的聊天室）
<send_target> = 6：AREA_CHAT_WOC,（可见区域内，除了所有聊天室）
<send_target> = 7：CHAT,（当前聊天室）
<send_target> = 8：CHAT_WOS,（当前聊天室，除了自己）
<send_target> = 9：PARTY,（当前队伍）
<send_target> = 10：PARTY_WOS,（当前队伍，除了自己）
<send_target> = 11：PARTY_SAMEMAP,（当前队伍，相同地图）
<send_target> = 12：PARTY_SAMEMAP_WOS,（当前队伍，相同地图，除了自己）
<send_target> = 13：PARTY_AREA,（当前队伍，一定区域内）
<send_target> = 14：PARTY_AREA_WOS,（当前队伍，一定区域内，除了自己）
<send_target> = 15：GUILD,（当前公会）
<send_target> = 16：GUILD_WOS,（当前公会，除了自己）
<send_target> = 17：GUILD_SAMEMAP,（当前公会，相同地图）
<send_target> = 18：GUILD_SAMEMAP_WOS,（当前公会，相同地图，除了自己）
<send_target> = 19：GUILD_AREA,（当前公会，一定区域内）
<send_target> = 20：GUILD_AREA_WOS,（当前公会，一定区域内，除了自己）
<send_target> = 21：DUEL,（决斗）
<send_target> = 22：DUEL_WOS,（决斗，除了自己）
<send_target> = 23：CHAT_MAINCHAT,（世界聊天）
<send_target> = 24：SELF,（自己）


strmobinfo

strmobinfo函数

作用：取得怪物各种信息

格式： | strmobinfo(<type>[,<mob_id>])
参数：
<type> | 类型（数值类型）
<mob_id> | 怪物ID（数值类型，在mob_db.txt中定义）
说明： | <type> = 1：name <type> = 2：jname <type> = 3：Lv <type> = 4：MaxHP <type> = 5：MaxSP <type> = 6：Base经验 <type> = 7：Job经验 怪物不存在或<type>超出范围时，返回0。


waitingroom2bg

waitingroom2bg函数

作用：把聊天室的玩家分配到战场队伍中

格式： | waitingroom2bg(<map_name>,<x>,<y>,<ev>,<dev>[,<npc_name>])
参数：
<map_name> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<ev> | 登出事件（字符串类型）
<dev> | 死亡事件（字符串类型）
<npc_name> | NPC名字（字符串类型。省略时表示当前NPC）
说明： | 把聊天室的玩家分配到一个新建立的战场队伍中，并返回战场队伍的ID。 如果战场对象创建失败，则返回0。 成功分配到战场队伍中的玩家，会自动传送到指定的地点。 把加入战场队伍的聊天室玩家名字列表记录到$@arenamembers[]数组中 并且把人数记录到$@arenamembersnum变量中。


waitingroom2bg_single

waitingroom2bg_single函数

作用：把聊天室的第一个玩家分配到战场队伍中

格式： | waitingroom2bg_single(<bg_id>,<map_name>,<x>,<y>,<npc_name>)
参数：
<bg_id> | 战场队伍ID（数值类型）
<map_name> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<npc_name> | NPC名字（字符串类型）
说明： | 成功传送的话返回1，否则返回0。 成功分配到战场队伍中的玩家，会自动传送到指定的地点。


warpchar

warpchar命令

作用：人物传送

格式： | warpchar <gatname>,<x>,<y>,<char_id>;
参数：
<gatname> | 地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<char_id> | 人物的char_id
说明： | 移动到<gatname>地图的(x,y)坐标。 如果<gatname>是SavePoint的话，则移动到人物储存点。此时<x>,<y>无意义。 如果<gatname>是Random的话，则在本地图内随机移动。此时<x>,<y>无意义。 注意：SavePoint、Random区分大小写。


warppartner

warppartner函数

作用：传送伴侣

格式： | warppartner(<map_name>,<x>,<y>[,<char_id>])
参数：
<map_name> | 目标地图名（字符串类型）
<x>,<y> | 坐标（数值类型）
<char_id> | 人物的char_id（数值类型，省略时为自己）
说明： | 如果人物不存在、没有结婚、伴侣不存在、地图不存在时，返回0。 成功传送时返回1。


warpportal

warpportal命令

作用：创建一个传送点

格式： | warpportal <from_x>,<from_y>,<to_map>,<to_x>,<to_y>;
参数：
<from_x>,<from_y> | 传送点的坐标（数值类型）
<to_map> | 目的地的地图名（字符串类型）
<to_x>,<to_y> | 目的地的坐标（数值类型）


areamisceffect

areamisceffect命令

作用：区域内显示各种效果

格式： | areamisceffect <gatname>,<x0>,<y0>,<x1>,<y1>,<type>;
参数：
<gatname> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 范围内坐标（数值类型）
<type> | 效果代码（数值类型）
说明： | <gatname>为this（区分大小写）时，表示当前地图。 <type>可参考“各种效果一览表（misceffect）”。


areasoundeffect

areasoundeffect命令

作用：区域内打开/关闭声音

格式： | areasoundeffect <gatname>,<x0>,<y0>,<x1>,<y1>,<name>,<type>;
参数：
<gatname> | 地图名（字符串类型）
<x0>,<y0>,<x1>,<y1> | 区域内的坐标（数值类型）
<name> | 文件名（字符串类型，最大24个字符）
<type> | 重复模式（数值类型） 0 - 播放1次 1 - 反复播放 2 - 停止播放
说明： | <gatname>为this（区分大小写）的话，则表示当前地图。


autobonus

autobonus命令

作用：发动自动念咒

格式： | autobonus <script>,<rate>,<tick>[,<flag>];
参数：
<script> | 执行的脚本代码（字符串类型）。推荐使用item_bonus.txt的效果
<rate> | 万分率（数值类型）
<tick> | 毫秒数（数值类型）
<flag> | 跟bonus4 bAutoSpell共同的标记（数值类型，可省略） 只有以下的标记是通用的： 发动条件（可复数）： 动作1：不指定的情况是攻击 EAS_ATTACK 攻击（直接输出伤害的时候） EAS_REVENGE 反击（受到了伤害的时候） 动作2：不指定的情况是物理攻击 EAS_WEAPON 物理攻击（输出或接受） EAS_SHORT 近距离物理攻击（输出或接受） EAS_LONG 远距离物理攻击（输出或接受） EAS_MAGIC 魔法攻击（输出或接受） EAS_MISC 其他攻击[陷阱、猎鹰、火烟瓶等]（输出或接受） ※火烟瓶投掷是武器攻击，为了方便使用而归类到其他攻击 动作3：不指定的情况是普通攻击 EAS_NORMAL 普通攻击（输出或接受） EAS_SKILL 技能攻击（输出或接受） ※在指定了EAS_MAGIC和EAS_MISC时忽略
说明： | 以<flag>条件、<rate>概率、在<tick>时间之内执行<script>代码


breakadoption

breakadoption函数

作用：解除养子关系

格式： | breakadoption([<name>])
参数：
<name> | 玩家名字（字符串类型，省略时表示当前玩家）
说明： | 解除家庭成员中包含<name>名字的养子关系。 成功则返回1，否则返回0。


changepettype

changepettype命令

作用：改变宠物捡物类型

格式： | changepettype <type>[,<char_id>];
参数：
<type> | 捡物类型（数值类型） 0 - 不捡取 1 - 宠物持有 2 - 放入主人随身物品中
<char_id> | 玩家的char_id（数值类型，省略时表示自己）


csvdelete

csvdelete命令

作用：删除一行

格式： | csvdelete <file>,<row>;
参数：
<file> | csv文件名（字符串类型）
<row> | 行号（数值类型）
说明： | 删除指定的csv文件中的第<row>行，之后的内容向前移。 为了安全起见，文件名仅限于[A-Za-z0-9]（包含目录或扩展名的话将失败）。


csvfind

csvfind函数

作用：查找csv文件

格式： | csvfind(<file>,<col>,<val>)
参数：
<file> | csv文件名（字符串类型）
<col> | 列号（数值类型）
<val> | 查找值（数组/字符串类型）
说明： | 查找csv文件中第<col>列的内容为<val>的第一行，然后返回该行号。 失败时，返回-1。


csvflush

csvflush命令

作用：刷新csv

格式： | csvflush <file>;
参数：
<file> | csv文件名（字符串类型）
说明： | 如果csv文件的内容被改变，则把变更内容全部写入到磁盘中，否则不做任何处理。 为了安全起见，文件名仅限于[A-Za-z0-9]（包含目录或扩展名的话将失败）。


csvgetcols

csvgetcols函数

作用：返回csv文件的列数

格式： | csvgetcols(<file>,<row>)
参数：
<file> | csv文件名（字符串类型）
<row> | 行号（数值类型）
说明： | 返回第<row>行的列数。


csvgetrows

csvgetrows函数

作用：返回csv文件的行数

格式： | csvgetrows(<file>)
参数：
<file> | csv文件名（字符串类型）
说明： | 文件不存在时，则返回-1。


csvinsert

csvinsert命令

作用：插入一行空行

格式： | csvinsert <file>,<row>;
参数：
<file> | csv文件名（字符串类型）
<row> | 行号（数值类型）
说明： | 从指定的csv文件中的第<row>行插入一行空行。 为了安全起见，文件名仅限于[A-Za-z0-9]（包含目录或扩展名的话将失败）。


csvread

csvread函数

作用：返回csv文件指定的一格内容

格式： | csvread(<file>,<row>,<col>)
参数：
<file> | csv文件名（字符串类型）
<row> | 行号（数值类型）
<col> | 列号（数值类型）
说明： | 返回csv文件中第<row>行第<col>列的字符串。 失败时，返回空字符串。


csvreadarray

csvreadarray命令

作用：把csv文件中的某行内容保存到数组中

格式： | csvreadarray <file>,<row>,<output_array>;
参数：
<file> | csv文件名（字符串类型）
<row> | 行号（数值类型）
<output_array> | 要输出的数组名（数组类型的变量）
说明： | 把csv文件中第<row>行的内容保存到<output_array>数组中。


csvreload

csvreload命令

作用：清除指定csv文件的缓存

格式： | csvreload <file>;
参数：
<file> | csv文件名（字符串类型）
说明： | 清除指定csv文件的缓存。 写入csvwrite, csvwritearray, csvsort, csvinsert, csvdelete命令变更的内容到磁盘中。


csvsort

csvsort命令

作用：排序csv

格式： | csvsort <file>,<col>,<order>;
参数：
<file> | csv文件名（字符串类型）
<col> | 列号（数值类型）
<order> | 顺序（数值类型，1:升序、-1:降序）
说明： | 将指定的csv文件以第<col>列的数值按<order>顺序进行排序。 为了安全起见，文件名仅限于[A-Za-z0-9]（包含目录或扩展名的话将失败）。


csvwrite

csvwrite命令

作用：把数据写入csv文件

格式： | csvwrite <file>,<row>,<col>,<val>;
参数：
<file> | csv文件名（字符串类型）
<row> | 行号（数值类型）
<col> | 列号（数值类型）
<val> | 写入的值（数组/字符串类型）
说明： | 指定的csv文件中，把<val>写入第<row>行第<col>列。 为了安全起见，文件名仅限于[A-Za-z0-9]（包含目录或扩展名的话将失败）。


csvwritearray

csvwritearray命令

作用：把数组写入csv文件

格式： | csvwritearray <file>,<row>,<array>;
参数：
<file> | csv文件名（字符串类型）
<row> | 行号（数值类型）
<array> | 数组（数组类型变量）
说明： | 把<array>的内容写入csv文件中的第<row>行。


delinventory

delinventory命令

作用：删除指定索引的物品

格式： | delinventory <index>,<count>[,<char_id>];
参数：
<index> | 物品索引（数值类型，0-99）
<count> | 数量（数值类型）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 删除人物身上索引为<index>的物品<count>个。


disguiseall

disguiseall命令

作用：把全服务器玩家变身为怪物/NPC/人工生命体

格式： | disguiseall <id>;
参数：
<id> | 怪物ID/NPC ID/人工生命体ID（数值类型）


flagname

flagname命令

作用：改变NPC名字

格式： | flagname <name>;
参数：
<name> | 新NPC名字（字符串类型）


getguildmembers

getguildmembers函数

作用：返回公会总人数

格式： | getguildmembers(<guild_id>)
参数：
<guild_id> | 公会ID（数值类型）


getguildrelation

getguildrelation函数

作用：取得公会关系

格式： | getguildrelation(<guild_id1>[,<guild_id2>])
参数：
<guild_id1> | 公会1的ID（数值类型）
<guild_id2> | 公会2的ID（数值类型，省略时表示触发脚本的玩家的公会）
说明： | 返回值： +1 相同公会 +2 同盟公会 +4 guild1方面敌对公会 +8 guild2方面敌对公会 返回-1时，表示任意一方公会不存在。


gethomuninfo

gethomuninfo函数

作用：获取携带人工生命体的详细信息

格式： | gethomuninfo(<type>[,<char_id>])
参数：
<type> | 类型（数值类型） 0 - homun_id（人工生命体唯一的ID） 1 - homun_base_lv（等级） 2 - homun_name（人工生命体名字） 3 - friendly（亲密度） 4 - hungry（饥饿度） 5 - class（homun_db.txt对应的ID）
<char_id> | 人物的char_id（数值类型，省略时表示自己）
说明： | 人物没有携带人工生命体、或者人物不存在时，返回0。


getip

getip函数

作用：解析域名

格式： | getip(<IP/host>)
参数：
<IP/host> | IP或主机名（字符串类型）
说明： | 返回一个字符串数据类型的IP地址。


getitemid

getitemid函数

作用：根据物品名字取得物品ID

格式： | getitemid(<item_name>)
参数：
<item_name> | 物品名字（字符串类型）


getnpcposition

getnpcposition命令

作用：改变NPC“职位”

格式： | getnpcposition <name>;
参数：
<name> | 新职位名字（字符串类型）


getpkflag

getpkflag函数

作用：检查地图的mapflag是否设置了pvp,gvg

格式： | getpkflag(<gatname>)
参数：
<gatname> | 地图名（字符串类型）
说明： | <gatname>为this（区分大小写）的话则表示当前地图。 返回值： =-1 失败 =0 没有设置这2个标识 +1 设置了pvp的mapflag +2 设置了gvg的mapflag


getweapontype

getweapontype函数

作用：返回装备的武器的类型

格式： | getweapontype([<char_id>])
参数：
<char_id> | 人物的char_id（数值类型）
说明： | 省略<char_id>时，表示当前人物。 返回的常量值请参考const.txt（从WT_FIST开始）。


homundel

homundel命令

作用：删除人工生命体

格式： | homundel[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时表示自己）


homunevolution

homunevolution命令

作用：让人工生命体进化

格式： | homunevolution[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时表示自己）


homunrename

homunrename命令

作用：改变人工生命体的名字

格式： | homunrename <name>[,<flag>[,<char_id>]];
参数：
<name> | 人工生命体的新名字（字符串类型）
<flag> | 更换名字标识（数值类型，默认时为0） 0 - 根据当前的改名状态 1 - 标记为未改名状态，日后可以更改名字 2 - 标记为已改名状态，日后不可以更改名字
<char_id> | 玩家的char_id（数值类型，省略时表示自己）


leaveguild

leaveguild命令

作用：强制离开公会

格式： | leaveguild[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时为自己）


leaveparty

leaveparty命令

作用：强制离开队伍

格式： | leaveparty[<char_id>];
参数：
<char_id> | 玩家的char_id（数值类型，省略时为自己）


npcskillattack

npcskillattack命令

作用：给玩家显示伤害效果

格式： | npcskillattack <skillid>,<skilllv>,<val>;
参数：
<skillid> | 技能ID（数值类型）
<skilllv> | 技能LV（数值类型）
<val> | 显示的伤害值（数值类型）
说明： | 被命令的NPC给玩家造成技能为<skillid>的伤害效果，伤害值显示为<val>（没有造成实际伤害）。 此命令仅限于攻击技能的效果。


npcskillpos

npcskillpos命令

作用：显示地面技能效果

格式： | npcskillpos <skillid>,<skilllv>,<x>,<y>;
参数：
<skillid> | 技能ID（数值类型）
<skilllv> | 技能LV（数值类型）
<x>,<y> | 坐标（数值类型）
说明： | 被命令的NPC在(x,y)坐标显示技能为<skillid>的技能效果（并没有实际效果）。 此命令仅限于指定的地面技能的效果。 但是不设置技能单位。 例 → LoV正常地被表示。 ME只显示初期效果，不在地面上显示单位效果。


recalcstatus

recalcstatus命令

作用：重新计算玩家的属性/状态

格式： | recalcstatus[<account_id>];
参数：
<account_id> | 帐号ID（数值类型，省略时表示自己）


sc_ison

sc_ison函数

作用：检查人物异常状态

格式： | sc_ison(<type>)
参数：
<type> | 异常状态的编号（数值类型，请参考skill.h或check_option的项目）
说明： | 返回关联的人物是否处于指定的异常状态。 如果是则返回1，否则返回0（包括失败）。


sc_starte

sc_starte命令

作用：造成指定对象异常状态

格式： | sc_starte <type>,<tick>,<val1>[,<target>];
参数：
<type> | 异常状态的编号（数值类型，请参考skill.h或check_option的项目）
<tick> | 异常状态持续的时间（数值类型，单位为ms）
<val1> | 造成异常状态对应的技能的等级（数值类型）
<target_id> | 对象的唯一ID值（数值类型，省略时为自己）
说明： | ※不重新计算异常状态。


setequipscript

setequipscript命令

作用：设置物品的装备效果

格式： | setequipscript <item_id>,<script>;
参数：
<item_id> | 物品ID（数值类型）
<script> | 物品的使用效果（字符串类型）
说明： | <script>一定要在首尾包含“{}”。


setestate

setestate命令

格式和作用：（和setoption函数一样）


setusescript

setusescript命令

作用：设置物品的使用效果

格式： | setusescript <item_id>,<script>;
参数：
<item_id> | 物品ID（数值类型）
<script> | 物品的使用效果（字符串类型）
说明： | <script>一定要在首尾包含“{}”。 <例> setusescript 501,"{ if(Class==0) killmonsterall \"this\"; else heal -HP+1,0; }";


undisguiseall

undisguiseall命令

作用：全服务器玩家取消变身

格式： undisguiseall;


usediteminfo

usediteminfo函数

作用：使用物品时，返回使用物品的ID、制造者的ID

格式： | usediteminfo(<flag>)
参数：
<flag> | 标识（数值类型）
说明： | <flag> = 0：返回使用物品ID <flag> = 1：返回制作者ID 人物不存在时，则返回-1。


表情代码一览表

代码 | 表情 | 预览图
0 | /！ |
1 | /？ |
2 | /高兴 |
3 | /爱心 |
4 | /流冷汗 |
5 | /灵感 |
6 | /生气 |
7 | /郁闷 |
8 | /金钱 |
9 | /无言 |
10 | 剪(Ctrl+-) |
11 | 锤(Ctrl+=) |
12 | 包(Ctrl+\) |
13 | 韩国国旗 |
14 | /大爱心 |
15 | /感谢 |
16 | /无奈 |
17 | /抱歉 |
18 | /欢笑 |
19 | /喷汗 |
20 | /迷惑 |
21 | /一级棒 |
22 | /寻找 |
23 | /天哪！ |
24 | /O |
25 | /X |
26 | /救命 |
27 | /出发 |
28 | /哭泣 |
29 | /奸笑 |
30 | /接吻 |
31 | /轻吻 |
32 | /呼 |
33 | /嗯 |
34 | (禁言) |
35 | 印尼国旗 |
36 | /e1 |
37 | /e2 |
38 | /e3 |
39 | /e4 |
40 | /e5 |
41 | /e6 |
42 | /e7 |
43 | /e8 |
44 | /e9 |
45 | /e10 |
46 | /e11 |
47 | /e12 |
48 | 菲律宾国旗 |
49 | 美国国旗 |
50 | 新加坡国旗 |
51 | 巴西国旗 |
52 | /e13 |
53 | /e14 |
54 | /e15 |
55 | /e16 |
56 | /e17 |
57 | /e18 |
58 | /e19(1点) |
59 | /e19(2点) |
60 | /e19(3点) |
61 | /e19(4点) |
62 | /e19(5点) |
63 | /e19(6点) |
64 | 印度国旗 |
65 | /e20 |
66 | 俄国国旗 |
67 | RWC旗 |
68 |  |
69 |  |
70 |  |
71 |  |
72 |  |
73 |  |
74 | /hum /e27 |
75 | /abs /e28 |
76 | /oops /e29 |
77 | /spit /e30 |
78 | /ene /e31 |
79 | /panic /e32 |
80 | /whisp /e33 |


各种效果一览表（misceffect）

注意：此效果一览表随客户端登陆器不同而略有变化。

代码 | 效果
1 | 打击声
2 | 档击声
3 | 爆冲
4 | 闪
5 | 闪
6 | 旧式玩家出现时特效
7 | 喝水效果
8 | 突闪光扩散
9 | 升华
10 | 金钱攻击
11 | 霸体
12 | 念咒(黄)
13 | 暗璧(旧)
14 | 喝水效果之蓝闪星光
15 | 圣灵
16 | 隐匿
17 | 怒爆
18 | 偷窃
19 | ----
20 | 涂毒
21 | 解毒
22 | 火狩
23 | 石化
24 | 火球
25 | 火壁
26 | 挥动声
27 | 冰冻
28 | 被冰冻
29 | 雷击
30 | 爆雷
31 | 吹火花
32 | 火光团
33 | 光猎
34 | 拳冲
35 | 传送1
36 | 传送2
37 | 加速
38 | 减速
39 | 天使之泪
40 | 天使之光
41 | 天使之障壁
42 | 天使之赐福
43 | DEX AGI UP
44 | 烟
45 | 小闪光飘动
46 | 吹沙
47 | 火烧
48 | 光板
49 | 被火箭打到
50 | 火圈(散开)
51 | 冰箭击
52 | 电突光散
53 | 突烟
54 | 念咒(白)
55 | 念咒(黄)
56 | 念咒(绿)
57 | 念咒(黄)
58 | 念咒(圣)
59 | 念咒(白)
60 | 被魔法瞄准
61 | 传点
62 | 火之猎杀
63 | 黄球罩
64 | 火球冲
65 | 白光雾(缩)
66 | 治疗术
67 | 挑衅
68 | MVP
69 | 滑动
70 | 骑乘攻击
71 | 白光圈螺旋x2
72 | 白光圈螺旋下
73 | 突光(大)
74 | 冰墙
75 | 幸运之颂歌
76 | 圣母之颂歌
77 | 复活术
78 | 痊愈术
79 | 崩裂术
80 | 投掷长矛攻击
81 | 挡之光圈
82 | 猎鹰寻敌
83 | 光耀之堂
84 | 神威祈福
85 | 天使之怒
86 | 洒水祈福
87 | 沉默术
88 | 牺牲祈福
89 | 暴风雪
90 | 怒雷强击
91 | 圣之祈福
92 | 陨石术
93 | 雷鸣术
94 | 被雷鸣
95 | 泥沼地
96 | 火球崩坏
97 | 火柱攻击
98 | 速度激发
99 | 强光陷阱
100 | 拆除闪光
101 | 修装备
102 | 大地之击
103 | 无视体型攻击
104 | 武器值最大化
105 | ----
106 | 爆炸陷阱
107 | 爆裂陷阱
108 | 霜冻陷阱
109 | 水泡
110 | 蚁洞的喷气
111 | 陷阱移除
112 | 霸邪之阵
113 | 十字驱魔攻击
114 | 旧暗壁放大版
115 | 闪冲
116 | 水球升起
117 | 水球术
118 | 火球升起
119 | 猎鹰寻敌
120 | 乎(透明一下)
121 | 音速(没字)
122 | 音投声
123 | 无影之牙
124 | 毒性散播
125 | 涂毒
126 | 毒性反弹
127 | 毒性反弹(有声)
128 | 凶砍声
129 | 毒性感染
130 | 双手剑攻速增加
131 | 反击
132 | 无影之牙突
133 | 水晶突光
134 | 水晶突光
135 | 水晶突光裂
136 | 毒性攻击
137 | 十字驱魔格
138 | 火柱攻击
139 | 睡眠陷阱
140 | 火突光圈
141 | 光壁(跟随)
142 | 崩裂术
143 | 音速(有字)
144 | 刀激光
145 | 魔耗
146 | 电光雾
147 | 火光烟
148 | 火光旋
149 | 怪物互击
150 | 火光闪
151 | 刀光闪
152 | 圣光闪
153 | 心神凝聚
154 | 锻造成功
155 | 锻造失败
156 | no jobchange.str
157 | no levelup.str
158 | 升技能等级
159 | PVP人物脚下光圈1
160 | PVP人物脚下光圈2
161 | no rain_gnd.tga 下雨
162 | 下雪
163 | 樱花叶
164 | ----
165 | 绿闪光
166 | 绿色能量外套
167 | no tamingsuccess.str
168 | no tamingfailed.str
169 | 水属性附加
170 | 手推车攻击
171 | 毒散光
172 | 念咒光柱(白)
173 | 念咒光柱(红)
174 | 念咒光柱(白)
175 | 念咒光柱(黄)
176 | 念咒光柱(白)
177 | 念咒光柱(红)
178 | 念咒光柱(白)
179 | 念咒光柱(紫)
180 | 暗属性攻击
181 | 蓝*闪光
182 | 雷X闪光
183 | 自爆
184 | ----
185 | ----
186 | 连击
187 | 连击
188 | 连击
189 | 连击
190 | 连击
191 | 瞄准
192 | 毒光
193 | 沉默攻击ooxx
194 | 晕眩
195 | 石化
196 | 暗属性攻击
197 | 睡眠攻击
198 | ----
199 | 泡泡
200 | 99光圈1
201 | 99光圈2
202 | 99光圈3
203 | 金刚不坏
204 | 喝水(红)
205 | 喝水(赤)
206 | 喝水(黄)
207 | 喝水(白)
208 | 喝水(绿)
209 | 喝水(蓝)
210 | 吃番薯
211 | 吃葡萄
212 | 红字9999
213 | 减少攻击(盾)
214 | 减少攻击(石)
215 | 隐匿
216 | 吸血
217 | 吸魔
218 | 集中药水
219 | 觉醒药水
220 | 菠色克药水
221 | 白光柱 小
222 | 反射盾
223 | 回旋白光
224 | 风旋转
225 | 火元素领域
226 | 圣十字审判
227 | 挟持音
228 | ----
229 | ----
230 | 雾
231 | 蓝光柱 小
232 | ----
233 | 雾 大
234 | 拆魔
235 | 魔法效果解除
236 | 水元素领域
237 | 风元素领域
238 | 地元素领域
239 | 火元素领域(在身上)
240 | 水元素领域(在身上)
241 | 风元素领域(在身上)
242 | 地元素领域(在身上)
243 | ----
244 | 魔法吸收
245 | 圣十字攻击
246 | 盾击
247 | 蓝色光柱 大
248 | 神佑之光
249 | 回旋盾击
250 | 集中攻击
251 | 牺牲
252 | 光盾
253 | 小光柱
254 | 金刚不坏
255 | 火箭击
256 | 冰冻击
257 | 冰箭击
258 | 石化击
259 | 绿光柱
260 | 红光柱
261 | 黄光扩散
262 | 潜击
263 | 类似元素领域(黄色)
264 | ----
265 | 弹指神通
266 | 潜击
267 | 轰音效
268 | 偷钱
269 | 拆武器
270 | 拆盾牌
271 | 拆盔甲
272 | 拆头盔
273 | 连环全身掌
274 | 偷钱音
275 | 音效
276 | 潜击
277 | 人字特效
278 | 摇篮曲地面效果
279 | 经验值倍增地面效果
280 | 永远的混沌地面效果
281 | 吹口哨地面效果
282 | 战鼓震天地面效果
283 | 为您服务地面效果
284 | 触媒之所地面效果
285 | 洛奇的悲鸣地面效果
286 | 哼唱之音地面效果
287 | 刺客的黄昏地面效果
288 | 布莱奇之诗地面效果
289 | 伊登的苹果地面效果
290 | 丑陋之舞地面效果
291 | 吹口哨地面效果
292 | 丑陋之舞地面效果
293 | 女神之吻地面效果
294 | 勿忘我地面效果
295 | 泠笑话(全员)
296 | 惊声尖叫(全员)
297 | 烟火
298 | 强酸攻击
299 | 烟火
300 | 化学保护
301 | 烟火音
302 | 火烟
303 | 气绝崩击
304 | 瞬间移动
305 | 做水成功
306 | 做水失败
307 | 阳光束 小
308 | 石头
309 | 紧急治疗
310 | 喷砂
311 | 大声呐喊
312 | 治愈术
313 | 治愈术
314 | 断线
315 | 暗壁
316 | 传送1
317 | 传送2
318 | 光格子
319 | 光格子小
320 | 治愈术攻击
321 | 传点
322 | 阳光束 大
323 | 阳光束 小
324 | 阳光束 小 短
325 | 药水投掷
326 | 脚印
327 | 脚印
328 | 阿修罗霸凰拳
329 | 六合拳 音效
330 | 猛龙夸强 火花
331 | HP回复声音
332 | SP回复声音
333 | 枫叶
334 | 晚上
335 | 中毒
336 | 霸邪挡音
337 | 升JOB
338 | 超初心者升级
339 | 爆气光
340 | 碟子
341 | 结婚传阵
342 | 念咒红光
343 | 爱心
344 | 玩家出现音效
345 | 蓝色翅膀
346 | 落花伴着月光下的水车小屋
347 | 结婚
348 | 激光
349 | 瀑布
350 | 同上
351 | 同上
352 | 同上
353 | 同上
354 | 同上
355 | 同上
356 | 同上
357 | ----
358 | 鬼魂
359 | 蝙蝠
360 | 蝙蝠
361 | 心灵震波
362 | 发光的泡泡
363 | 有翅膀的爱心跳出来
364 | 没有翅膀爱心跳出来
365 | 神之威压
366 | 红色闪光
367 | 灵气剑
368 | 狂怒之枪
369 | 双手剑攻速增加
370 | 圣音
371 | 升级
372 | 死亡
373 | 冒烟
374 | 神圣殿堂
375 | 圣母之祈福
376 | 猛龙跨强(身上变红喷火花)
377 | 爆破声身上全部变金色又消失
378 | 有点像吸魂术
379 | 身体变超蓝又恢复
380 | 魔击术
381 | 身上发出像刺猬般的光
382 | ----
383 | 吸魂术
384 | 吸收声
385 | 身体变黄透明又恢复
386 | 狙杀瞄准
387 | 闪然后身体转一圈
388 | 吸收声
389 | 风之步
390 | 野蛮凶砍
391 | 手推车加速
392 | 霸王魂
393 | 机关枪声
394 | 落花流水皆无情
395 | 吸收声
396 | 狂怒之枪
397 | 光环(周围)
398 | 光环(底部)
399 | 4道黄光+吸收声
400 | 白光*
401 | 挥拳声
402 | 变透明一下
403 | 精神撼动
404 | 蜘蛛网
405 | 薄雾之墙
406 | 头上一团红色闪电光团
407 | 心神
408 | 红光球散开
409 | 黑暗瞬间
410 | 彩虹
411 | no people1 2 3.tga
412 | 冲天炮
413 | 斩头
414 | 顺时针转体
415 | 脖子变短
416 | ----
417 | 发光一下(黄)
418 | 类似金刚不坏(红色闪电)
419 | 类似分身的效果
420 | 缩小(逐渐)
421 | 缩小(迅速)
422 | 变大(逐渐)
423 | 变大(迅速)
424 | 持续发光
425 | ----
426 | 左右震动
427 | ----
428 | ----
429 | 蓝色火星(大)
430 | 同上
431 | 同上
432 | 脚底闪电光束四射
433 | 交叉闪电右下脚射出
434 | 蓝色火星(小)
435 | 顺时针原地转2圈
436 | 保护盾(白色)
437 | 类似流星的效果(蓝色)
438 | 保护盾(风一样的效果)
439 | 蓝光型气绝崩击
440 | 圣母之祈福
441 | 咏唱声音(蓝色特效)
442 | 脚印
443 | ----
444 | 闪出6条光线
445 | 跳高
446 | 顺时针转体+上方落人
447 | 左脚印
448 | 右脚印
449 | 发光一下(蓝)
450 | 黑色圣十字审判
451 | 圣灵召唤(红色)
452 | 被闪光包围
453 | 束缚效果
454 | 咏唱声音(黑色特效)
455 | 类似金刚不坏(红色闪电)
456 | 加速术
457 | 准备动作
458 | 左右震动
459 | 逆时针旋转（带灰色北半球气旋）
460 | 绿色北半球气旋
461 | 蓝色北半球气旋
462 | 蓝色雾
463 | 砸踢准备
464 | 白色北半球气旋
465 | 紫色北半球气旋
466 | 身体旋转带声版
467 | 温暖的风（地）
468 | 温暖的风（风）
469 | 温暖的风（水）
470 | 温暖的风（火）
471 | 温暖的风（念）
472 | 温暖的风（暗）
473 | 温暖的风（圣）
474 | ----
475 | 太阳星星月亮的恶魔1级
476 | 太阳星星月亮的恶魔2级
477 | 太阳星星月亮的恶魔3级
478 | 太阳星星月亮的恶魔4级
479 | 太阳星星月亮的恶魔5级
480 | 太阳星星月亮的恶魔6级
481 | 太阳星星月亮的恶魔7级
482 | 太阳星星月亮的恶魔8级
483 | 太阳星星月亮的恶魔9级
484 | 太阳星星月亮的恶魔10级
485 | 超强爆气（泛白光）
486 | 超强爆气（泛蓝光）
487 | 黑色水波效果
488 | 蓝色光环(大)
489 | ----
490 | ----
491 | 彩色闪光效果
492 | 彩色闪光效果2
493 | 致命涂毒
494 | 投掷风属性斧
495 | 连续攻击声音
496 | 技能保留
497 | 红色纤细药水投掷
498 | 黄色纤细药水投掷
499 | 白色纤细药水投掷
500 | 蓝色深浅变化（闪烁型）
501 | 高速逆时针旋转
502 | 牺牲祈福无声版
503 | SOULLINK
504 | ----
505 | 牺牲祈福
506 | 冒出2个蓝色泡泡(小)
507 | 马牌效果
508 | 类似升级时的烟花
509 | 手制巧克力效果
510 | 阿修罗霸凰拳
511 | ----
512 | 气绝崩击+自身变金色
513 | 扩大缩小交替的魔法阵
514 | 光会聚、扩散
515 | 钢铁之都浓雾效果
516 | 云的效果
517 | 蓝色方块浮现头顶
518 | 烟火爆散（大地之击音效）
519 | 小天使翅膀效果
520 | 连锁盾击
521 | 红色深浅变化（闪烁型）
522 | 重力原野
523 | 命运的塔罗牌(愚者)
524 | 命运的塔罗牌(魔法师)
525 | 命运的塔罗牌(女教皇)
526 | 命运的塔罗牌(战车)
527 | 命运的塔罗牌(力量)
528 | 命运的塔罗牌(恋人)
529 | 命运的塔罗牌(命运之轮)
530 | 命运的塔罗牌(倒吊男)
531 | 命运的塔罗牌(死亡)
532 | 命运的塔罗牌(节制)
533 | 命运的塔罗牌(恶魔)
534 | 命运的塔罗牌(塔)
535 | 命运的塔罗牌(星)
536 | 命运的塔罗牌(太阳)
537 | 紫光上升、地震+火墙音效
538 | 绿色深浅变化（闪烁型）
539 | 投掷火烟瓶、盐酸瓶
540 | 缩小，然后逐渐变大
541 | ----
542 | 灵魂效果
543 | 灵魂效果+蓝雾上升
544 | 持续发光(红)
545 | （客户端会出错）
546 | 冒白色泡泡
547 | 艾斯提
548 | 发光一下(红)
549 | 发光一下(蓝)
550 | 左右震动
551 | 一串光环
552 | ----
553 | 艾斯麻
554 | 蓝雾爆炸
555 | 一串蓝雾飘过带音效（艾斯敦）
556 | ----
557 | 横向能量瀑布(古代迷宫中的)
558 | 纵向能量瀑布(古代迷宫中的)
559 | 横向能量瀑布(古代迷宫中的)(快)
560 | 纵向能量瀑布(古代迷宫中的)(快)
561 | 旋转光柱(古代迷宫中的)（消失型）
562 | 旋转光柱(古代迷宫中的)（持续型）
563 | 大地震
564 | 红色念咒
565 | 一刀（类似圣十字攻击的效果）
566 | 两刀（类似圣十字攻击的效果）
567 | 三刀（类似圣十字攻击的效果）
568 | 人工生命体升级
569 | 盾牌闪蓝光
570 | 忍者出现
571 | 狼头+狼叫
572 | 太阳的温暖
573 | 和平的象征（飘羽毛）
574 | 飘纤细白色药水
575 | 飘硫酸瓶、火药瓶
576 | 打雷
577 | 乌云
578 | 双死神环绕
579 | ZZZ~
580 | 下暴雨
581 | 一道阳光
582 | 跆拳系列升级
583 | 艾斯诬红色版
584 | 冲击波
585 | 大爆炸
586 | 幽灵状态
587 | 紫火出现
588 | 小爆炸
589 | 艾斯诬
590 | 白光迅速四射
591 | ----
592 | 飘血云
593 | 红色光圈
594 | 蓝色光圈
595 | 绿色光圈
596 | 紫色光圈
597 | 黄色光圈
598 | 橙色光圈
599 | 身体闪光+念咒声音
600 | 一个小东西在旋转
601 | 火狩攻击
602 | 左右震动+闪红光
603 | 旋转爆炸效果
604 | 地上出现3个触手
605 | 消除地上的触手
606 | ----
607 | ----
608 | 制作料理成功
609 | 制作料理失败
610 | SUCCESS
611 | FAILED
612 | 不知道什么升级-_-!
613 | 紫色小物体
614 | 深紫色小物体
615 | 红色小物体
616 | 粉红色小物体
617 | 能量外套（残影比较少）
618 | 红炎华
619 | 冰闪枪
620 | 深蓝光圈
621 | 未知音效
622 | 被雷劈
623 | 尖锐射击
624 | 绿色版艾斯提
625 | 闪蓝光
626 | 闪红光
627 | 子弹声
628 | 闪蓝光+雷鸣登声音
629 | ----
630 | 快速被砍3下
631 | 榻榻米逆转
632 | 雾切
633 | 一闪
634 | 火炎阵的火
635 | 爆炎龙
636 | 冰晶落
637 | 亡命之徒
638 | 地上出现一个未知物体(-__-!!)
639 | 同上
640 | 同上（紫色）
641 | 同上
642 | 同上（红色）
643 | 轮林弹雨
644 | 精确射击
645 | 未知射击效果
646 | 2个瞄准器
647 | 精确射击差不多的效果
648 | 三连击
649 | 1个瞄准器
650 | 冰窟洞的魔法阵1
651 | 冰窟洞的魔法阵2
652 | 减少1HP有声版（红色）
653 | 减少1HP无声版（红色）
654 | 减少1HP无声版（粉色）
655 | 变绿色
656 | 变绿色后恢复


NPC插图一览表（1）

NPC插图一览（1）

卡普拉职员
kafra_01 | kafra_02 | kafra_03 | kafra_04 | kafra_05
狄波萝太 | 泰依琳 | 绣灵 | 妣妮 | 克拉丽丝
kafra_06 | kafra_07 | kafra_08 | kafra_09 | zonda_01
Ｗ | 克魔岛卡普拉 | 里希塔乐镇卡普拉 | 里希塔乐镇卡普拉 | 准它职员

向导人员
prt_soldier | moc_soldier | gef_soldier | pay_soldier | ein_soldier
普隆德拉士兵 | 梦罗克士兵 | 吉芬士兵 | 斐扬士兵 | 艾音布罗克士兵

转职任务NPC
job_knight_herman1~2 | job_wizard_maria01~03 | job_black_hucke01~03 | job_huntermaster
骑士团长 海陆曼 ■ ■ | 玛莉亚 ■ ■ ■ | 修咖巴殷 ■ ■ ■ | 猎人公会会长
job_sage_kayron | job_alche_vincent | job_bard_aiolo01~02 | job_dancer_eir01~03
凯伦 葛瑞 | 宾珊特 卡乐士阿罗 | 艾欧鲁德 ■ ■ | 艾尔 ■ ■ ■

卢铁任务NPC
rutie_snownow01~03
雪人 ■ ■ ■

结婚NPC
wedding_bomars01~03 | wedding_marry01~03
波玛尔斯 ■ ■ ■ | 结婚快乐 ■ ■ ■

钻石交换NPC
katsua01~03
卡翠亚 ■ ■ ■

神器任务NPC
god_kukur01~03 | god_rebeireb | god_nelluad01~04 | god_tialpi01~02
库库勒 ■ ■ ■ | 雷贝依勒布 多 | 那留奥德 ■ ■ ■ ■ | 替尔匹 ■ ■

TheSign任务NPC
mets_alpha
麦兹

艾音布罗克任务NPC
ein_hicman
庞德 海宜柯曼

飞行船任务NPC
fly_felrock | fly_trock
裴陆 | 杜陆

里希塔乐镇任务NPC
lhz_karl | lhz_macu01~07 | lhz_diguts01~08
卡尔 | 麻库 ■ ■ ■ ■ ■ ■ ■ | 达伊戈次 ■ ■ ■ ■ ■ ■ ■ ■
lhz_benkaistin01~04 | lhz_kaz01~11 | lhz_ryo01~14
班卡依史丁 ■ ■ ■ ■ | 卡兹恩 ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ | 陆兹恩 ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■

梦罗克的封印任务NPC
mocseal_kid01 | mocseal_rin01 | mocseal_dan01
奇德 | 琳 | 段傣莉翁

料理任务NPC
orleans_1~7 | nyuang_1~4
奥日里昂 ■ ■ ■ ■ ■ ■ ■ | 猫咪 ■ ■ ■ ■

毁葛任务NPC
hu_alex01~04 | hu_laura01~04 | siide1~2 | heri1~3
亚历斯 ■ ■ ■ ■ | 拉乌拉 ■ ■ ■ ■ | 西伊岱 ■ ■ | 海力克 ■ ■ ■

基尔·海尔学院任务NPC
kh_elly01~04 | kh_ellisia | kh_kyel01~03 | kh_kiel01~04
爱丽 ■ ■ ■ ■ | 爱丽希雅 | 基尔·海尔 ■ ■ ■ | 基尔 ■ ■ ■ ■

拉赫任务NPC
ra_magic1~4 | ra_sboy | ra_nemma01~04 | ra_fano01~03
马希欧 ■ ■ ■ ■ | 冻僵的少年 | 奈莫 ■ ■ ■ ■ | 帕诺 ■ ■ ■
ra_usti1~2 | ra_gman~2 | ra_gwoman~2 | ra_bishop
乌丝提亚拉 ■ ■ | 杰特大神官 ■ ■ | 尼尔恩大神官 ■ ■ | 教皇

新神器任务NPC
wish_maiden11~33
ウィッシュメイデン ■ ■ ■ ■ ■ ■ ■ ■ ■

其他任务NPC
bard_eland01~04
イレンド ■ ■ ■ ■


NPC插图一览表（2）

NPC插图一览（2）

情人节活动NPC
v_breid01~06 | v_sprakki01~05 | v_seryu01~10 | v_jinha01~08
ブレイド ■ ■ ■ ■ ■ ■ | スプラキ ■ ■ ■ ■ ■ | セリュー ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ | ジンハ ■ ■ ■ ■ ■ ■ ■ ■

周年活动NPC
jpn_ateil01~04 | jpn_anni01~04
アテイル ■ ■ ■ ■ | 怪盗アニバーサリー ■ ■ ■ ■

发型一览
hair_f_01~27 | hair_m_01~27
女性发型 ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ | 男性发型 ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■ ■

龙之城毒药王的诗
poison_q1-1~5 | poison_q2-1~5 | poison_q3-1~5 | poison_q4-1~5
静夜思第1行 ■ ■ ■ ■ ■ | 静夜思第2行 ■ ■ ■ ■ ■ | 静夜思第3行 ■ ■ ■ ■ ■ | 静夜思第4行 ■ ■ ■ ■ ■

TheSign贴纸
sign_01~04
贴纸 ■ ■ ■ ■

优配擂斯纹章的碎片
1(-1) | 2(-1) | 3(-1) | 4(-1) | 5(-1)
纹章的碎片(蓝) ■ ■ | 纹章的碎片(绿) ■ ■ | 纹章的碎片(茶) ■ ■ | 纹章的碎片(红) ■ ■ | 纹章的碎片(全) ■ ■

梦罗克的封印
mocseal_wind01~02 | mocseal_earth01~02 | mocseal_ice01~02 | mocseal_fire01~02
风之封印 ■ ■ | 土之封印 ■ ■ | 水之封印 ■ ■ | 火之封印 ■ ■

基尔·海尔之肖像画
kh_family_port | kh_ellisia_port | kh_kyel_port | kh_ring_port
家族的肖像画 | 爱丽希雅的肖像画 | 男性的肖像画 | 爱丽希雅的戒指

白色情人节活动NPC
white_seed | white_choco | white_retto
チョコレートニンフの種 | チォチォコ | レト

新手向导
tutorial01~05
新手向导 ■ ■ ■ ■ ■


NPC代码一览表

NPC代码一览

45: 传送点
104: 上面不断出现光环叠加
111: 隐藏NPC（不显示名字，可以点击）
139: 隐藏NPC（不显示名字，不可以点击）
844: 地上有个黑点（像隐匿，可以点击）(clear_npc)

个别NPC在最新韩国客户端里已经没有，在客户端补丁中有补档。

46 | 47 | 48 | 49 | 50 | 51 | 52 | 53
1_etc_01 | 1_m_01 | 1_m_02 | 1_m_03 | 1_m_04 | 1_m_bard | 1_m_hof | 1_m_innkeeper
54 | 55 | 56 | 57 | 58 | 59 | 60 | 61
1_m_jobguider | 1_m_jobtester | 1_m_knightmaster | 1_m_librarymaster | 1_m_merchant | 1_m_orient01 | 1_m_pastor | 1_m_pubmaster
62 | 63 | 64 | 65 | 66 | 67 | 68 | 69
1_m_siz | 1_m_smith | 1_m_wizard | 1_m_youngknight | 1_f_01 | 1_f_02 | 1_f_03 | 1_f_04
70 | 71 | 72 | 73 | 74 | 75 | 76 | 77
1_f_gypsy | 1_f_librarygirl | 1_f_maria | 1_f_merchant_01 | 1_f_merchant_02 | 1_f_orient_01 | 1_f_orient_02 | 1_f_orient_03
78 | 79 | 80 | 81 | 82 | 83 | 84 | 85
1_f_orient_04 | 1_f_priest | 1_f_pubgirl | 4_dog01 | 4_kid01 | 4_m_01 | 4_m_02 | 4_m_03
86 | 87 | 88 | 89 | 90 | 91 | 92 | 93
4_m_04 | 4_m_barber | 4_m_orient01 | 4_m_orient02 | 4_f_01 | 4_f_02 | 4_f_03 | 4_f_04
94 | 95 | 96 | 97 | 98 | 99 | 100 | 101
4_f_maid | 4_f_sister | 4w_kid | 4w_m_01 | 4w_m_02 | 4w_m_03 | 4w_sailor | 4w_f_01
102 | 103 | 105 |  |  | 106 | 107 | 108
8_f | 8_f_grandmother | 8w_soldier |  |  | 1_m_moc_lord | 1_m_pay_elder | 1_m_pron_king
109 | 110 | 112 | 113 | 114 | 115 | 116 | 117
4_m_manager | 4_m_minister | 4_f_kafra6 | 4_f_kafra5 | 4_f_kafra4 | 4_f_kafra3 | 4_f_kafra2 | 4_f_kafra1
118 | 119 | 120 | 121 | 122 | 123 | 124 | 125
2_m_thiefmaster | 2_m_swordmaster | 2_m_pharmacist | 2_m_molgenstein | 2_m_dyeinger | 2_f_magicmaster | 4_f_teleporter | 4_m_teleporter
401 | 402 | 403 | 404 | 405 | 406 | 407 | 408
4_m_mut2 | 4_m_science | 4_f_valkyrie2 | 4_m_uncleknight | 4_m_youngknight | 2_monemus | 4_m_ateil | 4_f_anniversary
409 | 410 | 411 | 412 | 413 | 414 | 415 | 416
4_m_greatpo | 4_m_novelist | 4_m_champsoul | 4_m_oldfriar | 4_m_cru_sold | 4_m_cru_knt | 4_m_cru_head | 4_m_cru_crua
417 | 418 | 419 | 420 | 421 | 422 | 423 | 424
4_m_ky_sold | 4_m_ky_knt | 4_m_ky_head | 4_m_ky_kiyom | 4_m_bosscat | 4_m_babycat | 4w_f_kafra2 | 4_f_munak
425 | 426 | 427 | 428 | 429 | 430 | 431 | 432
4_m_bongun | 4_bear | 4_bluewolf | 4_pecopeco | 4_m_jp_mid | 4_m_jp_run | 4_orclady | 4_orclady2
433 | 434 | 435 | 436 | 437 | 438 | 439 | 440
4_orcwarrior | 4_orcwarrior2 | 4_f_fairy | 4_f_fairykid | 4_f_fairykid2 | 4_f_fairykid3 | 4_f_fairykid4 | 4_f_fairykid5
441 | 442 | 443 | 444 | 445 | 446 | 447 | 448
4_f_fairykid6 | 4_m_fairykid | 4_m_fairykid2 | 4_m_fairykid3 | 4_m_fairykid4 | 4_m_fairykid5 | 4_m_fairysoldier | 4_m_tuffold
449 | 450 | 451 | 452 | 453 | 454 | 455 | 456
4_man_benkuni | 4_man_galtun | 4_man_jerutoo | 4_man_lavail | 4_man_nitt | 4_man_piom | 4_man_piom2 | 4_m_dstman
457 | 458 | 459 | 460 | 461 | 462 | 463 | 464
4_m_dstmandead | 4_babyleopard | 4_m_redsword | 4_man_piom3 | 4_m_fairysoldier2 | 4_f_fairysoldier | 4_dragon_egg | 4_mimic
465 | 466 | 467 | 468 | 469 | 470 |  |
4_f_fairy1 | 4_f_guillotine | 4_m_guillotine | 4_m_knight_black | 4_m_knight_gold | 4_m_knight_silver |  |
700 | 701 | 702 | 703 | 704 | 705
8_f_girl | 4_f_godemom | 4_f_gon | 4_f_kid2 | 4_m_bibi | 4_m_gef_soldier
706 | 707 | 708 | 709 | 710 | 711 | 712 | 713
4_m_kid1 | 4_m_moc_soldier | 4_m_pay_soldier | 4_m_seaman | 4_m_snowman | 4_f_05 | 4_m_05 | 4_m_06
714 | 715 | 716 | 717 | 718 | 719 | 720 | 721
4_f_06 | 4_m_pierrot | 4_m_kid2 | 4_f_kid3 | 4_m_santa | 4_f_nacoruri | 4_f_shaman | 4_f_kafra7
722 | 723 |  | 724 | 725 | 726 | 727 | 728
guildflag90_1 | 1_shadow_npc |  | 4_f_07 | 4_f_job_assassin | 4_f_job_blacksmith | 4_f_job_hunter | 4_f_job_knight
729 | 730 | 731 | 732 | 733 | 734 | 735 |
4_f_novice | 4_m_job_assassin | 4_m_job_blacksmith | 4_m_job_hunter | 4_m_job_knight1 | 4_m_job_knight2 | 4_m_job_wizard |
736 |  | 737 |  | 738 | 739 | 740 | 741
4_baphomet |  | 4_dark_lord |  | 4_deviruchi | 8_doppel | 2_m_alche | 2_m_bard_orient
742 | 743 | 744 | 745 | 746 | 747 | 748 | 749
2_m_sage_b | 2_m_sage_old | 4_f_alche | 4_f_cru | 4_f_monk | 4_f_rogue | 4_m_alche_a | 4_m_alche_b
750 | 751 | 752 | 753 | 754 | 755 | 756 | 757
4_m_alche_c | 4_m_cru | 4_m_cru_old | 4_m_monk | 4_m_sage_a | 4_m_sage_c | 4_f_son | 4_f_jpn2
758 | 759 | 760 | 761 | 762 | 763 | 764 | 765
4_f_jpn | 4_f_jpnchibi | 4_f_jpnoba2 | 4_f_jpnoba | 4_m_jpn2 | 4_m_jpn | 4_m_jpnchibi | 4_m_jpnoji2
766 | 767 | 768 | 769 | 770 | 771 | 772 | 773
4_m_jpnoji | 8_m_jpnsoldier | 8_m_jpnmaster | 4_f_jpnmu | 4_f_twgirl | 4_f_twgrandmom | 4_f_twmaskgirl | 4_f_twmidwoman
774 | 775 | 776 | 777 | 778 | 779 | 780 | 781
4_m_twboy | 4_m_twmaskman | 4_m_twmidman | 4_m_twoldman | 4_m_twteaman | 4_m_yoyorogue | 8_m_twsoldier | 4_f_umgirl
782 | 783 | 784 | 785 | 786 | 787 | 788 | 789
4_f_umoldwoman | 4_f_umwoman | 4_m_umchief | 4_m_umdancekid2 | 4_m_umdancekid | 4_m_umkid | 4_m_umoldman | 4_m_umsoldier
790 | 791 | 792 | 793 | 794 | 795 | 796 | 797
4_m_salvation | 4_f_nfdeadkafra | 4_f_nfdeadmgcian | 4_f_nflostgirl | 4_m_nfdeadman2 | 4_m_nfdeadman | 4_m_nfdeadswdman | 4_m_nflostman
798 | 799 | 800 | 801 | 802 | 803 | 804 | 805
4_m_nfman | 4_nfbat | 4_nfcock | 4_nfcoffin | 4_nfwisp | 1_f_signzisk | 1_m_sign1 | 1_m_signalche
806 | 807 | 808 | 809 | 810 | 811 | 812 | 813
1_m_signart | 1_m_signmcnt | 1_m_signmonk2 | 1_m_signmonk | 1_m_signrogue | 4_f_valkyrie | tw_tower | 2_m_oldblsmith
814 | 815 | 816 | 817 | 818 | 819 | 820 | 821
4_f_chndoctor | 4_f_chndress1 | 4_f_chndress2 | 4_f_chndress3 | 4_f_chnwoman | 4_m_chn8guek | 4_m_chncook | 4_m_chngenerl
822 | 823 | 824 | 825 | 826 | 827 | 828 | 829
4_m_chnman | 4_m_chnmonk | 4_m_chnold | 4_m_chnsoldier | 4_m_dwarf | 4_m_grandmonk | 4_m_rogue | 4_m_domino
830 | 831 | 832 | 833 | 834 | 835 | 836 | 837
4_f_domino | 4_f_zondagirl | 4_m_reidin_kurs | 4_m_zondaoyaji | 4_m_buddhist | 2_board1 | 2_board2 | 2_bulletin_board
838 | 839 | 840 | 841 | 842 | 843 | 845 | 846
4_f_thaiayo | 4_f_thaigirl | 4_f_thaishaman | 4_m_thaiayo | 4_m_thaiold | 4_m_thaiongbak | 4_f_racing | 4_f_einold
847 | 848 | 849 | 850 | 851 | 852 | 853 | 854
4_m_einold | 4_m_einminer | 4_m_dieman | 4_f_einwoman | 4_m_repair | 4_m_ein_soldier | 4_m_yuri | 4_m_einman2
855 | 856 | 857 | 858 | 859 | 860 | 861 | 862
4_m_einman | 2_f_sign1 | 4_board3 | 4_bulletin_board2 | 4_f_agentkafra | 4_f_kafra8 | 4_f_kafra9 | 4_f_lgtgirl
863 | 864 | 865 | 866 | 867 | 868 | 869 | 870
4_f_lgtgrand | 4_f_operation | 4_lgtscience | 4_m_lgtgrand | 4_m_lgtguard2 | 4_m_lgtguard | 4_m_lgtman | 4_m_lgtpoor
871 | 872 | 873 | 874 | 875 | 876 | 877 | 878
4_m_operation | 4_m_president | 4_m_reindeer | 4_m_zondaman | 4_m_pecoknight | 4_cat | 4_f_yunyang | 4_m_oilman
879 | 880 | 881 | 882 | 883 | 884 | 885 | 886
4_f_capegirl | 4_m_maskman | 4_m_sitdown | 4_f_sitdown | 4_m_alche_d | 4_m_across | 4_f_across | 4_cook
887 | 888 | 889 | 890 | 891 | 892 | 893 | 894
4_m_lieman | 2_postbox | 4_bull | 4_lam | 4_f_hugirl | 4_f_hugranma | 4_f_huwoman | 4_f_khellisia
895 | 896 | 897 | 898 | 899 | 900 | 901 | 902
4_f_khelly | 4_m_huboy | 4_m_hugranfa | 4_m_human_01 | 4_m_human_02 | 4_m_humerchant | 4_m_huoldarmy | 4_m_khkiel
903 | 904 | 905 | 906 | 907 | 908 | 909 | 910
4_m_khkyel | 4_m_khman | 4_f_khwoman | 4_f_khgirl | 4_m_khboy | 4_m_philman | 4_poring | 2_colavend
911 | 912 | 913 | 914 | 915 | 916 | 917 | 918
4_f_soccer | 4_m_soccer7 | 4_m_soccer9 | 4_f_child | 4_f_madame | 4_f_mask1 | 4_f_mask | 4_f_rachold
919 | 920 | 921 | 922 | 923 | 924 | 925 | 926
4_f_shabby | 4_f_trainee | 4_m_child1 | 4_m_child | 4_m_doctor | 4_m_frozen1 | 4_m_frozen | 4_m_mask1
927 | 928 | 929 | 930 | 931 | 932 | 933 | 934
4_m_mask | 4_m_middle1 | 4_m_middle | 4_m_rachman2 | 4_m_rachman1 | 4_m_rachold1 | 4_m_rachold | 4_m_rasword
935 | 936 | 937 | 938 | 939 | 940 | 941 | 942
4_m_trainee | 4_f_aruna_pop | 4_m_aruna_nfm1 | 4_dst_camel | 4_dst_soldier | 4_f_desert | 4_f_dst_child | 4_f_dst_grand
943 | 944 | 945 | 946 | 947 | 948 | 949 | 950
4_m_desert | 4_m_dst_child | 4_m_dst_grand | 4_m_dst_master | 4_m_dst_tough | 4_angeling | 4_archangeling | 4_ghostring
951 | 952 | 953 | 954 | 955 | 956 | 957 | 958
4_f_eden_master | 4_f_eden_officer | 4_m_eden_guarder | 4_m_patrick | 4_donkey | 4_m_tristan | 4_white_cow | 4_f_ruschild
959 | 960 | 961 | 962 | 963 | 964 | 965 | 966
4_f_ruswoman1 | 4_f_ruswoman2 | 4_f_ruswoman3 | 4_m_ruschild | 4_m_gusliman | 4_m_rusbald | 4_m_rusking | 4_m_rusknight
967 | 968 | 969 | 970 | 971 | 972 | 973 | 974
4_m_rusman1 | 4_m_rusman2 | 4_m_drake | 4_f_babayaga | 4_f_rusgreen | 4_rus_dwolf | 1_flag_lion | 1_flag_eagle
975 | 976 | 977 | 978 | 979 | 980 | 981 | 982
4_m_mikid | 4_blue_flower | 4_red_flower | 4_yell_flower | 4_f_cave1 | 4_f_mut1 | 4_f_mut2 | 4_f_science
983 | 984 | 985 | 986 | 987 | 988 | 989 | 990
4_m_1stprin1 | 4_m_1stprin2 | 4_m_2ndprin1 | 4_m_2ndprin2 | 4_m_3rdprin1 | 4_m_3rdprin2 | 4_m_4thprin1 | 4_m_4thprin2
991 | 992 | 993 | 994 | 995 | 996 | 997 | 998
4_m_5thprin1 | 4_m_5thprin2 | 4_m_6thprin1 | 4_m_6thprin2 | 4_m_casman1 | 4_m_cave1 | 4_m_mocass1 | 4_m_mocass2
999 |  |  |  |  |  |  |
4_m_mut1 |  |  |  |  |  |  |